DE:Georeferenzierung mit QGIS unter Linux OpenSUSE 11.3

From OpenStreetMap Wiki
Jump to: navigation, search

… am Beispiel der Lausitzer Luftaufnahmen

Vorbereitung

  • Luftbilder und den dazugehörigen GPX-Track herunterladen zb.von:
  • Luftbilder mit einem Geotag versehen mittels Prune (Anleitung). Die Abweichung der Fotos vom Track beträgt 1 Stunde, 1 Minute und 40 Sekunden
  • Falls noch nicht geschehen, Qgis herunterladen und installieren. Plugins Photo2Shape und Gdal-Georeferenzierung werden benötigt.
  • Zur Georeferenzierung werden Vergleichsdaten benötigt, wir verwenden einen OSM-WMS-Dienst , dazu klicken wir auf Layer -> WMS-Layer hinzufügen -> Neu und geben in der

Url-leiste ein :

http://osmwms.itc-halle.de/maps/osmfree?

Zum Vergleichen, nicht zum Abzeichnen können auch WMS-Dienste wie zb. für:

Sachsen

http://www.landesvermessung.sachsen.de/ias/basiskarte4/service/SRV4DOPFREE/WMSFREE_TK/WMSFREE_TK/wmsservice?request=GetMap&version=1.1.1&layers=ortho_rgb06&SRS=EPSG:4326&format=image/jpeg&

Brandenburg

http://isk.geobasis-bb.de/ows/dnm.php?

Weitere WMS-Dienste

DE:DOP_Sources


geladen werden.

  • Damit wir beim georeferenzieren wissen wo die Luftbilder aufgenommen wurden, werden mit Qgis und dem Photo2Shape-Plugin

die Luftbilder mit Geotag in ein Shape-File konvertiert. Anschließend können wir mit der Georeferenzierung beginnen

Georeferenzierung

  • Qgis starten, unter

Einstellungen -> Bedienfelder aktivieren wir Layer.

  • Anschließend den GPX-Track mit

Erweiterungen -> GPS Werkzeuge -> GPX-Datei laden öffnen.

GPX-Track ist geladen


Im Layerfenster können wir nun durch Rechtsklick auf den Track unter Eigenschaften zb. die Trackfarbe und Liniendicke verändern.

  • Jetzt laden wir die WMS-Dienste (mit den zuvor gespeicherten URL)

Layer -> WMS-Layer hinzufügen -> Verbinden -> Hinzufügen



Qgis2.jpeg
GPX-Track und WMS geladen



Im Layerfenster können wir nun durch Rechtsklick auf den WMS-Layer unter Eigenschaften -> Transparenz diese auf 50% setzen

  • Danach laden wir unser aus den Luftbildern entstandenes Shape-File mit

Layer -> Vectorlayer hinzufügen -> Datei

GPX-Track, WMS und Fotostandorte geladen



Nun Zommen wir näher an das zu georeferenzierende Foto heran

  • Ab jetzt beginnt die eigendliche Georeferenzierung, dazu öffnen wir den Dialog mit

Erweiterungen -> Georeferenzierung -> Georeferenzierung -> Raster öffnen

Qgis5.jpeg
  • Ein Foto ist geladen und wir können beginnen mit

Punkt hinzufügen

Qgis6.jpeg


setzen wir einen Punkt auf zb. eine markante Kreuzung

  • Im folgenden Dialog klicken wir auf

Aus Kartenanzeige

Qgis7.jpeg

es wird automatisch in das Qgis-Fenster mit dem WMS-Dienst gesprungen, wo die gleiche Stelle wie auf dem Foto angeklickt wird.

Qgis8.jpeg

nun haben wir die Koordinaten des Punktes und können mit OK fortsetzen

Qgis9.jpeg

Diesen Vorgang wiederholen wir mehrmals, bis die Punkte schön auf dem Foto verteilt sind

Qgis10.jpeg
  • Anschließend klicken wir im Georeferenzierungsfenster auf

Transformationseinstellungen,

machen die geforderten Einstellungen und klicken auf OK.

Qgis11.jpeg
  • Jetzt Speichern wir unsere GCP-Punkte ab und klicken auf

Georeferenzierung beginnen

Qgis12.jpeg

Es wird ein Geotiff erstellt, und im Qgis-Fenster angezeigt. Dort machen wir den Geotiff-Layer transparent und schauen ob er mit dem WMS-Layer übereinstimmt. Wenn nicht die Georeferenzierung durch setzen neuer bzw. verschieben vorhandener Punkte fortsetzen.

  • Die GeoTiff-Datei kann zb. mit QLandkarteGT geladen werden.

Dort können über ein Overlay Tracks nachgezeichnet, in GPX exportiert werden, um diese in JOSM zu verwenden

  • Auch eine Konvertierung ins JPG-Format und anschließende Nutzung mit dem Piclayer-Plugin ist möglich