DE:Merkaartor/Documentation

From OpenStreetMap Wiki
Jump to: navigation, search
Verfügbare Sprachen — Merkaartor/Documentation
· Afrikaans · Alemannisch · aragonés · asturianu · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · Bân-lâm-gú · Basa Jawa · Baso Minangkabau · bosanski · brezhoneg · català · čeština · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · Kurdî · latviešu · Lëtzebuergesch · lietuvių · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk bokmål · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · português do Brasil · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tiếng Việt · Türkçe · Vahcuengh · vèneto · Wolof · Yorùbá · Zazaki · српски / srpski · беларуская · български · қазақша · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · मराठी · हिन्दी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 吴语 · 粵語 · 中文(繁體)‎ · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް

Contents

Schnellstart

MerkaartorMainWindow.png

Willkommen bei Merkaartor.

Nachdem du die Anwendung zum ersten Mal gestartet haben, kannst du die Hintergrundkarte bewegen, indem du die rechte Maustaste drückst und dann ziehst (oder indem du die Pfeiltasten betätigen).

Mit dem Mausrad lässt sich die Karte vergrößern oder verkleinern (zoomen) (dies geht auch durch Betätigung der + und - Tasten, oder über F3 und Auswahl einer Region) um zum Ausschnitt zu gelangen, den du bearbeiten willst.

Wenn du keine Karte im Hintergrund siehst, wähle eine im Kontextmenü des Ebenen-Andockfensters aus. Sobald du an der Stelle bist, die du bearbeiten willst, wähle "Herunterladen" im Dateimenü (oder den entsprechenden Button). Überprüfe im Download-Dialog, dass "Aktuelle Ansicht" markiert ist und klicke auf OK. Merkaartor verbindet sich nun mit dem OpenStreetmap-Server und ruft alle Kartendaten des gewählten Ausschnitts ab. Wenn die Fläche zu groß gewählt war, kann der Server die Daten verweigern, in diesem Fall zoome etwas näher und versuchen es nochmal. Mit "Mehr herunterladen" kannst du später weitere Daten abrufen.

Der heruntergeladene Bereich des im Download-Layer wird über die Hintergrundkarte gezeichnet. Bereiche, die nicht vollständig heruntergeladen wurden, sind mit eine Muster aus roten Punkten markiert - editiere dort nicht, sondern lade zuerst die Daten herunter!

Wenn du einen Knoten oder eine Weg selektierst, zeigt das Eigenschaften-Andockfenster alle Tags. Mehr über diese Tags erfährst du auf der DE:Map Features Wiki-Seite. Wenn du zum Beispiel einen fehlenden Briefkasten oder ein fehlendes Restaurant kennst, wähle den Menübefehl "Erstellen-Knoten", um den Punkt auf der Karte einzutragen. Dann gib die notwendigen tags an. Merkaartor vereinfacht dies mit dem DropDown "Nutzung" (amenity), welches eine Auswahl von vordefinierten Tags für häufig benutzte Dinge bereitstellt.

Ein aufgezeichneter GPS-Track kann mittels des Menübefehls Datei-Import in ein neues Layer geladen werden. Bevor du einen neuen Weg einträgst, stelle sicher, dass du die aktuellen OSM-Daten heruntergeladen hast, dann verwende "Erstellen-Straße", um den Weg zu zeichnen.

Wie bei den meisten anderen (aktuellen) Editoren auch, müssen Änderungen bei Merkaartor ausdrücklich hochgeladen werden. Verwende dazu "Datei-Hochladen". Natürlich musst du vorher im Einstellungsdialog (unter "Werkzeuge") deinen OSM-Namen und das Passwort angeben, davor ist der Hochlade-Menüpunkt nicht wählbar.

Installation

Linux, Mac OS X

Es sind mehrere Binärpakete für unterschiedliche Linux-Distributionen erhältlich. Details erfährst du auf der Merkaartor Download-Seite. Du kannst Merkaartor auch vom Quellcode kompilieren.

Voraussetzungen

Für Merkaartor ist die Trolltech Qt Version 4.3.3 oder neuer erforderlich (Quellen unter http://qt.nokia.com/downloads erhältlich, unter Umständen auch fertige Pakete für jede Linux-Distribution.)

Optionale Pakete

  • Qt ≥ 4.4 ist für die Yahoo!-Satelliten-Bildernutzung erforderlich
  • libxml2 + libxslt ist für das Rendern von SVG erforderlich
  • exiv2 ist für geo-getaggte Fotos erforderlich
  • Inkscape ist erforderlich, um von den zuvor gerenderten SVG-Dateien PNG-Dateien zu erzeugen

Windows

Ein Installationspaket für Windows kannst du von der Merkaartor Dateien-Seite herunterladen.

Es gibt eine gesonderte How-to über das Kompilieren von Merkaartor vom Quellcode mit Qt und MinGW auf Windows. Diese umfasst die Voraussetzungen und optionalen Bibliotheken. Windows binaries of the optional DLLs are included in the Windows installation package.

Hauptfenster

Die Karte

Interaktionen mit der Karte

Tasten:

  • Pfeile: Ansicht verschieben
  • +,-: Vergrößern/Verkleinern (zoomen)

Maus:

  • Linke Taste: siehe Tabelle unten (abhängig davon, ob "Bedienung mit einer Maustaste" in den Einstellungen gewählt ist oder nicht).
  • Rechte Taste: Klicken für Kontextmenü, Ziehen zum Verschieben, Strg+Ziehen zum Zoomen
  • Rad: Vergrößern/Verkleinern (zoomen)
Aktionen mit linker Maustaste
Funktion beide Tasten eine Taste
Merkmal auswählen Klick Klick
Merkmal zur Auswahl hinzufügen shift+Klick shift+Klick
Auswahl eines Merkmals umschalten Strg+Klick Strg+Klick
Merkmal aus der Auswahl entfernen - -
Auswahlrechteck Ziehen shift+Ziehen
Merkmahle wählen, die in das Auswahlrechteck hineinragen shift+Ziehen (1) alt+shift+Ziehen (1)
Merkmale innerhalb des Rechtecks abwählen oder umschalten - -
Merkmal verschieben (2) Ziehen Ziehen

Anm. (1) - wenn shift beim loslassen der Maustaste gedrückt ist.
Anm. (2) - ausgenommen der eigene Verschiebemodus ist aktiviert

Die Andock- oder Unterfenster

Viele Einzelheiten über die laufende Editiersitzung kann man in den Unterfenstern finden. Diese können frei links und rechts der Hauptkarte plaziert werden oder als gesonderte Fenster. Versehentlich geschlossene Unterfenster können im Menü " Fenster, Unterfenster, ... " wieder geöffnet werden.

Das Ebenen- oder Layers-Unterfenster

Die verschiedenen Datenquellen, wie Hintergrundkarte, GPS-Tracks, vom OSM-Server heruntergeladene Daten oder angefallene, noch hochzuladende Daten werden im Ebenen-Unterfenster angezeigt. Durch Linksklicken auf das kleine Augensymbol vor jeder Ebenenbezeichnung ist es möglich, bestimmte Ebenen anzuzeigen oder zu verbergen.

Ein Klick mit der rechten Maustaste auf ein Ebenenfeld öffnet das dazu gehörige Kontextmenü. Hier kann man die Durchsichtigkeit jedes Layers einstellen and zoom the visible area of the map to the bounding box of a layer's content.

Die Karten-Ebene ist dazu da darzustellen, was im Hintergrund gezeichnet ist. Es gibt verschiedene Server, aus denen man wählen kann, zum Beispiel der Mapnik Tile Server oder der tile@home-Server. Wenn Ihre Installation von Merkaartor Webkit-Unterstützung hat, können auch Yahoo-Luftaufnahmen angezeigt werden.


Die Download-Ebene enthält dasjenige, was vom Server abgerufen wurde, während die Arbeitsebene die Bearbeitungen enthält, die noch nicht auf den OpenStreetMap-Server hochgeladen wurden.


Geo Images

sample of Geo Image dock

The Geo Images dock is only available if explicitly compiled with this feature. It's being used to view geotagged images.

At least one track layer needs to be open (File - Import). After that, geotagged images can be opened using CTRL+o or through the menu. For each image, a small rectangle will appear on the map. By selecting the image icon (rectangle) the image will be shown in the Geo Images dock. Now you can start editing the map with all the relevant details you can derive from that image.

Use the mouse wheel to zoom the image or double-click it (hold CTRL to zoom out). If zoomed, you can click and hold the image to move it.

To select the next/previous image, press PAGE DOWN/UP respectively.

Das Menue

Datei

Neu
Öffnen
Importieren
Zuletzt geöffnet
Zuletzt importiert
Exportieren
Rendern

Das Rendern ist in Version 0.18 nicht mehr möglich.

  • Native
Allow the creation of a bitmap using the builtin, stylized, render engine.
  • Osmarender
Allow the creation of a SVG representation of the data, using Osmarender. Optionally, allow to create a bitmap from the SVG (requires Inkscape)
Speichern
Speichern unter
Herunterladen
Mehr herunterladen
Hochladen
Offline arbeiten
Beenden

Bearbeiten

Ansicht

GPS

Ebenen

Erstellen

Merkmal

Knoten

Straße

Relation

Werkzeuge

Stil
Objektvorlagen
Tastenkürzeleditor...
Welt-OSB-Manager...

Der Welt-OSB-Manager stellt im Wesentlichen den ganzen Planeten ohne Datenbank direkt offline zur Verfügung.

Der Planet ist in Regionen unterteilt, die heruntergeladen und in einem Binärformat (OSB) gespeichert werden.

Der Welt-OSB-Manager bewerkstelligt das Herunterladen der Regionen und die Umwandlung in das OSB-Format. Die Dateien werden im von Ihnen angegebenen Verzeichnis gespeichert ("Welt-Verzeichnis").

  • Select "Show grid" to display the grid of Regions. Regions already downloaded are hashed in green.
  • Click regions to tag them for download (blue hashing).
  • Click several time, until there is no hashing, to delete a region.
  • Click "Apply" to start the actual download from the API.

Thereafter, you can open the "world.osb" file in this directory, and every regions you downloaded will be available for display/change in Merkaartor.

TMS Servers Editor...
WMS Servers Editor...

The WMS Servers Editor allow you to add WMS servers to the list of WMS servers available as background images.

WMS-C Server
Merkaartor wmsc setup.jpg

Merkaartor support WMS-C servers as specified by the OSGeo recommendation.

More specifically, Merkaartor's implementation is based upon Metacarta Labs implementation of the recommendation in its TileCache product.

Basically, WMS-C defines a way to allow caching of WMS requests by offering a tiling interface (à la slippy map) to WMS servers, whose capability to provide images of arbitrary sizes and bounding boxes make them hard to cache.

When adding a server that support WMS-C, Merkaartor will detect this and inform the user, hiding un-relevant WMS information. The user can then just select the desired layer and click <Apply> (or <Add> if it is a brand new server).

Reset Discardable dialogs status
Preference...

Window

Help

Bearbeiten der Karte

Verschieben eines Knotens

Das Verschieben eines Knotens kann auf zwei unterschiedliche Weisen geschehen. Ist im Menü unter "Werkzeuge, Einstellungen, Visuell" das Kästchen vor "Seperater Verschieben-Modus" aktiviert (angekreuzt), wandelt sich der Mauscursor in ein besonderes kreuzförmiges Verschiebewerkzeug, sobald entweder im Menüpunkt "Bearbeiten" das "Verschieben" mit der linken Maustaste angeklickt wird oder aber das Verschieben-Feld in der oberen Iconleiste. Mit dem kreuzförmigen Cursor nunmehr auf den zu verschiebenden Knoten gehen, mit der linken Maustaste klicken und diese festhalten. Durch entsprechende Mausbewegungen verschiebt sich dann der ausgewählte Knoten. Fallenlassen des Knotens an der gewünschten Stelle geschieht durch Loslassen der linken Maustaste.

Ist das Kästchen vor "Separater Verschieben-Modus" nicht aktiviert, muss der zu verschiebende Knoten erst durch einen Linksklick mit der Maus auf diesen Punkt angewählt und die linke Maustaste wieder losgelassen werden. Wird nun mit dem Cursor auf diesem ausgewählten Knoten die linke Maustaste erneut gedrückt und festgehalten, kann der Knoten durch entsprechende Mausbewegungen verschoben werden. Fallenlassen des Knotens an der gewünschten Stelle geschieht hier ebenfalls durch Loslassen der linken Maustaste. Das vorherige Anklicken vor dem eigentlichen Verschieben dient dem Vermeiden versehentlichen Verschiebens.


Einen neuen Knoten setzen

Um einen neuen Knoten in die Karte einzufügen, in der Iconleiste den Button "Knoten" auswählen. Anschließend in der Karte an die gewünschte Stelle mit der linken Maustaste klicken. Es erscheint der neue Knoten in Form eines Fragezeichens und sollte ab der Version 0.14 von Merkaartor bereits ausgewählt sein. Wenn nicht, entweder in der Iconleiste oder im "Bearbeiten"-Menü "Auswählen" anklicken und anschließend mit der linken Maustaste den soeben eingefügten Knoten anwählen, um ihm zum Beispiel Eigenschaften zuzuweisen. (From 0.14 on the new node is automatically selected.)

Es ist möglich, einen neuen Knoten in einen bestehenden Weg einzufügen, um ihm einen passenderen Verlauf zu geben oder um andere Details einzusetzen. Dazu wie oben dargestellt verfahren und den Mauscursor an diejenige Stelle des Weges bewegen, an welcher der neue Knoten eingefügt werden soll. Sobald sich der Mauscursor über dem Weg befindet, leuchtet dieser auf. Jetzt mit der linken Maustaste klicken (Der Weg muss weiterhin aufleuchten), und der neue Knoten wird automatisch in den Weg eingefügt. Durch Verschieben dieses Punktes kann sodann dieser Weg ebenfalls modifiziert werden.

Soll der neue Knoten ausdrücklich nicht in einen existierenden Weg eingefügt, sondern nur dicht daneben gesetzt werden, drücke und halte die Tasten "Ctrl" (Strg) und "Alt", um ein automatisches "Einrasten" des Knotens in den Weg zu verhindern.

Einen neuen Weg erstellen

Vergewissere dich, dass du keinen Knoten ausgewählt hast, bevor du beginnst, einen neuen Weg zu erstellen. Zum Einfügen klicke auf den Button "Weg" in der Iconleiste und aktiviere so die Einfügefunktion für Wege. Anschließend klicke auf der Karte an die Stelle, an welcher der erste Knoten des neuen Weges gesetzt werden soll. Dann bewege den Mauscursor an die Stelle der Karte, an welcher der zweite Knoten entstehen soll. Während du den Cursor über die Karte bewegst, erscheint entlang der Strecke, die der Cursor verschoben wird, eine Vorschaulinie zusammen mit Angabe der Strecke seit dem letzten gesetzten Knoten. Auf dieselbe Weise können weitere, zum neuen Weg gehörende Knoten setzen. Nachdem du den letzten Knoten hinzugefügt hast, drücke die Escape-Taste oder wähle den Auswählen-Button, um die Einfügefunktion an dieser Stelle zu beenden. Der neue Weg erscheint als dünne schwarze Linie. Seit der Version v0.14 von Merkaartor sollte der neue Weg automatisch ausgewählt sein, sodass ihm sofort Tags hinzugefügt werden können. Falls dies nicht der Fall ist, klicke mit der Maus auf den Button "Auswählen" in der Iconleiste und wähle zunächst den neuen Weg aus.

Wenn du den Mauscursor über einen bestehenden Knoten oder einen bestehenden Weg bewegst, "rastet" er dort ein. Auf diese Weise kannst du einen neuen Weg an einem schon bestehenden Knoten oder mitten an einem bestehenden Weg beginnen oder beenden. Tue dies, wann immer eine Verbindung zwischen einem bestehenden Objekt und dem neuen Weg vorhanden sein soll, zum Beispiel an Straßenkreuzungen.


Soll der Knoten des neuen Weges ausdrücklich nicht in einen existierenden Weg eingefügt, sondern nur dicht daneben gesetzt werden, drücke und halte die Tasten "Ctrl" (Strg) und "Alt", um ein automatisches "Einrasten" des Knotens in den Weg zu verhindern. Dies ist nützlich, um Straßen nahe von Flächen einzufügen, wenn beide Objekte keinen direkten Kontakt miteinander haben.

Einen bestehenden Weg verlängern

Benutze das Auswählen-Werkzeug, um einen Knoten am Ende desjenigen Weges auszuwählen, der verlängert werden soll. Anschließend klicke auf den Button "Weg" in der Iconleiste, um an den Weg weitere Stücke anzufügen, wie im vorhergehenden Absatz beschrieben.

Der ausgewählte Knoten ist der erste Knoten für das Wegsegment, das du anfügst. Befindet sich dieser Knoten am Ende einer einzelnen Straße, wird diese Straße um die weiteren gesetzten Knoten verlängert. Liegt der ausgewählte Knoten mittendrin in einer Straße oder am Ende mehrerer Straßen, wird eine neue Straße gesetzt.

Entfernen eines Knotens

Die Entfernung eines Knoten lässt ihn völlig verschwinden! Man kann einen einzelnen Knoten oder mehrere aus einem Weg entfernen. Passen Sie auf, dass Sie nicht versehentlich ein besonderes Kartenmerkmal eines Wegknotens löschen. Benutzen Sie das Auswählen-Werkzeug, um den Knoten (nicht den Weg), den Sie löschen wollen, zu markieren. Anschließend klicken Sie auf den "Entfernen"-Button in der Iconleiste oder drücken Sie die Taste "Entf" bzw. "Del".

Entfernen eines kompletten Weges funktioniert entsprechend. Zumindest in der Version v0.16.3 von Merkaartor erscheint vor dem endgültigen Löschen des Weges in einem Pop-Up-Fenster die Frage, ob die Unterknoten ebenfalls gelöscht werden sollen. Gemeint sind damit die einzelnen Knoten, zwischen denen der Weg verläuft. Wird die Frage bejaht, löscht Merkaartor sowohl den Weg als auch alle diesem zugehörigen Knoten. Bei Verneinung bleiben die Knoten erhalten.

Aufteilen/Auftrennen einer Straße

Aufteilen einer Straße ist eine gängige Tätigkeit, um eine einzige Straße in zwei Segmente aufzuteilen, damit diesen unterschiedliche Eigenschaften (Tags) zugewiesen werden können, wie zum Beispiel unterschiedliche Straßennamen oder Geschwindigkeitsbegrenzungen. Benutze das Auswählen-Werkzeug, um diejenige Straße auszuwählen, die geteilt werden soll. Danach halte die Shift-Taste gedrückt und wähle denjenigen Knoten der Straße aus, an dem die Straße geteilt werden soll. Anschließend klicke

- in der Version v0.16.3 auf den linken der beiden"Auftrennen"-Buttons (Es erscheint ein Pop-up-Fenster mit "Trenne Weg in einzelne (verbundene) Wege")

bzw.

- in der Version v0.17.0 auf den "Auftrennen"-Button (Es erscheint ein Pop-up-Fenster mit "Weg in einzelne (verbundene) Wege teilen")

in der Iconleiste, um die Straße aufzuteilen. Nun kannst du das Auswählen-Werkzeug verwenden, um beide Segmente der Straße getrennt zu bearbeiten.

In einfachen Fällen kann es ausreichend sein, ausschließlich den Knoten auszuwählen, nicht jedoch ausdrücklich die Straße, zu der er gehört, bevor du das Auftrennen-Werkzeug einsetzen.

Du kannst auf einmal mehrere Knoten einer Straße auswählen, um die Straße in einem Rutsch in mehr als zwei Teile aufzuteilen. Das bietet sich beispielsweise an, um ein kleines Stück einer Straße abweichend von der übrigen Straße zu taggen, wie dies bei einer Brücke der Fall ist.

Aufteilen einer Straße bedeutet nicht vollständige Trennung der Verbindung zwischen den einzelnen Straßenstücken. Das Aufteilen erlaubt es nur, den einzelnen Straßenstücken unterschiedliche Eigenschaften zuzuweisen.

Lies im nächsten Abschnitt, wie miteinander verbundene Straßen derart getrennt werden, dass ihre Endknoten unabhängig voneinander verschoben werden können.

Trennen miteinander verbundener Straßen

Miteinander verbundene Straßen teilen sich normalerweise einen gemeinsamen Knoten an demjenigen Ende, an dem sie verbunden sind. Wird das Ende der einen Straße verschoben, verschiebt sich deshalb auch das Ende der anderen Straße. Um die Verbindung der beiden Straßen zu lösen, wähle mit dem Auswählen-Werkzeug unter Drücken und Halten der Shift-Taste die beiden Straßen und den gemeinsamen Punkt aus. Anschließend klicke auf den äußeren "Auftrennen"-Button (In v0.16.3 erscheint ein kleines Pop-up-Fenster mit "Trenne verbundene Straßen auf") in der Iconleiste. Dadurch wird der gemeinsame Knoten verdoppelt, wodurch sich die beiden Straßen trennen. Dabei bleiben die bisher dem einen Knoten zugewiesenen Eigenschaften bei beiden Knoten erhalten.

Da sich jedoch beide Knoten an derselben Position befinden, kannst du erst einmal nur einen Knoten auswählen. Sobald dieser verschoben ist, wird auch der zweite Knoten sichtbar und kann ebenfalls mit der anhängenden Straße verschoben werden. Dies funktioniert genauso, wie oben unter "Verschieben eines Knotens" beschrieben.

Auftrennen von zwei Straßen, die noch mit einer dritten Straße verbunden sind, trennt zwar diese beiden Straßen. Andere Verbindungen von zuvor miteinander verbundenen Straßen können jedoch erhalten bleiben. Um sämtliche Straßen, die in einem Knoten verbunden sind, voneinander zu trennen, müssen alle Wege, die durch den Knoten gehen, ausgewählt werden (wie oben beschrieben).

Zwei Straßen verbinden

Straßen können der Karte in mehreren Schritten hinzugefügt werden. Wenn du eine Straße dadurch verlängert hast, dass du einen neuen Weg am Endpunkt einer anderen Straße begonnen oder beendet hast, hast du grundsätzlich zwar zwei miteinander im Zusammenhang stehende, aber doch getrennte Straßenstücke. Getrennte Straßenstücke sind schwieriger zu unterhalten, weil Eigenschaften oder Änderungen an mehr Wegen vorgenommen werden müssen. Wenn beide Straßenstücke dieselben Eigenschaftentags haben sollen, wähle sie, wie oben beschrieben, beide aus, um sie zu vereinigen. Benutze anschließend den Menübefehl " Weg " und "Verbinden" oder klicke in der Icon-Leiste den Button "Verbinden" (Merkaartor v0.17.0)an, um sie zu einem einzigen Weg zu verschmelzen.

If you have extended a road by creating a new way starting or ending at another road's endpoint, you basically have two connected but separate roads. Separated roads are harder to maintain because features must be added or changed to more ways. If both roads shall have the same tags, use the Select tool to select both roads to join. Then use the menu command "Road, Join" to combine both ways into a single way.

Should both roads have set different values for common tags, their values are concatenated in the joined road. The combined road has all tags assigned that either road had assigned before, i.e. the tag set is united.

Du kannst Straßen nicht miteinander verbinden, die nicht an einem gemeinsamen Endpunkt miteinander verbunden sind; d. h. du kannst Straßen nicht miteinander verbinden, die über eine Abzweigung oder eine Kreuzung miteinander verbunden sind.

Lies oben, wie eine Straße an einem bestimmten Punkt aufgeteilt wird.

Detaching a node from a way

Detaching a node from a way, you can move it around without altering the way it was part of. This can also help to correct situations when you have moved a node too near to a way so that it has become a part of the way. Use the Select tool to select the node you want to detach from a way. Then use the menu command "Node, Detach" to detach the node from the way. You can now use the Move tool to further move the node somewhere else.

This feature is available from version 0.14 on.

Editing tags of an object

To edit the tags of an object (node, way or relation), select the object and add or change the tags in the "Properties" dock. You can edit a tag name or value by either clicking once on the table cell and start typing, or first double-click the table cell to get a text input field (if your first typing character would be an application hotkey). To add a new tag, select the last row of that table. To delete a tag/value pair from the selected object(s), select it in the table and click on the delete button right above the tags table (the one with the red X on it).

Keyboard Shortcuts

Listing only the most important shortcuts which help during the editing process

  • ESC Switch to "Select" mode
  • DEL Delete selected object
  • Ctrl-M Switch to "Move object" mode
  • Ctrl-N Switch to "Create Nodes" mode
  • Ctrl-R Switch to "Create Streets" mode
  • Ctrl-D Download OSM data
  • Ctrl-U Upload your changes to OSM

Roads

  • Alt-S Split: Select a road-node where to split. The result is two roads which are still connected by the one node.
  • Alt-B Break apart: Select two connected roads (connected by one node) and they will become separated (two nodes).
  • Alt-J Join: Select 2 streets to combine them. Attributes (keys) will be preserved. Conflicting attributes are concatenated with ";".

Nodes

  • Alt-M Merge: Select 2 or more nodes and they become one. Handy for resolving "nodes on the same spot" errors.
  • Alt-A Align: ???

Selection

  • TAB: After selecting node-road, press Tab to cycle through the nearby/overlapping elements

Relations

Adding to a relation

NOTE: this needs a Merkaartor newer than version 0.13.

  1. Select the relation to add a member to. To do so, click on the dashed bounding box around a relation. For more clarity, you can enable "Show" - "Show Relations"
  2. Ctrl-click the feature (road or other) to add to the relation
  3. Select "Relation" - "Add Member"

Styles and templates

You can change the way Merkaartor render the map under Tools->Style. Read more about styles.

Troubleshooting

If you have any problems with Merkaartor or think that something went wrong, this section may or may not have the answer for you.

Yahoo imagery offset

If the Yahoo background image is offset by a fair amount (about 240 pixels on the screen in all zoom levels) or the map tiles won't fit together after zooming, use the menu command "Layers, Map - Yahoo, Yahoo adapter" to align the background image correctly again. This always seems to happen when you start Merkaartor with the Yahoo Map layer disabled and then enable it after downloading some OSM data.

Should the Map item be missing in the Layers menu, you can also use the context menu on the Map layer from the Layers dock.

If the imagery is only a few metres off, that's by design and cannot easily be corrected.

Property window keeps growing

Every time one clicks into the main window the property window size increases both horizontally and vertically. It's not possible to make the window smaller by moving the divider. This makes it impossible to use the program after a while.

Solution: This a Qt issue, solved in 4.5.1. Select a custom Qt style like skulpture or cleanlooks in Preference-visual.


Adding Additional Projections

When you install Merkaartor, it includes support for two spatial reference systems: Lat/Long (epsg:4326) and World Mercator (epsg:3785). It is pretty easy to add support for additional spatial reference systems. The most common case for wanting to do this is when there are Web Map Services (WMS) that can be used for tracing/editing, but those services do not support one of the two default spatial reference systems.

To add support for a new spatial reference system, you just need to add a definition for that projection to the file that stores this information. Here are the steps:

  1. Merkaartor projections are stored in Proj.4 format. An easy way to get the definition for your spatial reference system(SRS) in the correct format is to go to spatialreference.org and search for it. Once you locate the correct SRS, click the link that will give you the SRS definition in Proj.4 format. Here is a link to UTM Zone15N NAD83
  2. Projections are stored in a file called Projections.xml. This file is located in a hidden folder called merkaartor in the user's home directory. On Mac OS X or Linux, the path is ~/.merkaartor/Projections.xml. On Windows, it is at %HOMEDRIVE%%HOMEPATH%\.merkaartor (e.g. c:\Users\MyUser\.merkaartor). Note the dot character at the beginning of the folder name, it indicates that the folder is hidden.
  3. Find this file and make a backup. Open Projections.xml with your favorite text editor. Copy one of the other Projection elements and paste in the Proj.4 definition that you got from spatialreference.org. Here is a new entry for UTM Zone15N: <Projection name="UTM 15N NAD83 (epsg:26915)" >+proj=utm +zone=15 +ellps=GRS80 +datum=NAD83 +units=m +no_defs </Projection>.
  4. Start up Merkaartor and go to View>Set Projection. You should see your new SRS listed there.


This is the full file after edition:

<?xml version="1.0"?>
<MerkaartorList>
 <Projections creator="Merkaartor 0.14" >
  <Projection name="Mercator (epsg:3785)" >+proj=merc +lat_ts=0.0 +lon_0=0.0 +x_0=0.0 +y_0=0 +k=1.0 +ellps=WGS84 +datum=WGS84 +no_defs</Projection>
  <Projection name="EPSG:4326" >+proj=longlat +ellps=WGS84 +datum=WGS84 +no_defs +to_meter=0.017453292519943295769236907684886</Projection>
  <Projection name="UTM 15N NAD83 (epsg:26915)" >+proj=utm +zone=15 +ellps=GRS80 +datum=NAD83 +units=m +no_defs </Projection> 
 </Projections>
</MerkaartorList>

See Also

OSB file format specification V2