FR:QGIS

From OpenStreetMap Wiki
Jump to: navigation, search
Langues disponibles — QGIS
· Afrikaans · Alemannisch · aragonés · asturianu · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · Bân-lâm-gú · Basa Jawa · Baso Minangkabau · bosanski · brezhoneg · català · čeština · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · Kurdî · latviešu · Lëtzebuergesch · lietuvių · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk bokmål · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · português do Brasil · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tiếng Việt · Türkçe · Vahcuengh · vèneto · Wolof · Yorùbá · Zazaki · српски / srpski · беларуская · български · қазақша · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · मराठी · हिन्दी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 吴语 · 粵語 · 中文(繁體)‎ · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް
QGIS
Screenshot of QGIS
Site web : http://qgis.org/
Version : 2.14.2 (2016-02-25)
Licence : GPL (gratuit)
Plateformes : Windows, Linux, macOS et Android
Languages de programmation : C++ et Python

a free, multiplatform GIS application

Texte partiellement traduit de l'anglais vers le français

QGIS (connu aussi sous le nom de Quantum GIS) est un logiciel de SIG libre (open source : GNU GPL v2) et gratuit. Il permet la visualisation, la gestion, l'édition, l'analyse et la création de cartes. Qgis est disponible pour Linux, Unix, Mac OSX, Windows et Android et peut être téléchargé gratuitement sur le site officiel du logiciel (qgis.org).

OpenStreetMap dans QGIS

QGIS2 et les vecteurs d'OpenStreetMap

QGIS 2.0 intègre nativement l'import de couches OpenStreetMap. Pour obtenir des données OSM:

  • Menu "Vecteur -> Openstreetmap -> Télécharger les données" vous connectera aux serveurs OSM et téléchargera des données. Vous pouvez sauter cette étape si vous avez déjà un fichier XML .osm.
  • "Importer la topologie depuis un fichier XML" convertira votre fichier .osm en base de données spatialite et créera un connection à cette base.
  • "Exporter la topologie OSM en Spatialite" vous connectera à la base de données, vous pourrez sélection le type de données voulu ( point, lignes, polygones) et choisir les tags à importer. Cette étape créera des couches spatialite géométriques que vous pourrez alors ajouter à votre projet Qgis via le menu "ajouter une couche spatialite".

Plus de détails ici (anglais).

OpenStreetMap Plugin (obsolète)

Pour les versions de Qgis antérieurs à la version 2: Le plugin OSM pour QGIS vous permettra de charger des données vecteur depuis OpenStreetMap, le cas échéant de les éditer et de mettre en ligne votre contribution. Cependant suite à un bug le plugin ne fonctionne pas avec les données actuelles. (voir page liée pour plus d'infos).

Shapefiles, PostGIS et autres options de conversion

Il existe de nombreuses manières de convertir les données OSM vers d'autres formats (anglais) pouvant être ouverts dans QGIS. In particular note the various options for Shapefiles and PostGIS databases.

Using raster maps from OpenStreetMap

There's a couple of different approaches to bring in tiles from OpenStreetMap (or from other OpenStreetMap tile providers) :

The QGIS OpenLayers Plugin probably offers the easiest way. In QGIS2.0 go to "Plugins" menu -> "Manage Installed Plugins...", then search for OpenLayers under 'Get More'. In older 1.x QGIS you need to enable the "Plugin Installer" from the Plugin Manager and then from "Plugins" -> "Fetch Python Plugins" and select the "Openlayers Plugin". The list of available OSM tile layers then appears from the "Plugins" -> "OpenLayers plugin" menu.

GDAL support is built in, so you can make a GDAL XML config and load this as a raster layer.

See Question:How to get OpenStreetMap as a raster layer in QGIS?

Quantumnik for style authoring

Quantumnik ([1]) is a python plugin for Mapnik style authoring in QGIS.

General QGIS info

See also wikipedia:Quantum GIS.

Features

The major features of QGIS include:

  • Direct viewing and exploration of spatial data
    • Advanced symbology (edit rendering styles)
    • QGIS Browser as a simple and fast data viewer
  • Support for numerous vector, raster, and database formats
  • Create, edit and export spatial data
    • Work with nodes, lines and polygons
    • Convert between different coordinate systems (re-projection)
    • Down/upload directly to a GPS unit
  • Perform spatial analysis
    • Find polygon centroids and basic statistics
    • Distance matrix and line intersections
  • Publish your map on the internet
  • An extensible plug-in architecture
  • Remote control JOSM [2]

Documentation & Tutorials

Rendering of Gallarate (see the 'Using OpenStreetMap data' tutorial).

The QGIS wiki provides numerous guides and video tutorials to help users of all abilities. For new users a good place to start is the Introduction to Quantum GIS video. It is also important to have a basic understanding about the #Coordinate Reference System.

Other useful pages to bookmark:

  1. The free Beginning Quantum GIS pdf guide (produced by learnosm.
  2. How do I do that in QGIS on the QGIS wiki.
  3. Quantum GIS Tutorials by Ujaval Gandhi.

The new QGIS version 1.7.0 allows to create advance symbology (similar to Mapnik or Osmarender) in a powerful but very easy way (a few mouse click), see examples here and a detailed video on youtube.

Coordinate Reference System

Earth is a three-dimensional body, roughly spherical in shape, yet the vast majority of maps are flat (2-dimesional). A Coordinate Reference System (CRS) defines a method of projecting all or part of the Earth onto a 2D surface. QGIS has support for approximately 2,700 known CRS. Some, such as WGS-84 are global projections, whereas others represent only specific regions.

Setting the CRS

When working with geo-spatial data it is essential that you are using the correct CRS. If you are lucky the projection will be specified as part of the vector file (for example, ESRI Shapefiles often include projection data in the .prj file), however you will often have to manually select the correct CRS.

To specify the CRS of a vector layer, select the layer and choice Layer->Set CRS of Layer(s).... Each layer can have a different CRS. If this is the case, you will need to convert them to the same CRS in order for them all to display correctly. The easiest way to do this is to use 'on the fly' CRS transformation:

  1. Settings->Project Properties (or click on the globe symbol in the lower right corner).
  2. Select the Coordinate Reference System (CRS) tab.
  3. Check the Enable 'on the fly' CRS transformation checkbox.
  4. Pick a suitable project CRS to work with (e.g. WGS-84).

More information can be found in this video tutorial.

Using QGIS to convert between CRS

QGIS can be used to convert between CRS. Open the input layer making sure to select the correct CRS as described above. Use Layer->Save As... to export the layer with a different CRS (you may choice between the "Project" CRS or select a CRS from QGIS's extensive list).

See also

External links