Hu:JOSM/Advanced editing

From OpenStreetMap Wiki
Jump to: navigation, search
Más nyelveken — JOSM/Advanced editing
· Afrikaans · Alemannisch · aragonés · asturianu · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · Bân-lâm-gú · Basa Jawa · Baso Minangkabau · bosanski · brezhoneg · català · čeština · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · Kurdî · latviešu · Lëtzebuergesch · lietuvių · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk bokmål · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · português do Brasil · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tiếng Việt · Türkçe · Vahcuengh · vèneto · Wolof · Yorùbá · Zazaki · српски / srpski · беларуская · български · қазақша · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · मराठी · हिन्दी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 吴语 · 粵語 · 中文(繁體)‎ · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް
  Bevezetés   Egyszerű szerkesztések   Haladó szerkesztések   Bővítmények   Gyorsbillentyűk(en) ±

Ezen az oldalon a JOSM szerkesztőprogram további lehetőségeivel ismerkedhetsz meg.

.OSM fájlok betöltése és kimentése

Általában legcélszerűbb a térképi adatokat közvetlenül az OSM szerverről letölteni, illetve oda feltöltve menteni. A feltöltéssel gyakorlatilag mentetted is a munkádat, sőt publikáltad és lehetővé tetted, hogy mások is tovább szerkeszthessék. Elvégre erről szól az OpenStreetMap!

Emellett a JOSM lehetőséget biztosít arra, hogy a térképet a gépeden helyi fájlba mentsd, illetve onnan betöltsd, hasonlóan a más programokhoz.

A Fájl -> Mentés másként... menüponttal a térképet és a változtatásaidat kimentheted egy fájlba.

A Fájl -> Megnyitás... kiválasztásával pedig betöltheted további szerkesztésre vagy feltöltésre.

A JOSM fájl formátumaen megegyezik a szabványos .osm XML formátummal. A JOSM annyival bővíti ki ezt, hogy a változtatásokat is nyilvántarthassa, amelyek még nem kerültek feltöltésre. Ezzel a lehetőséggel a JOSM akár offline szerkesztőként is használható.

Offline szerkesztés

Amikor van internet kapcsolat:

  • Töltsd le a szerkeszteni kívánt területet (lehet több egymáshoz nem kapcsolódó terület is).
  • Mentsd el .osm fájlként a gépeden.

Amikor nincs internet:

  • Nyisd meg a fájlt!
  • Megnyithatsz GPS nyomvonalakat is alátét rétegnek.
  • Szerkeszd a térképet (például a GPS nyomvonalaid alapján)!
  • Mentsd el a változtatásaid a fájlba! (A fájl tudja tárolni a meglévő elemeken végzett módosításokat és a törléseket is.)

Amikor újra van internet:

  • Nyisd meg az .osm fájlodat a JOSM-ban!
  • A Fájl -> Adatok frissítése pontjával frissítsd a már letöltött területet. Oldd meg az ütközéseket (lásd lentebb)!
  • A szokásos módon töltsd fel a változtatásaidat az OpenStreetMap-re!

Szűrt adatok

Az OpenStreetMap adatok egy leszűrt készletén is dolgozhatsz a JOSM-ban, például adott típusú pontok vagy valamilyen témához kapcsolódó adatok. Az gépeden lévő OSM fájlokból az osmosis, osmconvert vagy osmfilter és hasonló eszközökkel készíthetsz leszűrt adatállományt. Hasonló leszűrt adatokhoz juthatsz az XAPI és Overpass API szolgáltatásokból való letöltéssel. A szűrt adatfájlt a JOSM-ban megnyitva szerkesztheted, de meglévő elemek törlése vagy módosítása előtt mindenképpen töltsd le manuálisan a környékét, hogy tiszta képed legyen a kapcsolódó elemekről.

Ütközések feloldása

Amíg a JOSM-ban dolgozol, megeshet, hogy mások ugyanazon a környéken végeznek módosításokat. Mivel a JOSM csak akkor tölt le bármit is, amikor erre utasítod, igen sokáig dolgozhatsz egy területen anélkül, hogy észrevennéd, hogy a változtatásaid másokéval ütköznek. Általában érdemes rendszeresen feltölteni a változtatásokat, az ütközés esélyének a minimalizálásra. De ekkor is érdemes az adatokat frissíteni a feltöltés előtt (Fájl -> Adatok frissítése), hogy áttekinthesd, hogy más felhasználók időközben mit változtattak azon a környéken. Nem kell aggódni, a letöltés a saját változtatásaidat nem fogja felülírni.

Az ugyanazon területen történt változtatásokat mindenképpen hasznos áttekinteni, a feltöltés előtt. Ha valaki ugyanazt az elemet módosította, amelyet te is, a JOSM ütközést (conflict) fog jelezni. Ekkor az adataid még nincsenek feltöltve, meg kell oldanod az ütközéseket a feltöltés előtt! A JOSM lehetőséget biztosít, hogy eldönthesd, hogy a saját vagy a mások változtatásait szeretnéd megtartani az egyes elemeken. Amikor minden ütközést megoldottál, feltöltheted a szerkesztéseidet.

Konflikte loesen.png
Ezzel az ikonnal jelenítheted meg az ütközések panelt a jobb oldalon. Az egyes ütközések sorára kattintva megnyílik egy ablak, amiben megoldhatod a problémákat, az általad vagy a mások által végzett módosítások megtartásával. A különböző fülek és nézetek segítenek eldönteni, hogy vajon milyen döntést hozz: saját vagy a másoké? A „másoké” (theirs) reprezentálja azt az állapotot ami jelenleg fent van már az OSM szerveren, de azóta történt rajta változtatás, hogy te eredetileg letöltötted.

Szétválasztás és kibogozás

Az Egyszerű szerkesztések fejezetben tárgyaltuk az egyes pontok és vonalak szerkesztését és az olyan egyszerű műveleteket mint vonalak szétvágása, összekapcsolása vagy megfordítása. Bonyolódnak a dolgok, ha az adatok nagyon egybefonódnak, átfedésben vannak vagy egyszerűen össze vannak gabalyodva. Ne felejtsd el, hogy a változtatásaidat mindig visszavonhatod (a „Visszavonás” gombbal), tehát nyugodtan próbálgathatod megfejteni, hogy mi a helyzet az adatokkal. Átmenetileg arrébb is rakhatsz vagy törölhetsz elemeket, hogy megértsd azok átfedését vagy kapcsolatát, persze utána visszavonva ezeket a műveleteket. Szerkesztési technikák:

Átfedő vonalakról akkor beszélünk, ha két vagy több vonal pontosan egymásra van rajzolva, ugyanazon pontok között. Ez lehet tévedés vagy szolgálhat valamilyen cél. Két utca például biztosan nem szándékosan szerepel átfedésben, de lehet például két különböző földterület határa és ugyanott még egy utca is, máris 3 vonal fut egymáson. Szükség lehet arra, hogy az átfedésben lévő vonalak egyikét kiválaszd:

  • Kattints a középső gombbal az elemre, ekkor az átfedésben lévő elemek megjelennek egy menüben.
  • A Ctrl nyomva tartása mellett ebben a menüben kattintva kijelölheted a kívánt elemet.
  • Másik megoldás, hogy kattogsz a középső gombbal az elemek közötti lépkedéshez.
  • Ha nincs az egereden középső gomb, a jobb oldali Alt billentyű nyomva tartása mellett kattintgass a fedésben lévő elemekre.

Vonalak szétválasztásához a Eszközök -> Vonalak szétválasztása menüt használhatod. Ha két vagy több vonal egy pontban találkozik, ez a menü újabb pontokat fog ugyanott létrehozni, hogy az egyes vonalakat különválassza. Figyelj arra, hogy ezzel átfedésben lévő pontokat hozol létre, ami egy szerkesztési hiba! A szétválasztás után az egyiket mozgasd el - ha ez volt a célod a szétválasztással vagy ha csak meg szeretnéd nézni mi történt. Ne hagyj egymáson szétválasztott pontokat, ez félreértésekhez és hibás útvonaltervezéshez vezethet. Ha vonalak szétválasztásakor nem pont, hanem egy vonal van kijelölve, akkor a művelet annak minden csatlakozását szétválasztja. Ha mégis egyben kell maradnia bizonyos pontoknak, a Eszközök -> Pontok egyesítése menüponttal összekapcsolhatod őket. (Ez az egymáshoz közeli pontokat is egy helyre mozgatja!)

Egy ügyes fogás, ha arrébb raksz elemeket majd visszavonod a változtatást, azért hogy kiderítsd az egyes elemek pontos kapcsolatát és átfedéseket vagy, hogy egy pontban vajon valóban egyesítve vannak-e a pontok. Ha szét vannak választva vagy a szerkesztés miatt átmenetileg szétválasztottad, akkor a mozgatás után kijelölheted azokat amivel dolgozni szeretnél, majd visszavonva a mozgatást a kijelölés továbbra is megmarad, így azon folytathatod a módosításokat.

Ezek a műveletek nagyon hasznosak, ha összetettebb adatokkal kell dolgozni. Az Eszközökmenüben további hasonló műveleteket találhatsz, illetve bizonyos bővítmények még több hasonló lehetőséget biztosítanak (pl. More tools bővítmény).

Kapcsolatok

A kapcsolatok lehetőséget biztosítanak összetettebb tulajdonságok meghatározására, mint például tömegközlekedési járatok útvonala vagy kanyarodási korlátozások. A kapcsolatokba pontokat, vonalakat vagy másik kapcsolatokat szervezhetünk. A kapcsolat minden tagjához meghatározható a kapcsolatban betöltött szerepe (role), és a kapcsolatnak magának is lehetnek címkéi. Lásd a Kapcsolatoken oldalt.

A JOSM-ban lehetőség van a kapcsolatok „nyers” szerkesztésére. A szerkesztési ablakot többféleképp elérheted.

Liste aller Relationen.png
Ezzel az ikonnal megjelenítheted a kapcsolatok panelt. A panelen a jelenleg letöltött összes kapcsolat látható és lehetőség van szerkesztésre, törlésre, kiválasztásra, lemásolásra vagy új kapcsolat létrehozására.

A Tulajdonságok/Tagságok panelen, amelyet általában a címkézésre használsz, szintén megjelennek az éppen kiválasztott elemek kapcsolatai (tehát amely kapcsolatokban az adott elem tagként szerepel).

Új kapcsolat létrehozásához a kapcsolatok panelen lévő gombot kell használni, de meglévők szerkesztéséhez mindkét panel használható. A kapcsolat szerkesztő párbeszédablak 3 fő részre van tagolva. Legfelül a kapcsolat címkéit szerkesztheted. Lent, a bal oldalon azok az elemek vannak felsorolva, amelyek már tagjai a kapcsolatnak, egy külön oszloppal a szerepük megadására. A lista sorrendjének bizonyos kapcsolatoknál fontos szerepe van, az elemeket az oldalt látható ikonokkal mozgathatod. Lent, a jobb oldalon a térképen aktuálisan kiválasztott elemek listáját láthatod. A térképen kijelölhetsz más elemeket, ez a lista dinamikusan frissülni fog, így könnyen kiválaszthatod azokat az elemeket amelyeket a kapcsolathoz hozzá szeretnél adni.

Nagyon tömören így működik a kapcsolat szerkesztő ablak. A lehetőségek részletes leírást a JOSM dokumentáció 'Kapcsolatok' oldalán en találod. (Lásd még: OSMtippek: Kapcsolatokról röviden és egyszerűen - ford.)

Címkézési készletek

A JOSM-ban lehetőség van címkézési készletek használatára. Ezek XML fájlok, amelyek dialógus ablakokat definiálnak bizonyos elemek egyszerű címkézéséhez, a JOSM Címkék menüjén keresztül. Az XML fájlok bárhol lehetnek az interneten vagy a gépeden: ezeket a Szerkesztés -> Beállítások -> Térképbeállítások ablakban, a Címke készletek (Taggig presets) fülön nyithatod meg. A Címkék menü vagy egyes gombok hozzáadhatók az eszköztárhoz is, a Beállítások > Eszköztár testreszabása menüpontban.

További információk:



Következő >>

Ez ugyan már haladó szint, de még nagyon sok érdekességet lehet találni a JOSM bővítményekben is.