Hu:JOSM tippek

From OpenStreetMap Wiki
(Redirected from Hu:JOSM tips)
Jump to: navigation, search
JOSM kézikönyv    mvsz

Tippek és trükkök a JOSM használatához.

CTRL, SHIFT, ALT

  • Vonalrajzolás közben használjuk a CTRL, ALT, SHIFT billentyűk által nyújtott lehetőségeket. A CTRL nyomva tartása kikapcsolja a pontra illesztést vagy „tapadást” (snapping), illetve bekapcsolja azt, ha ki van kapcsolva. Utóbbi esetre példa amikor egy kijelölt pontot mozgatunk egérrel, alaphelyzetben ez nem tapadna hozzá egy közeli ponthoz. A CTRL-lal ezt megfordíthatjuk.
  • Ha az ALT nyomva tartása mellett kattintunk, akkor a JOSM új vonalszakaszt kezd a rajzolás megszakítása nélkül. Enélkül dupla kattintással kellene lezárnunk az előző vonalat, törölni a vonal kijelölését (különben folytatná a vonalat), majd még egy kattintás kell az új vonal megkezdéséhez.
  • A SHIFT módosító szintén új vonalat kezd, de kihagyja a közbenső szakaszt.


Vonal mozgatása alaktartással, pontra illesztéssel

Lehetőség van alakzat mozgatására pont illesztéssel is. Jelöljük ki az alakzatot, majd CTRL-al pluszban az illesztendő pontját is. A CTRL felengedése után mozgassuk a helyére az alakzatot, majd CTRL ismételt lenyomásával kapcsoljuk be a tapadást és az illesztési ponthoz mozgatjuk az alakzatot. A két pont egyesült, de az alakzat nem torzult el.


Szögtartás

Szabályos alakzat rajzolása JOSM-ban

Szabályos alakzatok rajzolásához nélkülözhetetlen az 'A' billentyű másodszori megnyomásával bekapcsolható szögigazítás (angle snapping). Bekapcsolását a zöld színre váltó szög ikon jelzi az állapotsoron. Érdemes egy jobb gombot nyomni ezen az ikonon és a további opciókat is bekapcsolni:

  • „Segédvonal megjelenítése” (Show helper geometry) -> sárga szaggatott vonal megjelenése jelzi az igazítást,
  • „Illesztés a pontok” (Snap to node projections) -> a rajzolt vonal előző pontjaira merőleges segédvonal jelenik így segítve például az épület rajzolást.
  • 0,90...
  • 0,45,90...
  • 0,300,45... -> A szögigazítás „lépésköze”

Bekapcsolt szögtartás mellett a vonal az előzőleg rajzolt vonalszakaszhoz képest az új szakasz a megadott szöghöz közeledve „tapadni” fog, amit a megjelenő sárga szaggatott segédvonal jelez, illetve a kurzor mellett megjelenő szögérték jelzi, hogy hány fokos szöget zár be a rajzolt szakasz az előző szakasszal.


Szögtartás bázisvonal-kiválasztással

Szögtartás a bázisvonal kiválasztásával JOSM-ban

Bekapcsolt szögtartás mellett a CTRL billentyűnek egy további funkciója is lesz. Ha nyomva tartjuk, a kurzor alatti tetszőleges vonalszakasz lesz a rajzolás viszonyítási szakasza a továbbiakban. Sokszor nem érzékeli elsőre a JOSM a kijelölni kívánt vonalat, ezért érdemes a CTRL nyomva tartása mellett végighúzni az egeret annak egy szakaszán (de ne kattintsunk az egérrel).

Az ilyen külső vonalhoz illesztést a viszonyítási vonalszakasz sárgára váltása jelzi. Ha egy „külső” vonal egy pontjára merőlegesen akarunk elhelyezni egy pontot rajzolás közben, nem szükséges a CTRL-al viszonyítási alappá tenni a vonalat. Tartsuk nyomva az 'A' betűt (HOLD felirat jelenik meg a kurzoron), majd vigyünk az egeret a referencia pontra, a rajzolt vonal a rögzített irányt tartva követi a kurzort.

Területek kihúzása

Épületek és egyéb szabályos alakzatok rajzolásához nélkülözhetetlen a Területek kihúzása (Create areas) eszköz ('X'). Dupla kattintással töréspontot adhatunk hozzá a vonalszakaszokhoz. Ha mondjuk egy rombusz alakú poligon egy oldalát akarjuk kihúzni, a szakaszra merőleges húzás mellett húzzuk egy kicsit oldalra is a szakaszt, a kihúzás igazodni fog a szomszédos szakaszok egyikéhez. Egy trapéz forma felső oldalának kihúzásakor az oldallapok által meghatározott két irány közül is választhatunk. Ha azt szeretnénk, hogy mindkét oldalsó szakaszhoz igazodjon, kapcsoljuk be a Szerkesztés/Dupla igazítás menüpontot.

Ha a CTRL-t nyomva tartjuk kihúzás közben, akkor a szomszédos szakaszok „megnyúlva” követik a kihúzott szakaszt. A SHIFT nyomva tartása esetén a kihúzás helyén megmaradnak a töréspontok, ALT esetén az eredeti szakasz is megmarad és egy új poligon keletkezik.


Kör rajzolása

A két kijelölt pont (átmérő) illetve három kijelölt pont köré kört rajzoló funkciót bizonyára ismerjük (Eszközök/Kör létrehozása, 'SHIFT+O'). A pontok számát a Szerkesztés -> Beállítások -> Haladó beállítások -> "createcircle.nodecount" változó határozza meg.


Pontok elrendezése kör mentén

A „Pontok elrendezése kör mentén” funkció további lehetőségeket rejt szabályos kör létrehozására: - Ha kijelölünk egy vonalat és egy külső pontot, a kör középpontja a pont lesz. - Ha kijelölünk egy vonalat, a vonalon egy pontot még egyszer és egy külső pontot, akkor a kör középpontja a külső pont lesz, a vonal pluszban kijelölt pontja helyben marad, a vonal többi pontja igazodik a kör kerületén. - Ha több kijelölt vonal van, amelyek egy gyűrűt alkotnak akkor a vonalak egyesítése nélkül rendezhetjük őket kör formába. Tipikus példa erre egy torz körforgalom, amelyet így néhány kattintással javíthatunk. - Nem zárt vonal esetén körívben rendeződnek a pontok. - Mivel a „kör” pontjainak számát a kiinduló vonal pontjainak száma határozza meg, egyéb szabályos alakzatokat is létre tudunk hozni (ötszög, hatszög stb.)


Körív rajzolása

Körív létrehozására további lehetőséget nyújt a "utilplugin2" bővítmény "Circle arc" funkciója. Három kijelölt pontra illeszt egy körívet, kijelölt vonal esetén annak utolsó három pontjára. Előnye hogy vonalrajzolás közben is aktiválható (SHIFT+C) a vonal megszakítása nélkül. A kör rajzoló funkcióval ellentétben nem a pontok számát adhatjuk meg, hanem hogy hány fokonként illesszen be egy pontot. (Szerkesztés -> Beállítások -> Haladó beállítások -> "curves.circlearc.angle-separation")


Pontok elrendezése egyenes mentén

Pontok elrendezése egyenes mentén funkció használata egyértelmű. ('L') Érdemes tudni, hogy a pontoknak nem kell ugyanahhoz a vonalhoz tartozniuk, illetve egy kijelölt pont esetén pedig automatikusan két szomszédos pont közé lesz igazítva a pont. Például egy egyenesen úton a zebra pontja megtöri az utat, holott az nyílegyenes a műholdkép alapján. Zebrát kijelöljük, 'L' és máris újra egyenes az út. Kettő (vagy több) kijelölt vonal esetén a metszéspontok úgy kerülnek áthelyezésre, hogy mindkét vonal egyenes maradjon. Tipikus alkalmazási példa a városrészek vagy a parkolók szabályos útjainak elrendezése.


Vonalpontok igazítása

Az "utilplugin2" könyvtár „Vonalpontok igazítása” (SHIFT+L) funkciója egy további lehetőséget biztosít:

  • Egy vonal két kijelölt pontja esetén csak a köztes pontok kerülnek igazításra.


Pontok elosztása

Az Eszközök -> "Distribute nodes" (SHIFT+B) funkció a kijelölt vonal pontjait vagy tetszőlegesen kijelölt pontokat egyenlő távolságba mozgatja egy egyenes mentén. Az első és az utolsó pont határozza meg az egyenest. Szintén szabályos városrészek vagy parkolók gyors rajzolására használatos. Segédpontokat is használhatunk, például egy bejárat 1/3 ill. 2/3 távolságra van a sarkoktól, akkor mellérajzolunk egy segédpontot, kijelöljük a négy pontot, SHIFT+B, majd töröljük a segédpontot és készen is vagyunk.


Alakzat derékszögesítése

Az „Alakzat derékszögesítése” ('Q') funkciót mindenki ismeri, aki rajzolt (javítgatott) épületeket. Érdemes tudni, hogy ha a kijelölt épület mellé két pontot is kijelölünk, akkor az épület a kijelölt pontokhoz fog igazodni. Így könnyedén az utca vonalához lehet igazítani az épületeket. Ha az épület nem minden szöge derékszögű, akkor az egyes pontokat utólag vissza lehet mozgatni az eredeti helyükre: előbb a pontok kijelölése szükséges, majd SHIFT+Q.


Párhuzamos vonalak készítése

A Párhuzamos vonalak készítése funkció főleg autópályák rajzolásához használatos. Egy belső udvarral rendelkező épület is gyorsan létrehozható vele, a külső fal megrajzolása után.

Pontok hozzáadása metszéspontokon szintén hasznos funkció.


Utilsplugin2 kijelölési lehetőségek

Az "utilplugin2" bővítmény számos lehetőséget nyújt kijelölésekre.

  • A "Select highway" a kijelölést bővíti egyező "name" illetve "ref" címkéjű szakaszokkal. Így egy szakaszokra bontott utcát tudunk kijelölni.
  • „Pont választás visszavonása”: nagy számú kijelölt vonal esetén előfordulhat, hogy véletlenül pontokat is kijelölünk. Érdemes rászokni az Ablakok/Kiválasztás (ALT+SHIFT+T) panel nyitva tartására figyelve a kijelölt vonalak és pontok számát. Ha vonalakat címkézünk és mégis látunk kijelölt pontokat ott (például Pont:2), akkor a Kiválasztás -> Pont választása visszavonása funkcióval törölhetjük a pontok kijelölését.


Utilsplugin2 Paste relations

  • A "Paste relations" funkciót akkor fogjuk értékelni, ha nagyszámú kapcsolatba kell felvennünk egy vonalat vagy pontot. Például egy új útszakasz rajzolásakor rendkívül fárasztó lehet és rengeteg hibalehetőséget rejt magában, ha egyenként kell arra haladó 15 buszjárat útvonalához hozzáadni. Ilyenkor csak kijelölünk egy korábbi kész szakaszt, majd új kijelöléssel az újonnan rajzolt szakaszt, CTRL+ALT+V és máris minden kapcsolat tagja lett az új vonal.

Források