IT:Osmosis/Installation

From OpenStreetMap Wiki
Jump to: navigation, search
Lingue disponibili — Osmosis/Installation
· Afrikaans · Alemannisch · aragonés · asturianu · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · Bân-lâm-gú · Basa Jawa · Baso Minangkabau · bosanski · brezhoneg · català · čeština · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · Kurdî · latviešu · Lëtzebuergesch · lietuvių · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk bokmål · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · português do Brasil · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tiếng Việt · Türkçe · Vahcuengh · vèneto · Wolof · Yorùbá · Zazaki · српски / srpski · беларуская · български · қазақша · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · मराठी · हिन्दी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 吴语 · 粵語 · 中文(繁體)‎ · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް

Installare in Debian

sudo apt-get install osmosis

Installare una versione pre-compilato Osmosis

# old: wget http://dev.openstreetmap.org/~bretth/osmosis-build/osmosis-bin-latest.tgz
wget http://bretth.dev.openstreetmap.org/osmosis-build/osmosis-latest.tgz
tar xvfz osmosis-latest.tgz
cd osmosis-0.36
chmod a+x bin/osmosis
bin/osmosis

Requisiti

Compilare Osmosis da svn attualmente richiede almeno Java 1.6 (vedere Osmosis#Notes per dettagli), Junit, ant, and ant-optional.

Compilare da svn

cd ~/src
git clone git://github.com/openstreetmap/osmosis.git
cd osmosis
java -version
ant publish
package/bin/osmosis

OS X

Lanciare osmosis su MAC OS X 10.5 richiede passare al framework java 1.6 (dalla versione 1.5 che è quella predefinita) impostando nel terminale la variabile JAVACMD prima di eseguire osmosis. Questo funziona sui MacBook Pro del 2007 , Dual Core 2.44MHz e successivi.

export JAVACMD="/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Commands/java -Xmx128m"

In alternativa: Le istruzioni di installazione per OS X 10.5 sono le stesse di cui sopra, eccetto per l'avvertimento che Java 1.6 è attualmente supportato solo sulle macchine Intel a 64-bit. Potete provare invece SoyLatte.