JA:Merkaartor/Documentation

From OpenStreetMap Wiki
Jump to: navigation, search
利用できる言語 — Merkaartor/Documentation
· Afrikaans · Alemannisch · aragonés · asturianu · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · Bân-lâm-gú · Basa Jawa · Basa Sunda · Baso Minangkabau · bosanski · brezhoneg · català · čeština · corsu · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · Kurdî · latviešu · Lëtzebuergesch · lietuvių · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk bokmål · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tiếng Việt · Türkçe · Vahcuengh · vèneto · Wolof · Yorùbá · Zazaki · српски / srpski · беларуская · български · қазақша · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · मराठी · हिन्दी · भोजपुरी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · བོད་ཡིག · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ ⵜⴰⵏⴰⵡⴰⵢⵜ‎ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 中文(繁體)‎ · 吴语 · 粵語 · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް
その他の言語このウィキの翻訳を支援してください

クイックスタート

MerkaartorMainWindow.png

ようこそ Merkaartorへ。あなたがここに来てくれてうれしいです。アプリケーションをスタートしたらまず、マウスボタンを押しっぱなしでドラッグ(カーソルキーでもいいです)すると、バックグラウンドを動かすことができます。

マウスホイール(キーの+ や- でも、 F3 で地域を選んでもいいです) でズームし、編集したい地域に行きます。

バッググラウンドマップが見たくないなら、レイヤードッグ(Layrers dock)内にあるマップレイヤー(Map layer)のコンテキストメニューから一つ選びます。いっぺんそうしたら、ファイルメニュー(File)にある、Webからダウンロード(Download from web)を選びます。

In the Download dialog, make sure the "Current view" option is selected, then hit OK. Now Merkaartor connects to the OpenStreetMap server and requests all map data for the select area. If the area was too big, the server might refuse to send data. Zoom in a little more and try again. If you later want to load additional data from OSM, the menu command "File, Download more" will take care of this.

The downloaded data in the "Download" layer is drawn over the background map. Areas that have not been downloaded from OSM are marked with a red dots pattern – don't edit there, but download OSM data first!

If you select a node or a way, the "Properties" dock will show all its tags. If you want to learn more about those tags, look at the Map Features wiki page. For example if you know of a post-box or a restaurant that is missing on the map, use the menu command "Create, Node" to put it on the map and then add the necessary tags. Merkaartor simplifies this with the "Amenity" dropdown menu from the Properties layer. It offers a selection of predefined tag sets that describe common things.

A recorded GPS track file can be imported to a new layer with "File, Import". Before you add a new way based on your track, make sure that you've downloaded the current OSM data, then use "Create, Road" to draw the way.

Potlatch のようなオンラインマップエディタを使った場合とは異なり、Merkaartor で行った変更は明示的にサーバーにアップロードする必要があります。 To do this, use the menu command "File, Upload". Therefore, you need to specify your OSM account in the preferences window. (You'll have to fill in this information before the menu item is enabled.)

Look here for a quick walk through or the manual.

インストール

Linux, Mac OS X

たくさんのLinuxディストリビューションに、バイナリーパッケージがあります。詳しくは、 Merkaartor ダウンロードページにあります。 また、compile Merkaartor をソースコードからコンパイルすることもできます。

必要条件

Merkaartor は、 Trolltech Qt バージョン 4.3.3 かそれ以上が必要です。 (ソースコードは http://trolltech.com/downloads/opensource で入手可能で、パッケージは多分個々のLinuxディストリビューションで入手可能でしょう。)

オプションパッケージ

  • Qt ≥ 4.4 は、 Yahoo! imagery に必要です。
  • libxml2 + libxslt は、SVG レンダリングに必要です。
  • exiv2 は、geo タグ付きのイメージに必要です。
  • Inkscape は、レンダリングされたSVGからPNGを生成するのに必要です。

Windows

Windows 用インストールパッケージは、Merkaartor ダウンロードページからダウンロードできます。

Merkaartor をWindowsで、QtとMinGWと一緒にソースコードから作るにはどうするかが、分離されたページにあります。これは、全ての必要なのとオプショナルなライブラリーを含みます。 Windows バイナリーのオプショナル DLLは、Windows用インストールパッケージに入ってます。

メインウィンドウ

地図部分

地図の操作の仕方

  • 右マウスボタンでドラッグか、カーソルキーで移動。
  • マウスホイールか、 +/- キーでズーム

ドック

Many details about the current editing session can be found in the docks. These widgets can be freely placed left and right of the main map or as separate windows. Accidentally closed docks can be opened again in the menu "Window, Docks, ...".

レイヤードック (Layers Dock)

The various data sources like a background map, the GPS tracks, data downloaded from the OSM server or data yet to be uploaded to the server are shown in the Layers dock. It is possible to show/hide specific layers by left clicking on the little eye widget next to each layer's name.

A right mouse click on a layer item opens the context menu. Here you can select the opacity of each layer and zoom the visible area of the map to the bounding box of a layer's content.

The map layer is special in that it describes what is drawn in the background. There are various servers to choose from, for example the Mapnik tile server or the tiles@home server. If your build of Merkaartor has Webkit support, Yahoo aerial images are available, too.

The download layer shows what has been retrieved from the server, while the dirty layer holds the edits that have not been uploaded to the OpenStreetMap server yet.


Geo イメージ

sample of Geo Image dock

The Geo Images dock is only available if explicitly compiled with this feature. It's being used to view geotagged images.

At least one track layer needs to be open (File - Import). After that, geotagged images can be opened using CTRL+o or through the menu. For each image, a small rectangle will appear on the map. By selecting the image icon (rectangle) the image will be shown in the Geo Images dock. Now you can start editing the map with all the relevant details you can derive from that image.

Use the mouse wheel to zoom the image or double-click it (hold CTRL to zoom out). If zoomed, you can click and hold the image to move it.

To select the next/previous image, press PAGE DOWN/UP respectively.

The Menu

ファイル

レンダリング
  • Native
Allow the creation of a bitmap using the builtin, stylized, render engine.
  • Osmarender
Allow the creation of a SVG representation of the data, using Osmarender. Optionally, allow to create a bitmap from the SVG (requires Inkscape)

ツール

World OSB 管理...

The World OSB Manager allows to basically have the entire planet directly available offline, without a database.

The planet is subdivided in regions, which are downloaded and saved in a binary format (OSB).

The World OSB Manager manages the download of the regions and the conversion in OSB format. The files are saved in the directory you specify ("World directory").

  • Select "Show grid" to display the grid of Regions. Regions already downloaded are hashed in green.
  • Click regions to tag them for download (blue hashing).
  • Click several time, until there is no hashing, to delete a region.
  • Click "Apply" to start the actual download from the API.

Thereafter, you can open the "world.osb" file in this directory, and every regions you downloaded will be available for display/change in Merkaartor.

地図を編集する

ノードを移動する

Depending on the preference setting "Separate Move mode", you either have a designated Move tool available or can move a node after selecting it. With the Move tool, you can move any node by dragging it in the map. With the Select tool, you first need to click on it once to select it, then you can drag this node in the map. Selecting it first avoids accidential moving.


新しいノードを作成する

Use the menu command "Create, Node" and click on the location of the map where the new node shall be created. The new node appears as a question mark icon. To set tags for the new node, use the Select tool and click on the new node to select it. (From 0.14 on the new node is automatically selected.)

You can insert a new node into an existing way to give it a smoother path or to otherwise add a detail to it. Again, use the menu command "Create, Node" and put the mouse cursor on the location where the new node shall be inserted. When hovering an existing way segment, it is highlighted. Now you can click on the path to insert the node into that way. The new node is automatically inserted into the way and moving the node around will also modify the way path.

To explicitly not insert the new node in an existing road near where you want to create the node, press and hold the Ctrl and Alt keys to prevent snapping to roads.

新しいウェイを作成する

Be sure not to have a node selected before you start creating a way. Use the menu command "Create, Road" and click on the location of the map where the first node of the new way shall be created. Then move the mouse cursor to the location where the second node shall be created. While moving the cursor, a preview line shows the path of the new way segment, along with the distance to the last created node. After adding the last node, press the Escape key or select the Select tool. The new way appears as a thin black line. To set tags for the new way, use the Select tool and click on the new way (not one of its nodes) to select it. (From 0.14 on the new way is automatically selected.)

If you hover the mouse cursor over an existing road or node, it will snap to that road/node. This way you can start or end a new road at an existing node or in the middle of an existing road. Please do so whenever there shall be a connection between the existing object and the new road, e.g. at road junctions.

To explicitly not insert a node of the new road in an existing road near where you want to create the node, press and hold the Ctrl and Alt keys to prevent snapping to roads. This is useful for creating roads nearby areas when both objects have no direct connection.

すでにあるウェイの端から続行する

Use the Select tool to select the node at the end of the way you want to continue. Then use the menu command "Create, Road" and continue to create the way as described above in Creating a new way.

The selected node will automatically be the first node of the way segment you're drawing. If the node was at the end of a single road, the road will be expanded by the new nodes you draw. If the selected node was in the middle of a road, or the end of more than road, a new road will be created.

ノード/ウェイを削除する

Removing a node makes it entirely go away! You can use this to remove single nodes or nodes from a way. Be sure that you won't accidently delete a special map feature from a way node. Use the Select tool to select the node (not the way) you want to delete. Then click on the red Remove toolbutton to remove that node.

Removing a way works the same, only that you select the entire way instead of a single node on it.

道路を分割する

Splitting a road is a common task to get a road split up into two segments and assign them different tags, like road names or maximum speeds. Use the Select tool to select the road you want to split. Then hold the Shift key pressed and select the node on the road at which the road shall be split. Then use the menu command "Road, Split" to split the road. You can now use the Select tool to further edit both segments of the road separately.

In simple cases, it may be sufficient to only select the node (not the road it is on) and use the menu command.

You can select multiple nodes on the selected road to split the road into more than two parts in one step. You can use this for example to be able to tag a small part of a road separately, like a bridge or a short speed limit.

Splitting a road does not mean disconnecting the two parts. Splitting a road allows you to assign different tags to each part. Read below on how to disconnect (break apart) connected roads to independently move their endpoints.

接続された道路を分離する

Connected roads usually share a single node at their connecting ends. Moving the end of one road also moves the end of the other road, because they're connected. To break up both roads, use the Select tool to the roads that you want to break apart. Then use the menu command "Road, Break apart" to duplicate the connecting node and thus disconnect the roads. (All tags assigned to the node are also duplicated.) You can now use the Move tool to move each road ends independently.

Since both nodes lie at the very same position, you can only select one node at first. See Moving a node above about how to select the right node to move.

Breaking apart two roads that are still connected to a third road will always disconnect the two roads that you have selected, but may keep other combinations of connected roads glued together. To break apart all roads that connect in a node, select all ways that go through this node.

二つの道路を結合する

Roads may be added to the map in several steps. If you have extended a road by creating a new way starting or ending at another road's endpoint, you basically have two connected but separate roads. Separated roads are harder to maintain because features must be added or changed to more ways. If both roads shall have the same tags, use the Select tool to select both roads to join. Then use the menu command "Road, Join" to combine both ways into a single way.

Should both roads have set different values for common tags, their values are concatenated in the joined road. The combined road has all tags assigned that either road had assigned before, i.e. the tag set is united.

You cannot join roads that are not connected in a common endpoint, i.e. you cannot combine roads connected in a junction or crossing.

Read above on how to split a road at a given node.

ウェイからノードを取り除く

Detaching a node from a way, you can move it around without altering the way it was part of. This can also help to correct situations when you have moved a node too near to a way so that it has become a part of the way. Use the Select tool to select the node you want to detach from a way. Then use the menu command "Node, Detach" to detach the node from the way. You can now use the Move tool to further move the node somewhere else.

This feature is available from version 0.14 on.

オブジェクトのタグを編集する

To edit the tags of an object (node, way or relation), select the object and add or change the tags in the "Properties" dock. You can edit a tag name or value by either clicking once on the table cell and start typing, or first double-click the table cell to get a text input field (if your first typing character would be an application hotkey). To add a new tag, select the last row of that table. To delete a tag/value pair from the selected object(s), select it in the table and click on the delete button right above the tags table (the one with the red X on it).

キーボードショートカット

編集プロセスの助けになる、最も重要なショートカットの一覧です。

  • ESC 「選択」モードに切り替えます
  • DEL 選択したオブジェクトを削除します
  • Ctrl-M 「オブジェクト移動」モードに切り替えます
  • Ctrl-N 「ノード作成」モードに切り替えます
  • Ctrl-R 「道路作成」モードに切り替えます
  • Ctrl-D OSM データをダウンロードします
  • Ctrl-U 変更点を OSM にアップロードします

道路

  • Alt-S 分割: 分割したい道路ノードを選択します。結果として、一つのノードで接続されている二つの道路ができます。
  • Alt-B 分離: (一つのノードで接続されている)二つの接続された道路を選択すると、(二つのノードに)分離します。
  • Alt-J 結合: 接続されている二つの道路を選択します。属性(キー)は保存されます。競合する属性は ";" で結合されます。

ノード

  • Alt-M マージ: 2 以上のノードを選択すると、一つになります。"nodes on the same spot" エラーを解決するのに便利です。
  • Alt-A Align: ???

Selection

  • TAB: After selecting node-road, press Tab to cycle through the nearby/overlapping elements

関連

Adding to a relation

NOTE: this needs a Merkaartor newer than version 0.13.

  1. Select the relation to add a member to. To do so, click on the dashed bounding box around a relation. For more clarity, you can enable "View" - "Show Relations"
  2. Ctrl-click the feature (road or other) to add to the relation
  3. Select "Relation" - "Add Member"

Styles and templates

You can change the way Merkaartor render the map under Tools->Style. Read more about styles.

Troubleshooting

If you have any problems with Merkaartor or think that something went wrong, this section may or may not have the answer for you.

Yahoo imagery offset

If the Yahoo background image is offset by a fair amount (about 240 pixels on the screen in all zoom levels) or the map tiles won't fit together after zooming, use the menu command "Layers, Map - Yahoo, Yahoo adapter" to align the background image correctly again. This always seems to happen when you start Merkaartor with the Yahoo Map layer disabled and then enable it after downloading some OSM data.

Should the Map item be missing in the Layers menu, you can also use the context menu on the Map layer from the Layers dock.

If the imagery is only a few metres off, that's by design and cannot easily be corrected.

Property window keeps growing

Every time one clicks into the main window the property window size increases both horizontally and vertically. It's not possible to make the window smaller by moving the divider. This makes it impossible to use the program after a while.

Solution: This a Qt issue, solved in 4.5.1. Select a custom Qt style like skulpture or cleanlooks in Preference-visual.


Adding Additional Projections

When you install Merkaartor, it includes support for two spatial reference systems: Lat/Long (epsg:4326) and World Mercator (epsg:3785). It is pretty easy to add support for additional spatial reference systems. The most common case for wanting to do this is when there are Web Map Services (WMS) that can be used for tracing/editing, but those services do not support one of the two default spatial reference systems.

To add support for a new spatial reference system, you just need to add a definition for that projection to the file that stores this information. Here are the steps:

  1. Merkaartor projections are stored in Proj.4 format. An easy way to get the definition for your spatial reference system(SRS) in the correct format is to go to spatialreference.org and search for it. Once you locate the correct SRS, click the link that will give you the SRS definition in Proj.4 format. Here is a link to UTM Zone15N NAD83
  2. Projections are stored in a file called Projections.xml. This file is located in a hidden folder called merkaartor in the user's home directory. On Mac OS X or Linux, the path is ~/.merkaartor/Projections.xml. On Windows, it is at %HOMEDRIVE%%HOMEPATH%\.merkaartor (e.g. c:\Users\MyUser\.merkaartor). Note the dot character at the beginning of the folder name, it indicates that the folder is hidden.
  3. Find this file and make a backup. Open Projections.xml with your favorite text editor. Copy one of the other Projection elements and paste in the Proj.4 definition that you got from spatialreference.org. Here is a new entry for UTM Zone15N: <Projection name="UTM 15N NAD83 (epsg:26915)" >+proj=utm +zone=15 +ellps=GRS80 +datum=NAD83 +units=m +no_defs </Projection>.
  4. Start up Merkaartor and go to View>Set Projection. You should see your new SRS listed there.


This is the full file after edition:

<?xml version="1.0"?>
<MerkaartorList>
 <Projections creator="Merkaartor 0.14" >
  <Projection name="Mercator (epsg:3785)" >+proj=merc +lat_ts=0.0 +lon_0=0.0 +x_0=0.0 +y_0=0 +k=1.0 +ellps=WGS84 +datum=WGS84 +no_defs</Projection>
  <Projection name="EPSG:4326" >+proj=longlat +ellps=WGS84 +datum=WGS84 +no_defs +to_meter=0.017453292519943295769236907684886</Projection>
  <Projection name="UTM 15N NAD83 (epsg:26915)" >+proj=utm +zone=15 +ellps=GRS80 +datum=NAD83 +units=m +no_defs </Projection> 
 </Projections>
</MerkaartorList>

See Also

OSB file format specification V2