Fi:JOSM-opas/Alku

From OpenStreetMap Wiki
< Fi:JOSM-opas(Redirected from JOSM-opas/Alku)
Jump to: navigation, search
Saatavilla kielillä — JOSM/Guide
· Afrikaans · Alemannisch · aragonés · asturianu · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · Bân-lâm-gú · Basa Jawa · Baso Minangkabau · bosanski · brezhoneg · català · čeština · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · Kurdî · latviešu · Lëtzebuergesch · lietuvių · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk bokmål · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · português do Brasil · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tiếng Việt · Türkçe · Vahcuengh · vèneto · Wolof · Yorùbá · Zazaki · српски / srpski · беларуская · български · қазақша · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · मराठी · हिन्दी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 吴语 · 粵語 · 中文(繁體)‎ · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް
  JOSM   Alku   Peruskäyttö   Relaatioiden käsittely   Muut työkalut ±

Asentaminen

Voit ladata JOSM:in koneellesi osoitteesta josm.openstreetmap.de. Tarvitset lisäksi suhteellisen tuoreen version Java Runtime Environmentista (myös vapaa IcedTea toimii).

Useimmille käyttäjille "tested" -versio on käytännöllisin; kehitystyössä on tällaiseen versioon mennessä pyritty aina minimoimaan virheelliset toiminnot aiemmin lisätyissä toiminnoissa. Voit käyttää myös uusinta "latest" -versiota, mutta siinä voi olla joissain versioissa häiritseviä bugeja. Kehitystyö on kiivasta, joten uusia versioita tulee melkein päivittäin, mutta vakaampia tested-versioita pääsääntöisesti kerran kuukaudessa.

Käynnistäminen

Jos kaikki on kunnossa, JOSM:in pitäisi käynnistyä, kun kaksoisklikkaat lataamaasi josm-latest.jar-tiedostoa (käyttöjärjestelmästä riippuen). Jos homma ei lähde pelittämään, voi kysyä apua vaikka talk-fi-postituslistalta tai katso käyttöjärjestelmäkohtaiset ohjeet englanniksi, tai vilkaise erillistä ongelmanratkaisusivua.

Asetukset

Ensimmäisen käyttökerralla tulee säätää asetukset kohdalleen. Tämä onnistuu valitsemalla Muokkaa -> Asetukset (Edit->Preferences) (pikanäppäin F12).

  1. Ensimmäiseltä välilehdeltä kannattaa valita "Piirrä suuntanuolet/Draw Direction Arrows".
  2. Toiselle välilehdelle puolestaan täytä OSM-käyttäjätunnuksesi (sähköpostiosoite, jolla olet rekisteröitynyt) ja salasanasi.
  3. Kolmannella välilehdellä projektioksi kannattaa valita Mercator, sillä vaihtoehtoinen EPSG:4326 vääristää Suomen leveyksillä muotoja huomattavasti. Mercator on oletusasetus uusissa asennuksissa, mutta jos olet asentanut JOSMin joskus kauan sitten, asetus voi olla yhä EPSG:4326.
  • Myös "Käytä sisäänrakennettuja oletusarvoja/Enable built-in defaults" on hyvä valita niin saat valikon jossa on valmiina usein käytettyjä tageja.

Muuta valittavaa tuskin ensimmäisellä kerralla onkaan. Kannattaa myöhemmin tutustua kaikkiin asetuksiin, mutta näillä pääsee hyvin vauhtiin joten valitse OK ja siirry ohjeissa seuraavalle sivulle peruskäyttö. Joidenkin asetusten muutokset tulevat voimaan vasta JOSMin seuraavalla käynnistyskerralla.

Karttanäkymä

Normaalisti JOSM käyttää ns. mappaint-tilaa, jossa erilaiset polut piirretään eri väreillä ja useat aluetyyppiset kohteet esitetään täytettyinä. Jos mappaint-tila tuntuu hitaalta tai tottumuksiisi huonolta, voit käyttää rautalankanäkymää, jossa kaikki polut piirretään samalla värillä eikä alueita täytetä. Rautalankatilan saat päälle ja pois valitsemalla Näytä -> Rautalankanäkymä (View->Wireframe view), pikanäppäin ctrl+w.

Vikatilanteet

Joskus harvoin JOSM:kin voi kaatua, joten tallenna tai lähetä muutoksesi ajoittain. Useimmiten nämä tilanteet johtuvat JOSMin saaman muistin loppumisesta. Voit pakottaa Java-virtuaalikoneen antamaan JOSMille enemmän muistia käynnistämällä sen seuraavasti:

java -Xmx512m -jar josm-tested.jar

Windows-koneissa

Erityisesti jos lataat kartoitusvalokuvia JOSMiin, Java ei anna ohjelmalle tarpeeksi muistia.

  1. Avaa Muistio/Notepad ja kirjoita tiedostoon vain ylläoleva rivi
  2. Jos käytät JOSMista muuta kuin "tested" -versiota, vaihda tiedoston nimi merkkijonon josm-tested.jar tilalle
  3. Tallenna tiedosto esim. nimellä josm.bat samaan kansioon missä tiedosto josm-tested.jar on
  4. (Sulje Muistio/Notepad)
  5. Käynnistä JOSM jatkossa kaksoisnapauttamalla josm.bat:ia
  6. Voit luoda esim. työpöydälle pikakuvakkeen raahaamalla (resurssienhallinnasta) josm.bat:in hiiren oikealla napilla työpöydän päälle ja valitsemalla aukeavasta valikosta "Luo pikakuvake tähän"