RU:ВикиПроект Россия/Космоснимки

From OpenStreetMap Wiki
Jump to: navigation, search


Историческая справка

Компания ИТЦ СканЭкс (scanex.ru), также известная как kosmosnimki.ru, предоставила сообществу OpenStreetMap доступ к слою спутниковых снимков IRS для полного использования в рамках проекта. Об этом объявили 3 декабря 2009 года на конференции "Веб и ГИС", которая проходила в Москве.

IRS покрывает почти всю европейскую территорию России и даже захватывает немного Украины, Беларуси и Казахстана. Заявленное разрешение 6 м на пиксель. Для сравнения у Landsat это 15 м на пиксель. На IRS видны все дороги с покрытием, а иногда даже грунтовые дороги. Хотя там нельзя разобрать отдельные дома, но чётко просматриваются все улицы городов. Есть возможность чётко прорисовывать границы лесов и водоёмов.

В 2012 концепция была обновлена и к IRS в качестве базового слоя добавился слой с высокодетальными снимками (с разрешением лучше 1м) "OSMosnimki копилка", который должен пополняться за счет социального финансирования и добровольных вкладов.

2012

В апреле 2012 года был настроен общий сервис TMS для космоснимков (совмещённый слой IRS+Spot4+остальное) и копилки снимков. Все предыдущие способы подключения слоя IRS должны быть заменены на обращение к этому сервису.

Тестирование сервиса

Пользователь OSM:

  • ключ доступа - U96GP973UH

на специальном сервисе можно просмотреть набор доступных слоев - http://projects.scanex.ru/osm

Запрос к описанию данных

Для запроса необходимо использовать ключ авторизации пользователя OSM - http://maps.kosmosnimki.ru/TileService.ashx?Request=GetCapabilities&apikey=U96GP973UH

Содержание слоев

Данные собираются в два слоя, представляющие собой мультислои снимков:

   *“Scanex_Base” - базовый слой снимков, предоставленных компанией СКАНЭКС бесплатно
       **Modis (world)
       **Landsat (world)
       **IRS (5 млн. кв. км - Европ часть России)
       **Spot4 (5 млн. кв. км - Вост. часть России)
   *“OSMosnimki” - слой, пополняемый за счет дополнительных заказов


Ссылки для подключения

Ссылка TMS для подключения в JOSM базового слоя “Base_Scanex” - http://maps.kosmosnimki.ru/TileService.ashx?Request=gettile&layerName=19195FD12B6F473684BF0EF115652C38&apikey=U96GP973UH&crs=epsg:3857&z={zoom}&x={x}&y={y}

Ссылка TMS для подключения в JOSM дополнительного слоя “OSMosnimki” http://maps.kosmosnimki.ru/TileService.ashx?Request=gettile&LayerName=A84D7850D1E645DDB5F0E1C6E5763E37&apikey=U96GP973UH&crs=epsg:3857&z={zoom}&x={x}&y={y}

Чтобы подключить слой в JOSM вручную:

  1. Правка - Настройки - WMS / TMS - добавить новый
  2. Ввести вышеуказанную ссылку в поле вкладки TMS

WMS ссылка для подключения в другие ГИСы, например Quantum GIS: http://maps.kosmosnimki.ru/TileService.ashx/apikeyU96GP973UH

Проекция

Примечание: Для получения WMS или тайлов в производной проекции, требуется указать дополнительный параметр: crs=epsg:3857

Как подключить подложку kosmosnimki.ru в Potlatch 1

  • С помощью ссылки: запустите Potlatch с подложкой kosmosnimki
    В ссылке http://www.openstreetmap.org/edit?lat=55.16627&lon=34.53601&zoom=14&tileurl=http://irs.gis-lab.info/?request=GetTile%2526layers=irs%2526format=image/jpeg%2526z=!%2526x=!%2526y=! значения параметров lat, lon, и zoom замените на те, с которыми вы обычно смотрите карту OSM.
  • Или воспользуйтесь другим способом:
    1. Запустите Potlatch как обычно.
    2. Нажмите в левом нижнем углу кнопку "Задание настроек, выбор карты-подложки" (на ней изображён квадратик с галочкой).
    3. Выберите пункт "Особая".
    4. Вставьте в окошко справа от этого пункта строчку:
      http://irs.gis-lab.info/?request=GetTile&layers=irs&format=image/jpeg&z=!&x=!&y=!
    5. Нажмите "ОК" и дождитесь появления подложки Кosmosnimki

Внимание! Подложка может быть довольно сильно смещена!

Необходимо проверить, совпадают ли треки и другие объекты с соответствующими объектами на подложке. Если есть смещение - необходимо подогнать подложку под треки или хорошо привязанные объекты. Для этого нажмите и удерживайте клавишу "Пробел" и двигайте мышкой подложку в Potlatch, стараясь совместить треки, дороги и другие объекты в OSM с соответствующими объектами на снимках. Для более точного выравнивания используйте клавиши со стрелками при нажатой клавише "пробел". Таким образом компенсируется расхождение привязки координат фотоснимка к местности. Проводите данную операцию каждый раз, когда вы начинаете редактирование или смещаетесь слишком далеко от того места, где вы выравнивали подложку.

Дополнительные преимущества подложки Кosmosnimki перед снимками Yahoo в Potlatch.

  • Снимки на большинстве территории видно на 15-м зуме, в отличие от 13-го в Yahoo.
  • Доступен "overzoom" (При дальнейшем увеличении уровня увеличения подложка не пропадает, а заменяется увеличенной, но более размытой копией изображения).

Как подключить подложку kosmosnimki.ru в Potlatch 2

С октября 2011 года подложка доступна в меню "Background" редактора.

Как подключить подложку kosmosnimki.ru в JOSM

Подключение к модулю Imagery

1. Запускаем JOSM. Начиная с версии 3715 модуль Imagery уже встроен в ядро JOSM. Начиная с версии 3878 есть нативная поддержка Scanex.

2. Заходим в настройки (Жмём F12 или в меню "Правка" - пункт в самом низу "Настройки".)

3. В столбике закладок ищем закладку "Править список слоёв подложек" (на которой картинка с надписью WMS TMS) и щёлкаем по ней.

4. В верхней части открыта закладка Поставщики подложек. По умолчанию имеются Bing Sat, Landsat, OpenStreetMap, Yahoo Sat. Нам нужно добавить Kosmosnimki

5. Нажимаем на кнопку "Добавить". Открывается окно "Добавить ссылку снимка".

6. В строку "Название меню" вписываем например "Scanex IRS", строку "Служебная ссылка" оставляем пустой.

7. Внизу в строку "Ссылка на WMS" вводим

tms:http://irs.gis-lab.info/?request=GetTile&layers=irs&format=image/jpeg&z={zoom}&x={x}&y={y}

(с корректировкой привязки)

или

scanex:irs

(без корректировки привязки, быстрее)

8. Жмём на "OK", чтобы закрыть окно "Добавить ссылку снимка" и ещё раз, чтобы выйти из настроек с сохранением параметров.

9. В меню "Снимок" появится дополнительный пункт "Scanex IRS" (или как вы его назвали).

10. После загрузки данных OSM, выберите в вехнем меню "Снимок" пункт "Scanex IRS" (или как вы его назвали). Появится подложка.

ВНИМАНИЕ! Практический всегда дороги на спутниковом снимке не совпадают с их реальным расположением, полученным путём записи треков на навигационном устройстве. Для того, чтобы их совместить, необходимо подвинуть подложку.

Делается это так: В меню "Снимок" выбираем пункт "Новое смещение". Появляется окно "Настроить смещение снимков" и тогда можно мышкой двигать подложку (само окошко лучше сдвинуть в сторону, чтобы не мешало двигать подложку), подгоняем её под треки. В появившемся окне автоматически появятся цифры смещения. После совпадение треков и снимка нажимаем "ОК". Можно начинать рисовать.

Корректировка привязки

Слой космоснимков привязан хорошо, но недостаточно хорошо. Привязку http://irs.gis-lab.info/?layers=irs& можно поправить вручную. Для этого:

  1. в качестве WMS подключить http://irs.gis-lab.info/?layers=irs&force=nocorrect&
  2. установить плагин "irsrectify" (потребуется перезапуск JOSM);
  3. загрузить в нужной области GPS-треки и подвинуть подложку WMS, пока треки не совпадут с дорогами;
  4. выбрать пункт меню «Инструменты» -> «Update IRS Adjustment Layer»;
  5. если на расстоянии 50-80 км от точки привязка уплывает, повторить предыдущие два шага и там;
  6. сохраните полученный слой в файл .osm и отправьте его на me@komzpa.net с пометкой [irs rectify] в теме;
  7. пинайте Komzpa в IRC, пока он не включит ваши поправки в общую базу.

Заготовки тегов

При использовании подложки космоснимков желательно проставлять у срисованных объектов source=IRS. Для упрощения этого сделаны пресеты для JOSM. Чтобы их поставить, откройте Настройки (F12), там вкладка с сеткой (обычно третья), Заготовки с тегами, и в списке доступных заготовок найдите «IRS Presets». Затем синей стрелкой переместите её в правый список. В меню «Заготовки» появится несколько пунктов с названиями «IRS ...». Их можно вывести на панель инструментов в соответствующей вкладке настроек.

Как подключить подложку kosmosnimki.ru в Merkaartor

  1. Запускаем Merkaartor
  2. Открываем меню Tools/Инструменты, команда "WMS Servers Editor/Редактор серверов WMS..."
  3. В окошке "Имя" пишем "Космоснимки", в окошко "Server Url/Ссылка на сервер:" вставляем вставляем одну из перечисленных ниже строк:
  • http://irs.gis-lab.info/?layers=irs&
  • http://glebius.int.ru/wms/irs?
  1. Нажать кнопку "Показать возможность". Появится список выбора. В нём проставим галочку в позиции OpenStreetMap mapnik
  2. В поле "Проекция:" выбираем EPSG:4326
  3. В поле "Формат изображения" выбираем image/jpg
  4. Нажимаем "Добавить"
  5. Открываем меню "Слои", команда "Карта-АдаптерWMS-Космоснимки"
  6. Если подложка не появится в течение минуты, проверяем наличие галочки в меню "Слои", команда "Карта-WMS-Космоснимки-ВИДИМЫЙ"
  7. Смотрим, как постепенно прорисовывается подложка Космоснимки в окне редактора.

Полезные ссылки

См. также