RU:Merkaartor/Documentation

From OpenStreetMap Wiki
Jump to: navigation, search
Доступные языки — Merkaartor
· Afrikaans · Alemannisch · aragonés · asturianu · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · Bân-lâm-gú · Basa Jawa · Basa Sunda · Baso Minangkabau · bosanski · brezhoneg · català · čeština · corsu · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · Kurdî · latviešu · Lëtzebuergesch · lietuvių · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk bokmål · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tiếng Việt · Türkçe · Vahcuengh · vèneto · Wolof · Yorùbá · Zazaki · српски / srpski · беларуская · български · қазақша · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · मराठी · हिन्दी · भोजपुरी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · བོད་ཡིག · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ ⵜⴰⵏⴰⵡⴰⵢⵜ‎ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 中文(繁體)‎ · 吴语 · 粵語 · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް

Введение

Добро пожаловать в Merkaartor. Рады приветствовать вас здесь. После начальной загрузки приложения вы сможете двигать фоновую карту (подложку на жаргоне картописателей), удерживая правую кнопку мыши и протаскивая её (или используйте кнопки со стрелками движения на клавиатуре)

Увеличивайте карту при помощи колеса мыши (или клавишами + и -, или F3 и выберите область, которую хотите увеличить. Если вы не видите фоновую карту, выберите одно из контекстных меню из слоя Map layer в панели Layers. И раз вы уже здесь, выберите "Download from web" из меню "File".

В диалоге загрузки Download dialog, проверьте, что выбрана функция "Current view", затем нажмите OK. Теперь Merkaartor соединяется с сервером OpenStreetMap и запрашивает все данные карты для выбранной области.Если область слишком велика, сервер может отказаться отсылать данные. Увеличьте немного масштаб, и попробуйте еще раз. (Обычно срабатывает загрузка зоны с масштабом 1 км. Если потом вам понадобиться добавить дополнительный участок карты, не стирая этого, выберите в меню File команду "Download more".

Загруженные данные, в слое "Download" рисуются поверх фоновой карты. Области, которые не были загружены сейчас из ОСМ, отмечены матрицей из красных точек, - не редактируйте в этих местах, сначала загрузите свежие данные из ОСМ!

Если вы выбираете сооружение или дорогу панель "Properties" (свойства) покажет все их признаки. Если вы хотите узнать больше об этих признаках, посмотрите страницу wiki "Map Features". Например, если вы знаете, где почтовый ящик или ресторан, пропущенный на карте, используйте команду в меню "Create, Node" чтобы поместить его на карту и затем добавьте необходимые признаки (tags) Merkaartor упрощает это при помощи выпадающего меню "Amenity" из слоя Properties (свойств). Оно предлагает на выбор предварительно установленный набор наиболее употребимых признаков. Если вы не нашли там необходимый признак, вы можете ввести его в поле вручную, после этого он останется в вашем списке в дальнейшем.

Записанный файл следа (GPS track) может быть вставлен в новый слой командой "File, Import". Прежде, чем вы добавите новую дорогу, основанную на вашем следе, убедитесь, что вы загрузили текущие данные ОСМ, затем, для того, чтобы нарисовать дорогу, используйте команду "Create, Road".


В отличие от онлайнового редактора Potlatch, редактирование в Merkaartor должно быть загружено на почтовый сервер. Для этого используйте меню "File, Upload". Кроме того, вам нужно указать ваш логин с паролем в окне индивидуальных настроек. Вы будете спрошены об этом, если забудете их внести.

Теперь попробуем пробежаться по руководству.


Смотрите здесь введение walk through или подробную инструкцию manual.

Установка

Linux, Mac OS X

Существуют несколько двоичных пакетов доступных для различных сборок Линукс. Смотрите подробности Merkaartor download page Вы также можете скомпилировать их из исходного кода. Merkaartor/Compiling.

Требования

Merkaartor необходима Trolltech Qt версия 4.3.3 или выше (исходник доступен http://trolltech.com/downloads/opensource, двоичные пакеты (на жаргоне линуксоидов - бинарники) доступны, вероятно, в каждом отдельном дистрибутиве (сборке) Linux.

Дополнительные пакеты

  • Qt ≥ 4.4 Необходим для Yahoo! imagery
  • libxml2 + libxslt Необходим для SVG rendering
  • exiv2 Необходим для geo-tagged images
  • Inkscape Необходим для создания PNGs из SVGs

Windows

Вы можете загрузить готовый двоичный пакет для установки на Merkaartor download page. Двоичные (откомпилированные) пакеты дополнительных библиотек Windows уже включены в данный установочный пакет.

Исходные коды

Исходные коды и всю необходимую информацию по сборке Merkaartor под Linux, Mac OS X и Windows, можно найти в следующем описании: Merkaartor compiling page. Здесь также описаны все требования и дополнительные библиотеки, необходимые для сборки.

Основное окно

Карта

Взаимодействие с картой

  • Перемещайтесь с помощью правой кнопки мыши или используйте клавиатурные стрелки
  • Для изменения масштаба используйте колесико мыши либо клавиши +/- .

Дополнительные панели

Много информации о текущей сессии редактирования можно найти на дополнительных панелях. Эти панели могут быть свободно размещены с лева или с права от основной карты, либо вообще могут располагаться на отдельном окне. Случайно закрытые панели могуты быть вновь открыты через меню "Window->Docks->..."("Окно->Панели->...").

Панель слоев

Различные источники данных, такие как фоновое изображение карты, GPS - треки, данные, загруженные с OSM сервера или данные которые которые будут на него загружены, показываются на панели слоев. Присутствует возможность скрыть/показать отдельные слои, нажатием левой кнопкой мыши на иконке маленького глаза возле каждого из названий слоев.

При нажатии правой кнопкой мыши на названии слоя появляется контекстное меню. Здесь вы можете выбрать прозрачность каждого слоя, масштаб и видимую область с содержимым слоя.

Слой карты специально предназначен для отображения на заднем фоне. Есть несколько серверов, с которых можно его получить, например Mapnik сервер или сервер tiles@home. Если ваша сборка Merkaartor имеет поддержку Веб интерфейса, Yahoo аэроснимки так же доступны.

Слой загрузки показывает то, что было загружено с сервера OSM, а слой для рисования содержит правки, которые еще не были заргужены на сервер OpenStreetMap.


Geo Images

sample of Geo Image dock

The Geo Images dock is only available if explicitly compiled with this feature. It's being used to view geotagged images.

At least one track layer needs to be open (File - Import). After that, geotagged images can be opened using CTRL+o or through the menu. For each image, a small rectangle will appear on the map. By selecting the image icon (rectangle) the image will be shown in the Geo Images dock. Now you can start editing the map with all the relevant details you can derive from that image.

Use the mouse wheel to zoom the image or double-click it (hold CTRL to zoom out). If zoomed, you can click and hold the image to move it.

To select the next/previous image, press PAGE DOWN/UP respectively.

The Menu

File

Render
  • Native
Allow the creation of a bitmap using the builtin, stylized, render engine.
  • Osmarender
Allow the creation of a SVG representation of the data, using Osmarender. Optionally, allow to create a bitmap from the SVG (requires Inkscape)

Tools

World OSB Manager...

The World OSB Manager allows to basically have the entire planet directly available offline, without a database.

The planet is subdivided in regions, which are downloaded and saved in a binary format (OSB).

The World OSB Manager manages the download of the regions and the conversion in OSB format. The files are saved in the directory you specify ("World directory").

  • Select "Show grid" to display the grid of Regions. Regions already downloaded are hashed in green.
  • Click regions to tag them for download (blue hashing).
  • Click several time, until there is no hashing, to delete a region.
  • Click "Apply" to start the actual download from the API.

Thereafter, you can open the "world.osb" file in this directory, and every regions you downloaded will be available for display/change in Merkaartor.

Editing the map

Moving a node

Depending on the preference setting "Separate Move mode", you either have a designated Move tool available or can move a node after selecting it. With the Move tool, you can move any node by dragging it in the map. With the Select tool, you first need to click on it once to select it, then you can drag this node in the map. Selecting it first avoids accidential moving.


Creating a new node

Use the menu command "Create, Node" and click on the location of the map where the new node shall be created. The new node appears as a question mark icon. To set tags for the new node, use the Select tool and click on the new node to select it. (From 0.14 on the new node is automatically selected.)

You can insert a new node into an existing way to give it a smoother path or to otherwise add a detail to it. Again, use the menu command "Create, Node" and put the mouse cursor on the location where the new node shall be inserted. When hovering an existing way segment, it is highlighted. Now you can click on the path to insert the node into that way. The new node is automatically inserted into the way and moving the node around will also modify the way path.

To explicitly not insert the new node in an existing road near where you want to create the node, press and hold the Ctrl and Alt keys to prevent snapping to roads.

Creating a new way

Be sure not to have a node selected before you start creating a way. Use the menu command "Create, Road" and click on the location of the map where the first node of the new way shall be created. Then move the mouse cursor to the location where the second node shall be created. While moving the cursor, a preview line shows the path of the new way segment, along with the distance to the last created node. After adding the last node, press the Escape key or select the Select tool. The new way appears as a thin black line. To set tags for the new way, use the Select tool and click on the new way (not one of its nodes) to select it. (From 0.14 on the new way is automatically selected.)

If you hover the mouse cursor over an existing road or node, it will snap to that road/node. This way you can start or end a new road at an existing node or in the middle of an existing road. Please do so whenever there shall be a connection between the existing object and the new road, e.g. at road junctions.

To explicitly not insert a node of the new road in an existing road near where you want to create the node, press and hold the Ctrl and Alt keys to prevent snapping to roads. This is useful for creating roads nearby areas when both objects have no direct connection.

Continuing an existing way at either end

Use the Select tool to select the node at the end of the way you want to continue. Then use the menu command "Create, Road" and continue to create the way as described above in Creating a new way.

The selected node will automatically be the first node of the way segment you're drawing. If the node was at the end of a single road, the road will be expanded by the new nodes you draw. If the selected node was in the middle of a road, or the end of more than road, a new road will be created.

Removing a node/way

Removing a node makes it entirely go away! You can use this to remove single nodes or nodes from a way. Be sure that you won't accidently delete a special map feature from a way node. Use the Select tool to select the node (not the way) you want to delete. Then click on the red Remove toolbutton to remove that node.

Removing a way works the same, only that you select the entire way instead of a single node on it.

Splitting a road

Splitting a road is a common task to get a road split up into two segments and assign them different tags, like road names or maximum speeds. Use the Select tool to select the road you want to split. Then hold the Shift key pressed and select the node on the road at which the road shall be split. Then use the menu command "Road, Split" to split the road. You can now use the Select tool to further edit both segments of the road separately.

In simple cases, it may be sufficient to only select the node (not the road it is on) and use the menu command.

You can select multiple nodes on the selected road to split the road into more than two parts in one step. You can use this for example to be able to tag a small part of a road separately, like a bridge or a short speed limit.

Splitting a road does not mean disconnecting the two parts. Splitting a road allows you to assign different tags to each part. Read below on how to disconnect (break apart) connected roads to independently move their endpoints.

Break apart connected roads

Connected roads usually share a single node at their connecting ends. Moving the end of one road also moves the end of the other road, because they're connected. To break up both roads, use the Select tool to the roads that you want to break apart. Then use the menu command "Road, Break apart" to duplicate the connecting node and thus disconnect the roads. (All tags assigned to the node are also duplicated.) You can now use the Move tool to move each road ends independently.

Since both nodes lie at the very same position, you can only select one node at first. See Moving a node above about how to select the right node to move.

Breaking apart two roads that are still connected to a third road will always disconnect the two roads that you have selected, but may keep other combinations of connected roads glued together. To break apart all roads that connect in a node, select all ways that go through this node.

Joining two roads

Roads may be added to the map in several steps. If you have extended a road by creating a new way starting or ending at another road's endpoint, you basically have two connected but separate roads. Separated roads are harder to maintain because features must be added or changed to more ways. If both roads shall have the same tags, use the Select tool to select both roads to join. Then use the menu command "Road, Join" to combine both ways into a single way.

Should both roads have set different values for common tags, their values are concatenated in the joined road. The combined road has all tags assigned that either road had assigned before, i.e. the tag set is united.

You cannot join roads that are not connected in a common endpoint, i.e. you cannot combine roads connected in a junction or crossing.

Read above on how to split a road at a given node.

Detaching a node from a way

Detaching a node from a way, you can move it around without altering the way it was part of. This can also help to correct situations when you have moved a node too near to a way so that it has become a part of the way. Use the Select tool to select the node you want to detach from a way. Then use the menu command "Node, Detach" to detach the node from the way. You can now use the Move tool to further move the node somewhere else.

This feature is available from version 0.14 on.

Editing tags of an object

To edit the tags of an object (node, way or relation), select the object and add or change the tags in the "Properties" dock. You can edit a tag name or value by either clicking once on the table cell and start typing, or first double-click the table cell to get a text input field (if your first typing character would be an application hotkey). To add a new tag, select the last row of that table. To delete a tag/value pair from the selected object(s), select it in the table and click on the delete button right above the tags table (the one with the red X on it).

Keyboard Shortcuts

Listing only the most important shortcuts which help during the editing process

  • ESC Switch to "Select" mode
  • DEL Delete selected object
  • Ctrl-M Switch to "Move object" mode
  • Ctrl-N Switch to "Create Nodes" mode
  • Ctrl-R Switch to "Create Streets" mode
  • Ctrl-D Download OSM data
  • Ctrl-U Upload your changes to OSM

Roads

  • Alt-S Split: Select a road-node where to split. The result is two roads which are still connected by the one node.
  • Alt-B Break apart: Select two connected roads (connected by one node) and they will become separated (two nodes).
  • Alt-J Join: Select 2 streets to combine them. Attributes (keys) will be preserved. Conflicting attributes are concatenated with ";".

Nodes

  • Alt-M Merge: Select 2 or more nodes and they become one. Handy for resolving "nodes on the same spot" errors.
  • Alt-A Align: ???

Relations

Adding to a relation

NOTE: this needs a Merkaartor newer than version 0.13.

  1. Select the relation to add a member to. To do so, click on the dashed bounding box around a relation. For more clarity, you can enable "Show" - "Show Relations"
  2. Ctrl-click the feature (road or other) to add to the relation
  3. Select "Relation" - "Add Member"

Troubleshooting

If you have any problems with Merkaartor or think that something went wrong, this section may or may not have the answer for you.

Yahoo imagery offset

If the Yahoo background image is offset by a fair amount (about 240 pixels on the screen in all zoom levels) or the map tiles won't fit together after zooming, use the menu command "Layers, Map - Yahoo, Yahoo adapter" to align the background image correctly again. This always seems to happen when you start Merkaartor with the Yahoo Map layer disabled and then enable it after downloading some OSM data.

Should the Map item be missing in the Layers menu, you can also use the context menu on the Map layer from the Layers dock.

If the imagery is only a few metres off, that's by design and cannot easily be corrected.

Property window keeps growing

Every time one clicks into the main window the property window size increases both horizontally and vertically. It's not possible to make the window smaller by moving the divider. This makes it impossible to use the program after a while.

Solution: This a Qt issue, solved in 4.5.1. Select a custom Qt style like skulpture or cleanlooks in Preference-visual.

See Also