Sk:JOSM

From OpenStreetMap Wiki
Jump to: navigation, search
Dostupné jazyky — JOSM
· Afrikaans · Alemannisch · aragonés · asturianu · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · Bân-lâm-gú · Basa Jawa · Baso Minangkabau · bosanski · brezhoneg · català · čeština · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · Kurdî · latviešu · Lëtzebuergesch · lietuvių · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk bokmål · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · português do Brasil · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tiếng Việt · Türkçe · Vahcuengh · vèneto · Wolof · Yorùbá · Zazaki · српски / srpski · беларуская · български · қазақша · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · मराठी · हिन्दी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 吴语 · 粵語 · 中文(繁體)‎ · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް
JOSM Screenshot, showing the geo-tagged images feature.
JOSM Screenshot with (outdated) landsat.jar and mappaint.jar plugin.

JOSM znamená "Java Open Street Map Editor". Naprogramoval ho Immanuel Scholz a aktuálne je spravovaný Frederik Ramm. Jeho domovská stránka je http://josm.openstreetmap.de/, kde si môžete stiahnúť poslednú verziu (nočnú kompiláciu, cca 1MB). Vyžaduje Javu vo verzií aspoň 1.5.

Ktorý editor je lepšie používať

Existujú aj iné editory pre OpenStreetMap dáta, ako napr. Potlatch online editor alebo Merkaartor. Prečo teda používať JOSM? JOSM je editor s množstvom funkcií pre skúsených OSM mapperov. Vyžaduje určité úsilie pri inštalácii a konfigurácii, ale ak chcete byť "veľkým" OSM mapperom, Váš vložený čas na naučenie sa, sa Vám vráti. A ak to znie príliš komplikovano, nemajte strach. Nie je to také strašné ako to znie, ak máte základnú zručnosť s počítačmi.

Offline editor JOSM by ste mali použiť, ak:

  • Sa chystáte meniť väčšie množstvo údajov
  • Chcete meniť údaje bez okamžitého efektu.
  • Ak ste spravili fotky s vaším foťákom a chcete ich zobraziť na pozíciách, kde ste ich vyfotili.
  • Ak chcete použiť offline editor a idete meniť oblasť, kde predpokladáte zmeny inými používateľmi. JOSM podporuje správu konfliktov medzi viacerými užívateľmi (nezabudnite spraviť download pred každým uploadom údajov).


Nemali by ste JOSM používať, ak:

  • Chcete pomenovať 1 ulicu. Použite online editor Potlatch.
  • Ak nechcete stahovať aplikáciu.
  • Ak chcete upravovať mapu a nachádzate sa za firewallom, ktorý blokuje JOSM komunikáciu (napr. z práce).
  • Ak váš počítač nemá aspoň nižšie uvedenú konfiguráciu - požiadavky.

Požiadavky

Váš počítač by mal pre spustenie JOSM spĺňať tieto požiadavky:

  • Java 1.5 a vyššia (Java 1.5 nie je dostupná pre Mac OS X 10.3, JOSM pracuje dobre na OS X 10.4)
  • 256 MB RAM a viac
  • rozlíšenie 1024*768 a vyššie (800*600 neprinesie veľa pohodlia)
  • grafický adaptér so zapnutou 2D akceleráciou je doporučený. Ak máte len OpenGL, skúste pridať
    -Dsun.java2d.opengl=true
    . Ak máte problémy s týmto nastavením (neviditeľné ikony a pozadie, dialóg. testovaný na WinXP + nVidia FX1500 + dual monitor) použite:
    -Dsun.java2d.opengl=true -Dsun.java2d.opengl.fbobject=false

Stiahnutie & inštalácia

Budete potrebovať Javu 1.5 ak chcete spustiť editor JOSM. Unfortunately Java 1.5 is not available for Mac OS 10.3.x.

Potom len stiahnete jar súbor, ktorý nájdete na hlavnej stránke editora JOSM.

Various people started hacking on JOSM, so there are different flavours and plugins available. While the main JOSM trunk is at http://josm.openstreetmap.de/, you can download modified versions of JOSM, plugins or external tools that enhance JOSM.

Inštalácia JAVY

Skôr ako budete chcieť spustiť JOSM, musíte mať na Vašom počítači nainštalovanú Javu:

Linux

  • Nainštalujte Java Runtime z tejto adresy Java SE
Ubuntu
  • zadajte do konzoly:
    $ sudo aptitude install sun-java6-jre
Debian "pure"
  • zadajte do konzoly (ako root):
    $ apt-get install sun-java6-jre

Poznámka: Ak máte nainštalovaný iný JVM (Java Virtual Machine), vyberte JVM buď určením cesty (/usr/lib/jvm/java-6-sun/java) alebo updatujte konfiguráciu spustením "update-java-alternatives -s java-6-sun"

Gentoo

Štandardná inštalácia:

emerge josm

If you are interested in latest josm-development and plugins use the OpenStreetMap Gentoo Overlay. By using the "x86"-keyword you get a stable release, the "~x86"-keyword installs the svn-version.

There are many plugins already available as ebuilds. Look at http://svn.openstreetmap.org/applications/utils/gentoo/ for a complete list.

openSUSE

JOSM balíky sú dostupné na openSUSE's build service v repozitáry home:rodrigomoya:

zypper ar http://download.opensuse.org/repositories/home:/rodrigomoya/openSUSE_10.3
zypper ref
zypper in josm

Windows

  • Inštalujte Java Runtime z tejto adresy: Java SE

Mac OS X

  • Java 1.5 je inštalovaná pri OS X 10.4 a vyššom.

JOSM plugins

Zoznam pluginov je na JOSM/Plugins stránke alebo tiež na JOSM Wiki. Plugins are installed as described below:

Linux & Mac OS X

  • Install Java Runtime, if not already installed
  • To install plugins, save them in ~/.josm/plugins (e.g. /home/$USER/.josm/plugins/wmsplugin.jar)

Windows

  • Install Java Runtime, if not already installed.
  • On the latest version of JOSM (April 2007), put the plugins in the directory is C:\Documents and Settings\your user name\Application Data\JOSM\plugins

Ako spustiť JOSM

Jar súbor je potrebné predať Java 1.5 runtime. Tento krok je závislý od Vášho OS:

Linux

Do konzoly napíšte java -jar josm.jar. There are also some tutorial videos. One describes the steps to set up KDE for starting JOSM by clicking on the JAR file. Get the tutorials from one of the mirrors listed at openstreetmap.de.

Pre používateľov Ubuntu je príručka na UbuntuForums (v angličtine).

Ak spúštate JOSM za proxy, môžete JVM povedať aby ich použil nasledovne: java -Dhttp.proxyHost=192.168.1.1 -Dhttp.proxyPort=3128 -jar josm.jar. Kde 192.168.1.1 je IP a 3128 je port Vášho proxy servera .


Ak potrebujete použiť IPv6, môžete pridať nasledujúci parameter -Djava.net.preferIPv6Addresses=true

čiže java -Djava.net.preferIPv6Addresses=true -Dhttp.proxyHost=proxy.ipv6.uni-leipzig.de -Dhttp.proxyPort=3128 -jar josm/josm-snapshot-xxx.jar

Proxy je tu spomenuté len preto, lebo openstreetmap server zatiaľ nepodporuje IPv6.

Windows

Obyčajne stačí dvoj-klik na josm.jar a JOSM sa spustí.

In the rare case that this doesn't work, create a text file named start_JOSM.bat with a simple text editor, for example Notepad. Write the following line in the file:

java -jar josm.jar

Save this .bat file into the same directory where josm.jar is located. Now you can just double-click on the .bat file and JOSM will start up.

You can also set up a shortcut to the JOSM.jar file which allows the inclusion of additional parameters. I have the following as the short cut "Target" in my Start Menu which starts a control prompt window (useful to see progress of uploads/downloads), loads JOSM in its separate window, and assigns 512mb of memory for the process which dramatically speeds up operation when editing dense data. Change "path" to the full path of your josm-latest.jar file.

C:\WINDOWS\system32\java.exe -jar -Xmx512M "C:\path\josm-latest.jar"

Mac OS X systems

You need Mac OS 10.4 or better. 10.3 will not do the job. In 10.4.x, simply double click on the jar file and Java 1.5 should load the JOSM jar file. If you need to allocate more memory to JOSM (in order to edit larger files), the following script will help:

java -jar -Xmx256M -XX:MaxPermSize=256M josm-latest.jar

Začíname

  • If you have a GPX tracklog file of the ways you want to map, start JOSM. Choose File → Open to select and load your track. JOSM will automatically fit the workspace to the bounding box of your track.
  • If you don't have a GPX tracklog file then you may want to use data collected from other users. See Korea Mapping Guide
  • If you want to play around while learning how to use JOSM without changing the data on the server then just don't upload (downloading is OK), delete the layers you changed, and then start over.
  • Always download before editing even if you are using data stored on your own computer.
  • To exchange data with the server ensure you have entered your username and passphrase in the preferences of JOSM. Your username is not your wiki username but the email address you used for registering.
  • Now choose File → Download from OSM. In the following dialog ensure that the checkbox to get OSM data is enabled and press the OK button. Always download before uploading.
  • If the track is too long, the server will refuse to send you the OSM data for that area. Zoom in a bit to restrict the request to a reasonable size.
  • Wait a bit until all the data has been received. If there are existing ways of your area in the database, you will now see them in JOSM.
  • Now start your editing session. Be careful when changing existing data, as streets and nodes can have lots of tags assigned.
  • The JOSM manual is available online here, and these pages can also be accessed by pressing F1 from within JOSM. If you really mess things up simply delete the layers that have been changed before you do an upload and then start over.
  • See here for a list of default shortcuts.

Tipy a triky

See also JOSM/Advanced Tricks (more tips for more experienced users)

  • After installing a plugin, you have to visit the preferences where you can enable and disable each plugin individually
  • For users new to OSM, it is recommended to use a presets file for easier tagging. Ask for one in the mailing list or User:SlowRider
  • To see the ways in different colours and thicknesses, install the mappaint plugin
  • If you do not have a wheelmouse, you can zoom in and out using the key combo Ctrl-. (period) and Ctrl-, (comma).
  • If you mapped one lane of a motorway, find here a tool which creates the opposite lane for you.
  • The node dragging sensitivity is set quite low. You will probably find that setting the threshold to 5 will make it more sensitive. In Advanced Preferences add a key named edit.initial-move-threshold and give it a value of 5.

Automatické priradenie fotiek ku GPS trase

Jedným z problémov pri mapovaní s GPS je záznam názvov ulíc pri križovaní ulíc. Ak máte digitálny foťak, zoberte ho so sebou.

  • urobte fotku obrazovky Vášho GPS kde je vidieť GPS čas pred začiatkom mapovania

Ak mapujete môžete robiť fotky tam kde to považujete za potrebné (napr. na križovatke, zaujimavých miestach a pod.). Po návate domov si otvorte Vašu GPS trasu v JOSM:

  • Vo vrstvách vpravo hore
  • Kliknite pravým tlačítkom na GPX vrstvu ktorú ste si natiahli. Poznámka: musíte to urobiť pre GPX vrstu a nie pre data vrstvu ktorú ste stiahli z OSM servera .
  • Vyberte možnosť "Importovať obrázky"
  • Right click the photos layer,
  • Zadajte rozdiel času medzi časom z fotky (čas Vášho fotoaparátu) a GPS časom na fotke (z displeja GPS prístroja)
    • Ak nemáte fotku obrazovky GPS prístroja, možete zapnuť foťak a GPS teraz. Urobte fotku, zistite rozdiel času a zadajte ho do dialógu.

Automatically Matching Sound Recordings to GPS traces

There is now a similar facility for applying and synchronizing sound recordings.

There are three methods, described with step-by-step instructions, in the JOSM Help:

1. Continuous audio with GPS waymarks

With this method, you collect explicit waypoints along your track using the buttons on your GPS and at the same time dictate onto a continuous sound recording on your voice recorder what the waymark represents on the ground - a street name or point of interest. Your GPS notes three key pieces of information about each waypoint - its location, the time it was made, and it's name or number. The audio and waypoint data are then synchronized in JOSM so that you can play back each description by clicking on a Marker representing the waypoint.

2. Continuous audio with vocally-identified points of interest

With this method you also make a continuous sound recording but instead of entering waypoints into your GPS you dictate an audible cue for each point of interest, for example "MARK! River Lane Primary School on left".

3. Audio clips with waymarks

With this method, you make waypoints to identify locations of interest. However you record a separate audio file for each one and the name of each file is added as a <link> element in the corresponding waypoint in the GPX file before loading into JOSM. When JOSM then creates the Audio Marker for each waypoint, it knows which audio clip to play when you click on the marker.

Chybové hlásky JOSM

Error while parsing. An error has occurred

The most likely cause of the above error is that the server is slow and has not sent the required response back to JOSM. If this occurs just try uploading the data again, and JOSM will resume from where it left off.

If you get error 412 precondition failed, it means that something changed on server in unexpected way. Try deleting affected objects.

JOSM sa spustí ale okno je prázdne

Može sa to stať vdety ak máte aktivovaný compiz/beryl. Riešenie je jednoduché, pridajte nasledujúci riadok do užívateľského profilu:

export AWT_TOOLKIT="MToolkit"

Poznámky pre začiatočníkov

Here's a few notes from a beginner's (Parsingphase) first couple of days working on OSM, using the JOSM editor (on Mac OS X).

Mac-specific points

  • "Installing" JOSM on OS X is a cinch — just download and double-click the .jar file.
  • Use a two-button mouse with a scroll wheel — it makes life much easier. Right-dragging moves the map, the scrollwheel zooms.
  • Otherwise, command-click (aka "Apple-click") does a right click, ctrl-arrows to move the map, and ctrl-, and ctrl-. to zoom.
  • Because it starts with a dot, your ~/.josm directory will be invisible to the Finder. You either have to move the plugins into it from the command line, or open the folder using "Go to Folder..." ("Go" menu in the Finder).
  • There's a Mac OS X look and feel under the Edit → Preferences menu; it doesn't actually change any functionality but it fits in ;)

Points for all platforms

  • Get the "mappaint" rendering mode. It makes it far easier to see what's going on in your maps (and even work out where on earth you are), at the expense of slightly higher processor load on your machine (my PowerBook 12" copes fine). (This plugin has now been integrated into JOSM and can be turned on and off from the view menu > view wireframe.)
  • Upload and download small areas, frequently. The less time you've got unstored or unchecked changes, the lower the risk of conflict with other users.
  • Always download an area before you start work on it, even if you have your own GPX data.
  • Always download the area you are going to upload before doing so, to get any modifications made by other users and avoid overwriting data.
  • When downloading an area you get all the data within the rectangular bounding box you choose, and also, where any way within that bounding box extends outside the box it is completely downloaded. It therefore becomes difficult to precisely know which areas you have downloaded full data for. If you check the "Draw boundaries of downloaded data" box (found in Display Preferences), a yellow rectangle is drawn around all the areas for which full data has been downloaded. Caution should be exercised when adding new data to areas outside these rectangles as it may duplicate already existing data, which you have not downloaded.
  • A "small area" to start with might either be that from a short GPX track you've taken, or about a 1-km square around a known location. This equates to about 0.06° of latitude/longitude (give or take polar distortion), so enter an area about that size into the File → Download from OSM → Bounding Box.
  • Rural areas with less detail might work better with larger areas — the 1-km recommendation is about right for a suburb of London.
  • Once you're viewing an area in JOSM, at whatever zoom level, the JOSM download dialog box will default to the currently viewed area.
  • It's very easy to select more than you expect to, particularly when making "ways". Open the "Current Selection" panel (Alt-e, fifth button up on the left) to keep an eye on what you've selected.
  • Switch back to "select" mode regularly and click on nothing or type Ctrl-Shift-A to clear your select list.

Prečo sa moje zmeny nezobrazujú?

  • See Map Features for how to specify that your way is a road/railway etc, and what type. If you're not sure of the type (e.g. primary/secondary) be conservative and choose the lesser (e.g. secondary).

See also

Related

External links