Talk:The Rails Port

From OpenStreetMap Wiki
(Redirected from Talk:Rails port)
Jump to: navigation, search

Discuss The Rails Port page here:


Installation/usage Experience documented

I'd like to add a link to "User:BigPeteB/Setting up a local database copy", where I've documented my experience setting up a database, Osmosis, and the Rails port, but I'm not sure where to put it. --BigPeteB 18:04, 29 September 2010 (BST)

One more link, but only in Russian RU:Создание локального OSM-сервера --s-s-s 13:19, 19 July 2012 (BST)

GIST indices

Shouldn't the GIST indices be created on all three databases (production, dev and test)? It's my first time setting up the rails port, so I didn't want to edit the main page directly. Martijn van Exel 23:13, 7 January 2012 (UTC)

The instructions currently require setting up the GIST on the development and production databases. The info for rake db:migrate indicates that it will automagically copy the development database. Not sure if that includes replicating the index information? Jeffmeyer 01:19, 22 October 2012 (BST)

Rake Test errors - Attribute Lat Redefined

Using the current instructions, I am seeing the following:

Note the parser errors: Attribute lat redefined

$ rake test
Loaded suite /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/rake_test_loader
Started
.................................................................................................................................................................................................Entity: line 1: parser error : Attribute lat redefined
<osm><node id='123' lon='23.23' lat='23.1' lat='12' changeset='23' version='23' 
                                                                               ^
Entity: line 1: parser error : Attribute lat redefined
<osm><node id='123' lon='23.23' lat='23.1' lat='12' changeset='23' version='23' 
                                                                               ^
....................................................................................................................................
Finished in 53.454388 seconds.

Not sure what is going on here...

Jeffmeyer 03:06, 22 October 2012 (BST)

This error is generated out of line 232 in this test: openstreetmap-website/test/unit/node_test.rb
  def test_from_xml_double_lat
    nocs = "<osm><node id='123' lon='23.23' lat='23.1' lat='12' changeset='23' version='23' /></osm>"
    message_create = assert_raise(OSM::APIBadXMLError) {
      Node.from_xml(nocs, true)
    }
    assert_match /Fatal error: Attribute lat redefined at/, message_create.message
    message_update = assert_raise(OSM::APIBadXMLError) {
      Node.from_xml(nocs, false)
    }
    assert_match /Fatal error: Attribute lat redefined at/, message_update.message
  end
Jeffmeyer 04:24, 25 January 2013 (UTC)

Populating the database section

To populate a PostgreSQL database using Osmosis from a planet file, do this:

osmosis --read-xml-0.6 file="planet.osm.bz2" --write-apidb-0.6 populateCurrentTables=yes host="localhost" database="openstreetmap" user="openstreetmap" password="openstreetmap" validateSchemaVersion=no

Q?: Should the docs explain how to do this with something smaller than planet.osm?

AND

You will need the latest Osmosis to have the right database scheme.

Q?: Is this an implication that using apt-get install is a potentially bad way to go?

Jeffmeyer 02:57, 20 October 2012 (BST)

To err on the side of caution, I've added instructions for installing the latest version of Osmosis to the Rails Port / Ubuntu page. Jeffmeyer 01:21, 22 October 2012 (BST)

Populating the database "Sessions" relation error

This command:

openstreetmap=# select setval('sessions_id_seq', (select max(id) from sessions));

yields the following error:

ERROR:  relation "sessions" does not exist
LINE 1: ...ct setval('sessions_id_seq', (select max(id) from sessions))...

Anyone know what's going on here? e.g. is there no sessions table available on first run?

Jeffmeyer 09:24, 21 October 2012 (BST)

rake problems I encountered... (unclear)

I encounter Error ! As follower aj@ubuntu:~/rails$ rake gems:install --trace rake/rdoctask is deprecated. Use rdoc/task instead (in RDoc 2.4.2+) Please install RDoc 2.4.2+ to generate documentation.

    • Invoke gems:install (first_time)
    • Invoke gems:base (first_time)
    • Execute gems:base
    • Invoke environment (first_time)
    • Execute environment

rake aborted! syntax error on line 9, col 2: host: localhost' /usr/lib/ruby/1.8/yaml.rb:133:in `load' /usr/lib/ruby/1.8/yaml.rb:133:in `load' /usr/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:926:in `database_configuration' /usr/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:437:in `initialize_database' /usr/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:141:in `process' /usr/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:113:in `send' /usr/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:113:in `run' /home/aj/rails/config/environment.rb:9 /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require' /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `require' /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:182:in `require' /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:547:in `new_constants_in' /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:182:in `require' /usr/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/tasks/misc.rake:4 /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:205:in `call' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:205:in `execute' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:200:in `each' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:200:in `execute' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:158:in `invoke_with_call_chain' /usr/lib/ruby/1.8/monitor.rb:242:in `synchronize' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:151:in `invoke_with_call_chain' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:144:in `invoke' /usr/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/tasks/gems.rake:17 /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:205:in `call' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:205:in `execute' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:200:in `each' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:200:in `execute' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:158:in `invoke_with_call_chain' /usr/lib/ruby/1.8/monitor.rb:242:in `synchronize' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:151:in `invoke_with_call_chain' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:176:in `invoke_prerequisites' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:174:in `each' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:174:in `invoke_prerequisites' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:157:in `invoke_with_call_chain' /usr/lib/ruby/1.8/monitor.rb:242:in `synchronize' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:151:in `invoke_with_call_chain' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/task.rb:144:in `invoke' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:112:in `invoke_task' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:90:in `top_level' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:90:in `each' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:90:in `top_level' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:129:in `standard_exception_handling' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:84:in `top_level' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:62:in `run' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:129:in `standard_exception_handling' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/application.rb:59:in `run' /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/bin/rake:32 /usr/bin/rake:19:in `load' /usr/bin/rake:19 Tasks: TOP => environment

Unclear what this post is asking or the date of when it was posted. Tough to tell if it's still valid. Jeffmeyer 03:30, 22 October 2012 (BST)

Page move (Hopefully fixed)

Somebody moved this page to a new title (twice actually). I've moved it back to it's original title 'The Rails Port'

Why? Because there's about a bazillion pages linking to this original title (Special:WhatLinksHere/The Rails Port) because this is very old wiki page deeply meshed into the wiki (and many external sites) We could move the page, but that would be a fairly big thing to do. We should discuss it first.

-- Harry Wood 23:50, 23 June 2011 (BST)

I couldn't find the right place to discuss this thing. As it's an wiki i just did it, as we could easily move everything back. Moving pages in Mediawiki is no problem as long as the old names like "The Rails Port" redirect to the new name.
There were many "rails port specific" pages in the wiki, which title don't really say, where they belong to. I think subpages are good way to achieve this, see Osm2pgsql and Tirex as example, so i moved the regarding pages to Rails_port/*. Now after your Name restoring all, relative links on this page don't work any more. So we need either
  • move all subpages too (there is an checkbox in the moving form which does that) and repair the redirects from the old pages
  • modify the links in the page
  • rename it back to Rails_Port
The main reason for this whole restructuring action by me is still unfixed: During the munich hacking weekend i came across the fact that we don't really describe the different database schemas we have at different parts. There is Database, Database schema, Osm2pgsql/schema Osmosis PostGIS "simple" schema and "snapshot" schema...
There is some (outdated) overview at Databases_and_data_access_APIs#Database_Schemas but the main problem is that there are so many redundant pages inside this wiki. Maybe it would be a good starting point to define definitive names for the different databases and database schemas.
But maybe this database thing should not be discussed on the talk page of the rails port... ;-)
--Saerdnaer 11:19, 24 June 2011 (BST)
Yes the database pages are a bit messy aren't they? We should start some little Talk page discussions about how to tackle those messes too.
OK so I see there's been several other page moves. A lot of the Special:PrefixIndex/Rails port pages under a 'Rails port' subpage were moved to that position by you and User:Avatar. because "title don't really say, where they belong to"? . Using wiki subpages isn't necessarily the organisational masterstroke people tend to imagine it to be. Wikis link and flow more naturally with simpler page titles (more on that here). Then again many of your page moves do work quite nicely actually (and Tirex is an example of subpages working quite well) although I'm not convinced that "Rails port/Development" is a better page name than "Committing to the rails port" for instance.
So anyway just thinking about the name of this page. "The Rails Port" is a bad name and I've thought about moving it for a long time. "Rails port" is slightly better name, so I do actually support the move, but not without discussing, and not without fixing all the double-redirects it creates.
One thing to discuss... if we're going to the trouble of moving the page (and adjusting lots of incoming links) we might consider that this thing is only called "The Rails Port" because once upon a time the code was ported from pure ruby. The name just stuck. It might better be called the "Rails App" (or other suggestions?). Something to consider perhaps, but then arguably that's too interfering. The wiki should be "descriptive not prescriptive" some might say. I don't know to what extent people call it "the rails port" because the wiki influences them to call it that. Does that name get used on the mailing lists a lot? not sure.
In summary a move to "Rails port" is not such a bad idea. What do other people think though?
-- Harry Wood 00:57, 27 June 2011 (BST)
Leave it as-is. It's currently known as "the rails port", you'll hear people saying "I was hacking on the rails port this weekend", similarly "I was hacking on osmosis" or "I was hacking on osm2pgsql". In other words, the definite article ("the") is part of the name of the software. It's a stupid name, and it would be great to have a better one, but that's no justification for getting its current name incorrect. Gravitystorm 09:24, 15 November 2011 (UTC)
Hopefully fixed with a statement in the first paragraph of the page explaining the origins of the name. I believe there are ongoing, separate discussions about changing the name in other various fora. Hoopefully, this brief explanation will be a reasonable mid-term solution. Jeffmeyer 22:39, 21 October 2012 (BST)

Gems (libraries) fails (fixed)

I assume the line

# cd /path/to/rails_port/

directs me to where I cloned openstreetmap-website.git into?

In the current tip of branch master (1cc882b23f161ade83fb94052fa4a43c0caa16d2) there is no file "config/postgres.example.database.yml" (anymore?), thus the copy in

# cp config/postgres.example.database.yml config/database.yml

fails. Subsequently (but I don't know if caused by this),

# bundle install

fails at "gcc -I. -I/usr/lib/ruby/1.8/x86_64-linux -I/usr/lib/ruby/1.8/x86_64-linux -I. -fPIC -I/usr/lib/ruby/gems/1.8/gems/memcached-1.4.1/ext/include -L/usr/lib/ruby/gems/1.8/gems/memcached-1.4.1/ext/lib -fno-strict-aliasing -g -g -O2 -fPIC -fno-strict-aliasing -g -g -O2 -fPIC -Os -c rlibmemcached_wrap.c" with a rather extensive error list.

Is there a workaround? (If this is the wrong place to ask this question, I apologize. Please redirect me to a more appropriate place). Baeuchle 16:29, 16 March 2012 (UTC)


Yes, I had the same issue on 11.10. Before "bundle install", run "sudo apt-get install libsasl2-dev" . This solved the above problem. --Fodor99 08:01, 6 April 2012 (BST)

This is fixed in the current instructions with the addition of libsasl2-dev in the Ubuntu install page. Jeffmeyer 02:33, 17 October 2012 (BST)

Проблема при выполнении ~$ bundle install (fixed)

Устанавливаются все пакеты за исключением memcached (1.3.7) При попытке установить проблемный пакет отдельно, инсталлятор выдает в терминал гигантский лог. При попытке уставить более ранние версии memcached происходит то же самое. Операционные системы где проявляется ошибка: Ubuntu 10.04 Ubuntu 11.10

Эта ошибка не может быть устранена пользователем, незнакомым с Rails. Выше приведенный факт ставит под сомнение ценность статьи как части wiki-проекта

Translation: The problem in the performance of ~ $ bundle install

Installed all the packages except for memcached (1.3.7) when trying to install the package the problem separately, the installer displays a huge log into the terminal. If you try to stare earlier memcached is the same. Operating systems where the error appears: Ubuntu 10.04 Ubuntu 11.10

This error can not be removed by the user, unfamiliar with Rails. The above fact calls into question the value of the article as part of a wiki-project

User:Dmitriy 06:27, 20 February 2012

Нашел решение для Linux http://www.wetware.co.nz/2010/10/rails-or-ruby-memcached-gem-on-ubuntu-and-linux/ когда искал решение для FreeBSD --s-s-s 12:59, 19 July 2012 (BST)
This is fixed in the current instructions with the addition of libsasl2-dev in the Ubuntu install page. Jeffmeyer 02:33, 17 October 2012 (BST)

libmagick (fixed)

On Ubuntu 10.04 LTS I had to install libmagick9-dev and libxslt-dev to satisfy ruby dependencies:

  apt-get install libmagick9-dev libxslt-dev

-- Martijn van Exel 11:50, 16 May 2010 (UTC)

This has been fixed. Jeffmeyer 02:33, 17 October 2012 (BST)

Issues with installation on Ubuntu 11.04 (Old)

I will update the wiki with this when I have finished, but thought I'd put it here for now.

  • It appears to need rails version 2.3.14, (not 2.3.8 or 2.3.11)

</nowiki>

  • It appears to need the latest stable version of osmosis (0.39), not 0.38 which comes with Ubuntu, or 0.30.3 as stated on the wiki page, otherwise you get an error about a missing column in the users table.
This issue is old & possibly out of date. Osmosis latest build is .41 and Ubuntu is on Release 12.10 Quantal. Jeffmeyer 22:54, 21 October 2012 (BST)

Database.yml instructions - missing osm_test and osm usernames? (fixed)

The prior instructions don't say to set up the osm_test or osm usernames - should they? Jeffmeyer 02:50, 20 October 2012 (BST)

now fixed in the instructions. Jeffmeyer 01:20, 22 October 2012 (BST)

Gems library section (fixed)

The instructions prior to this section have already instructed you to cp example.database.yml - is it necessary below? If you do this, then you'll overwrite your prior changes.

 # cp config/example.database.yml config/database.yml

Jeffmeyer 02:53, 20 October 2012 (BST)

The instructions have been reordered to address this problem. Jeffmeyer 01:20, 22 October 2012 (BST)

Installing the quadtile function (fixed)

The instructions in this section are vague and semi-helpful at best:

'''This section is not essential and can be skipped by most users. The test suite requires it, however, so if you want a clean test run, you need this.'''

If you don't install the quadtile functions, you will get three(?) errors when running the test. You can ignore this.

If the goal of this page is to ensure successful Rails Port installations, with as few problems as possible, and the test suite requires these functions, we should either (a) encourage people to install this stuff *and* to test it, or (b) change the test so that it doesn't require this stuff.

Also - if we tell people they will "get three errors" when running the tests, we should tell them which errors they will get, otherwise they have no way of knowing the errors they are seeing are the ones they are supposed to be seeing.

Jeffmeyer 07:04, 20 October 2012 (BST)

Quadtile installation instructions have been brought into a more logical sequence in the instructions and marked as "optional" Jeffmeyer 01:25, 22 October 2012 (BST)

Problem with sql_session_store (Old - MySQL)

When checking out via svn co http://svn.openstreetmap.org/sites/rails_port error is reported

Fetching external item into 'rails_port/vendor/plugins/sql_session_store'
svn: Server sent unexpected return value (405 Method Not Allowed) in response to PROPFIND request for '/svn/plugins/sql_session_store/trunk'

This is because these repos are no longer hosted at http://railsexpress.de/svn/plugins/sql_session_store/trunk they now reside at http://github.com/joergbattermann/sql_session_store/tree/master and are obtaibable via:

git clone git://github.com/joergbattermann/sql_session_store.git

in the vendor/plugins directory

also needed:

svn co http://opensvn.csie.org/rails_file_column/plugins/file_column/trunk 

in vendor/plugins

and on Ubuntu 8.10 needed:

sudo apt-get install ruby1.8-dev

...solved gem being able to install libxml-ruby and RMagick

--SamRose 13:20, 15 April 2009 (UTC)

I believe these problems have been solved by current instructions. Jeffmeyer 01:29, 22 October 2012 (BST)

Two problems I encountered... (old / fixed)

... and how I resolved them. I am a Ruby/rails newbie, but maybe sharing my experience will help others.

My configuration was: Debian GNU/Linux "Lenny" amd64 (x86_64)

  • When installing several gems, it showed dependency errors. For example, the postgresql connector failed. The headers and libraries were there (libpq-dev), so I was confused at first. The problem turned to be "gem install" using cc as the compiler, instead of the available gnu version "gcc". Creating a link or an alias will be enough to solve it.
  • After setting up the database and the software, the site worked seamlessly. However, any call to the API (via wget or with the "data" overlay at the main page) resulted in an error: 501 internal error. Reviewing the logs I found that the request was processed and even it generated a good sql query, but failed with the following message:
 API threw unexpected NameError exception: uninitialized constant XMLEncoding::UTF_8

A dependency was missing: Builder gem. So:

 # gem install Builder

and everything worked fine. --jynus (discusión) 12:01, 23 April 2010 (UTC)

I doubt the "gem install builder" is the solution to the second problem. I encountered the same XMLEncoding error, and it seems to appear if you restart the server (and possibly if you let it sit long enough), and to disappear reliably if you do a hard reload (CTRL+F5 on firefox) on the main page of your install. --Janschejbal 15:22, 31 August 2012 (BST)
I believe the gem bundler issues are fixed in the current instructions. Jeffmeyer 01:29, 22 October 2012 (BST)

For PgSQL Section (Fixed)

You need to install the *server* extension headers for PostgreSQL, on Ubuntu/Debian that is typically called postgresql-server-dev-8.3 (or 8.2, or whatever version of pgsql you have).

Q?: Why are these steps in this part of the instructions? (as opposed to earlier?)

Jeffmeyer 02:59, 20 October 2012 (BST)

A copy of this section has been placed in a more logical place in the flow of the instructions.

rubyonrails.org showcase (old)

Can someone drop a note to rubyonrails.org so they can showcase the openstreetmap depoyment? - User:Mila 19:32, 18 July 2009

I am presuming this has either (a) been done, or (b) is old news. Jeffmeyer 03:22, 22 October 2012 (BST)


Quadtile installation - which login? (fixed)

In the Quadtile installation section, the user is asked to "log into pgsql" and do...

Log into PgSQL and execute the CREATE FUNCTION statement from maptile.c's comment:

sudo -u postgres -i

psql

CREATE FUNCTION maptile_for_point(int8, int8, int4) RETURNS int4 AS '/full(no~)/path/to/rails-port/db/functions/libpgosm', 'maptile_for_point' LANGUAGE C STRICT;

CREATE FUNCTION tile_for_point(int4, int4) RETURNS int8 AS '/full(no~)/path/to/rails-port/db/functions/libpgosm', 'tile_for_point' LANGUAGE C STRICT;

Q: This will create functions in the public schema for the postgres instance, which I believe should be fine, but I am not sure.

Jeffmeyer 01:39, 22 October 2012 (BST)

Indeed! These functions need to be created in the openstreetmap and osm databases. Putting them in public doesn't work. (perhaps "public" doesn't mean what I think it means...?) Fixed in the current instructions. Jeffmeyer 06:19, 22 October 2012 (BST)

Rake Test - <500> errors (fixed)

  • The tests gave three failures:
/usr/bin/ruby1.8 -I"lib:test" -I"/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib" "/usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/rake_test_loader.rb" "test/functional/**/*_test.rb" 
Loaded suite /usr/lib/ruby/gems/1.8/gems/rake-0.9.2/lib/rake/rake_test_loader
Started
.................................F.F.F.....................................................................................................................................................
Finished in -44161077.318441 seconds.

  1) Failure:
test_changes_simple(ApiControllerTest) [test/functional/api_controller_test.rb:207]:
Expected response to be a <:success>, but was <500>
<"">

  2) Failure:
test_changes_zoom_valid(ApiControllerTest)
    [test/functional/api_controller_test.rb:231:in `test_changes_zoom_valid'
     test/functional/api_controller_test.rb:229:in `upto'
     test/functional/api_controller_test.rb:229:in `test_changes_zoom_valid']:
Expected response to be a <:success>, but was <500>
<"">

  3) Failure:
test_hours_valid(ApiControllerTest)
    [test/functional/api_controller_test.rb:260:in `test_hours_valid'
     test/functional/api_controller_test.rb:258:in `upto'
     test/functional/api_controller_test.rb:258:in `test_hours_valid']:
Expected response to be a <:success>, but was <500>
<"">

187 tests, 2413 assertions, 3 failures, 0 errors


  • It appears to need the latest stable version of osmosis (0.39), not 0.38 which comes with Ubuntu, or 0.30.3 as stated on the wiki page, otherwise you get an error about a missing column in the users table.
I am currently seeing this issue when following the instructions, as prescribed. Jeffmeyer 03:12, 22 October 2012 (BST)
Fixed by the maptile and tile function fixes in osm and openstreetmap. Jeffmeyer 06:19, 22 October 2012 (BST)

Vague Error References in Running the tests section (fixed)

There may be some errors which does not matter here.

Q?: How to tell which errors matter and which do not?

To get a chance for a clean test run without errors, install the required functions first as described in the section for pgSQL below.

Q?: What does "to get a chance for a..." mean? If the required functions are required, why not include them in this section?

Jeffmeyer 02:55, 20 October 2012 (BST)

Deleted this section. Either the tests should return no errors or they should be explained or mentioned in the instructions or the tests should be fixed. Jeffmeyer 06:19, 22 October 2012 (BST)

Updating the documentation - Oct 2012

I've been putting some questions directly into the installation instructions rather than here on the Discussion Page for 2 reasons: (1) the questions are proximate to the relevant text, so there's no page flipping; and (2) it doesn't look like this page is being tended to. So, I'll try to go through and make sure that all of these issues are either fixed or bumped. I'm also going to reorder some of the discussion topics so that more recent or higher priority items are closer to the top of the page. Please let me know if anyone thinks this is a suboptimal approach!

Please be sure to sign your posts with 4 ~'s - Jeffmeyer 02:14, 17 October 2012 (BST)

Also - I'm hoping this will only take a week or two (17 - 31 Oct 12), so hopefully, the mess won't be there for too too long. Jeffmeyer 18:09, 17 October 2012 (BST)
hmm. So what you're saying is... you've found a few little things wrong with the documentation on this page so you've cluttered the docs with confusing personal questions and comments. That does sound like a suboptimal approach yes. I mean it will probably get your questions answered quickly, but if everyone did that when they got stuck on one of these steps then it wouldn't be very readable and usable ever. -- Harry Wood 11:34, 18 October 2012 (BST)
Hi Harry - thanks for the note. There aren't a "few little things wrong" with the docs. They didn't work as written. Or, at least, they didn't for me, and for others, as evidenced by questions on this discussion page and a variety of online postings. I've fixed a few things that were incorrect already - things that are apparently well known, but just weren't fixed in the doc. My apologies if my questions have confused anyone. I've always found that it's reassuring to know when something is confusing and it's not "just me." My goal is to improve the doc so that - at least for the OS I'm using (Ubuntu Precise) - following the instructions as presented will result in a successful installation without having to consult any other online message boards or IRC channels.
I'll move all questions here to the discussion page, although it seems that these questions are rarely answered or addressed in the core doc. If you have any suggestions or answers for the questions, they're most appreciated! Also - not all spurious comments in the docs have been moved b/c they weren't all mine. Jeffmeyer 02:49, 20 October 2012 (BST)
Sorry. Was being a bit grumpy earlier :-) It's great you're working on improving these docs. Best not to add lots of comments, but I see you're managing to resolve them anyway. I'll try to do a big run through test install again some time to see how it goes for me. Also the Engineering Working Group are interested in making these things easy. They'd probably be interested in where the docs need fixing and where you're getting stuck. -- Harry Wood 14:52, 22 October 2012 (BST)
No worries, mate! I need to learn how to fit in around these parts. How about if I ping you to take you up on the install offer when I'm done with the edits? I've been testing the instructions so far repeatedly against a blank Precise VM snapshot, but I'm sure I'm not seeing my own assumptions and shortcuts. As for getting stuck... that's not an option! : ) osm-railsdev has been a big help. Jeffmeyer 21:07, 22 October 2012 (BST)

Move content from Troubleshooting to relevant sections

Anyone object to moving the troubleshooting content to the sections that are relevant?

For example, the Troubleshooting section is structured like this:

  • Problems with Section X
  • Problems with Section Y

I'm proposing we move the "Problems with Section X" to the actual Section X, in order to put answers proximate to where problems might be encountered.

Thoughts?

Jeffmeyer 22:31, 21 October 2012 (BST)

I've done this to see what it looks like. Barring objections, I'll eliminate the duplicative stuff at the end of the doc and leave the changes as recommended above. Jeffmeyer 01:25, 22 October 2012 (BST)


Postgres Tuning

The installation instructions should have a section for recommended host machine or postgres tuning settings. Jeffmeyer 03:27, 22 October 2012 (BST)

This is now taken care of... there's a link to: http://wiki.openstreetmap.org/wiki/Nominatim/Installation#Tuning_PostgreSQL Jeffmeyer (talk) 07:25, 18 February 2013 (UTC)