JOSM/Plugins/public transport

From OpenStreetMap Wiki
< JOSM‎ | Plugins
Jump to: navigation, search

Contents

Introduction

The JOSM Plugin Public Transport is designed to simplify the mapping and editing of public transport routes according to best practice standards (see Oxomoa scheme). After some installation instructions, we start with a chapter about usage examples: Mapping public transport means mapping of its stops and its routes. In the first three sections, we present different methods of how to map stops and how this plugin can be used to simplify this. The first section is about mapping by waypoints. The second section explains how to map with the help of a stopwatch. The third section explains mapping by tracklogs only. The subsequent sections are devoted to map routes. In the fourth section, we describe how to create a bus route from scratch. If there exists already one or more lines running partly or completely parallel, you can take advantage of this (see fifth section). Also, you can easily convert routes from older data formats to the Oxomoa scheme (see sixth section). The following chapter explains the notions used along the plug-in. The last chapter contains a reference manual of all items in the plug-in.

This manual refers to the version of 2010-04-13. This plug-in is still a beta version, so don't forget to save your work before and during you use this plug-in. Feel free to make suggestions for simplifications or extra functionality or report bugs to me (mailto:roland.olbricht(at)gmx.de).

How to Install

Open JOSM and select from menu Edit > Preferences, then there Plugins > Download list. Check public_transport in the list. Now restart JOSM.

Examples how to Use

To map public transport, in particular bus services, means to map stops and routes. The larger part of the work is to map stops; the routes can usually be derived from other information in the map and local knowledge. To properly map the stops, you need a GPS device, because an estimation is almost always surprisingly inexact (even bus stops are often a lot larger than one would expect).

We discuss three different approaches. The basic assumption of all three approaches is that you are mapping the public transport service by actually using it. Take the GPS device, pen and paper with you and ride on the vehicle from its starting point to its terminus. With some cleverness and fortune, you should be able to log forth and back direction within a single ride. Also, all three methods will need more or less post-processing with JOSM and the plugin.

Map Stops from Waypoints

You need a GPS logger which can register waypoints and pen and paper. Get on the vehicle and mark a waypoint at each station: bus stops and tram stops are mapped on the side of the road at their respective sign, all other stops are mapped as part of the railway line. Use pen and paper to note the names of the bus stops and whether they have a shelter or not. I personally also collect stops forth and back during a single ride and thus take also a note whether the stop is in forward or backward direction.

When you are back at your computer, download the collected data from your GPS device into a GPX file: the exact steps depend on your particular device, but in general one of the programs GPSBabel, mtkbabel or BT747 may help. They are explained on the respective pages of the wiki.

Once you have created the GPX file, open JOSM. Now choose Create Stops from GPX in the menue Public Transport. This raises first a file selection dialogue. Select here your just generated GPX file. The plugin now generates one stop at every waypoint. Now go to the tab Settings and select the type of stop you want to create. Open tab Waypoints and click onto the table. Now you can use keyboard shortcuts to edit the stops: Alt-N will focus the stop of the current line in the table and activate the name cell of this line. Alt-S, Alt-T and Alt-U help you to select the proper type of shelter: Alt-S yields Yes, Alt-T yields No and Alt-U yields implicit. If you don't want to map the shelter, just use only Alt-N. The key combination Alt-D disables the current waypoint and deletes the node associated to it. Now process all waypoints and then close the dialogue. Or process all waypoints, mark the lines they belong to and click Detach - this has the same effect. Once you have pressed Detach, the nodes are released from the dialogue and complete. Congratulations.

Map Stops with a Tracklog and a Stopwatch

You need a GPS logger that displays its current time, pen and paper and a stopwatch that can store sufficently much split times. First, syncronise stopwatch and GPS logger: Note the time the GPS logger has shown in the moment when you have started the stopwatch. Take a split time for every stop you pass: bus stops and tram stops are mapped on the side of the road at their respective sign, all other stops are mapped as part of the railway line. Use pen and paper to note the names of the bus stops and whether they have a shelter or not.

When you are back at your computer, download the collected data from your GPS device into a GPX file: the exact steps depend on your particular device, but in general one of the programs gpsbabel, mtkbabel or bt747 may help. They are explained on the respective pages of the wiki.

Once you have created the GPX file, open JOSM. Now choose Create Stops from GPX in the menu Public Transport. This raises first a file selection dialogue. Select here your just generated GPX file. Select in the tab Tracks the track to create stops from. Now go to the tab Settings and select the type of stop you want to create. Put the sync time of the GPS device and the stopwatch in the respective fields. Open tab Stops and click onto the table. Click the button Add unless you have sufficiently much lines for all your split times. Now enter your split times in the first column. Then proceed as explained in the last paragraph of the section before.

Map Stops with a Tracklog only

N.B.: This apporach requires the software to do some semi-automatic guesswork. Although I've tried several approaches, the software still produces annoyingly much false positive (e.g. halts at traffic lights) and might miss stops (in particular, if the bus has passed them with no stop). Thus you should try to use one of the other two methods (with or without waypoints) first or a combination of these methods. The method might be useful to map stops you have forgotten to record.

You need a GPS logger, pen and paper. Record a GPS track while taking a ride on the route you want to map. Note the names of the bus stops you have passed and whether they have a shelter or not.

When you are back at your computer, download the collected data from your GPS device into a GPX file: the exact steps depend on your particular device, but in general one of the programs gpsbabel, mtkbabel or bt747 may help. They are explained on the respective pages of the wiki.

Once you have created the GPX file, open JOSM. Now choose Create Stops from GPX in the menu Public Transport. This raises first a file selection dialogue. Select here your just generated GPX file. Select in the tab Tracks the track to create stops from. Now go to the tab Settings and select the type of stop you want to create. Put the sync time of the GPS device and the stopwatch in the respective fields. Click the button Suggest stops and open tab Stops. If there are way too much or way too few stops or clusters of stops, adapt the values Time window and Move Threshold in the tab Settings. Now enter in the second column the names of the stops: Mark a line in the table and press Alt-N. This focuses and marks the stop and makes its name editable. If the stop is a false positive, you can delete it with the button Delete or Alt-D. All keyboard shortcuts are explained in the waypoints section.

Map a Bus Line from Scratch

The Oxomoa schema consists of a relation per direction and contains the itinerary (the way a bus actually takes from its starting stop to its terminus) and the stops served by the bus. Roughly, you need to enter one direction of the itinerary by hand. The stops and the back direction can mostly be derived from that by the software.

Download the area where your bus route takes place. Choose the menu item Public Transport > Route patterns. This opens a window where you can see all public transport routes existing in the downloaded data set. Create a new relation by clicking on the button New. Now change to the tab Tags and set appropriate values for a least route (the type of public transport), ref (the line number) and to (the destination displayed).

Change to the tab Itinerary. Now select on the map the first way that belongs to your route and press Add. Mark the second item and press Add again. You also can select several ways at once and click Add. If your ways are added in the wrong order or with wrong roles, mark them (click the first entry in the window, then shift-click the last entry in the window) and press Sort. If there appear one or more lines [gap], then your ways don't fit together. If sorting won't solve that then there are gaps in your itinerary and you need to add the missing links or split ways (mark the way, the node where to split at and then use menu Tools > Split Way) if your bus service only partly uses them. To help you with the tasks you can:

There are buttons Mark, Show and Find with similar functionality in the tab Stops.

You can delete one or more entries from the list by marking them and clicking Delete. You can also move one or more entry by marking them, clicking on Mark (this copies them to the clipboard, like the middle mouse button on X servers), then Delete, then mark the first item before which you want to insert the items and click Add.

Now you can add the bus stops in a convenient way: change to the tab Meta and press Suggest Stops. This will compile a list of stops that are near the itinerary. You can choose up to which distance from the itinerary stops should be considered and whether stops only the right hand side, only on the left hand side or on both sides are possible. Now change to the tab Stops. You can identify the stops by their entries as follows: click Mark and/or Show. Delete spurious entries by marking them and pressing Delete. Add missing stops by marking them on the map, marking the entry before which you want to insert the stop (unmark all entries if you want to append stops to the end), then press Add.

When you are complete with the forward direction, go back to the tab Overview. Then click Duplicate (this adds a copy of the relation) and click Reflect (this reflects the copy to become the backward direction). Review the itinerary in the tab Itinerary and correct oneways passed in the now wrong direction. Then change to the tab Meta and let you suggest bus stops. Review them. Congratulations, you are done with the entire bus line.

Reuse a partly parallel line

The plug-in has an internal clipboard to simplify copying parts of the itinerary or the stops from one bus route to another. Data is put into the clipboard following the X server paradigm. Mark one or more entries from the itinerary list or stops list and click the respective button Mark (in Itinerary, in Stops). The objects themselves are kept by being marked on the map. The plug-in additionally saves their order and role. You can paste data from clipboard by using the respective button Add (in Itinerary, in Stops).

To do this, first choose the source route at the tab Overview and then change to the tab Itinerary. Mark there the entries you want to copy and click Mark. Then choose at the tab Overview your destination relation and mark in the tab Itinerary the entry before which you want to paste the entries or unmark all entries if you want to append the data from clipboard.

Stops can be copied in the same way: first choose the source relation at the tab Overview and change to the tab Stops. Mark there the entries you want to copy and click Mark. Then choose at the tab Overview your destination relation and mark at the tab Stops the entry before which you want to paste the entries or unmark all entries if you want to append the data from clipboard.

Reuse an Old Relation

If you have a bus route in an old format, you can spread it with the help of the plug-in into separate relations for both (or more) directions. Go to the tab Overview, mark the respective relation and click Duplicate, then Reflect. Now you have a relation for each direction. The remaining task is to cleanup the new relations.

First, mark again the first relation. Go to the tab Itinerary and cleanup the itinerary to contain only the forward direction as described above. Now you can use Suggest Stops from tab Meta to obtain a good guess for the bus stops. Use the tools in the tab Stops to cleanup this list.

Now go back to the tab Overview and select the newly created route. Proceed with the same steps as for the forward direction. Congratulations, now you have corrected the bus line.

Used Notions

Note: I'm not a native English speaker. Thus, if you have suggestions for better wording, please send them to me (mailto:roland.olbricht(at)gmx.de).

clipboard - Beside the operating system, the plug-in has an internal clipboard that allows to maintain the order and roles of relation members, in particular bus stops and ways belonging to the itinerary. The clipboard is used similar to the X window system clipboard: there you copy text into the clipboard by marking it with the mouse and paste it by clicking the middle mouse button. We can't assume that every computer has a middle mouse button. Thus, in the plug-in you copy data into the internal clipboard by marking the entries and clicking Mark (in Itinerary, in Stops). You paste data by keeping it marked on the map and clicking Add (in Itinerary, in Stops).

entry - An entry in the list of objects that are members of a relation. Here, the relations are public transport routes and members are stops or stations or the ways that constitute the itinerary. The notion entry is used to discriminate between the relation members (entries) and the objects referred to by the relation members (objects on the map).

GPX file - This is a common file format supported by most GPS loggers. The data you log in the real world, in particular logged stops and stations, get fed into this software as GPX files.

itinerary - The way a bus service actually takes. Note that buses or other vehicles can't make jumps, thus there cannot be gaps in an itinerary. For that reason, a line [gap] is displayed in the itinerary list whenever the first node of a way differs from the last node of the preceding way.

(bus) line - The notion refers usually to all bus or train services that are offered in a certain network with the same line identifier. The line identifier for a relation is declared by the tag ref.

mark - see select.

network - the set of all services that a organised as a whole by some kind of transport authority. Often, the network is the responsible party for ticket fares. It is used to disambiguate different routes with the same line identifier in different regions. In particular, we assume that in every network a line identifier is unique, i.e. that all relations with the same line identifier constitute a logical unit. The network is declared by the tag network.

node - The respective OSM primitive. The only objects represented by nodes here are stops and stations. Nodes are visible in the JOSM main window and a list of nodes as members of the route relation constitutes the served stops of a public transport route.

Oxomoa scheme - see http://wiki.openstreetmap.org/wiki/User:Oxomoa/Public_transport_schema. This plug-in implements a subset of the Oxomoa scheme. We implement in particular here the splitting of bus lines into bus routes. This allows to display the correct order of an itinerary and stops even if a section is passed twice or several times. The extra relations per line number on top of the bus route relations aren't implemented yet because there is no known use case for them. Also, the concept stop_position has not been implemented as it causes ambiguities: if it is placed on a non-oneway, the direction of the stop_position is unclear.

In particular, the data model underlying this plug-in is as follows: Every bus stop is represented at its road sign by a node with tag highway=bus_stop which is off the road itself, usually a few meters, depending on the width of the street. Every bus route (i.e. every service with distinct starting point, ending point or itinerary) is represented by a relation on its own with tags type=route, route=bus|tram|light_rail|subway|rail and ref set to the line number or line identifier and network set to the network the line belongs to. The name tag may be used if the line has a name but it won't appear somewhere. The relation contains as members the ways which constitute the itinerary the bus actually takes and the bus stops in the order they are served. The member role of the ways is set to either forward or backward, depending on whether the bus passes the street in or against the direction it is drawn in the map.

public transport route - The pattern of passed roads and served stops by a particular public transport service. A (bus) line usually consists of two or more (bus) routes but there are exceptions: bus services only operating in one direction or bus services with the same line number but different branches.

relation - The respective OSM primitive. The only objects represented by relations here are the public transport routes. They are not visible on the JOSM main map but can be edited with this plug-in.

Route type - You don't want to see an international high speed rail service and a local school bus to be mapped in the same way. For this purpose, we need some further taxonomy to classify public transport services into. As a preliminary classification, we use the following:

  • Bus: Any service that operates completely or partly on ordinary streets with rubber tyre vehicles.
  • Tram: A service that operates on rails, almost always on the surface and often shares space with car traffic.
  • Light rail: Most newer tram-like services will go into this category. Operates on rails, has most of the time separated tracks, might go underground or overgorund or use wide area railway networks and has usually a level entrance.
  • Subway: A service that has its tracks grade separated from street traffic but is also apart from wide area railway networks.
  • Railway: Services that operate on wide area railway networks.

select - Unfortunately, there are different things that can be selected. You can and need to mark objects (ways and nodes) on the map in the JOSM main window. Or you can mark entries in the list in one of the tabs Overview, Itinerary or Stops. The former is usually referred to as select on the map, the latter as select an entry. For the entries it is sometimes useful to know that you can mark several entries at once by clicking on the first entry, then shift-clicking on the last entry. You can unmark all entries as follows: click an entry (this marks it and unmarks all other entries) then Ctrl-click it again (this unmarks this entry).

stop - The location where a bus or train calls. It is represented here by the position of the road sign that indicates the bus stop in the real world. In particular, bus stops are always off the road. This is necessary because buses have doors only on one side. Thus, there are no two-directional bus stops. This is in contrast to railway stations: as trains have usually doors on both sides, a train station can and is often used in both directions.

track - A data structure from GPX files: GPX files are organised as a collection of waypoints and tracks. While waypoints are just points, each track is a sequence of points representing an arbitrary motion. The track contains the information when the vehicle was where. Usually, a GPS logger starts a new track each time you put its power on.

way - The respective OSM primitive. It is visible in the JOSM main window and a list of ways constitutes the itinerary of a bus route. A way has an orientation from its first node to its last node. In JOSM, this is visualised by the direction of the arrows that represent the way. Thus, a vehicle can pass a way in or against its orientation. This is indicated by the role of the relation membership representing the itinerary: forward means that the vehicle passes the way in its orientation while backward means the opposite.

Create Stops from GPX

If you have a GPX file and want to create bus stops or stations from it, use this dialogue window. Each time you open this dialogue window, you must select from which GPX file you want to create stops. For this purpose, please choose a file in the file open dialogue window Select GPX file. After you have chosen a file, you can use the subsequently described items. If you close the dialogue window, the generated stops remain as ordinary nodes in the JOSM dataset - you cannot manage them any more from this dialogue window.

Tab Tracks

List Tracks in this GPX file

The large list in the center contains all tracks that have been found in the GPX file. They are described by their name. The features in the tabs Settings and Stops depend on the content of the track and can only be used if you choose a track here.

Tab Settings

In this tab you configure the values for the nodes you create or manage with the dialogue window. Depending on the method you use to create stops, different parts of this tab might be relevant:

Combo box Type of stops to add

Choose here which kind of stops you want to generate. Available options are bus stops, tram stops, light rail stations, subway stations and railway stations.

Text field Time on your GPS device

If you map with a tracklog and a stopwatch, put here the time on your GPS device when you have synchronised your logger and your stopwatch. For other mapping methods, this field is meaningless. It is initially set to the time of the first trackpoint in the track.

Text field Time on your stopwatch

If you map with a tracklog and a stopwatch, put here the time on your stopwatch when you have synchronised your logger and your stopwatch. Usually, this will be zero. If you map with a tracklog only, set this field to the same value as Time on your GPS device. Then you can see the real GPS times of the points where the software guesses the stops to be. For other mapping methods, this field is meaningless.

Text field Time window

This field influences the behaviour of the suggest stops feature. It indicates for how much the tracklog must remain at (almost) the same position to guess the location to be a stop.

Text field Move Threshold

This field influences the behaviour of the suggest stops feature. It indicates for what amount of meters the position in a tracklog may move to still assume the location to be a stop. It also sets the minimum distance between two stops: a location is only guessed to be a stop if it is at least this amount of meters away from the last guessed stop.

Button Suggest Stops

Creates a collection of nodes from the selected track at all the positions where the vehicle has stopped. This feature works with heuristics and is thus configurable to fit best to the characteristics of the GPS logger (in particular, its exactitude) and the journey made: the software assumes a stop when the tracklog remains for a certain time (by default, 20 seconds) within a certain distance (by default, 20 meters). If the software generates too few stops, you should try to raise distance or afterwards to lower time. If the software generates clusters of stops, you should try to raise distance. If the software generates too much stops, try to lower distance.

Tab Stops

This tab is only accessible if you have selected a track from Tracks in this GPX file in the tab Tracks. You can ignore this tab if you have mapped the stops by using waypoints.

List of created stops

This list contains all the nodes created from the current track and still managed by the dialogue window. The tag that identifies such a node as a certain kind of stop is set according to Type of stops to add. The two other important tags are name and shelter: name should be set to the name of the stop, shelter can be set to yes (there is a shelter), no (there is no shelter) or implicit (there is no shelter but some other kind of rain protection, e.g. the stop is situated below a bridge). If you don't have noted whether there were shelters, you can leave the tag empty (this is the default). These values are edited in the second and third column. The first column specifies the stopwatch time when the tracklog has passed this point. You can edit this column as well and input the values from you stopwatch record if you have mapped with tracklog and stopwatch.

Button Find

Detects lines in the list of created stops whose corresponding nodes are marked on the map. Mark one or more nodes on the map. Then a click on Find marks the created nodes for the current track that are currently marked on the map.

Button Show

Changes the view on the map such that all nodes belonging to a marked line in the list of created stops become visible. If no entry is marked, then the view will show all nodes belonging to a line in the list.

Button Mark

Marks all nodes belonging to a marked line in the list of created stops and unmarks all other nodes.

Button Detach

Detaches the nodes belonging to marked lines in the list of created stops. In particular, the dialogue window no more manages these nodes. You can use this functionality for example to generate stops of one type first, then detach these nodes, then change the type of nodes to generate and treat the other stops.

Button Add

Adds a line to the list of created stops before the first marked entry. If no line is marked, then the new line is appended. New lines contain always 00:00:00.000 as a default time and don't have a node associated yet. The node gets associated when you start to edit this line by setting the time, a name or the shelter status.

Button Delete

This button deletes all currently marked lines in the list of created stops and their associated nodes. If no line is marked, then all lines are deleted.

Button Sort

Exists for your convenience only and allows to sort the marked lines in the list of created stops by their time. It doesn't change the associations between the lines and their nodes. If no line is marked, then all lines are sorted.

Tab Waypoints

This tab only contains useful information if your GPX file contains waypoints.

List of waypoints in the file

This list contains all the nodes created from the current waypoints and still managed by the dialogue window. Each line corresponds to a waypoint from the GPX file. Thus, line can neither be deleted or added. Only the node corresponding to a particular line can be enabled or disabled. The tag that identifies such a node as a certain kind of stop is set according to Type of stops to add. The two other important tags are name and shelter: name should be set to the name of the stop, shelter can be set to yes (there is a shelter), no (there is no shelter) or implicit (there is no shelter but some other kind of rain protection, e.g. the stop is situated below a bridge). If you don't have noted whether there were shelters, you can leave the tag empty (this is the default). These values are edited in the second and third column. The first column contains the name of the respective waypoint.

Button Find

Detects lines in the list of waypoints whose corresponding nodes are marked on the map. Mark one or more nodes on the map. Then a click on Find marks the created nodes that are currently marked on the map.

Button Show

Changes the view on the map such that all nodes belonging to a marked line in the list of waypoints become visible. If no entry is marked, then the view will show all nodes belonging to a line in the list.

Button Mark

Marks all nodes belonging to a marked line in the list of waypoints and unmarks all other nodes.

Button Detach

Detaches the nodes belonging to marked lines in the list of waypoints. In particular, the dialogue window no more manages these nodes. You can use this functionality for example to generate stops of one type first, then detach these nodes, then change the type of nodes to generate and treat the other stops.

Button Enable

Adds nodes to all lines in the list of waypoints that are marked and don't have a node yet. If no line is marked, then all lines that don't have a node yet are invoked.

Button Disable

Deletes nodes from all lines in the list of waypoints that are marked and have an associated node. If no line is marked, then all lines that have an associated node are invoked.

Route patterns

Tab Overview

List Existing route patterns

The large list in the center contains all relations that are recognised as public transport routes. They are listed with the value of their tag ref, the value of their tag to and the ID of their relation. A relation is considered as public transport service if it has the tags type=route and route is set to one of the values bus, tram, light_rail, subway or rail.

Button Refresh

This button refreshes the list Existing route patterns.

Button New

This button generates a new route pattern.

Button Delete

This button deletes the currently marked route pattern.

Button Duplicate

This button makes a copy of the currently marked route pattern.

Button Reflect

This button changes the direction of the route pattern: the values of the tags to and from are exchanged and the itinerary and the list of the stops are reflected.

Tab Tags

List Required tags

The list contains the five tags that every public transport route must have:

  • type: Must always have the value route.
  • route: Designates the kind of vehicle that performs the service. It can be set to one of the values bus, tram, light_rail, subway or rail.
  • ref: The line identifier of the route.
  • to: The destination shown in front of the vehicle and/or at the platform to clarify the direction of the service. It is usually the name of the terminus. Compare the tag direction.
  • network: The network this route belongs to.

List Common tags

The list contains further tags which are quite common for public transport routes:

  • direction: The destination shown in front of the vehicle and/or at the platform (an alternative for the tag to).
  • from: The origin of this route. Usually the first station.
  • operator: The company that runs this service.
  • color: If the line has a designated color then set this tag to it. It should be either a valid keyword (see [specification]), i.e. aqua, black, blue, fuchsia, gray, green, lime, maroon, navy, olive, purple, red, silver, teal, white or yellow. Or a RGB value, i.e. a # followed by six hexadecimal values.
  • name: If the route has a particular name, then add it here. Unlike ref, this is neither displayed anywhere nor needs it to fulfil any uniqueness properties.

List Additional tags

Additional tags can be added here. These tags might be of use for specific software or describe special local features but aren't part of the standard data format. If you leave a key empty or delete the key, the respective key will be removed from the relation.

Button Add a new Tag

This adds an empty line to the additional tags list.

Tab Itinerary

List of member ways

This list contains all the current members of the relation you are editing that are ways. The intended format of a route relation expects a continuous list of ways that represents the itinerary the vehicle takes in reality. Whenever two ways don't fit head on tail, a marker [gap] is put between the two corresponding entries in an extra line to make breaks clearly visible. This is not a member of the relation but just a marker. You can change the role of a way in the right column. Choose forward if the vehicle passes the way along the orientation of the way and backward if the vehicle passes the way against the orientation of the way. To properly display relations that don't follow the Oxomoa scheme, all other roles including the empty role are also displayed and you can choose despite forward and backward also an empty role.

Button Find

Detects entries whose corresponding objects are marked on the map. Mark one or more ways on the map. Then a click on Find marks every entry in the current relation that corresponds to a way currently marked on the map.

Button Show

This button changes the view on the map such that all ways belonging to a marked entry become visible. If no entry is marked, then the view will show all ways belonging to an entry.

Button Mark

This button marks all entries that are marked in the list as ways on the map and unmarks all other ways. It also copies a list of the marked entries to the plug-in's internal clipboard, such that roles and the order can be reconstructed. If no entry is marked, then all objects belonging to an entry are marked and copied to the clipboard.

Button Add

This button adds all ways that are currently marked on the map as entries in the list. The entries are added in arbitrary order before the first marked entry. If no entry is marked, then the new entries will be appended. You can order the just added elements by marking them and clicking Sort.

Button Delete

This button deletes all currently marked entries.

Button Sort

If one or more entries are marked, all marked entries are sorted. I.e. their order and role is changed such that they form a continuous itinerary. If this is not possible, the plug-in tries to construct long continuous sequences of sections. If no entries are marked, the entire list is sorted.

Button Reflect

If one or more entries are marked, their order is reflected and their roles get swapped between forward and backward, i.e. every entry is put after its successor. If no entry is marked, then the entire list will be reflected.

Tab Stops

List of member nodes

This list contains all the current members of the relation you are editing that are nodes. The intended format of a route relation expects a list of nodes that represents the stops in the order the bus takes them in reality. The roles can be changed to forward_stop or backward_stop but according to Oxomoa scheme, they should remain empty.

Button Find

Detects entries whose corresponding objects are marked on the map. Mark one or more nodes on the map. Then a click on Find marks every entry in the current relation that corresponds to a node currently marked on the map.

Button Show

This button changes the view on the map such that all nodes belonging to a marked entry become visible. If no entry is marked, then the view will show all nodes belonging to an entry.

Button Mark

This button marks all entries that are marked in the list as nodes on the map and unmarks all other nodes. It also copies a list of the marked entries to the plug-in's internal clipboard, such that roles and the order can be reconstructed. If no entry is marked, then all objects belonging to an entry are marked and copied to the clipboard.

Button Add

This button adds all nodes that are currently marked on the map as entries in the list. The entries are added in arbitrary order before the first marked entry. If no entry is marked, then the new entries will be appended. You can order the just added elements by marking them and clicking Sort.

Button Delete

This button deletes all currently marked entries.

Button Sort

If one or more entries are marked, all marked entries are sorted. The sorting order depends on the itinerary, the settings for the distance limit and the orientation check box: the sorting algorithm attaches each stop to the nearest segment of the itinerary and then orders them in the order they are passed on the itinerary. Then all stops that can't be attached are added to the end of the list. If no entry is marked, all entries are sorted.

Button Reflect

If one or more entries are marked, their order is reflected. I.e. every entry is put after its successor.

Tab Meta

Check box Stops are possible

This check box controls the behaviour of the button Suggest stops and the button Sort in the tab Stops. If you mark only one of the boxes Right hand side or Left hand side, only stops on the respective side are taken into account. If you mark both boxes, stops on both sides are taken into account.

Text field Maximum distance from route

This text field also controls the behaviour of the button Suggest stops and the button Sort in the tab Stops. Only stops that have a distance less or equal the limit set here are taken into account.

Button Suggest Stops

This button replaces the current list of stops by a list of all stops that are close to the itinerary with regard to the setting of the check boxes and the text field described above.