Talk:Proposed features/Conveyor

From OpenStreetMap Wiki
Jump to navigation Jump to search

This page should be merged with Proposed features/Escalator. --Lulu-Ann 14:56, 25 August 2009 (UTC)

My "Conveyor" proposal is intentionally designed as a counter-proposal to "escalator" because of its different central idea: new highway tag instead of reusing highway=steps. You can do either the one or the other, but not both. So unless you want to give up the idea of reusing highway=steps, we cannot merge them. --Tordanik 16:34, 25 August 2009 (UTC)
OK - If you want, you can use "escalator" as keyword aswell. Only one proposal can make it, I don't mind if the word is used. --Lulu-Ann 12:02, 26 August 2009 (UTC)
I think this is a bad idea because it will conflict with conveyors used to convey goods not just people, you should use man_made=conveyor, type=people or type=grain, type=coal etc --Delta foxtrot2 13:13, 29 August 2009 (UTC)
Use man_made=goods_conveyor for goods, highway=conveyor for people. Where's the conflict? highway=* does traditionally contain (among others) all features relevant for pedestrian traffic - these are relevant for routing, for example, and are part of the road network -, whereas man_made contains things like pipelines. Imo, using two different tags is justified for two categories of features with completely different purposes, even if they use similar technologies. Using the same tag would make sense if applications could handle these in the same way, but that isn't the case - they are simply completely different things for every practical use case. --Tordanik 13:37, 29 August 2009 (UTC)
I agree with Tordanik here. Even if not specifically mentioned on the wiki (perhaps it should be), man_made itself has an implication that the feature is not any kind of highway (otherwise we would have man_made=motorway/trunk/footway/etc.) --Waldo000000 23:20, 29 August 2009 (UTC)

There are steep escalators with steps and steep moving walkways without steps. Can we use 'steps' / 'ramp' / 'no incline' or similar to differentiate? With steps are wheelchair=no, without are wheelchair=yes --Lulu-Ann 12:05, 26 August 2009 (UTC)

These are covered by
  • conveyor=escalator -> has steps
  • conveyor=travelator + incline=* -> has no steps, but incline
  • conveyor=travelator without incline -> has no steps and no incline
Is anything missing? --Tordanik 14:50, 28 August 2009 (UTC)

If the only difference between "escalator" and "travelator" is the presence or absence of steps, perhaps the following would be more explicit?: highway=conveyor + steps=yes/no (rather than highway=conveyor + conveyor=escalator/travelator) --Waldo000000 23:20, 29 August 2009 (UTC)


Should this imply foot=permissive rather than foot=yes, as generally the conveyor will be owned by someone who "gives general permission for access" rather than there being an "official, legally-enshrined right of access"? --Waldo000000 23:25, 29 August 2009 (UTC)

All implications are currently either yes, no or designated, so I expect that permissive is counter-intuitive. I'm sure that people would rarely remember to add a foot=yes if access isn't just permissive.
To make this clear: You would actually suggest to use "permissive" for things like escalators leading to down to subway stations that are not privately owned? --Tordanik 08:18, 30 August 2009 (UTC)

This is a way!

I think it should be in highway tag. --Lulu-Ann 22:48, 17 March 2010 (UTC)

I'm proposing to use a highway value for this (highway=conveyor). The subtags use different keys, of course. So I'm not sure what you are suggesting. Could you elaborate? --Tordanik 12:43, 18 March 2010 (UTC)
Escalator --Lulu-Ann 20:03, 18 March 2010 (UTC)
This still doesn't tell me what you mean with "should be in highway tag". About your proposal: Using highway=steps for escalators would be possible (though it's not an ideal solution, because movement on escalators is more restricted than on steps), but using highway=steps for speedwalks/travelators isn't justified at all. These clearly aren't steps. --Tordanik 08:35, 4 April 2010 (UTC)


IMHO I like the data model of Proposed_features/Conveyor but we also need some ideas of Proposed features/Escalator. Rationale: There are conveyors additional to steps and there are conveyors on their own.
At least here in Stuttgart, Germany there are many public transport stations which have one up to three escalators right beside steps. During off-peak hours they might operate in only one direction or be switched off. So the main feature is the steps which means tagging highway=steps and conveyor=escalator and conveyor:direction=up/down/both/on_demand depending on the direction of the steps.
Also, e.g. at Frankfurt Flughafen Fernbhf there are travelators in parallel to a footway so this needs highway=footway conveyor=travelator and conveyor:direction=forward/backward/both/on_demand.
But there are many cases where the conveyor is the only way, so the tag highway=conveyor is well suited.

Other consideration:

  • [EDITED] Rename conveyor_direction to conveyor:direction since this seems the current way. Also add up, down and both for conveyor:direction since ecalators in natural language move up and down.
  • The tag conveyor:trolley is nice and should be kept.
  • I think on_demand is a better description since dynamic sounds like the escalator has a mind of it's own and not depending on input.

Open questions:

  • travelator (a word I as a german never heard of) or moving_walkway as in Wikipedia.
  • [EDITED] while conveyor:count sounds reasonable, to add the directions here is overkill. I would leave it out for now.

Some of your suggestions appear to be based on the idea of representing a group of parallel steps/footways and conveyors as a single way. However, I prefer to use several parallel ways for modelling that situation. Using multiple ways has the advantage that it is much easier to add tags which only apply to one of the entities (the steps may have a different width than the adjacent escalator, the conveyor directions are different, etc.). It also lets you map the order of the entities (is the escalator to the left or to the right of the steps). As for the remaining topics:
  • I think renaming conveyor_direction to conveyor:direction and travelator to moving_walkway are acceptable suggestions. If anyone else is reading this: What is your opinion? As these are primarily aesthetic decisions, I'd simply choose the most popular variant.
  • conveyor:trolley sounds as if it could be an useful addition, but I'm not sure about the exact meaning. Is it a conveyor that people pushing trolleys can use, or is it a conveyor for trolleys only?
  • "up" and "down" for conveyor direction seem redundant. With the current proposal, you could draw the conveyor so that the way direction matches the conveyor direction and add incline=up/down. I don't see why that would be a problem, but maybe I'm missing something?
--Tordanik 15:50, 17 November 2011 (UTC)