WikiProject Hungary/Importálás/Corine Land Cover 2006

From OpenStreetMap Wiki
Jump to: navigation, search

CLC importálás

Figyelem!

Úgy tűnik, hogy a EU-s Corine adatok alapján történő rajzolás SEMMILYEN előnnyel nem jár olyan területen ahol Bing műholdkép látható! Ott a műholdképről felismerhető területeket rajzoljuk meg! Ahol már importálva van a CLC, ott hozzá kell igazítani a Binghez, amennyiben aktuálisabbnak tűnik!

Az adatok forrása © EEA, Koppenhága (2009); Készítette a FÖMI a KvVM megbízásából (2009)

A Corine Land Cover (CLC) adatbázis területhasználati adatokat tartalmaz. Ebből könnyen felrajzolhatóak az erdők, mezők, lakott területek határai és hasonlók. Az adatok nyers formában álltak rendelkezésre, amelyeket településenként darabolt és könnyen beszerkeszthető formára hoztunk.

A szerkesztési feladat tulajdonképpen abból áll, hogy a CLC területhasználati vonalakat a térképpel együtt letöltve, pontosítás, összekötözgetés és a korábban felrajzolt hasonló adatokkal való összeegyeztetés után feltöltjük az OSM-be. A pontosításhoz a BING műholdképet és közeli helyeken helyszíni bejárást használunk.

A szerkesztéshez JOSM szükséges, haladó felhasználói ismeretekkel. Fontos, hogy jó áttekintéssel rendelkezz a kapcsolatok szerkesztéséről!

A szerkesztésnél a WikiProject Hungary/Területfunkció oldalon látható "Multipoligonos módszert" használjuk. A letölthető adatfájlok tartalmazzák ezt a struktúrát, de szerkesztés közben mégis fontos a megértése és a vonalszerkezet karbantartása.

CLC fájl letöltése

Keressük meg a szerkeszteni kívánt települést CLC adatok letöltési oldalán.

  • Nyers adatok: a település nevére kattintva tölthető le, de általában ez nem javasolt!
  • Egyesített adatok: a Letöltés gombra kattintva egy olyan OSM fájlt tölthetünk le, amiben nem csak a CLC adatokat, hanem az érintett területen szereplő minden adat szerepel. Ezzel a megoldással kihagyható a "Duplikált CLC:id tag-gel rendelkező relációk egyesítése" rész.

Megjegyzés: Ugyanezen az oldalon elérhető a teljes ország optimalizált CLC adathalmaza is egyetlen fájlban, tehát településenkénti bontás nélkül.

Betöltés szerkesztőbe

A letöltött CLC file megnyitása Fájl->Megnyitás paranccsal érhető el a JOSM-ban, a szerkesztő így egy külön rétegfájlba tölti be az adatokat.

Opcionális: Amennyiben csupán a nyers adatokat töltöttük le, szükséges lesz manuálisan letölteni a település határait teljesen lefedő térképadatokat az OSM-szerverről. A letöltött adatokat érdemes lehet egy rétegbe tölteni a betöltött CLC réteggel, így elkerülhetjük a fölösleges váltogatást, valamint lehetőségünk nyílik a későbbi feladatok elvégzésére is.

Duplikált CLC:id tag-gel rendelkező relációk egyesítése (Opcionális)

Csak nyers adatok használata esetén szükséges. Egyesített adatokkal ezt átugorhatjuk.

(1. ábra) Szomszédos településből átnyúló terület

Duplikált CLC:id-vel rendelkező relációk akkor keletkeznek, amikor a szeresztésre kiválasztott területünk szomszédos egy már korábban megszerkesztett területtel és a szomszédból egy terület eredetileg átnyúlna a jelenlegibe, azonban a településhatárnál az ideiglenesen elvágásra került.

A megoldás a következő:

Induljunk el végig a jelenlegi terület határai mentén, és ha a szomszéd felől a átlógó területet találtunk és az új területből is tart vonal a terület felé, akkor jó eséllyel ott duplikált relációra is számíthatunk. (lásd: 1.ábra).

Hogy egyesítendő relációkról van-e szó, azt a két vonal relációinak vizsgálatával tudhatjuk meg: a CLC:id mező egyezése esetén a relációkat egyesíteni kell.

Ilyenkor szükséges a jelenleg feldolgozott terület érintett relációját (annak minden tagját) hozzáadni a már korábban megszerkesztett terület relációjához, majd az új terület relációját törölni, így elkerülhető, hogy ugyanazon területet 2 külön reláció jelöljön fölöslegesen. (Érdemes megjegyezni, hogy mindenképpen a korábbi relációt kell megtartani és nem az újonnan importáltat, mivel a régi tartalmazhat egyéb információkat is.)

(2. ábra) A meglévő terület előkészítese az egyesítéshez
(3. ábra)

Szomszédos, már megszerkesztett települések bekapcsolása

A cél, hogy az 1. ábrán látható problémát megoldjuk.

Ennek menete a következő:

  • Válasszuk ki a már megszerkesztett terület felől érkező vonal piros karikában jelzett pontját, majd válasszuk a Eszközök->Vonalak kettévágása menüpontot.
  • Tegyük meg ugyanezt az érintett, meglévő terület másik végénél is (az ábrán jobb alsó sarok), ezáltal 3 különálló vonalhoz jutottunk.
  • A 3 vonal közül töröljük a középsőt. Ha minden jól megy, a 2. ábrához hasonló állapotnál kell tartanunk.
  • Ezután az egyik vonalból húzzunk vonalat annak folytatásaként a másikba (lent és fent is).
  • A keletkező közös pontokat kijelölve egyesítsük azokat (Eszközök->Pontok egyesítése), ezáltal biztosítva azok folytonosságát.

A kívánt eredmény a 3. ábrán látható.

FONTOS: A korábbi időkben csábító megoldás volt, a települséhatár által elmetszett vonalakat a településhatárba bekötni (a multipolygon lezárása miatt), azt feldarabolni és relációba foglalni. Ezt SEMMIKÉPPEN ne tegyük, mindig rajzoljunk külön vonalat erre a célra.

Új relációk (Multipolygonok) feldolgozása

A relációs listában egyesével nézzük végig a területinformációkra vonatkozó multipolygon relációkat. Figyeljünk rá, hogy mindegyik zárt kört alkosson, valamint állítsuk be a vonalak szerepét is a reláción belül(outer=külső vonal, inner=belső vonal, azaz kivétel). Ennek elmulasztása esetén feltöltéskor figyelmeztetést is kapunk a szerkesztő programtól. Megjegyzés: Habár a CLC adatok gyakran tartalmazzák előre az inner/outer adatokat, ezek gyakran hiányosak, ritkán tévesek is, így mindenképpen érdemes manuálisan is ellenőrizni ezeket.

Már meglévő területjelöléssel való ütközés/átfedés esetén érdemes a relevánsabb információt megtartani, kiegészíteni (pl. Bing vagy helyismeret alapján). Ilyen leggyakrabban a települések közvetlen landuse=residental jelölésénél adódik, de előfordulhat tavaknál is (pl.Balaton). Ennek megoldása sokszor időigényes folyamat, a jó munka érdekében nagy fokú türelmet és szerkesztési jártasságot igényelhet.

Utómunkálatok

  • Gyakori jelenség a CLC adatokban a pontok értelmetlen halmozódása, ezeket érdemes "ritkítani", vagyis az új információt nem tartalmazó fölösleges pontokat törölni.
  • Előfordulnak az import fájlban nem jelölt területek. Ezeket megfelelő adatforrás birtokában (Bing, helyismeret, stb...) új reláció létrehozásával bejelölhetjük. (Feltöltjük a lyukas területeket)
  • Megfelelő minőségű műholdkép birtokában (pl.: Bing) hozzáigazíthatjuk az importált területek pontjait a műholdképen látható területekhez.

Megyjegyzés: Előfordulhat, hogy a műholdkép szöges ellentétben áll a CLC importtal. Ez sajnos előfordulhat, mivel a CLC adatok és a műholdkép "aktualitása" között jelentős eltérés lehet, sokszor több év. Ezekre nincs bevett módszer, a szerkesztő feladata eldönteni, melyik adatot tekinti megbízhatónak.

  • Ismeretlen területjelölő tag-értékek korrigálása: a leggyakoribb a "industrial;retail", melynél a szerkesztő feladata eldönteni, hogy melyiket tartja meg, csak az egyik helyes, halmozásukra nincs lehetőség.
  • A feldolgozott relációkról a fixme=unchecked és a CLC:surfaceoverlap=* tag-ek eltávolítása.


Javasolt Szűrők

Szűrő ablak megjelenítése: Ablakok->Szűrő

Megjegyzés: Új szűrő hozzáadása után érdemes bepipálni az Inverz szűrőt, ezáltal a szerkesztő mindent elrejt, a szűrőben szereplő dolgokon kívül.

  • child fixme=unchecked: A CLC fájl alapértelmezettben minden relációhoz hozzárendel egy fixme=unchecked kulcs-érték párt, melynek feladata, hogy a térképen gyorsan megjeleníthetővé tegye a még feldolgozásra váró területeket. (Ezek egy-egy terület feldolgozása során eltávolítandók.)
  • child landuse=* OR child natural=* OR boundary=administrative OR untagged OR landuse=* OR natural=*: Az elsőre kicsit hosszúnak tűnő szűrő szerepe, hogy csak a számunkra releváns adatokat lássuk(landuse, natural, boundary kulcsokkal rendelkező vonalak, valamint relációk vonalai, ezen kívül a tagek nélküli vonalak(ez új vonalak rajzolásánál szükséges)).

Importálást végző tagok

Technikai részletek

Az alábbi leírásokat az eredeti CLC adatok feldolgozásához, átkonvertálásához használtuk, csak azoknak lesz rá szüksége aki ezekben a technikai lépésekben is részt szeretne venni, vagy alternatív módszeren dolgozik.

CLC adatok feldolgozása (régi módszer)

Háttéradatok letöltése napi országos adatbázis kivonat és Osmosis segítségével

Figyelem ez napi kivonat! Lehetnek konfliktusok majd feltöltésnél. Magyarország OSM adatai itt letölthetőek. Egyéb letöltési források Planet.osm. Itt eltérhetnek a frissességek.

Letöltés és kicsomagolás után:

osmosis-0.38/bin/osmosis --read-xml  enableDateParsing=no file=hungary.osm \
--bounding-box top=46.478 left=16.558 bottom=45.926 right=17.4  completeWays=yes completeRelations=yes \
--way-key keyList="landuse,natural,water" \
--used-node \
--write-xml file=hungary_cutted.osm

Ez kiszűri a megfelelő kulcsú területeket az adatokból.

CLC adatok feldolgozása

Magyar CLC import osm-be konvertálva itt elérhető: http://w3m.hu/clc06_hu_resave.osm

Érdemes kisebb darabra vágni az adatot:

osmosis-0.38/bin/osmosis --read-xml  enableDateParsing=no file=clc06_hu_resave.osm \
--bounding-box top=46.478 left=16.558 bottom=45.926 right=17.4  completeWays=yes completeRelations=yes \
--write-xml file=clc_cutted.osm

Településenkénti darabolásos módszer

A fentebbi részletes leírás ilyen adatokra alapul: Herrbert74 módszere