IT:Emilia Romagna edificato

From OpenStreetMap Wiki
Jump to: navigation, search

Guida all' importazione degli edifici della Regione Emilia Romagna

La Regione Emilia Romagna ha reso disponibile con licenza CC-BY 2.5 i dati relativi all' edificato della regione, scaricabili dal portale Open Data della Regione.

La presente guida spiega come inserire tali dati in OpenStreetMap con piccoli "import" mirati in modo da evitare sovrapposizioni con gli edifici ed il grafo stradale già inseriti.

Allo scopo si impiegheranno Qgis (versione usata 1.7.3 Wroclaw) e shp-to-osm (versione shp-to-osm-0.8.5-jar-with-dependencies.jar)

Dopo avere accettato il contratto di licenza si può scaricare il file "Edifici_v1.zip" contenente a sua volta nove cartelle compresse, ciascuna corrispondente ad una provincia.

Decomprimendo la cartella interessata, saranno visibili i files contenenti i dati che ci interessano.

Importazione in Qgis

Per confrontare i dati già presenti in OSM con gli edifici che si vogliono importare, è molto utile installare in Qgis il plugin "OpenLayers" che consente di inserire la mappa OSM.

Se non già disponobile, da : Plugins -> Recupero Plugins Pyton -> Aggiungi repository di terze parti si può scaricare ed installare OpenLayers Plugin.

A questo punto, da : Layer -> Aggiungi vettore si seleziona il file "V_EDI_GPG.shp" e lo si visualizza.

I dati importati sono nel formato ETRS_1989_UTM_Zone_32N, occorre trasformarli nel formato WGS84 : click col pulsante destro sul nome del file nella colonna alla sinistra dello schermo, selezionare "Salva con nome" nel menu, assegnare un nome al fle da salvare (ad esempio edifici_bo), come sistema di riferimento selezionare "WGS 84" e procedere al salvataggio.

Dopo la conferma di corretto salvataggio, rimuovere il layer con "V_EDI_GPG.shp" ed inserire un nuovo layer con il file salvato.

Le coordinate saranno ora visualizzate nel formato Lon Lat in gradi centesimali.

Conviene poi selezionare un' area limitata con lo strumento "Ingrandisci" ed inserire la mappa OSM con : Plugin -> OpenLayers Plugin -> Add OpenStreetMap layer.

Per portarla sullo sfondo, trascinare "OpenStreetMap" nella barra a sinistra dello schermo sotto il file caricato in precedenza.

Per migliorare la visualizzazione, è possibile modificare l' aspetto del layer degli edifici : click con il pulsante destro sul nome del file, selezionare "Proprietà" e cambiare il Tipo layer del simbolo da "riempimento semplice" a "Cornice:linea semplice"

Applicando il cambiamento, appariranno più evidenti gli edifici già inseriti in OSM.

Passiamo ora a selezionare gli edifici da importare : dallo strumento "Selezione", possiamo disegnare un poligono che contenga gli edifici interessati che saranno evidenziati in giallo.

Dal menu "Layer" -> Salva la selezione come vettore, scegliamo un nome (edifici_esportati ad esempio) e procediamo al salvataggio impostando il sistema di riferimento a WGS 84 (importando la mappa OSM il sistema di riferimento del progetto viene cambiato a EPSG 900913 che è proprio di OSM).

Il nuovo file conterrà solamente gli edifici da inserire in OSM.

Conversione con shp-to-osm

Scaricare il file shp-to-osm-0.8.5-jar-with-dependencies.jar da qui (scaricare il file shp-to-osm-0.8.1-with-dependencies.jar o una delle versioni successive, eccetto la 0.8.6 che genera file che JOSM non riesce ad aprire)

Preparare il file delle regole che chiameremo "rules_edificato.txt" copiando il testo sotto riportato in un file di testo e salvarlo nella stessa cartella con shp-to-osm con il nome "rules_edificato.txt".

I ruoli sono stati definiti in base al parametro assegnato al campo D_TY_EDI nel database.

rules_edificato.txt

# Regole per convertire in dati OSM gli shapefile appartenti all' edificato della Regione Emilia Romagna
# tramite il programma shp-to-osm

# This is a comma-delimited format.
# Field:  Description:
#      1  The shapefile type to match (outer, inner, line, point) (see below)
#      2  The source attribute name to match
#      3  The source attribute value to match. Can be empty to match all values.
#      4  The name of the tag to apply when the source key/value pair match.
#      5  The value of the tag to apply. Use a sinlgle dash ("-") to use the original value.
#
# The shape file types are:
#  outer  = The outer polygon of a MultiPolygon
#  inner  = The inner polygon of a MultiPolygon
#  line   = A line string of a MultiLineString
#  point  = A point of a PointString

#  Edifici

outer,D_TY_EDI,altro,building,yes
outer,D_TY_EDI,anfiteatro,building,yes
outer,D_TY_EDI,anfiteatro,historic,monument
outer,D_TY_EDI,campanile,building,yes
outer,D_TY_EDI,campanile,man_made,tower
outer,D_TY_EDI,campanile,tower:type,bell_tower
outer,D_TY_EDI,capannone,building,warehouse
outer,D_TY_EDI,castello,building,castle
outer,D_TY_EDI,chiesa/basilica,building,church
outer,D_TY_EDI,edificio industriale,building,industrial
outer,D_TY_EDI,edificio rurale,building,farm
outer,D_TY_EDI,edificio monumentale,historic,monument
outer,D_TY_EDI,edificio monumentale,building,yes
outer,D_TY_EDI,generica,building,yes
outer,D_TY_EDI,hangar,aeroway,hangar
outer,D_TY_EDI,hangar,building,yes
outer,D_TY_EDI,mulino,man_made,watermill
outer,D_TY_EDI,mulino,building,yes
outer,D_TY_EDI,non assegnato,building,yes
outer,D_TY_EDI,non conosciuto,building,yes
outer,D_TY_EDI,palazzo dello sport,leisure,stadium
outer,D_TY_EDI,palazzo dello sport,building,yes
outer,D_TY_EDI,tribuna di stadio,building,yes
outer,D_TY_EDI,villa,building,detached
outer,D_TY_EDI,villetta a schiera,building,terrace
outer,D_TY_EDI,,source,Regione Emilia Romagna

Preparare un file .bat contenente la stringa di comando per shp-to-osm copiando quanto sotto riportato in un file di testo e salvarlo nella stessa cartella con shp-to-osm con il nome "comando.bat".

comando.bat

java -cp shp-to-osm-0.8.5-jar-with-dependencies.jar com.yellowbkpk.geo.shp.Main --shapefile ./edifici_esportati.shp --rulesfile ./rules_edificato.txt --osmfile edifici_osm --outputFormat osm

Ovviamente i nomi dei files "edifici_esportati.shp", "rules_edificato.txt" e "edifici_osm" sono arbitrari e possono essere modificati.

Eseguendo "comando.bat", il file risultante sarà "edifici_osm.xml" , un formato che può essere aperto da JOSM.

Inserimento con JOSM

Aperto il file .xml con JOSM, è opportuno procedere ad una "pulizia" dei dati eseguendo una validazione e cancellando i nodi duplicati.

Selezionare tutte le entità, eseguire "Convalida" dalla finestra relativa ed eliminare i nodi duplicati segnalati negli errori ed i nodi duplicati segnalati negli avvertimenti, riducendo in questo modo i nodi da importare.

Si può inoltre allineare gli edifici alle ortofoto del PCN se necessario, lo scostamento tra i dati e le ortofoto è abbastanza piccolo e varia da quasi nulla a qualche metro.

Scegliendo le ortofoto del PCN come riferimento si utilizzerà un riferimento uniforme valido anche per altre entità (strede etc.)ed è quindi da preferirsi.

Si possono poi scaricare i dati dal server OSM per la zona interessata, abilitando l' opzione "scarica come nuovo livello" dalla finestra di selezione dell' area di download.

In questo modo, prima di unire i livelli e procedere all' upload, si possono agevolmente confrontare i dati già presenti nel database OSM con quelli in corso di importazione ed eseguire le correzioni del caso.

Per una ottimale gestione ex post delle importazioni, è bene indicare un preciso commento al gruppo di modifiche apportate (cd "changeset") che identifichi la fonte dei dati.

Nel nostro cosa il commento potrebbe essere :

source=http://dati.emilia-romagna.it/dato/item/6-6-edifici.html

Provincie e Comuni importati

Vedere anche lo stato dell' import terremoto emilia del 2012

Provincia stato import edifici
Bologna import completato State Buildings3.svg, non verificato da altri utenti
Ferrara import completato daState Buildings3.svg mcheck, non verificato da altri utenti
Forlì-Cesena import completato daState Buildings3.svg mcheck, non verificato da altri utenti
Modena import completato daState Buildings3.svg mcheck, non verificato da altri utenti
Parma import completato daState Buildings3.svg mcheck, non verificato da altri utenti
Piacenza import completato daState Buildings3.svg mcheck, non verificato da altri utenti
Ravenna import completato daState Buildings3.svg mcheck, non verificato da altri utenti
Rimini import completato daState Buildings3.svg mcheck, non verificato da altri utenti
Reggio Emilia import completato daState Buildings3.svg mcheck, non verificato da altri utenti