JA:MLIT ISJ CHOME

From OpenStreetMap Wiki
Jump to: navigation, search

国土数値情報の「大字・町丁目レベル位置参照情報」から osmに入力するための手順。 動作にはJava動作環境が必要となります。

注意 : テスト公開中です。手順やタグなどはまだ決定ではありません。現在、Talk-jaで議論中 です。
2014年5月16日現在
place in Japan

国土数値情報の「大字・町丁目レベル位置参照情報」から osmに入力するための手順

Status


地名(大字・町丁目)をトレースする方法

ここでは、位置参照情報データの地名(大字・町・丁目)をを市町村単位ごとに入力する手順を紹介致します。

位置参照情報データをGPXファイルやOSMファイルに変換するプログラムはJOSMと同じJavaで作られた自由に利用できるソフトウェアですので、JOSMが動作する環境ならどのような環境でも動作します。 ここではWindowsを例にして説明いたします。


1. 位置参照情報データ

1-1 位置参照情報データのダウンロード

まず最初に、位置参照情報データをダウンロードします。

位置参照情報ダウンロードサービス
  1. 国土地理院の位置参照情報ダウンロードサービス(http://nlftp.mlit.go.jp/isj/index.html )で、「都道府県単位」を選択してください。
  2. 入力したい市町村が含まれる都道府県を選択して、「大字・町丁目レベルのみ」を選択し、「選択」をクリックします。
  3. 全ての大字・町丁目レベルを選択」にチェックを入れて、「選択」をクリックします。
  4. 「利用約款」に「同意」して、ダウンロードします。
  5. ZIPファイルがダウンロードされます。(例:「14000-06.0b.zip」 )
  6. ダウンロードした圧縮ファイルを任意のフォルダに解凍してください。
解凍すると「META_14_2012.xml」、「format_2012.html」というようなファイルがありますが、必要なのは「14_2012.csv」というようなCSVファイルだけです。


1-2 OSM変換ソフトウェアのダウンロード

下記のリンクからOSM用のデータに変換するソフトウェアをダウンロードしてください。

https://sourceforge.jp/projects/convaddr/releases/
'ConvAddr.zip'ダウンロード
  • 「ConvAddr.zip」というファイルがダウンロードされます。
  • 「ConvAddr.zip」ファイルを適当なフォルダに解凍してください、6個のファイルができます。
ISJ CHOME 002.png
  • 解凍先のフォルダに先ほどダウンロードした位置参照情報データを移動させてください。


1-3 ソフトウェアを実行してOSM用のファイルを生成

  • 「ConvAddr.bat」ファイルをダブルクリックしてください。

:: 2014-05-06現在のところ「ConvAddr.bat」には不具合があります。

「ConvAddr.bat」を編集して、下記のように書き換えてください。(要するに改行を入れてください)
delete -f database
java -cp .;ConvAddr.jar;hayashi_0225.jar;hsqldb_2.2.9.jar osm.jp.ConvAddr -nocheck
pause

実行すると、黒いウインドウが立ち上がり、なにやらいろいろな文字が表示され、いくつかのファイルとフォルダが生成されます。
※ MacやLinuxをお使いの方はコンソール画面から
 $> chmod 777 ConvAddr.sh
 $> sh ConvAddr.sh
と入力すると動き出すと思います。
ISJ CHOME 001.png
  • 実行が完了すると以下のフォルダやファイルが生成されます。
 フォルダ 'database'		<-- 変換用の作業データベース(処理完了後は必要ありません)
 フォルダ 'ISJ_CHO'		<-- 変換された市町村ごとのOSMファイルが格納されているフォルダ
 ファイル 'ISJ_CHO.html'	<-- 変換結果をまとめたインデックス HTMLファイル
 ファイル 'ISJ_CHO.wiki.txt'	<-- 進捗状況をOSMのWIKIページで管理するためのWIKIテキスト
 ファイル 'Logging.0'		<-- ゴミデータ


入力するISJファイル

* フォルダ 'ISJ_CHO'とファイル 'ISJ_CHO.html'をJOSMがあるフォルダに移動させてください。

ISJ CHOME 003.png
  • ファイル 'ISJ_CHO.html'をWebブラウザで開きます。
ISJ CHOME 004.png
この一覧から入力したい市区町村のOSMファイル名をダウンロードしてください。
OSMの欄にあるリンクを「右クリック」して「別名で保存」とするとOSMファイルを保存することができます。 ([Download]ボタンではありません)
ここで確認したOSMファイルをJOSMで開くことになります。
なお、目的のOSMファイルは「フォルダ 'ISJ_CHO'」に格納されています。
  ブラウザでOSMのリンクをクリックすることでOSMの内容を確認することができます。
OSMファイルの中身は下図のようなXML形式になっています。 ISJ CHOME 005.png

タグ付け

key value 備考
name 大字町丁目名 当該範囲の大字・町丁目名

(町丁目の数字は漢数字)

ref 大字町丁目コード JIS市区町村コード+独自7桁
place quarter / neighbourhood / locality
  • 1 = 大字 = quarter
  • 2 = 字 = neighbourhood
  • 3 = 丁目 = neighbourhood
  • 4 = 不明 = locality
fixme 既存のノードが存在しないかチェックしてください このタグはJOSMでの作業時に削除する
source 街区レベル位置参照情報 国土交通省 位置参照情報利用約款 第2条(3)に従う
source:date 2012 位置参照情報の整備年
source_ref http://nlftp.mlit.go.jp/isj/ このタグは不要
note National-Land Numerical Information (place) 2012, MLIT Japan このタグは不要
note:ja 国土数値情報(大字・町丁目レベル位置参照情報)2012年 国土交通省 このタグは不要

既存データのダウンロード

  • ファイル 'ISJ_CHO.html'をWebブラウザで開きます。
ISJ CHOME 004.png
この一覧から入力したい市区町村の[Download]ボタンをクリックしてください。
OSMサーバーから現在のOSMデータをダウンロードします。(しばらく時間がかかります)
(Overpass API を使って目的の市町村周辺の place タグのみを取得しています)
  • ダウンロードが完了したら、ダウンロードファイルの名前を任意の名称に変更します。
    このとき、ファイル名に拡張子「.osm」をつけてください。
: ISJ CHOME 60.png
この例では、「interpreter」を「interpreter.osm」に変更しています。

3. 入力手順

3-1 環境設定

(1) JOSMを起動する

  • JOSMを起動してください。
  • JOSM起動時のダウンロードパネルが表示された場合には「キャンセル」をクリックして閉じてください。
JOSMstrtup.png


(2) OSMファイルと既存OSMファイルを開く

  • JOSMメニュー⇒[ファイル]-[開く...]で、位置参照情報から変換したOSMファイルを選択してください。


  • JOSMメニュー⇒[ファイル]-[開く...]で、OverpassAPIで取得した既存OSMデータファイルを選択してください。


  • 位置参照情報データをコピーして
    • (1) 位置参照情報から変換したレイヤーをクリックしてチェックマークがついた状態にする。
    • (2) JOSMメニュー⇒[選択]-[すべて選択..Ctl+A]で、位置参照情報から変換したすべてのデータを選択する。
    • (3) JOSMメニュー⇒[編集]-[コピー..Ctl+C]を選択する。
      または、キーボードの「Ctrl」キーを押しながら「C」を押す。(コピー)
ISJ CHOME 61.png


  • 既存OSMデータレイヤーに貼り付け
    • (1) 既存OSMデータレイヤーをクリックしてチェックマークがついた状態にする。
    • (2) JOSMメニュー⇒[選択]-[貼り付け..Ctl+V]を選択する。
      または、キーボードの「Ctrl」キーを押しながら「V」を押す。(貼り付け)
ISJ CHOME 62.png


  • JOSMメニュー⇒[画像]で、「OpenStreatMap(Mapnik白黒)」を選択してください。
ConvAddr 44.png
ConvAddr45.png


  • 「GPXレイヤー」と「Mapnik(背景)レイヤー」の表示輝度を30~40%ぐらいに下げたほうが作業がやりやすくなります。
CommPt56.png

3-2 入力チェック

既存データを確認

赤いノードが位置参照データのノードです。既存のノードが存在しないかどうか調べてください。

  • 既存データが存在するとき
    • 既存ノードを削除してください
緑のノードで、sourceタグに「GIS_KIBAN」となっているものは暫定的に入力されたものです。
(1) 既存ノードを削除してください
(2) 位置参照データのノードを既存ノードが在った位置へ移動させる
(3) 位置参照データのFIXMEを削除
  • 既存データが存在しない時
    • 「FIXME」を削除してください
ConvAddr51.png
(1) FIXMEの項目をセレクト
(2) 「削除」ボタンをクリック


ノードの位置を修正

  • 地名が示す領域の中央付近にノードを配置させてください。
  • 他のPOIと重ならないような位置が望ましい


3-3 アップロード

  • FIXMEがすべて削除されたのを確認してからアップロードを行ってください
ConvAddr52.png

参考情報