Talk:JOSM/Plugins/EditGpx

From OpenStreetMap Wiki
Jump to: navigation, search

[german]

Probleme bei mir: - Problem mit anonymisierten Timestamps: JOSM vermischt diese nach dem Hochladen mit anderen anonymisierten Timestamps, wenn man sagt "Verbinde GPX-Punkte mit Linien".

Ich weiß nicht genau was du mit "Verbinde GPX-Punkte mit Linien" meinst. Wo befindet sich dieser Menupunkt in JOSM? leoss


- Es kann immer nur eine GPX-Datei bearbeitet werden. Für ein zweites GPX-File muss man JOSM neu starten. Das GPX-Auswahlfenster hat (noch) keine Funktion.

Steht noch auf meiner todo Liste. leoss


- Is it popssible to add a "move" button , to correct some gpx-points? [cantece)

It would be possible but my intention is not to write an GPX editor. There are other tools outside doing that. I try to do a minimal manipulation of the track. If some points are incorrect don't matter. The mass of GPX tracks will correct this. leoss

possible problem?

Hello,

please do not get offended. I am new here and this might not be the place to report, please re-direct me, if I got it wrong.

Thing is, I updated JOSM today to Version 3592 and opted (of course) to also update this plugin.

So my EditGpx now shows as:

Version 22548 (under help / about) and also under (edit / preferences / plugins)

the more complete info under help / about gives this (and more):

---quote 2907_Plugin-Url: 21706;http://trac.openstreetmap.org/browser/applications/editors/josm/dist/editgpx.jar?rev=22549&format=raw Ant-Version: Apache Ant 1.7.1 Author: Martin Garbe Created-By: 16.3-b01 (Sun Microsystems Inc.) Manifest-Version: 1.0 Plugin-Class: org.openstreetmap.josm.plugins.editgpx.EditGpxPlugin Plugin-Date: 2010-08-03T06:13:23.326063Z Plugin-Description: Allows the user to anonymize timestamps and delete parts of huge GPX tracks very fast. ---unquote

Now I noticed that the editing still works fine.

But anonymizing the timestamps does not work any more. I feels as if all is working fine. No errors, no hangup. But the timestamps just stay the same. I believe that I have understood the usage, but I might be wrong. I could always edit my files manually, but it would be a shame.


Please advise; would love to keep using this plugin.

greetings,

"Webtooslow"

Thanks for that advise. You are right. There is a bug. While code conversion with one JOSM version to the next the anonymization got broken. I fixed it now. Please test it and report when it is not working for you. leoss


Update: I am now on Version 23659, today is 2011_02_20. I can confirm that anonymization does work again. (Convert to GPX layer with anonymised time). But now the next problem is, that I can not upload the result with the DirectUpload plugin (Version 24239):

I select it, but I get an error saying "No GPX layer selected. Cannot upload a trace." I dubblechecked - I can direct-upload any non-anonymised GPX traces, but not the treated ones. I tried re-naming with a .gpx ending but that did not help (the proposed names are a bit weird).

Sorry again. When I saw your kind note Leoss, about having fixed it, I went straight to test it. And I had wanted to write you confirmation here today. Well, maybe you can tell me how to upload, or maybe fix it again. Keep keeping; it is indeed useful to have all major tools right within JOSM. Uploading traces via the website is a pain from Africa...

--Webtooslow 17:29, 20 February 2011 (UTC)

Update to my update: Seems to me that User magic_doc in the section below (Anonymize timestamps) has identified the underlying issue. Anonymising works, just the date become a bit too neutral... I exported a track and fixed just the dates and re-loaded into JOSM and then DirectUpload worked fine. So this is the same issue as below.

--Webtooslow 17:51, 20 February 2011 (UTC)

Anonymize timestamps

It seems OSM no longer allows you to upload GPX traces which have been run through the Anonymize timestamps option --Pobice 15:00, 5 December 2010 (UTC)

Uploading of anonymize tracks is still possible. I tested it with the web interface. But there is a problem with DirectUpload plugin. This gives some errors.leoss 20:45, 11 December 2010 (UTC)
I have to correct myself. I received an email with an error message for the upload. I try to check this.leoss 20:07, 12 December 2010 (UTC)

---

magic_doc, 2011-02-18

I had the same issue today- and found the root cause: the plugin generates this timestamp:


and this is an illegal value of course- I looked up older uploads and changed all lines into this:


Can you resolve this issue? The anonymous-function ist very essential for me.

My workarround (linux systems only :():

cat foo.gpx | sed -e 's/1970-00-00T00:00:00.000Z/1970-01-01T00:00:00Z/g' > bar.gpx

Thanks in advance and just mail me if you have further questions or tests to do- gern auch in Deutsch :)


I can confirm the issue with the 00 days and months. DirectUpload in JOSM also refuses the upload (see my update in the section above; I had not noticed this subject right away). So once the date is changed to something "legal", DirectUpload uploads without any trouble.

I like Linux too, but you can just as easily do a search&replace in OpenOffice Writer (this will then work in my Operating Systems):

search for  

--Webtooslow 17:48, 20 February 2011 (UTC)

Thanks for that hint. I am correcting the bug now. Tomorrow the new version is online. leoss 20:51, 23 February 2011 (UTC)

---

magic_doc, 2011-03-09

Updated JOSM and the plugin today, WFM now- thank you!

Feature Request: Multiple sequences

Thank you for this plugin. I use this plugin a lot to clean GPX tracks I record. Is there any chance it could be extended to provide functionality for splitting a GPX trace into multiple tracks or track sequences?

Most helpful would be the ability to split a track when editing. When my device looses its position, it will typically continue on recording on the same track and thus when it finds itself again there is a big straight line that does not match the actual traveled path. Currently I am needing to manually correct this and it would be much faster if I could use the plugin.

This would also likely fix a problem I sometimes have of editgpx connecting trks/trkseqs that were previously discrete. Vossad01 (talk) 21:50, 6 October 2016 (UTC)

A thought

Most of the ways that I've submitted are real roads now, but in a year or two who knows? Seems to be the date of the creation carries important information. Maybe if you want to cover the actual date, use some date that you know the way was valid for. —Preceding unsigned comment added by RickCharon (talkcontribs) 2017-04-08T01:35:13‎

Hi RickCharon, are you referring to uploaded gps traces or to OSM ways? Regarding GPS traces: there is a date filter available in JOSM, so users can filter to show only current traces. --Aseerel4c26 (talk) 11:28, 8 April 2017 (UTC)
I was referring to the timestamps in the gpx files. Seems like it's a good idea to preserve them. --RickCharon (talk) 22:48, 8 April 2017 (UTC)
Yes, I agree. The timestamp anonymization of this plugin could be less aggressive... for example keep the month and year but only fake the day and time. --Aseerel4c26 (talk) 23:55, 8 April 2017 (UTC)

Sounds to me like a perfect solution. --RickCharon (talk) 00:05, 9 April 2017 (UTC)