Talk:Ubuntu tile server

From OpenStreetMap Wiki
Jump to: navigation, search

Hier die Inhalte der Seite diskutieren.

I already have the world.osm loaded. By installing it via the package manager, will this erase my exisiting database? Thanks!


A couple of issues:

Ubuntu 11.10 (64bit)

  • world_boundaries dosen't get installed
  • the update script seems to actually be called /usr/bin/openstreetmap-tiles-update-expire.sh not /usr/bin/openstreetmap-tiles-expire.sh
  • the update script seems to be broken
    • while initializing seems to work it at least in my case failed to download a valid state.txt file
      simon@hz:/var/lib/mod_tile/.osmosis$ cat state.txt
      #original-source: 000/000/000.state.txt
      #generated-by: http://toolserver.org/~mazder/replicate-sequences/
      simon@hz:/var/lib/mod_tile/.osmosis$

SimonPoole 21:32, 20 December 2011 (UTC)

seems to work for me. Do you still get the problem? --Amm 03:29, 23 January 2012 (UTC)

Further suggestion: it yould be a goog idea to include the mod_tile munin plugins in the package.

SimonPoole 14:10, 24 December 2011 (UTC)

Install 2012-01-03 clean machine Ubuntu 11.10 64bit

  • this I forgot to note on the original install above

add-apt-repository missing from hetzner minimal install 11.10

sudo apt-get install python-software-properties

to fix

  • previously mentioned: world_boundaries doesn't get installed
  • osm2pgsql default.style exists both in /usr/share/osm2pgsql and /usr/share/osm2pgsql/osm2pgsql

SimonPoole 14:12, 3 January 2012 (UTC)

silent install ?

silent install is possible? ( with default values - without asking questions.)--IPella 14:17, 6 May 2012 (BST)