JA:Nara opendatathon

From OpenStreetMap Wiki
Jump to: navigation, search

奈良オープンデータソン

奈良オープンデータソンのページです。

第1回 日時:2014年11月23日(日)10:00-

場所:ならまち(奈良女子大学奈良町セミナーハウス)

参加頂ける方は、募集ページへの登録をお願いします。

マッピングエリア

フィールドワークで収集する情報

  • 初心者向けコース
    • お店の情報収集
      • 必須:店名(日本語名と英語名)と業種
      • オプション:定休日・営業時間・車いすアクセス・デリバリーの有無,WIFIアクセスなど
  • 上級者向けコース
    • 初心者向け以外の場所で自由に
      • 消火栓マッピング
      • トイレマッピング
      • 自販機マッピング
      • 駐車場マッピングなどなど

使用が想定されるタグ

  • タグ付けについてはOSMのWikiを参照。 Map Featuresのページ
  • 人しか通れない道路はhighway=pedestrianかhighway=footway
  • 門は「barrier=gate」とする。通用門のようなところは「access=no」とする。
  • 駐車場は「amenity=parking」
  • 建物を描くとき「name=xx」と付け、「building=yes」と付ける。
  • 歴史的建造物には「building=yes」「historic=yes」
  • 郵便ポストは「amenity=post_box」

OSMアカウントの作成

  1. OpenStreetMapメインページ画面右上の「登録」をクリック。
  2. 「ユーザアカウントの作成」ページで、Eメールアドレス表示名(実名でなくてOK。後から変更可能)/パスワードを入力し、「続行」を押す。
  3. 入力情報に問題がなければ登録したEメールアドレスにOSMから本人確認メールが届くので、そこに記載されたURLからコンファームを行う。
  4. 登録完了後、主な活動地域などの情報を入力(任意)。

ログのアップロード方法

(GPSログを取得できる方のみ)

  1. OpenStreetMapにログインし、メインページから「GPSトレース」のタブを開く。
  2. 「トレースをアップロード」を選択。
  3. 「GPSトレースのアップロード」のページから、GPXファイルのパス(保存場所)/詳細(地域名、アップロードした日付など)/タグ(使用したGPSデバイス名,地域など)を入力。可視性を「パブリック」にしてアップロード。

地図の編集方法

ローカルエディタ(JOSM)を用いる方法【推奨環境】

  http://josm.openstreetmap.de/からWindowsの場合は「Windows JOSM installer」をダウンロードし、インストール。
  Macの場合は「Mac OS X JOSM package」ををダウンロードし、インストールしてください。実行環境としてJavaが必要になります。
  インストーラでのインストールに失敗する場合は、Java Runtime https://java.com/ja/download/index.jspをインストール後、
  josm-tested.jarをダウンロードし、ダブルクリックで実行してみてください。
  注)イベント当日はJOSM(josm-tested.jar)とJavaのインストーラを用意しますが、できる限り自宅で環境を整えてきて下さい。
    メニューの「編集」にある「設定」の「接続設定」にログイン情報を入れて、アップロードまで確認できてますと完璧です。

手順

  1. JOSMを起動。画面左上の下向き矢印アイコンあるいはメニューバーで「ファイル」→「OSMからダウンロード」を選択。
  2. ダウンロードウィンドウが別窓で開くので、必要な範囲をマウスでドラッグして選択し、「ダウンロード」をクリック。
    なお、画面は右ドラッグでスクロールが可能。
  3. サーバからデータのダウンロードが完了したら、中央の編集画面にすでに描画されたノードやウェイが表示される。
    これらをもとにノードで道路や建物(地物 FeaturesPOI (Point of Interest))を描いていく。
  4. 次に、描いた地物が何であるかを表すためにタグ付けTagging)をおこなう。 例)道路の名前・種類(国道・県道・高速など)
    タグ付けについてはOSMのWikiを参照。 Map Featuresのページ
  5. 以上の編集が完了したら、編集・変更したデータをOSMサーバにアップロードする。画面左上の上向き矢印アイコンあるいは「ファイル」→「データをアップロード」を選択。
  6. 別窓が開くので、変更についての概略コメントを付記して「変更のアップロード」をクリック。この時編集したデータに問題があるとエラー警告が表示される。
  7. JOSMを終了するときは画面を閉じるか「ファイル」→「終了」を選択する。保存/アップロードするかどうかを聞かれるので、適宜チェックを入れたり外したりして終了する。
注:アップロードには「OSMアカウントの作成」と「接続設定」が必要です。


ブラウザエディタ(iD・Potlatch)を用いる方法

  OpenStreetMapにログインし、「編集」のタブにカーソルを乗せ「iDで編集」あるいは「Potlatch 2で編集」を選択。 (奈良データソンでは利用しません)