JOSM/Plugins/RasterFilters

From OpenStreetMap Wiki
< JOSM‎ | Plugins
Jump to: navigation, search
Available languages — JOSM/Plugins/RasterFilters
· Afrikaans · Alemannisch · aragonés · asturianu · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · Bân-lâm-gú · Basa Jawa · Baso Minangkabau · bosanski · brezhoneg · català · čeština · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · Kurdî · latviešu · Lëtzebuergesch · lietuvių · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk bokmål · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · português do Brasil · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tiếng Việt · Türkçe · Vahcuengh · vèneto · Wolof · Yorùbá · Zazaki · српски / srpski · беларуская · български · қазақша · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · मराठी · हिन्दी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 吴语 · 粵語 · 中文(繁體)‎ · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް

Introduction

Figure 1. Image Filters subtab screenshot
Figure 2. Choose Filters button
Figure 3. Filters Dialog
Figure 4. Filters Dialog GUI: controls, Remove and Disable buttons

The JOSM's RasterFilters plugin provides the pack of image filters for processing layers of JOSM.

Icon JOSM Version Plugin Version Maturity
RasterFilters-icon.png
8625 1.0.1 Beta

Source Code

The source code is available in josm official svn repository and revision history may be found also there: Filters plugin.

Installation

  1. Open JOSM and go to Edit -> Preferences or type F12 and choose the tab Plugins.
  2. Add checkbox in the opposite of rasterfilters and press OK button. JOSM will download and install the plugin.
  3. In the JOSM Restart dialog confirm the restart of JOSM. Installation has been finished.

Usage

The existing filters you may find following this link.

After installation there is the new sub-tab in the JOSM's preferences dialog. You may find it here Edit -> Preferences -> Setting for the map projection and data interpratation -> Image Filters(Figure 1).

Also after adding at least one layer you can find button Choose Filter in the JOSM main window (Figure 2).

There is the table in the Image Filters subtab so you can choose filters you need and then click to the Download button. Filters will be downloaded to your local machine and it become visible and accessible in the Choose Filter dialog.

Note: if you added not raster but OSM layer the Choose Filters button will be disabled.

Filters dialog

  1. First of all, choose the layer you want to change and make it the Active Layer (indicated by the green checkmark).
  2. Click on Choose Filter button, the Filters dialog will be shown (Figure 3). In this dialog you can choose the filter you need from the select list and click on the button Add.
  3. After adding filter, there will appear GUI for every filter you choose in the Filters dialog (Figure 4). Moving sliders, checking checkboxes, selecting from select list or picking colors you may process and get the changed layer according to the settings of chosen filters.
  4. If you want to disable some filter check the checkbox Disable (Figure 4).
  5. If you want to delete some filter click the button Remove under the filter's gui (Figure 4).

Implementation new filters

If you want to add some filter because existing filters do not meet your needs, you can code and integrate your filter to the JOSM's RasterFilters plugin following this page: JOSM plugins developer's guide.