DE:API

From OpenStreetMap Wiki
Jump to: navigation, search
Verfügbare Sprachen — API
Afrikaans Alemannisch aragonés asturianu azərbaycanca Bahasa Indonesia Bahasa Melayu Bân-lâm-gú Basa Jawa Baso Minangkabau bosanski brezhoneg català čeština dansk Deutsch eesti English español Esperanto estremeñu euskara français Frysk Gaeilge Gàidhlig galego Hausa hrvatski Igbo interlingua Interlingue isiXhosa isiZulu íslenska italiano Kiswahili Kreyòl ayisyen kréyòl gwadloupéyen Kurdî latviešu Lëtzebuergesch lietuvių magyar Malagasy Malti Nederlands Nedersaksies norsk bokmål norsk nynorsk occitan Oromoo oʻzbekcha/ўзбекча Plattdüütsch polski português português do Brasil română shqip slovenčina slovenščina Soomaaliga suomi svenska Tiếng Việt Türkçe Vahcuengh vèneto Wolof Yorùbá Zazaki српски / srpski беларуская български қазақша македонски монгол русский тоҷикӣ українська Ελληνικά Հայերեն ქართული नेपाली मराठी हिन्दी অসমীয়া বাংলা ਪੰਜਾਬੀ ગુજરાતી ଓଡ଼ିଆ தமிழ் తెలుగు ಕನ್ನಡ മലയാളം සිංහල ไทย မြန်မာဘာသာ ລາວ ភាសាខ្មែរ ⵜⴰⵎⴰⵣⵉⵖⵜ አማርኛ 한국어 日本語 中文(简体)‎ 吴语 粵語 中文(繁體)‎ ייִדיש עברית اردو العربية پښتو سنڌي فارسی ދިވެހިބަސް

OpenStreetMap hat eine Editier-API welche zum Lesen und Speichern von Rohen Geodaten von bzw. auf die OpenStreetMap Datenbank benutzt werden kann. — Dieses ist die Eingangsseite für die Dokumentation.

Wenn Sie nur eine Karte in Ihre Webseite einbinden möchten, dann benötigen Sie diese API nicht. Benutzen Sie stattdessen ein Web Map Framework.

Zusätzliche Spezifikationen über die Editier-API

  • API v0.6 - (Aktuelle Version, seit April 2009)
  • API v0.5 (Nicht länger im Gebrauch seit April 2009); obwohl dieses Dokument immer noch von Nutzen sein mag
  • API v0.4 (Nicht länger im Gebrauch seit Oktober 2007)
  • API v0.3 (Nicht länger im Gebrauch seit Mai 2007)

Wir kennzeichen Wiki-Seiten mit {{not 0.6 compatible}}, wenn sie etwas beschreiben, was (eventuell) nicht mit der Version 0.6 der API funktioniert.

Instanzen

Siehe Databases and data access APIs

Einbindung und Benutzung (Scripting)

Die aktuelle vollständige Serverseitige Einbindung sind die Rails port.

Zum anderweitigem Gebrauch siehe Develop/Frameworks.

Nutzungsbedingungen

Die Editier-API dient nur dazu um Kartendaten zu bearbeiten, sie dient nicht irgendwelchen Projekten oder Nur-Lese-Zwecken. Benutzer können ohne vorherige Ankündigung gesperrt werden, falls sie sich auf ein Service-Level anderer begeben oder Daten beschädigen. Siehe unsere API usage policy.


Nur-Lesen

Zum Nur-Lesen ist das hier: DE:Overpass API

Zusammenfassungen der Änderungen der Editier-API

Verweise

  • API v0.7 - Brainstorming für die nächste Version der API