From OpenStreetMap Wiki
Jump to: navigation, search
Available languages — Oziexplorer
Afrikaans Alemannisch aragonés asturianu azərbaycanca Bahasa Indonesia Bahasa Melayu Bân-lâm-gú Basa Jawa Baso Minangkabau bosanski brezhoneg català čeština dansk Deutsch eesti English español Esperanto estremeñu euskara français Frysk Gaeilge Gàidhlig galego Hausa hrvatski Igbo interlingua Interlingue isiXhosa isiZulu íslenska italiano Kiswahili Kreyòl ayisyen kréyòl gwadloupéyen Kurdî latviešu Lëtzebuergesch lietuvių magyar Malagasy Malti Nederlands Nedersaksies norsk bokmål norsk nynorsk occitan Oromoo oʻzbekcha/ўзбекча Plattdüütsch polski português português do Brasil română shqip slovenčina slovenščina Soomaaliga suomi svenska Tiếng Việt Türkçe Vahcuengh vèneto Wolof Yorùbá Zazaki српски / srpski беларуская български қазақша македонски монгол русский тоҷикӣ українська Ελληνικά Հայերեն ქართული नेपाली मराठी हिन्दी অসমীয়া বাংলা ਪੰਜਾਬੀ ગુજરાતી ଓଡ଼ିଆ தமிழ் తెలుగు ಕನ್ನಡ മലയാളം සිංහල ไทย မြန်မာဘာသာ ລາວ ភាសាខ្មែរ ⵜⴰⵎⴰⵣⵉⵖⵜ አማርኛ 한국어 日本語 中文(简体)‎ 吴语 粵語 中文(繁體)‎ ייִדיש עברית اردو العربية پښتو سنڌي فارسی ދިވެހިބަސް
Screenshot of OziExplorer
Author: Des Newman
Website: http://www.oziexplorer.com
Version: 3.95.5k (2010-05-05)
License: proprietary (30€)
Platforms: Windows, Windows Mobile 2000, navman, mio, medion, tomtom, magellan


OziExplorer (oziexplorer.com) is navigation and mapping software for Windows and WindowsCE. It is closed-source commercial software, with paid-for licensing and free trial and free shareware versions. As well as displaying raster maps, it supports uploading and downloading of tracks and waypoints to most Garmin, Magellan, Lowrance, Brunton and MLR GPS devices.

TODO: Everything below this point is in need of a serious rewrite. If you know or care about this software, please dive in and edit this page


In the newest version 3.95.5d there is finally experimental support for OSM (and other internet map services). You need to download a special map file, which provides an control panel, and a working internet connection. Downloaded tiles are cached and stored for further use, so there is no need to download it again. Further information can be found here: [1]

Screenshot oziexplorerOSM.png

OziExplorer comes in three flavours: a full version for PC and versions with fewer features for WindowsCE and Android devices. The PC version works with OpenStreetMap and derivatives such as OpenCycleMap as well as Google and others, but there is currently no provision for user-defined on-line maps to be added. On a PC it acts as a viewer for maps on which you can add annotations and overlay routes and tracks from a number of sources, including live NMEA messages. It can read maps in a variety of raster file formats and will georeference them if such data is embedded in the file but otherwise you create a georeference file (.map extension) to calibrate the image.

The portable versions were conceived before the mobile internet, and do not support on-line maps, but they continue to work in the outback and at sea! Many satnavs run WindowsCE and can be hacked to run OziCE, but the weapon of choice now is an Android tablet. The Android version is still under development, though. These versions read raster data from local files, preferably in the proprietary ozfx2 or ozfx3 formats, but also in ECW or JPEG2000. The ozfx files are generated with the img2ozf conversion tool and contain pre-rendered versions of the base image at various zoom levels but the software makes other zooms on the fly. A mobile device running OziExplorerCE or OziAndroid should make a good data gathering device for OSM data. Waypoints can be added and annotated in the field and tracks can be recorded. The resulting files are convertible to GPX or anything else using gpsbabel. There is a very flexible screen designer where you can set up buttons for the functions you use a lot.

The simplest tool for making maps for OziExplorerCE and OziAndroid from OSM is MAPC2MAPC. Areas can be downloaded from OSM (and other online map sources including some WMS) based on a location or to include the extent of a GPX track or route. The program will create these as a OZF2 file and accompanying MAP calibration.

Otherwise, making maps for OziExplorerCE and OziAndroid from OSM requires production of a raster image, calibration with the PC Ozi (the shareware version will do this) and conversion to the ozfx format. To get images of OSM over your area of interest, you could query OSM with Overpass and render with Mapnik's generate_image. Alternatively, Googleak (see the TrekBuddy website) is useful as it can download all the tiles you need and output the required calibration file. Each map is at a single OSM zoomlevel and will be scaled by OziExplorer but you could make one for each zoom level (or, say, 18, 16, 14 ...) and Ozi can switch between them quickly. For viewing out in the open, especially on older equipment, you may find adjusting the gamma of map images to, say, 0.4 useful before converting them.

You can use some pretty big rasters (e.g. 20,000 pixels square) but if you do need more than one sheet at the same scale, you set up the overlap areas when you calibrate the map and Ozi will automatically load the next sheet when you get near the edge.

Many mobile device need don't use specific OSM format but their own proprietary format like Garmin(*.img) or WhereAmI (importtodb.7z). Some tools can be used to convert osm map to ozi map compatible on desktop & mobile version. This page cover gui tool that directly support osm data in input and ozi compatible file in output rather than other solutions like:

  • use the Export tab on the OSM site.
  • use Planet dump of an entire country
  • use JOSM
  • use perl command-line download (see some older chapter here)
  • use the osmxapi

The tools differ by:

Some website offer many file formats like cloudmade that support only for country extract

For downloading a small number of tiles along with a calibration file for OziExplorer, BigMap 2 could be used. For generating bigger georeferenced images with Mapnik, use Nik4.


OziExplorerCE is a separate product in the OziExplorer family that requires a separate license to run without limitations (GPS communication will require manual restart every 20 or 10 minutes).

The best way to work when using OziExplorerCE is to know which road have been already design in osm map. The tools described after can produce files (projection, raster graphic, vector) with or without deal with projection knowledge for produce files that'll be compatible with oriexplorer/oziexplorer. The file compatible for oziexplorer have to be convert before import them in oziexplorer CE using a converter of name "IMG2OZF". This tool convert .ecw/.tif/.jpg/.map files into special .ozfx3/.map file format best in terms of memory consumption [2].

The last version of Img2ozf (3.03) exporte only in the new format extension *.ozfx3!! For find location ; oziexplorer use like OSM gns Service.

  • Options | toponimy search

Ozi searchnames.jpg

  • View |Name search

Ozi ce name-search.jpg

The chapters about perl is not compatible with the new 0.6 OSM API not the perm script.

file format compatible with oziexplorer

if you use other gis software that support natively access to some tile rasters of osm [3] and could export raster with georeference compatible with oziexplorer then use it!! Here the capture screen that show which raster must be used. The first chapter is about manifold and ecw file.

  • File |open and calibrate map support many raster

Ozi import file.jpg

  • img2ozf support many filter raster file

Img2ozf import file.jpg

  • oziexplorer CE support many raster file but can't be discover using gui because load *.map that link to raster file.

OziCE import-file.jpg

get ozi map/raster tiles file

The tools described here differ by the output file, some create calibrate raster files where map file will be extracted, others create only map files that will be used to extract raster files. The best tool will extract map and tiles file at once without the need to use other steps/tools. The only projection supported by OSM is WGS84. The more difficult step will be to have a non calibrate raster file (scanned or merge from tiles images) that must be calibrate using well known coordinate point (two lat long point left-top and right-bottom) in a well known projection setting. In some case the calibration could be wrong so read this article [4].Some professional gis software natively support access to osm data so avoid use specific osm tool (use free tools, command line ogr gdal perl ...).


It is a must have tool that support access to osm server in the aim of to export in 1 *.map and 1 *.jpeg file. NoniMapView support only jpeg file format (no others formats).


OSMmap-properties.JPGOSM-map could be find here and manage projection tiles using a.tile.openstreetmap.org url. It's need more steps compare to NoniMapview like convert to valid tif but support many projections (*.tab *.map) and raster graphic format (*.jpg,*.png,*.bmp,*.gif,*.tif).

use OSM map

OSM-map exportproject.jpg OSM-map1-valenciennesexport.jpg OSM-map directoryview.jpg

  • Go to openstreet map and zoom to the area you'll go and click to the permalink (bottom right) to see lat long zoom value in the URL field of browser
  • enter the values that come from openstreetmap
  • update map by click on Lataa kuvat
  • export map by
  • select tif under tallennus
  • check Tallenna MAP Tallenna TAB
  • click on Tallenna kuva button to saves files (*.map, */tab *.tif) in a directory. ozi will open this files without need projection/calibration steps. After converting this project for oziexplorer CE, the background could easily know which gpx route to follow. Move the map will not change the coordinate (min max long lat in the input textarea form window)

Osm-map area.jpg OSm-map input gis-information.jpg


irfanview is a free graphic tool that support many plug in (tiff/ecw). It can be downloaded here.

  • irfanview is used to convert tiff (24 bit raster LZW) from OSM-map to tiff (16 bit only non-compressed)
  • the final tif file is 24x bigger that the one create by OM-map

Irfanview saveAs.jpg

Irfanview export tif.jpg

Irfanview after.jpg


OSMtiledownloader is a .net 2.0 Windows application for downloading from OSM server tiles and calibration file (map/PGW) using a GPX track. Also tile stitching to make a large map for Ozi Explorer or other programs is possible.

map creation tool

Map creation tool is a web map server [5]that use many background map server to create a map file. See chapter '[Oziexplorer#extract_raster_from_map | extract raster from map] to know how to download BoudingBox raster from this map file. Mapcacher.jpg

manifold gis

Manifold Gis system is a software that support import/export raster and vector data from gis server like virtual Earth ... but also OSM. Manifold is a gis professional example.

manifold osm raster

Manifold have an interface that manifold user/programmer could use to implement access to gis server. In this case the user must implement functions define in the ISI. Some users implement it for access to OSM raster using Cloudmade cyle, MApnik, Osmarenderer.

import osm raster

For Link (link for server import for local file) osm raster use the steps:

MAnifold Link Image.jpg

Manifold Link ManifoldImageServer.jpg

Osm export.jpgOSM-map-KuvanKoodinaatit.jpg

Manifold osm-boundingBox.jpg

export osm raster

The best file to use for import in oziexplorer is a ecw with embedding projection information. Manifold export IMage.jpg MAnifold export Image choose.jpg

manifold osm vector

manifold support also import osm xml data in the manifold vector format call drawing using let you export vector data (kml) that could be import in Ozi explorer for export in plt for oziExplorer CE!!

perl script

With Oziexplorer you can calibrate scanned pixel map, and show them. The normal vector data of osm can not be used directly into the Oziexplorer. But with the help of Importing Planet.osm into QGIS the OSM data can used as overlay. An Perl-script is called "convert_osm2mif.pl" and can be found under Oziexplorer#Availability:

  • load the seeked map part e.g. with JOSM
  • save this as e.g. "planet.osm"
  • start the script convert_osm2mif.pl < planet.osm > planet.mif (tested for Linux only! -> successful report for win outstanding)
  • after this you should find a file called "planet.mif"
  • open the Oziexplorers
  • load the your pixel map
  • load the MIF-File (File → Load from File → Import → From MapInfo MIF File)

After this you could have e.g this picture:

Example osm ozi.png

Now you can find such areas which have not been already mapped and you can set waypoint marks for your next bike trip with your Navi/Garmin.

Notice: Please don't use these waypoints directly in OSM. Please respect the copyright of the scanned map.

Convert OSM data into a pixel map with calibration (not maintained)

Please refer to the tiles@home version.

taho.pl and taho.exe

Both can download maps in different sizes (1024*1024 to 8192*8192) for an area of any size. For each map calibration files in the following formats can be produced:

  • *.bat for Pathaway
  • *.cal for TTQV
  • *.jpr for Fugawi
  • *.kal for Glopus
  • *.map for Oziexplorer

For more information see the Taho page

Tiles sources

Here some tiles sources:

at all URLs starting with "http://a." the 'a' can be exchanged for 'b' or 'c'

second step

extract map from raster

this chapter could use tiff result from OMS-map but example extract map from ecw from manifold gis even other compatible raster file could be used.

Ozi import ecw.jpg Ozi ecw defaultprojection.jpg Ozi ecw import succeedend.jpg Ozi osm project.jpg Ozi ecw save project.jpg

extract raster from map

convert Calibration map file

  • OziMapConverter - support export between .jpr, .rsf, .gmw, .gcp, .prc, .cal, .cap, .geo, .cpt, .map
  • MAPC2MAPC - support export beetween .MAP (Ozi), .JPR (Memory-map, Fugawi), .GMI (GPSTuner), .GUX (GPSU), .MCD (GPSMAPOS, GPSGO), .CAL (Pathaway), .TFW (Mapyx/Quo). Will handle different input datums but always writes WGS84.

software compatible with ozi map/raster file

The calibrate raster file and calibration file could then use in mobile device for record lat/long to update OSM database. Some other software can also use this files after use some converter for have compatible file:

import in oziCE for tracking GPX

oziCE and IMG2OZF

This tool is on oziexploerer web site and help user to make ozi file project compatible with ozi CE software . for example after use OSM-map for valenciennes we can use img2ozf to transform tiff file to ozf file extension

  • import project in oziexplorer

Ozf2-tiff-error.jpg Ozf2-tiff-ok.jpg

  • convert image to ozf
  • this could be achieve by checking one of the item Name
  • Simply click on the button call PRocess Images files to OZF2 Files
  • then the image properties and mini image would appear in the left bottom side

Ozf2-tiff directory end.jpg

  • copy project to mobile device

because oziexwplorer work only in window mobile device you'll have to use activeSync or other tool in vista since vista doesn't use by default activesync but a more up-to-date technology

  • load map in oziCE

OziCE import select file.jpg OziCE openMap.jpg OziCE openmap select map.jpg OziCE view valencienneswithzoom.jpg

oziCE record GPX

  • oziexplorer CE can record poi waypoint route and track information in plt file.
  • oziExplorer CE let us view the track that have been record after save this track to pda. The track is in the plt format.
  • View-Toolbar-Track toolbar

OziCE Tracktool.jpg

  • 1 is the number of the track
  • +: use for record track Points
  • 0: inserting track points
  • grande croix: delete track
  • table: 5 track can be record from gps or load from external file to be view
  • petit croix: for close menu bar tool (track toolbar)
  • click on TrackToolbar->table->select one line->Load->*.plt->ok

OziCE File configuration tracks.jpg

  • wait that all the point of the route are viewable (3816)
  • Do the same for other track store in plt file
  • File->configuration->Tracks for define the properties of the plt track file during track recording, the point are in red and after the two track have been define in red and yellow.
  • activate rendering during record view ->Toolbars -> Main toolbar -> click on T icon

OziCE mainToolbar.jpg

OziCE view data.jpg

  • step to record track of GPS coordinates
  • 1) start GPS if bluetooth
  • 2) File -> Open Map file and then go to directory that contain osm map (*.map (calibration) + *.tif (graphic osm))
  • 3) clik on GPS icon flash to activate GPS in oziexploer
  • 4) click on View -> ToolBar -> Track Toolbar
  • 5) inside this Track Toolbar: click on +: a red message Adding track Points must appear in the bottom right
  • 6) oziexplorer record all the GPS using File -> Configuratoipn -> track values properties
  • -->File log Dist
  • -->Mem Mog Dist
  • -->Track Tail
  • -->Track Color
  • -->track Width
  • 7) save track: best is to save the record points from the memory to plt file ont the pda file system
  • File -> Track Log -> Save track Log (mem) '
  • File -> Track Log -> Delete track Log (mem) '
  • click on number to add new row of lat/long
  • verify that the red message is still here
  • use plt file on PC
  • connect pda device using Active sync
  • copy file from pda to window OS file sytem
  • open oziexploer, load map and then load plt

the capture screen here show track of name MIDMIF that come from OSM project using manifold GIS. The capture background will be updated using Valenciennes instead.

  • OziCe tracjmenu Table2 select.jpg

OziCE rendering tracks.jpgOziCE track2 nopoint.jpg

convert plt to gpx

Oziexplorer CE record gps information in a plt file that must be convert to gpx. OSM support upload only gpx format for import. Here the list of the tool that can achieve this aim.


GPSBabel easily converts OziExplorerCE *.plt tracks to gpx. This format is used for upload gps information into osm (use osm for output).





easy Geo





TurboGPS import png raster file.


Mapwel import ozi map file and support open OSM local file.

Demo videos