Talk:Tag:barrier=ditch

From OpenStreetMap Wiki
Jump to: navigation, search

barrier=ditch doubles waterway=ditch?

In response to the recent edit: "Ditch" might be an unfortunate choise for the value, as far as browsing wiktionary goes; barrier=trench (used only once) might have been better, as that seems not to imply anything about a waterway at the bottom of the long, narrow intendation, whereas "ditch" might be taken by the native English speakers to have a such connotation. Usage to date suggests that most of the time users enter just a waterway=ditch (200 000+ uses) - it's hard to imagine a water filled ditch without it being a barrier, and we don't tag bigger waterways with both waterway=* and barrier=*. For really miniscule waterways that don't pose a barrier for most uses, there's waterway=brook (see also Key:waterway/Narrow_variants). On the other hand, there are empty ditches/trenches, that don't for the most part of the year don't channel any water (or never do), but are definitively barriers. Hence it's not always possible to substitute a barrier=ditch with a waterway=ditch. Alv 09:03, 17 October 2011 (BST)

I made this edit because I had to map a ditch (empty at the time of my mapping) and saw there were two tags for it. In page waterway=ditch, it is said that it may be dry most of the year. I understand it as: it can be empty all the time. Given that definition, I don't see any difference between both tags. I agree that "waterway" is not an obvious tag to map ditches (all the more a dry ones). I assume waterway=ditch implicitly is a barrier, as waterway=[stream|river|canal|...] are, because we don't tag them as barrier... maybe that's the point?
We have two tags to map the same object with the same properties (may hold water and is a barrier) and I think it's not a good practice. The intent of my edit was to prevent the use of multiple tags for same thing or at least minimize it. --Oligo 10:51, 17 October 2011 (BST)
Worse than two tags for identical things is two meanings for one tag, i.e. if people were to use waterway=ditch for trenches that most people wouldn't ever consider waterways. Alv 06:57, 21 October 2011 (BST)

man_made

Perhaps this should be renamed man_made=trench? This would solve some problems about implications.--Jojo4u (talk) 20:38, 25 March 2015 (UTC)