Pl:JOSM/FAQ

From OpenStreetMap Wiki
Jump to: navigation, search
Dostępne języki — JOSM/FAQ
· Afrikaans · Alemannisch · aragonés · asturianu · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · Bân-lâm-gú · Basa Jawa · Baso Minangkabau · bosanski · brezhoneg · català · čeština · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · Kurdî · latviešu · Lëtzebuergesch · lietuvių · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk bokmål · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · português do Brasil · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tiếng Việt · Türkçe · Vahcuengh · vèneto · Wolof · Yorùbá · Zazaki · српски / srpski · беларуская · български · қазақша · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · मराठी · हिन्दी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 吴语 · 粵語 · 中文(繁體)‎ · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް

Contents

Pobieranie i wysyłanie

Jak pobrać relację na podstawie numeru id?

Ctrl+Shift+O (Plik -> Pobierz obiekt).

Jak pobrać dane z linku, z XAPI?

Ctrl+L (Plik -> Otwórz adres).

Czy jest jakiś sposób na pobranie większych rozmiarów kafelków, niż pozwala API?

Chcę pobrać wszystkie sklepy w swoim mieście

  1. Otwórz taginfo i przejdź na stronę tagu shop=*.
  2. Kliknij na overpass turbo na górze po prawej stronie, pod polem filtra.
  3. Przesuń i zmień skalę mapy, żeby wyświetliło się na niej nasze miasto.
  4. Uruchom
  5. Upewnij się, ze w JOSM jest włączone zdalne sterowanie (F12 -> przycisk z pilotem).
  6. Kliknij Eksport, potem "załaduj dane do edytora OSM: JOSM", potem "napraw kwerendę".
  7. W edytorze pojawią się wszystkie sklepy.

Jak pracować z JOSM na komputerze bez internetu?

Potrzebny jest tylko josm-latest.jar. Najpierw z komputera z internetem pobieramy potrzebny obszar, zapisujemy warstwę danych i przenosimy na drugi komputer. Tam robimy, co trzeba, znowu zapisujemy i przenosimy do komputera z internetem. Otwieramy w JOSM, pobieramy z serwera ten kawałek, żeby sprawdzić czy nie ma konfliktów - upload i gotowe. Jeśli potrzebny nam podkład, można skorzystać z twms .

Czy w JOSM jest możliwość pobrania tylko jednej linii, ale bardzo długiej i składającej się z małych kawałków?

  • Można poprzez xapi albo overpass wyciągnąć linie z określonym tagiem.
  • Można pobrać ślad GPX wzdłuż tej drogi, kliknąć go prawym przyciskiem myszy w liście warstw i wybrać "Pobierz dane OSM wzdłuż tej ścieżki".
  • Można wykorzystać plugin WayDownloader. Pobieramy kawałek, zaznaczamy linię albo jej koniec, i po kliknięciu przycisku pluginu zostaną pobrane wszystkie pojedyncze nieprzerwane odcinki. Na skrzyżowaniu pobieranie jest przerywane i trzeba całą procedurę powtórzyć.

Dlaczego nie działają linki "Edytuj w Zdalne sterowanie (JOSM lub Merkaartor) "?

Żeby działały linki typu http://localhost:8111/load_and_zoom?top=...&right=..., zdalne sterowanie musi być włączone w ustawieniach JOSM (F12 - ikonka pilota - włącz zdalne sterowanie), a sam JOSM - musi być uruchomiony. Czasami problem powstaje z powodu zajętego (na przykład, zawieszoną kopią JOSM) portu 8111 albo ustawień firewalla.

Edycja

Jak obracać i skalować obiekty?

Ciągnąć myszką, trzymając Ctrl+Shift (obracanie) albo Ctrl+Alt (skalowanie).

Jak połączyć kilka obszarów (budynków, zbiorników wodnych)?

Upewnij się, że są połączone albo nakładają się, i naciśnij Shift+J (narzędzia -> połącz nakładające się obszary).

Zaznaczyć wszystkie obszary, przecinające dany obszar, można przy użyciu klawisza I (potrzebny Utilsplugin2, zaznaczenie - przecinające się linie).

Jak połączyć linie?

C (narzędzia -> połącz linie).

Jak dodać węzeł z konkretnymi współrzędnymi?

Shift+D (narzędzia -> dodaj węzeł). Żeby przesunąć węzeł w potrzebne miejsce, «narzędzia -> przesuń węzeł».

Jak najlepiej dodawać węzły do istniejących linii?

  • Na odcinkach linii przy zbliżeniu pojawiają się krzyżyki, określające środek odcinka. Jeśli pociągniemy za krzyżyk, utworzymy nowy węzeł.
  • Drugi wariant — naciśnij «A» (Rysuj) i kliknij w potrzebnym miejscu na linii (linia wtedy powinna być podświetlona). W ten sposób można również utworzyć węzły na przecięciu linii.
  • Naciśnij «W», wybierz linię i kliknij w potrzebne miejsce, trzymając przyciśnięty Ctrl.

Jak narysować okrąg?

  • Narysuj wstępnie okrąg, potem naciśnij O (narzędzia-> wyrównaj węzły na kole).
  • Narysuj średnicę (linię z dwóch albo trzech węzłów), potem Shift+O (narzędzia -> utwórz okrąg).

Patrz też #Co zrobić, żeby tworząc okrąg, było w nim 2 razy więcej węzłów?

Jak skopiować relację?

Plugin UtilsPlugin2, Ctrl+Alt+V (więcej narzędzi -> wklej relacje).

Jak z obszaru trzciny wyciąć obszar wodny?

Trzeba zrobić multipolygon. Zaznacz te dwa obszary, potem Ctrl+B (narzędzia -> utwórz wielokąt złożony).

Jak w JOSM rozdzielić linie, należącą do dwóch obszarów?

Wybierz jeden z obszarów i naciśnij G (narzędzia -> rozdziel linie).

Jak dodać wspólne węzły w miejscach przecięcia linii

Mając zainstalowany UtilsPlugin2, zaznacz linie i naciśnij Shift + I (więcej narzędzi -> dodaj węzły na skrzyżowaniach)

Czy można z JOSM wyciągnąć link do linii?

Ctrl+I (widok -> szczegółowe informacje), albo od razu Ctrl+Shift+I (otwiera stronę w przeglądarce).

Czy jest w JOSM prosty sposób podzielić obszar na dwa obszary?

Wtyczka UtilsPlugin2, wybierz dwa węzły na obrysie i Alt+X (więcej narzędzi -> rozdziel obiekt).

Jaki jest skrót do dodania relacji?

Plugin reltoolbox, Ctrl+Shift+C albo Ctrl+Alt+N.

Jak tymczasowo wyłączyć przyklejanie do linii i węzłów w procesie rysowania?

Naciśnij i przytrzymaj Ctrl.

Czy można zmusić JOSM do przesuwania obiektów klawiaturą?

Shift+strzałki.

Jak dołączyć jedną linię do drugiej, na przykład dwa budynki?

Przesuwamy budynki bliżej siebie (można tylko ich części). Dalej J — połącz węzeł z linią, M — połącz węzły (zaznaczone albo jedną do najbliższej).

Jak prawidłowo wydłużyć budynek? Jak zrobić występ w budynku?

X (ikonka ekierki), potem wyciągnąć potrzebną stronę. Poprzez podwójne kliknięcie dodajemy węzły i można wtedy wyciągnąć tylko część liniiDo.

Jak wyrównać budynek wzdłuż drogi?

Zaznacz budynki (ich kąty powinny być proste) i dwa węzły z linii drogi, potem naciśnij Q.

Do węzła jest dołączonych kilka linii, jak wybrać tą, która jest potrzebna?

  • Naciśnij kółko myszy (albo trzeci przycisk) i zaczekaj.
  • Kliknij lewym przyciskiem myszy na linię, przyciskając Alt.

Jak szybko wybrać relację, do którego należy linia albo węzeł?

Patrz poprzednie pytanie: kliknij obiekt z Alt albo środkowym przyciskiem myszy.

Coś kliknąłem, i mapa automatycznie podąża za kliknięciami myszy. Jak to wyłączyć?

Ctrl+Shift+F (widok -> automatyczne przesuwanie mapy).

Tagowanie

Jak zrobić zakaz skrętu?

Przy pomocy wtyczki turnrestrictions.

Jak zrobić szablony? Komu ich wysyłać?

Trzeba zrobić swój plik xml, wzorując się na istniejących szablonach (jeden z prostszych) i wskazać ścieżkę do niego w ustawieniach, zakładka «Ustawienia mapy» (trzecia od góry), dalej «Szablony», plusik po prawej. Dokładna instrukcja i format pliku — na stronie JOSM. Żeby szablon był dostępny dla wszystkich, trzeba go opublikować na wiki JOSM.

Jak dodać przyciski szablonów do pasku narzędzi?

Ustawienia (F12) -> Pasek narzędzi -> Dostępne -> Szablony -> strzałką przenosimy potrzebne przyciski do lewego okna.

Jak dodawać tagi skrótem na klawiaturze?

Alt+A.

Jak skopiować tagi z jednego obiektu na drugi?

Ctrl+C, potem Ctrl+Shift+V — wklejamy tylko tagi. Po zainstalowaniu utilsplugin2, zamiast Ctrl+Shift+V można używać skrótu Shift+R

Jak dodać numer do obrysu budynku?

Szablony -> Adnotacja -> Adresy. Trzeba koniecznie podać nazwę ulicy (jak jest).

Jak zobaczyć listę autorów i historię obiektu?

Ctrl+H (Widok -> Historia) albo Ctrl+Shift+H (w przeglądarce).

Czy jest możliwość zaznaczenia kilku obiektów i zobaczyć wszystkich ich autorów od początku?

Jest panel autorów(Alt+Shift+A), ale pokazuje on tylko ostatnich edytorów.

Jak poznać id zaznaczonego obiektu?

W ustawieniach zaawansowanych (ostatnia zakładka w oknie ustawień) osm-primitives.showid = true włączy wyświetlanie numeru id w panelu "Zaznaczenie" .

ID jest widoczny w pasku stanu, jeśli umieścić kursor nad obiektem. Można nacisnąć Ctrl+I: otworzy się okienko szczegółowych informacji o obiekcie, gdzie, między innymi, są numery id.

Filtry i wyszukiwanie

Wybór obiektów na podstawie kryterium — Ctrl+F, tam trzeba wprowadzić kryterium.

Nie mogę znaleźć budynku z addr:street

Potrzebny jest cudzysłów: "addr:street"="nazwa ulcy".

Przeszkadza mi rysować obszar z wartością town, jak go tymczasowo ukryć?

Widok szkieletowy (Ctrl+W) - wyłączane jest wypełnienie obszarów. Albo poprzez filtr:

  1. włącz panel filtra (Okna -> Filtr)
  2. w panelu kliknij «Dodaj», wpisz w polu place type:way
  3. klinij enter
  4. jeśli szary obrys nam przeszkadza i chcemy go ukryć całkowicie, to zaznaczamy kwadracik w drugiej kolumnie.

Patrz też #Jak wyrzucić z warstwy niepotrzebne dane, nie usuwając ich z OSM? и #Przeszkadza mi wypełnienie obszarów, zasłania podkład.

Czy można ustawić filtr tak, żeby zostały tylko drogi i ich węzły?

Wpisz highway, potem odwróć filtr, zaznaczając pole w ostatniej kolumnie.

Jak przejść do współrzędnych?

Shift+D — wprowadź współrzędne węzła. Potem można go usunąć.

Jak zobaczyć, które z obiektów są mojego autorstwa?

user:<Twój login>

Jak wyrzucić z warstwy niepotrzebne dane, nie usuwając ich z OSM?

Zaznacz te obiekty, potem Ctrl+Shift+P (edycja -> czyszczenie).

Czy można zaznaczyć wszystkie węzły zaznaczonych linii?

type:node child selected

Mając zainstalowany UtilsPlugin2 — Ctrl+Shift+N albo po prostu «E».

Czy można pokolorować budynki w zależności od ulicy albo tagu building?

Oczywiście. Otwórz panel "Style rysowania map" (Okna -> Style rysowania map), kliknij przycisk ustawień i dodaj do aktywnych stylów jeden z następujących:

  • Wg ulicy i obecności numeru: Address Tags Validator (zalecany), Coloured Addresses, Coloured Streets.
  • Wg wartości tagu building=*: Coloured Buildings.de

Pełna lista stylów z opisami i obrazkami leży na wiki edytora.

Jak znaleźć węzły, ne należące do jakiegokolwiek obiektu?

type:node -child. Jeśli potrzebne są tylko węzły bez tagów, to type:node untagged -child

Jak zaznaczyć obiekty wewnątrz obszaru?

Przy pomocy narzędzia «lasso». Albo zainstaluj Utilsplugin2, zaznacz obrys i znajdź inside selected (można zrobić ograniczenie liniami, na przykład: type:way inside selected itp.).

Jak znaleźć nazwy przy użyciu skomplikowanego filtru?

Zwróć uwagę na pozycje «wyrażenie regularne» i «uwzględnij wielkość liter» w oknie wyszukiwania. Na przykład, wyrażenie name=[a-z]{3}lin.+ znajdzie obiekty o określonej długości od siedmiu symboli,w środku którego jest «lin», a zaczyna się od dowolnych trzech łacińskich liter. Katalog dopuszczalnych konstrukcji znajdziemy tutaj (po angielsku). Jeśli krótko:

  • Po dowolnym symbolu może następować kwantyfikator ilości powtórzeń: ? — 0 albo 1 raz, * — 0 albo więcej razy, + — 1 albo więcej razy, {3,4} — od trzech do czerech razy(można pomijać części: {3}, {3,} albo {,4}).
  • Podsłowa można grupować poprzez nawiasy: (raz ){3} znajduje «raz raz raz » (ze spacją na końcu!).
  • Pionowa kreska oznacza wybór, ograniczony nawiasami: ((raz|dwa|trzy) ?){3} znajduje «razdwaraz» i «trzy dwa raz».
  • Kropka — dowolny symbol: l.+s znajdzie «las», «lis» i «lexus».
  • W kwadratowych nawiasach podawane są warianty dla jednego symbolu: [abc] — a, b albo c; [a-z0-9] — dowolna litera od a do z albo liczba 0 do 9. Jeśli jest potrzebny minus, postaw go na początku albo końcu. Negacja: [^ac-e] — dowolny symbol, oprócz a, c, d i e.
  • Standardowe klasy symboli: \d dla liczb, \w dla liczb, liter i znaku podkreślenia, \s dla spacji i tabów. Rejestr górny inwertuje klasę: \S — wszystko oprócz spacji.
  • Granice: ^ — początek linii, $ — koniec linii, \b — granica słowa: \btwór znajduje «twór» i «twórca», ale nie znajdzie «potwór».

Zwróć uwagę, że wyszukiwanie ze znakiem równości wyszukuje pełną zgodność, a z dwukropkiem — podsłowa. Innymi słowy, name=wyrażenie jest ekwiwalentne name:^wyrażenie$

Ślady i waypointy

Zrobiłem zakładki w CityGuide, jak zaimportować je do JOSM?

Przekonwertuj do formatu latitude, longitude, desc (prostym perlowym skryptem, jeśli w systemie windows, to przy użyciu excel), potem

gpsbabel -w -i csv -f points.cvs -O osm -F points.osm

Jak importować punkty Garmin do JOSM?

gpsbabel -w -i gdb -c cp1251 -f <mój_plik>.gdb -o GPX -c UTF-8 -F MyPoi.gpx

Można bezpośrednio z urządzenia, usuwając klucz -f файл.gdb i zamiast -i gdb napisz -i usb.

A z OziExplorer?

gpsbabel -i ozi -c cp1251 -f %1 -o GPX -c UTF-8 -F %1.gpx


Czy można wysłać ślady GPX do bazy OSM bezpośrednio z JOSM?

Wtyczka DirectUpload.

Czy w JOSM jest możliwość wysyłania na serwer OSM kilka śladów naraz?

Zarchiwizuj ślady do zip i wyślij przez web interface.

Czy w JOSM jest możliwość filtrowania pobieranych śladów GPS?

Prawy przycisk myszy na warstwie "Pobrane dane GPX", «Wybierz widoczne ścieżki». Tam można odznaczyć niepotrzebne ślady i odfiltrować stare.

Jak ustalić autora konkretnego śladu?

Prawy przycisk myszy na warstwie "Pobrane dane GPX", tam «Informacje»: wyświetli się okno z listą śladów, i dla nieanonimowych śladów będzie link w rodzaju http://api.openstreetmap.org/trace/00000/view. Otwórz stronę z linka i tam zobaczysz autora.

Jak pokolorować ślady wg prędkości?

W ustawieniach (F12) pierwsza zakładka, «Kolorowanie ścieżek i punktów».

Co oznaczają kolory śladów w JOSM?

Oznaczają któryś z parametrów śladu: prędkość albo wysokość. Czerwony — wolno albo wysoko, żółty — średnio, zielony — szybko albo nisko. Fioletowy — zbyt szybko.

Pobrałem ślad, i bardzo przeszkadzają jakieś okręgi

Ustawienia (F12), pierwsza zakładka, «Rysuj okręgi na podstawie wartości HDOP».

Pobieram ślad do JOSM - linia jest przerywana, w Potlatch linia nie ma przerw

Ustawienia (F12), pierwsza zakładka, zwiększ wartość «Maksymalna długość (w metrach)».

Podkłady

Jak przesunąć podkład?

Prawy przycisk myszy na warstwie podkładu, «Nowe przesunięcie». Potem po prostu myszką przesuwaj obrazek, albo strzałkami na klawiaturze. Więcej na wiki. (Nie zwracaj uwagi na wyświetlone okno, lepiej przesuń go na bok).

Żeby przesuwać bez dodatkowych okien, zainstaluj wtyczkę imageryadjust: ona doda narzędzie do lewego panelu.

Rekomendujemy korzystanie z pluginu bazy przesunięć, żeby uniknąć podwójnej pracy.

Nie mogę znaleźć podkładu Bing w menu "Podkłady mapy"

Wejdź do ustawień (F12), WMS/TMS i, wybierając z listy «Wpisy dostępne domyślnie» pozycję «Bing aerial imagery», kliknij «Aktywuj».

Alternatywnie, kliknij w tej zakładce «+» po prawej stronie. Wprowadź nazwę «Bing», a poniżej, — bing:bing.

Warstwa MapBox jest na liście dostawców zdjęć pod nazwą «MapBox Satellite».

Nie działa podkład wms:scanex:irs

Adres powinien być bez wms:, po prostu scanex:irs.

Jak ustawić swój obrazek jako podkład?

Wtyczka PicLayer. Otwieramy obrazek i go przesuwamy/skalujemy/obracamy. Zapisać otrzymaną kalibrację można, klikając prawym przyciskiem myszy na warstwie i wybierając «Zapisz kalibrację».

Jak wyczyścić cache kafelków?

Ustawienia -> zakładka WMS/TMS -> Zawartość cache -> Wyczyść

Bing jest dostępny tylko na najmniejszym zoomie, gdzie na całą planetę są 4 kafelki

W ustawieniach (F12 -> WMS/TMS -> Ustawienia -> Maksymalny/Minimalny poziom przybliżenia - ustaw właściwe wartości (2 albo więcej, 18). Również na liście "Wybrane wpisy" można ustawić maksymalny zoom.

Kafelki warstwy MapBox znikają na dużych zoomach

Na liście dostawców zdjęć (F12 -> WMS/TMS) znajdź MapBox i zamień tms[19] w linku na tms[17]. Pamiętaj, że to ograniczenie nie pozwoli zobaczyć zdjęcia na większych zoomach w Europie, USA i Australii.

Ustawienia

Nie mam niektórych przycisków i elementów, opisywanych w tym FAQ

Włącz tryb eksperta w oknie ustawień albo w menu «Widok».

Edytuję tak dużo naraz, że dla JOSM-a brakuje pamięci

Uruchom JOSM przy użyciu pliku .bat
 java -Xmx1024m -jar josm-latest.jar
(ilość pamięci można zmieniać) albo przy użyciu bardziej zaawansowanego skryptu

Jesli trzeba przydzielić więcej, niż 1-2Gb trzeba dodac ścieżkę do x64 wersji java. Poniżej parametry dodatkowych optymalizacji (-Xmx - maksymalna Xms - początkowa ilość:

"ścieżka\java.exe" -XX:+UseConcMarkSweepGC -XX:+DisableExplicitGC -XX:+UseAdaptiveGCBoundary -XX:MaxGCPauseMillis=500 -XX:-UseGCOverheadLimit -XX:SurvivorRatio=12 -Xnoclassgc -XX:UseSSE=3 -Xincgc -Xmx1024M -Xms512M -jar "ścieżka\josm-latest.jar"

Jesli uruchamiasz JOSM przy użyciu pliku .jnlp (Java Web Start), to dla zwiększenia dostępnej pamięci ustaw parametry jnlp: initial-heap-size (początkowa) i max-heap-size (maksymalna) ilość dostępnej pamięci, czyli w samym pliku .jnlp dokonaj takich zmian z własnymi liczbami

 <j2se version="1.6+" initial-heap-size="128m" max-heap-size="1024m" />

Nie podoba mi się, że JOSM przechowuje na dysku twardym miliony plików cache i nie usuwa ich

Zainstaluj wtyczkę ImageryCache, ona łączy kafelki w jeden plik.

Albo można przenieść folder JMapViewerTiles do ramdysku — na przykład, tworząc junction.

junction.exe %src% %trg%

gdzie

%trg%=Z:\temp  - ścieżka do ramdysku
%src%=...\JMapViewerTiles

Oprócz automatycznego czyszczenia cache otrzymujemy pewne przyśpieszenie i zmniejszenie obciążenia HDD. Dla utworzenia ramdysku rekomendujemy "RAMDisk Enterprise" jako najszybszy, elastyczny i bezpłatny.

U mnie wszystko się wyświetla w zniekształconej projekcji, tak jakby w perspektywie

W ustawieniach wybierz odwzorowanie Merkatora: Ustawienia (F12), trzecia zakładka "Ustawienia mapy" -> Rodzaj odwzorowania kartograficznego -> wybierz «odwzorowanie Merkatora». Do tego, wybierając tą projekcję, prawidłowo będzie działać narzędzie ortogonalizacji (Q)

Co zrobić, żeby tworząc okrąg, było w nim 2 razy więcej węzłów?

W ustawieniach zaawansowanych (ostatnia zakładka w oknie ustawień) utwórz createcircle.nodecount z potrzebną wartością, domyślnie — 8.

Gdzie można zmienić parametry dla generalizacji Simplify Way?

simplify-way.max-error w ustawieniach zaawansowanych.

Czy można korzystać z angielskiego interfejsu, a przy tym nazwy na mapie były polskie?

W ustawieniach zaawansowanych mappaint.nameOrder, kliknij «Edycja». Przykład: mappaint.nameOrder=name:pl;name:en;name;name:fr;int_name zawsze będzie wyświetlać polska nazwę, jeśli jest, w innym przypadku angielską, przy jej braku - lokalną.

Zauważyłem, że zniknęły strzałki, wskazujące kierunek linii

Prawdopodobnie, masz włączone wyświetlanie realnej szerokości mappaint.useRealWidth=true.

Jak zaktualizować JOSM do najnowszej wersji?

Pobierz josm-latest.jar z oficjalnej strony i zamień nim swój plik. Albo uruchom z nowego miejsca: ustawienia zostaną zachowane.

Można aktualizować automatycznie, tworząc plik .bat o następującej treści:

cd %~dp0
del josm-latest.jar
aria2c.exe http://josm.openstreetmap.de/josm-latest.jar --dir=%~dp0

aria2c.exe umieść obok, napisz pełną ścieżkę albo do PATH.

Zamiast aria2 można skorzystać z innych narzędzi do pobierania, na przykład wget.

Nie podoba mi się najnowsza wersja, skąd wziąć poprzednią?

http://gis-lab.info/programs/josm/

Gdzie można zresetować checkboxy «nie pytaj ponownie»?

To klucze message.* w ustawieniach zaawansowanych. Żeby pytanie się pojawiło, trzeba odpowiednia wartość ustawić wtrue albo usunąć. Na przykład, jeśli okno edycji relacji nie pozwala dodać dwukrotnie do jednej relacji, zresetuj klucz message.add_primitive_to_relation.

Gzie znajduje się plik ustawień?

Domyślnie — w ~/.josm, w systemie Windows — %appdata%\JOSM (wskazuje na \Users\UserName\AppData\Roaming\JOSM albo C:\Documents and Settings\UserName\Application Data\JOSM\). Określić na nowo (na przykład, żeby uruchomić z pendrive) można przy użyciu klucza uruchomienia -Djosm.home.

Jak wyłączyć podświetlenie obiektów pod kursorem?

Dodaj draw.target-highlight=false w ustawieniach zaawansowanych.

Przeszkadza mi wypełnienie obszarów, zasłania podkład

Dwa warianty:

  • Ctrl+W (Widok -> Widok Szkieletowy).
  • Ustawienia (F12) -> pierwsza zakładka -> zakładka «Dane OSM» -> Rysuj tylko kontury obszarów.

Jak przesuwać węzły i widzieć ikonki na małych zoomach?

W nowym stylu JOSM niektóre obiekty (w tym ikonki i pojedyncze węzły) przestają być widoczne na małych zoomach. Można to zmienić: włącz panel styli (Okna -> Style rysowania map), naciśnij prawym przyciskiem myszy na linii «JOSM default (MapCSS)», i tam w «ustawienia stylu» odhaczamy "Bardziej stonowane symbole przy niskim przybliżeniu".