RU:JOSM/FAQ

From OpenStreetMap Wiki
Jump to: navigation, search
Доступные языки — JOSM/FAQ
· Afrikaans · Alemannisch · aragonés · asturianu · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · Bân-lâm-gú · Basa Jawa · Baso Minangkabau · bosanski · brezhoneg · català · čeština · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · Kurdî · latviešu · Lëtzebuergesch · lietuvių · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk bokmål · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · português do Brasil · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tiếng Việt · Türkçe · Vahcuengh · vèneto · Wolof · Yorùbá · Zazaki · српски / srpski · беларуская · български · қазақша · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · मराठी · हिन्दी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 吴语 · 粵語 · 中文(繁體)‎ · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް
  Начальное руководство   Простая правка   Расширенная правка   Загрузить изменения в openstreetmap.org(en)   Модули   Часто задаваемые вопросы   Горячие клавиши ±

Contents

Загрузка и выгрузка

Как загрузить отношение по его номеру?

Ctrl+Shift+O (файл -> скачать объект).

Как загрузить данные по ссылке, по XAPI?

Ctrl+L (файл -> открыть адрес).

А есть какой-нибудь способ качать квадраты большие, чем позволяет API?

  • В режиме эксперта «Файл», «Скачать с Overpass API». В поле запроса введите (node;<);out meta; и выделите прямоугольник.
  • Нужен длинный GPX-трек. Загружаете его в JOSM, правую кнопку на слое и «скачать с OSM данные вдоль этого трека».
  • osmget.pl

Хочу загрузить все магазины в своём городе

  1. Откройте taginfo и перейдите на страницу тега shop=*.
  2. Нажмите на руль справа вверху, под полем фильтра.
  3. Подвиньте и отмасштабируйте карту, чтобы на ней отображался город.
  4. Убедитесь, что в JOSM включено удалённое управление (F12 -> кнопка с пультом).
  5. Нажмите Export, затем JOSM, затем в диалоге "repair query".
  6. Теперь снова Export, JOSM.
  7. В редакторе загрузятся все магазины.

Как работать в JOSM на компьютере без интернета?

Нужен только сам josm-latest.jar. Сначала с компа с инетом качаем нужный кусок, сохраняем слой данных и слой с треками, и тащим на другой комп. Там делаем с ним всё, что нужно, опять сохраняем и тащим на комп с инетом. Открываем josm`ом, подгружаем с сервера этот кусок, чтобы проверить на конфликты, после их разрешения - upload и готово. Если нужна подложка, в принципе, можно воспользоваться Котяриным twms-ом.

Есть ли в JOSM возможность скачать только одну дорогу, но очень длинную и состоящую из маленьких кусочков?

  • Можно через xapi или overpass вытащить линии с заданным тегом.
  • Загрузить трек по этой дороге, нажать на нём правую кнопку в списке слоёв и выбрать «скачать данные вдоль трека».
  • Использовать плагин WayDownloader. Cкачивается один кусок, выделяется линия или её конец, и по нажатию клавиши плагина скачиваются все одиночные непрерывные куски. Когда доходит до развилки, скачивание останавливается, надо у нужной развилки опять выделить конечную точку и нажимать снова.

Почему не работают ссылки "Редактировать в JOSM" (удалённое управление)?

Чтобы ссылки типа http://localhost:8111/load_and_zoom?top=...&right=... работали, управление должно быть включено в настройках JOSM (F12 - дистанционное управление - включить), а сам JOSM - запущен. Изредка проблема возникает из-за занятого (например, повисшей копией JOSM) порта 8111 или настроек файрвола.

В браузере Opera не работают ссылки редактирования в JOSM

Разрешите Cross Network Navigation в настройках Opera

  • Введите в адресную строку браузера opera:config#Cross%20Network и нажмите клавишу Enter;
  • Поставьте галку напротив выделенного пункта;
  • Нажмите сохранить;
  • Перезагрузите браузер;

Редактирование

Как поворачивать и масштабировать объекты?

Тянуть мышкой с зажатым Ctrl+Shift (поворот) или Ctrl+Alt (масштабирование).

Повороты на заданный угол есть в плагине ShapeTools и среди команд плагина CommandLine.

Работа с картой на трекпаде

Если у вас Mac OS X и есть мышка — включите вторую кнопку в настройках мыши. С трекпадом сложнее:

  • Масштабирование — как прокрутка, вверх-вниз двумя пальцами;
  • Перемещение объекта — как перетягивание в других приложениях, тремя пальцами;
  • Сдвиг карты — либо сильно нажать и тащить двумя пальцами, либо зажать Ctrl и тащить тремя;

Как склеить несколько полигонов (домов, водоёмов)?

Убедиться, что они соединены или пересекаются, и нажать Shift+J (инструменты -> объединить полигоны).

Выделить все полигоны, пересекающие данный, можно клавишей I (Utilsplugin2, выделение - пересекающиеся линии).

Как объединять дороги?

C (инструменты -> объединить линию).

Как добавить точку с конкретными координатами?

Shift+D (инструменты -> добавить точку). Чтобы переместить точку в нужное место, «инструменты -> двигать точку».

Как грамотнее всего добавлять точки в старые линии?

  • На отрезках при достаточном приближении есть крестик, отмечающий середину. Если потянуть за него, будет новая точка, иначе будет перемещение полигона.
  • Второй вариант — нажать «A» (рисовать точки) и кликнуть в нужном месте на линии (линия при этом должна подсветиться голубым цветом). Так же можно поставить точки и на пересечении линий.
  • Нажать «W» (улучшение геометрии), выбрать линию и тыкнуть в нужное место с зажатым Ctrl.

Как нарисовать окружность?

  • Нарисовать её примерно (например, обрисовывая спутник), затем нажать O (инструменты -> выстроить точки).
  • Нарисовать диаметр (линию с двумя точками) или край (с тремя) окружности, затем Shift+O (инструменты -> создать окружность).

Также см. #Как сделать, чтоб при создании окружности, в ней было в 2 раза больше точек?

Можно ли как-то скопировать вхождение элемента в отношения?

Плагин UtilsPlugin2, Ctrl+Alt+V (ещё инструменты -> вставить отношения).

Как из полигона тростника вырезать полигон водной поверхности?

Нужно сделать мультиполигон. Выделите оба полигона, затем Shift+A (инструменты -> создать мультиполигон).

Как в JOSMе расковырять линию, принадлежащую двум полигонам?

Выбрать один из полигонов и нажать G (инструменты -> разъединить линии).

Как добавить общие точки в местах пересечений линий

Подключить UtilsPlugin2, выделить линии и нажать Shift + I (Ещё инструменты -> Добавить точки на перекрёстки)

Можно ли из josm вытащить ссылку на way?

Ctrl+I (вид -> информация об элементе), либо сразу Ctrl+Shift+I (откроет страницу в браузере).

Есть ли в JOSM простой способ разрезать полигон на два полигона?

Плагин UtilsPlugin2, выберите две точки на контуре и Shift-P (ещё инструменты -> разделить объекты).

Есть шорткат для добавления отношений?

Плагин reltoolbox, Ctrl+Shift+C или Ctrl+Alt+N.

Как временно отказаться от привязки к линиям и точкам в процессе рисования?

Зажмите Ctrl.

Можно заставить josm передвигать объекты клавиатурой?

Shift+стрелочки.

При копировании линий и их вставке, оказываются выделенными точки у последней. Как с этим бороться?

  • Обновить JOSM до последней версии (от 5990).
  • Ctrl+F -> -type:node selected. Или можно воспользоваться панелью выделения - там все по порядку (релейшны, веи, ноды) и есть кнопка «Выбор».
  • При установленном Utilsplugin2 снять выделение с узлов можно, нажав Alt-U (выделение - снять выделение с точек).

Как две линии, например, два отдельно стоящих здания «слепить вместе»?

Подтаскиваете здания поближе (возможно, только их части). Дальше J — прилепить точку к ближайшей линии, M — склеить две точки (выбранные или одну к ближайшей).

Как правильно удлинять здание? Как добавить выступ?

X (инструмент с угловой линейкой), затем вытянуть нужную сторону. По двойному нажатию добавляются точки, и можно вытянуть только часть линии.

Как выровнять здание вдоль дороги?

Выбрать все нужные здания (их углы должны быть прямыми) и две точки из линии дороги, затем нажать Q.

Можно использовать плагин ShapeTools.

Через точки проведено несколько линий, как выбрать нужную?

  • Нажать колёсико мыши (или третью кнопку) и подождать.
  • Кликать левой кнопкой на линии с зажатым Alt.

Как быстро выбрать отношение, в которое входит линия или точка?

См. предыдущий вопрос: нажать на объект с Alt или средней кнопкой.

Что-то нажал, и карта автоматически следует за кликами мышки. Как отключить?

Ctrl+Shift+F (вид -> режим следования).

Тегирование

Как сделать ограничение на поворот?

С помощью модуля turnrestrictions.

Как сделать заготовки тегов (пресеты)? Кому их отправлять?

Нужно создать свой xml-файлик наподобие файлика с существующими заготовками (один из самых простых) и указать до него путь в меню Правка/Настройка, вкладка «Настройки карты» (третья), подвкладка «Заголовки с тегами», плюсик справа. Подробная инструкция и формат файла — на сайте JOSM. Чтобы сделать пресет доступным всем, нужно разместить его в вики JOSM.

Как добавить кнопки пресетов в панель инструментов?

Настройки (F12) -> Панель инструментов -> Доступно -> Заготовки -> перегнать нужные кнопки в левую панель.

Как добавить теги хоткеем на клавиатуре?

Alt+A.

Как скопировать теги с предыдущего объекта?

Ctrl+C, затем Ctrl+Shift+V — вставить только теги. В utilsplugin2 есть комбинация Shift+R, которая копирует теги с предыдущего выбранного объекта.

Как сделать чтобы в дальнейшем на карте навитела был поиск по улицам?

Нарисовать городу границу (линию с тегом place=* и name, как у точки). Желательно поставить точке с линией addr:country=RU, addr:region=<название области> и addr:district=<название района>.

Как присвоить номер дому?

В меню: Заготовки -> Аннотация -> Адреса. Название улицы обязательно.

Как посмотреть список авторов и историю объекта?

Ctrl+H.

А нельзя выделить кучку объектов и посмотреть всех их авторов за всё время?

Есть панель авторов (кнопка с человечками, Alt+Shift+A), но она показывает только последних редакторов.

Как узнать идентификатор выделенного объекта?

В расширенных настройках (последняя вкладка окна настроек) osm-primitives.showid = true включит отображение идентификаторов в панели выделенных объектов.

ID видно в строке статуса, если навести курсор на объект. Можно нажать Ctrl+I: откроется окно информации по выделенным объектам, где, помимо прочего, пишутся их номера.

Поиск и фильтры

Выбор объектов по условию — Ctrl+F, туда нужно ввести критерий отбора.

Не получается найти дома с addr:street

Нужно использовать кавычки: "addr:street"="название улицы".

Мне мешает рисовать область со значением town, как его можно временно скрыть?

Режим каркаса (Ctrl+W) - отключается вся раскраска. Либо фильтром:

  1. включите панель фильтра (слева среди иконок такая серая воронка)
  2. в панели нажмите «добавить», в строку впечатайте place type:way
  3. жмите enter
  4. если серый контур не устраивает и хочется скрыть целиком, ставьте галочку в столбце «H».

Также см. #Как выкинуть из слоя ненужные данные, не удаляя их из OSM? и #Мне мешает заливка площадей, скрывает снимок.

Есть способ сделать фильтр так, чтобы остались только дороги и принадлежащие им точки?

highway, затем инвертируйте, поставив галочку в столбце «I».

Как перейти к координатам?

Shift+D — поставить точку по координатам. Затем её можно удалить.

Как посмотреть, какие из объектов нарисовал я?

user:<ваш логин>

Как выкинуть из слоя ненужные данные, не удаляя их из OSM?

Выбрать их, затем Ctrl+Shift+P (правка -> очистить).

Можно как-то выделить все точки выделенных линий?

type:node child selected

При установленном UtilsPlugin2 — Ctrl+Shift+N или просто «E».

Можно ли раскрасить дома в зависимости от улицы или тега building?

Конечно. Откройте панель стилей (кнопка слева с палитрой), нажмите на ней кнопку настройки и добавьте в активные стили один из следующих:

  • По улице и наличию номера: Address Tags Validator (предпочтителен), Coloured Addresses, Coloured Streets.
  • По значению тега building=*: Coloured Buildings.de

Полный список стилей с описаниями и картинками лежит в вики редактора.

Как найти точки, не принадлежащие ни одному объекту?

type:node -child. Если нужны только точки без тегов, то type:node untagged -child

Как выделить объекты внутри полигона?

Инструментом «лассо». Либо поставить Utilsplugin2, выбрать контур и найти inside selected (можно ограничить линиями, например: type:way inside selected и т.п.).

Как найти названия по сложному фильтру?

Обратите внимание на галочки «регулярное выражение» и «с учётом регистра» в окне поиска. Например, выражение name=[a-z]{3}lin.+ найдёт объекты с названием длиной от семи символов, в середине которого есть «lin», а начинается с любых трёх латинских букв. Справочник допустимых конструкций здесь (на английском). Если кратко:

  • После любого символа может идти квантификатор количества повторений: ? — 0 или 1 раз, * — 0 или более раз, + — 1 или более раз, {3,4} — от трёх до четырёх раз (можно опускать части: {3}, {3,} или {,4}).
  • Подстроки можно группировать скобками: (раз ){3} найдёт «раз раз раз » (с пробелом на конце!).
  • Вертикальная черта означает выбор, ограничивается скобками: ((раз|два|три) ?){3} найдёт «раздвараз» и «три два раз».
  • Точка — любой символ: л.+с совпадёт с «лес», «лис» и «лексус».
  • В квадратных скобках указываются варианты для одного символа: [abc] — a, b или c; [a-z0-9] — любая буква от a до z или цифра от 0 до 9. Если нужен минус, ставьте его в начало или конец. Отрицание: [^ac-e] — любой символ, кроме a, c, d и e.
  • Стандартные классы символов: \d для цифр, \w для цифр, букв и знака подчёркивания, \s для пробелов и табов. Верхний регистр инвертирует класс: \S — всё кроме пробелов.
  • Границы: ^ — начало строки, $ — конец строки, \b — граница слова: \bпень найдёт «пень» и «пенька», но пропустит «лупень».

Обратите внимание, что поиск со знаком равенства ищет полное вхождение, а с двоеточием — подстроку. Другими словами, name=выражение эквивалентно name:^выражение$

Треки и вейпоинты

Наделал закладок в СитиГиде, как их импортировать в JOSM?

Преобразовать в вид latitude, longitude, desc (простым перловым скриптом, если под виндой, то через excel), затем

gpsbabel -w -i csv -f points.cvs -O osm -F points.osm

Как импортировать точки Garmin в JOSM?

gpsbabel -w -i gdb -c cp1251 -f <ваш_файл>.gdb -o GPX -c UTF-8 -F MyPoi.gpx

Можно сразу с устройства, убрав ключ -f файл.gdb и вместо -i gdb написав -i usb. Если что-то не работает, почитайте эту тему.

А из OziExplorer?

gpsbabel -i ozi -c cp1251 -f %1 -o GPX -c UTF-8 -F %1.gpx

Также см. эту тему, там есть батник.

Возможна ли загрузка GPX треков в базу OSM из JOSM и как это сделать?

Модуль DirectUpload. Описание работы есть на форуме.

Подскажите, есть в JOSM возможность загрузки на OSM треков "пачками"?

Заархивируйте в zip и загрузите через web-интерфейс.

Можно ли в JOSM фильтровать загружаемые треки?

Правая кнопка мыши на слое скачанных данных GPX, «Фильтровать треки». Там можно снять выделение с ненужных треков или отфильтровать старые.

Как выяснить автора конкретного трека?

Правой кнопкой на слое с треками, там «Информация»: отобразится окно со списком треков, и для неанонимных треков будет ссылка вида http://api.openstreetmap.org/trace/00000/view. Открываете её, кликаете в пользователя.

Как раскрасить треки по скорости?

В настройках (F12) первая вкладка, «Раскрасить треки и точки».

Что означает цветовой окрас треков в жосме?

Означает какой-то из параметров трека: скорость или высоту. Красный — медленно или высоко, жёлтый — средне, зелёный — быстро или низко. Фиолетовый — слишком быстро.

Загрузил трек, и очень мешают какие-то окружности

Настройки (F12), первая вкладка, «Изобразить значение HDOP».

Скачиваю трек в JOSM - линия получается прерывистой, в Potlatch линия без разрывов

Настройки (F12), первая вкладка, увеличьте значение «Максимальная длина (в метрах)».

Подложки

Как двигать подложку?

Правую кнопку на слое подложки, «Смещение -> Новое смещение». Затем просто мышкой тягать картинку, либо стрелочками на клавиатуре. Подробнее в вики. (Не обращать внимание на появившееся окно, лучше его сдвинуть к краю).

Чтобы двигать без лишних окон, поставьте плагин imageryadjust: он добавит инструмент в левую панель.

Рекомендуется использовать плагин базы смещений, чтобы не делать работу дважды.

Не могу найти подложку Bing в меню Снимок

Зайдите в Настройки (F12), WMS/TMS и, выбрав в списке «Доступные по умолчанию» пункт «Снимки Bing», нажмите кнопку «Активировать». Заодно неплохо бы добавить «ScanEx IRS» оттуда же.

Альтернативно, нажмите в этой вкладке «+» справа от (пустого) списка выбранных слоёв. Введите как название «Bing», а внизу, в поле «URL подложки», — bing:bing. Таким же образом можно добавить подложку IRS, с адресом scanex:irs.

Слой MapBox есть в списке доступных подложек под названием «Спутниковые снимки MapBox».

Не работает подложка wms:scanex:irs

Адрес должен быть без wms:, просто scanex:irs.

Как использовать свою картинку как подложку?

Плагин PicLayer. Загружаете картинку и двигаете/масштабируете/поворачиваете её. Сохранить полученную привязку можно, нажав правую кнопку на слое и выбрав «сохранить».

Можно ли использовать данные, полученные из SASPlanet?

Тема на форуме.

Как очистить кэш тайлов?

Удалить содержимое C:\Documents and Settings\%USER%\Local Settings\Temp\JMapViewerTiles_%USER%. Есть скрипт для запуска josm, который скачивает последнюю версию, удаляет кэш тайлов и выделяет побольше памяти редактору.

Bing выдаёт только самый грубый масштаб, где на всю планету четыре тайла

В настройках (F12 -> WMS/TMS -> Настройки -> Уровень мин/макс) надо выставить нужные уровни (2 или больше, 18). Также в списке выбранных поставщиков подложек может быть задано максимальное увеличение.

Тайлы слоя MapBox исчезают, когда увеличиваешь масштаб до удобного

В списке слоёв (F12 -> WMS/TMS) найдите MapBox и замените tms[19] в ссылке на слой на tms[17]. Учтите, что это ограничение не позволит увидеть более детальные масштабы в Европе, США и Австралии.

Настройка

У меня отсутствуют некоторые кнопки или элементы, описываемые в этом FAQ

Включите экспертный режим в окне настроек или в меню «Вид».

Я редактирую так много сразу, что JOSM-у не хватает памяти

Запускайте JOSM батником со строкой
 java -Xmx1024m -jar josm-latest.jar
(объём памяти можно менять) или более продвинутым скриптом

Если нужно выделить более чем 1-2Гб нужно писать путь к x64 версии java. Вот параметры дополнительных оптимизаций (-Xmx - максимальный Xms - начальный размер:

"путь\java.exe"
  -Xmx1024M -Xms128M
  -XX:UseSSE=3 -Xincgc -Xnoclassgc
  -XX:+UseConcMarkSweepGC -XX:+DisableExplicitGC -XX:+UseAdaptiveGCBoundary
  -XX:-UseGCOverheadLimit -XX:MaxGCPauseMillis=500 -XX:SurvivorRatio=12
  -jar "путь\josm-latest.jar"

Если вы запускаете JOSM через .jnlp файл (Java Web Start), то для увеличения доступной памяти используйте параметры jnlp: initial-heap-size (начальный) и max-heap-size (максимальный) обьем памяти доступный приложению, т.е. в сам файл .jnlp добавьте такие вот такие изменения со своими цифрами

  <j2se version="1.6+" initial-heap-size="128m" max-heap-size="1024m" />

Я недоволен тем, что JOSM хранит на жестком диске миллионы файлов кеша и не удаляет их

Поставьте плагин ImageryCache, он объединяет тайлы в одном файле.

Либо можно перенести папку JMapViewerTiles на RAM-диск — например, создав junction.

junction.exe %src% %trg%

где

 %trg%=Z:\temp  - путь к рамдиску
 %src%=...\JMapViewerTiles

Кроме автоотчистки кеша получим некоторое ускорение и снижение нагрузки на HDD. Для создания рамдиска рекомендуется "RAMDisk Enterprise" как самый быстрый, гибкий и бесплатный.

У меня всё отображается в наклонной проекции, как бы в перспективе

В настройках выбрать меркаторовскую проекцию: меню Правка -> Настройки (F12), там третья вкладка Настройки карты -> Картографическая проекция -> выбрать в типе проекции «Проекция Меркатора». И, кстати, при выборе этой проекции будет нормально работать инструмент ортогонализации (Q)

Как сделать, чтоб при создании окружности, в ней было в 2 раза больше точек?

В расширенных настройках (последняя вкладка в окне) создать createcircle.nodecount с нужным значением, по умолчанию — 8.

Где можно менять параметры для генерализации Simplify Way?

simplify-way.max-error в расширенных настройках.

А можно как-то использовать английский интерфейс, но чтобы при этом названия на карте были русские?

В расширенных настройках mappaint.nameOrder, нажать «Правка». Пример: mappaint.nameOrder=name:ru;name:en;name;name:fr;int_name всегда будет показывать русское название, если оно есть, иначе английское, при отсутствии и его - местное.

Обнаружил, что пропали стрелочки, которые указывают направление линии

Скорее всего, у вас включено использование реальной ширины mappaint.useRealWidth=true.

Как обновить josm на более свежую версию?

Скачать josm-latest.jar с официального сайта и заменить им свой файл. Или запустить из нового места: настройки подхватятся.

В Mac OS X, если вы устанавливали JOSM из готового пакета, этот файл нужно скопировать в /Applications/JOSM.app/Contents/Java, удалив оттуда другие файлы.

Автоматически можно обновлять, создав .bat-файл со следующим содержимым:

cd %~dp0
del josm-latest.jar
aria2c.exe http://josm.openstreetmap.de/josm-latest.jar --dir=%~dp0

aria2c.exe положить положить рядом, написать полный путь или в PATH.

Вместо aria2 можно использовать и другие качалки, вроде wget.

Мне не нравится свежая версия, где взять предыдущие?

http://gis-lab.info/programs/josm/

Где сбрасывать чекбоксы «не спрашивать снова»?

Это ключи message.* в расширенных настройках. Чтобы вопрос появился, нужно соответствующее значение поставить в true или удалить. Например, если окно редактирования отношений не даёт добавить элемент дважды в одно отношение, сбросьте ключ message.add_primitive_to_relation.

Где хранится файл настроек?

По умолчанию — в ~/.josm, в винде — %appdata%\JOSM (указывает на \Users\UserName\AppData\Roaming\JOSM или C:\Documents and Settings\UserName\Application Data\JOSM\). Переопределить (например, для запуска с флэшки) можно ключом запуска -Djosm.home.

Как отключить подсветку объекта под курсором?

Добавить draw.target-highlight=false в расширенных настройках.

Мне мешает заливка площадей, скрывает снимок

Два варианта:

  • Ctrl+W (вид -> каркас).
  • Настройки (F12) -> первая вкладка -> вкладка «Данные OSM» -> Рисовать только контур области.

Что делать, если в окне загрузки и на карте вместо текста мусор и квадратики?

Попробуйте удалить из системы шрифт Helvetica: вероятно, в нём нет русских букв.

JOSM выбирает шрифты по цепочке Helvetica → Calibri → Arial, если какой-то из них не русифицирован, могут быть проблемы.

Как двигать точки и видеть значки на низких масштабах?

В новом стиле JOSM некоторые объекты (в том числе, значки и квадратики узлов) отключаются на низких масштабах. Это можно настроить: включите панель стилей (слева кнопка с палитрой), нажмите правую кнопку на строке «Стандартный JOSM», и там в «настройках стиля» снимите лишние галочки.

Под Mac OS X ничего не скачивается

Установите prefer.ipv6=false в расширенных настройках и перезапустите JOSM.