RU:JOSM/Расширенная правка

From OpenStreetMap Wiki
Jump to: navigation, search
Доступные языки — JOSM/Advanced editing
· Afrikaans · Alemannisch · aragonés · asturianu · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · Bân-lâm-gú · Basa Jawa · Basa Sunda · Baso Minangkabau · bosanski · brezhoneg · català · čeština · corsu · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · Kurdî · latviešu · Lëtzebuergesch · lietuvių · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk bokmål · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tagalog · Tiếng Việt · Türkçe · Vahcuengh · vèneto · Wolof · Yorùbá · Zazaki · српски / srpski · беларуская · български · қазақша · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · मराठी · हिन्दी · भोजपुरी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · བོད་ཡིག · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ ⵜⴰⵏⴰⵡⴰⵢⵜ‎ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 中文(繁體)‎ · 吴语 · 粵語 · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް
  Начальное руководство   Простая правка   Расширенная правка   Загрузить изменения в openstreetmap.org(en)   Модули   Часто задаваемые вопросы   Горячие клавиши ±

Сохранение и загрузка .osm файлов

В большинстве случаев вам будет вполне достаточно возможности скачать данные с сервера и загрузить на сервер свои изменения. Когда вы загрузили изменения на сервер, они уже надежно сохранены. Более того, они становятся доступны другим людям для просмотра на карте и дальнейших улучшений. OpenStreetMap предназначен для совместной работы через интернет! Тем не менее JOSM умеет работать и с файлами на вашей местной файловой системе, сохраняя и загружая файлы с жесткого диска. По сути это не отличается от других приложений.


Используйте меню Файл (File) > Сохранить как... (Save As...) для сохранения информации (в т. ч. ваших изменений) в файл.

Используйте меню Файл (File) > Открыть... (Open...) чтобы открыть ранее сохраненный файл для редактирования или загрузки на сервер.


Формат файлов JOSM - это XML-представление данных OpenStreetMap в стандартном .osm-формате. JOSM слегка дополняет его сведениями об изменениях в информации OpenStreetMap; имеются в виду изменения, которые не были загружены на сервер к моменту сохранения файла. Это полезная возможность, которая означает, что JOSM может быть использован в качестве оффлайн-редактора (т. е. без подключения к интернету) следующим образом:

Оффлайн-редактирование

Когда вам доступно подключение к интернету...

  • Скачайте область карты (это может быть как один, так и несколько сегментов)
  • Сохраните информацию в .osm-файл на свой жесткий диск (и при необходимости перенесите на компьютер без доступа к интернету)

Теперь, даже когда интернет недоступен...

  • Откройте файл
  • При желании догрузите GPS-треки и наложите их на карту
  • Редактируйте карту как обычно, например, добавляйте информацию по результатам личных исследований
  • Сохраните изменения обратно в тот же файл. Он будет включать всю информацию о внесенных вами изменениях, включая перемещение и удаление данных.

Когда снова появится возможность доступа к интернету...

  • Откройте файл с изменениями в JOSM
  • Выполните команду Файл (File) > Обновить данные (Update Data) чтобы еще раз скачать с сервера области, над которыми вы работали (ваши изменения потеряны не будут). Разрешите все конфликты (см. ниже)
  • Нажмите Загрузить на сервер (Upload) чтобы сохранить изменения на сервер OpenStreetMap.

Разрешение конфликтов

Пока вы выполняете правку, есть шанс, что в это же время кто-то еще редактирует ту же область. JOSM скачивает и обновляет информацию, только когда вы его об этом просите. Как результат, если вы редактируете достаточно долго, вы можете не заметить пересечения интересов (т. е. кто-то успеет загрузить на сервер свое видение области, которую вы как раз редактируете). В целом, неплохим вариантом решения будет более-менее частая загрузка на сервер сделанных вами изменений, что позволит уменьшить последствия конфликтов, если они возникнут. Но есть еще и вариант обновлять данные до того, как загружать на сервер изменения. Команда Скачать (download) не замещает ваши изменения данными с сервера. (В этом контексте чуть быстрее будет использовать команду 'Обновить данные' - прим. перев.) Таким образом можно не беспокоиться о том, что вы потеряете свои наработки; при этом вы вовремя увидите изменения, внесенные другими пользователями.

Безусловно, рассмотрение изменений, сделанных другими пользователями, должно быть выполнено до загрузки данных на сервер. Если другой пользователь изменил элемент, который вы тоже изменили, JOSM сообщает о "конфликте". (Также конфликт может возникнуть, если вы удалили пересечение дорог за пределами скачанной области правки; такое бывает, например, при использовании команды "Упростить линию" - прим. перев.) Поскольку, к этому моменту вы еще не загрузили изменения на сервер, вам придется разрешить конфликты до загрузки. Эта возможность разработана для того, чтобы помочь вам обнаруживать области, где возникло противоречие с правками других пользователей. Когда вы разрешите конфликты, у вас появится возможность завершить загрузку ваших правок на сервер.

Отключаемая панель конфликтов появляется справа. Там перечисляются все конфликты, и щелчком на конфликте вы можете открыть дополнительное окно, чтобы разрешить каждый из них. Различные вкладки и представления предназначены для того, чтобы помочь вам понять, как выглядят данные в одном и другом варианте. Хотя прочтение этих представлений и может показаться сложным, на самом деле все сводится к простому выбору: сохранить чужие данные или ваши. Под "чужими" понимаются те данные, которые уже были изменены кем-то на сервере, пока вы работали.

Unglueing and untangling

В разделе простой правки было рассказано о редактировании точек и линий, и, в том числе, об операциях, таких как разделение, объединение и изменение направления линий. Работа может несколько усложниться, когда возникает взаимная зависимость, перекрытие и сложная привязка линий, но не забывайте, что вы всегда можете попробовать сделать изменения, а потом отменить несколько шагов, если дело пошло не так. Вы также можете временно сместить точки или даже удалить элементы, чтобы лучше рассмотреть связи и перекрытия, а потом отменить это действие. Вот еще несколько полезных техник редактирования:

Перекрывающиеся линии, когда 2 или более линии нарисованы точно друг над другом, могут получиться по ошибке, а могут и являться правильным представлением чего либо. Две дороги (highway=*) редко будут перекрываться, но, например, можно встретить границу землепользования (landuse=*), которая использует общие с дорогой точки. В этом случае вам может понадобиться выбрать одну или другую из перекрывающихся линий. Это можно сделать по-разному:

  • Щелчок средней кнопкой мыши открывает контекстное меню, в котором будут отражены теги всех объектов, находящихся под курсором.
  • Щелчок левой кнопкой мыши при удерживаемой клавише Ctrl позволяет изменять выбор.
  • Другой способ - последовательный перебор выбора щелчками средней кнопкой мыши.
  • Если у вас нет средней кнопки мыши, удерживайте Alt и щелкайте левой кнопкой мыши для последовательного перебора выбора

Unglue ways is an option on the 'Tools' menu. If two (or more) ways are connected at one node, this option will create a second node, freeing one way from the other. Note that this normally results in a 'duplicate node' (two different nodes sitting exactly top of one another) with both nodes being selected. As a follow-up, or just to understand the situation, you may want to clear your selection and then drag just the top node off to one side. You should do this to avoid leaving a duplicate node in the data. They are usually regarded as a bad thing, often resulting in confusion and routing connectivity problems. There should be no need for them in the data. The 'unglue ways' action can also be used with a way element selected, to unglue it from any nodes it shares along it's entire length.

The features described here are particularly useful for working with complex data. There are several other actions on the tools menu, and more can be installed via plugins.

Отношения

Отношения - это совокупность признаков, которая может быть использована для создания на карте составных объектов и правил, таких как маршруты и ограничения на поворот. В состав отношения входят, среди прочего, элементы, такие как точки и пути. Сами отношения также могут быть участниками отношений, в этом случае выстраивается иерархия участников (родительские-дочерние отношения). Для каждого из участников может (иногда - должна) быть установлена роль. Кроме того в отношение входят теги. Для детального понимания раздела изучите справку по отношениям.

JOSM предоставляет интерфейс для детального низкоуровневого редактирования отношений. Доступ к окну редактирования отношений можно получить двумя способами.

Liste aller Relationen.png
Панель просмотра отношений находится в правой части окна JOSM. Включить и выключить отображение панели можно кнопкой, которая показана слева. Панель содержит список всех отношений, которые находятся в скачанной области, и содержит кнопки для создания, редактирования, дублирования, удаления и выбора отношений.

Панель свойств ("properties/membership"), которая в первую очередь используется для просмотра и назначения тегов, также показывает отношения, участником которых является выбранный в данный момент объект.

Чтобы создать отношение с нуля, вам потребуется использовать именно панель отношений (попробуйте также использовать меню Заготовки > Отношения, предварительно выбрав будущих участников отношения - прим. перев.), но обе упомянутые выше панели позволяют редактировать отношения. Главное окно редактирования отношений разбито на три области. В верхней части редактируются теги отношения. Слева внизу - список участников отношения и их ролей. Список отсортирован (в ряде случаев порядок важен). В правой нижней части находится список объектов, которые могут быть добавлены в отношение. Это объекты, которые в данный момент выбраны в окне редактирования карты. Можно изменять список выбранных объектов, не закрывая окно редактирования отношения.

Заготовки тегов

JOSM поддерживает распространяемые заготовки тегов. Это конфигурационный файл в формате XML, который создает в JOSM специальное графическое меню Заготовки для задания тегов (характеристик объектов, см. RU:Map_Features). Этот XML-файл может находиться где угодно в интернете или на локальной файловой системе. Заготовки JOSM можно добавить в меню Настройки (Preferences> Настройки карты (Map Settings> Заготовки тегов (Tagging Presets).

Больше информации можно получить на http://josm.openstreetmap.de:



Далее >>

Вы уже изучили достаточно сложные приемы, но возможности можно расширить, используя различные модули JOSM.