From OpenStreetMap Wiki
Jump to: navigation, search
Available languages — QGIS
Deutsch English español français
Screenshot of QGIS
Website: http://qgis.org/
Version: 2.10.1 (2015-07-20)
License: GPL (free)
Platform: win;linux;macos;android

a free, multiplatform GIS application

QGIS (previously also known as Quantum GIS) is a free (GNU GPL v2) and open source GIS application enabling the user to visualize, manage, edit, analyse data, and compose printable maps. It runs on Linux, Unix, Mac OSX, Windows and Android and can be downloaded free of charge from qgis.org.

OpenStreetMap in QGIS

QGIS 2 OpenStreetMap Vectors

QGIS 2.0 integrates OpenStreetMap import as a core functionality. To get OSM data:

  • Menu "Vector -> Openstreetmap -> Load data" will connect to the OSM server and download data. You can skip this step if you already have a .osm XML file.
  • "Import topology from an XML file" below will convert your .osm file into a spatialite database, and create a db connection.
  • "Export topology to Spatialite" then allows you to open the database connection, select the type of data you want (points, lines, polygons) and choose tags to import. This creates a spatialite geometry layer that you can then add to your project via the "add a spatialite layer" menu.

More details here. Note that this process imports raw OSM GIS data not any particular map style/symbology.


QuickOSM allows you to work quickly with OSM data in QGIS thanks to Overpass API.

OpenStreetMap Plugin (obsolete)

For QGIS older than version 2: The QGIS OSM Plugin lets you load in vector data from OpenStreetMap, and even edit and upload your changes. However, due to a bug related to 64-bit Identifiers, newer data is not read. See the QGIS OSM Plugin page for more info and workarounds.

Shapefiles, PostGIS and other conversion options

There are many ways converting OSM data to other formats which can then be opened within QGIS. In particular note the various options for Shapefiles and PostGIS databases.

Using raster maps from OpenStreetMap

There's a couple of different approaches to bring in tiles from OpenStreetMap (or from other OpenStreetMap tile providers) :

The QGIS OpenLayers Plugin probably offers the easiest way. In QGIS2.0 go to "Plugins" menu -> "Manage Installed Plugins...", then search for OpenLayers under 'Get More'. In older 1.x QGIS you need to enable the "Plugin Installer" from the Plugin Manager and then from "Plugins" -> "Fetch Python Plugins" and select the "Openlayers Plugin". The list of available OSM tile layers then appears from the "Plugins" -> "OpenLayers plugin" menu. (Note that this process alters the CRS (coordinate reference system) for the QGIS project, and that you may encounter issues with printing the map).

GDAL support is built in, so you can make a GDAL XML config and load this as a raster layer.

The Bigmap service makes it relatively easy to import a georeferenced image created from glued-together map tiles (for a very limited area).

See Question:How to get OpenStreetMap as a raster layer in QGIS?

Quantumnik for style authoring

Quantumnik ([1]) is a python plugin for Mapnik style authoring in QGIS. It worked with Qgis 1.8 or lower.

Styles for OSM data in QGIS

There are an increasing number of QGIS styles pre-prepared and available for Openstreetmap data - for example:

[Anita Graser's styles on Github]. For data in Spatialite format (as produced using process noted above).

[Charley Glynn's styles on Github]. For OSM data in Shapefile format.

General QGIS info

See also wikipedia:Quantum GIS.


The major features of QGIS include:

  • Direct viewing and exploration of spatial data
    • Advanced symbology (edit rendering styles)
    • QGIS Browser as a simple and fast data viewer
  • Support for numerous vector, raster, and database formats
  • Create, edit and export spatial data
    • Work with nodes, lines and polygons
    • Convert between different coordinate systems (re-projection)
    • Down/upload directly to a GPS unit
  • Perform spatial analysis
    • Find polygon centroids and basic statistics
    • Distance matrix and line intersections
  • Publish your map on the internet
  • An extensible plug-in architecture
  • Remote control JOSM [2]

Documentation & Tutorials

Rendering of Gallarate (see the 'Using OpenStreetMap data' tutorial).

The QGIS wiki provides numerous guides and video tutorials to help users of all abilities. For new users a good place to start is the Introduction to Quantum GIS video. It is also important to have a basic understanding about the #Coordinate Reference System.

Other useful pages to bookmark:

  1. The free Beginning Quantum GIS guides stored in Google Docs (produced by learnosm).
  2. How do I do that in QGIS on the QGIS wiki.
  3. Quantum GIS Tutorials by Ujaval Gandhi.

QGIS allows you to to create advanced symbology (similar to Mapnik or Osmarender) in a powerful but very easy way (a few mouse clicks), see examples here and a detailed video on youtube.

Coordinate Reference System

Earth is a three-dimensional body, roughly spherical in shape, yet the vast majority of maps are flat (2-dimesional). A Coordinate Reference System (CRS) defines a method of projecting all or part of the Earth onto a 2D surface. QGIS has support for approximately 2,700 known CRS. Some, such as WGS-84 are global projections, whereas others represent only specific regions.

Setting the CRS

When working with geo-spatial data it is essential that you are using the correct CRS. If you are lucky the projection will be specified as part of the vector file (for example, ESRI Shapefiles often include projection data in the .prj file), however you will often have to manually select the correct CRS.

To specify the CRS of a vector layer, select the layer and choice Layer->Set CRS of Layer(s).... Each layer can have a different CRS. If this is the case, you will need to convert them to the same CRS in order for them all to display correctly. The easiest way to do this is to use 'on the fly' CRS transformation:

  1. Settings->Project Properties (or click on the globe symbol in the lower right corner).
  2. Select the Coordinate Reference System (CRS) tab.
  3. Check the Enable 'on the fly' CRS transformation checkbox.
  4. Pick a suitable project CRS to work with (e.g. WGS-84).

More information can be found in this video tutorial.

Using QGIS to convert between CRS

QGIS can be used to convert between CRS. Open the input layer making sure to select the correct CRS as described above. Use Layer->Save As... to export the layer with a different CRS (you may choice between the "Project" CRS or select a CRS from QGIS's extensive list).

See also

External links