JOSM/Plugins/Imagery-XML-Bounds

From OpenStreetMap Wiki
< JOSM‎ | Plugins
Jump to: navigation, search
Available languages — JOSM/Plugins/Imagery-XML-Bounds
Afrikaans Alemannisch aragonés asturianu azərbaycanca Bahasa Indonesia Bahasa Melayu Bân-lâm-gú Basa Jawa Baso Minangkabau bosanski brezhoneg català čeština dansk Deutsch eesti English español Esperanto estremeñu euskara français Frysk Gaeilge Gàidhlig galego Hausa hrvatski Igbo interlingua Interlingue isiXhosa isiZulu íslenska italiano Kiswahili Kreyòl ayisyen kréyòl gwadloupéyen kurdî latviešu Lëtzebuergesch lietuvių magyar Malagasy Malti Nederlands Nedersaksies norsk norsk nynorsk occitan Oromoo oʻzbekcha/ўзбекча Plattdüütsch polski português română shqip slovenčina slovenščina Soomaaliga suomi svenska Tiếng Việt Türkçe Vahcuengh vèneto Wolof Yorùbá Zazaki српски / srpski беларуская български қазақша македонски монгол русский тоҷикӣ українська Ελληνικά Հայերեն ქართული नेपाली मराठी हिन्दी অসমীয়া বাংলা ਪੰਜਾਬੀ ગુજરાતી ଓଡ଼ିଆ தமிழ் తెలుగు ಕನ್ನಡ മലയാളം සිංහල ไทย မြန်မာဘာသာ ລາວ ភាសាខ្មែរ ⵜⴰⵎⴰⵣⵉⵖⵜ አማርኛ 한국어 日本語 中文(简体)‎ 吴语 粵語 中文(繁體)‎ ייִדיש עברית اردو العربية پښتو سنڌي فارسی ދިވެހިބަސް

Description

The Imagery XML Bounds plugin for JOSM allows to edit boundaries used to describe Aerial imagery sources coverage that can be found on http://josm.openstreetmap.de/wiki/Maps.

These boundaries are then displayed in the Imagery Preferences dialog:

Josm imagery preferences.png

Features

  • Import XML files describing imagery entries, compliant with the XML Schema located at http://josm.openstreetmap.de/maps-1.0, to a JOSM data layer.
  • Export a data layer, or selected objects to such a XML file.
  • Edit boundaries, just by using classic JOSM edition tools.
  • Direct and syntax-colored view of corresponding XML code for a data layer or selected objects.

Installation

The plugin is available on OSM SVN and can be installed from Plugins tab in JOSM preferences:

Josm plugins preferences bounds.png

Usage

Direct view

You can view the corresponding XML code using right click menu on any layer/closed way/multipolygon relation in JOSM main dialogs:

Josm generate xml imagery bounds.png

This opens a dialog window allowing you to copy XML code:

Josm imagery bounds ouput.png

Import

Just open a file (Ctrl-O) and select a XML file using the extension *.imagery.xml:

Josm open imagery xml.png


If you want to edit http://josm.openstreetmap.de/maps, you can open it with using Ctrl-L shortcut (File -> Open Location):

Josm open imagery xml location.png


Note that the selected XML file is first validated against the XSD. However, the plugin allows you to bypass this check if you desperately need to open an invalid file (at your own risks):

Josm open imagery xml error.png

Export

Just save a layer using "Save" or "Save as" and select the same extension as for import:

Josm save imagery xml.png

Edition

To "download" and edit an existing shape from one of the Imageries/Maps you can use the Edit button in the Imagery preferences. This creates a data layer with the bounds as closed way(s), which you can edit like every other data layer in JOSM.

Bugs

If you find a bug, please open a ticket on JOSM trac by clicking in JOSM on menu Help -> Report Bug. Remember first to check you are at least using the latest stable versions of JOSM and its plugins.