Pl:Poradnik rysowania granic wsi oraz aktualizacji granic gmin

From OpenStreetMap Wiki
Jump to: navigation, search
Dostępne języki — Poradnik rysowania granic wsi oraz aktualizacji granic gmin
Afrikaans Alemannisch aragonés asturianu azərbaycanca Bahasa Indonesia Bahasa Melayu Bân-lâm-gú Basa Jawa Baso Minangkabau bosanski brezhoneg català čeština dansk Deutsch eesti English español Esperanto estremeñu euskara français Frysk Gaeilge Gàidhlig galego Hausa hrvatski Igbo interlingua Interlingue isiXhosa isiZulu íslenska italiano Kiswahili Kreyòl ayisyen kréyòl gwadloupéyen kurdî latviešu Lëtzebuergesch lietuvių magyar Malagasy Malti Nederlands Nedersaksies norsk norsk nynorsk occitan Oromoo oʻzbekcha/ўзбекча Plattdüütsch polski português română shqip slovenčina slovenščina Soomaaliga suomi svenska Tiếng Việt Türkçe Vahcuengh vèneto Wolof Yorùbá Zazaki српски / srpski беларуская български қазақша македонски монгол русский тоҷикӣ українська Ελληνικά Հայերեն ქართული नेपाली मराठी हिन्दी অসমীয়া বাংলা ਪੰਜਾਬੀ ગુજરાતી ଓଡ଼ିଆ தமிழ் తెలుగు ಕನ್ನಡ മലയാളം සිංහල ไทย မြန်မာဘာသာ ລາວ ភាសាខ្មែរ ⵜⴰⵎⴰⵣⵉⵖⵜ አማርኛ 한국어 日本語 中文(简体)‎ 吴语 粵語 中文(繁體)‎ ייִדיש עברית اردو العربية پښتو سنڌي فارسی ދިވެހިބަސް
Poradnik rysowania granic wsi oraz aktualizacji granic gmin dla edytora JOSM

Narzędzia źródłowe

Zarys granic wsi oparty jest na danych z EMUiA.

Niezbędne źródła

  • Plik nazwa_gminy.osm lub teryt:terc_gminy.osm

Plik ten otrzymujemy otwierając, jako osobną warstwę, jeden z link:

UWAGA: ze względu na wyłączenie EMUiA 1 pobieranie granic miejscowości i przysiółków nie działa.

gdzie: 1804052 - numer teryt:terc danej gminy.
Po ściągnięciu możemy zmienić jego nazwę na bardziej czytelną, np gPerlejewo.osm i umieścić w katalogu Granice wsi

Uwaga

Można też otworzyć plik bezpośrednio w JOSM, należy jednak wcześniej w ustawieniach zaawansowanych ustawić timeout na pobieranie danych w następujący sposób:

  1. Otwieramy Edycja/Ustawienia
  2. Upewniamy się, że na dole jest zaznaczony tryb ekspercki
  3. Przechodzimy do zakładki bezpośrednich ustawień (ikonka po lewej stronie na samym dole - JOSM - Preferences - Advanced icon.png
  4. W okienko wyszukiwania wpisujemy timeout
  5. Dla socket.timeout.read wpisujemy wartość 150

Po tych zmianach można po prostu wcisnąć CTRL+L lub Plik => Otwórz położenie i tam wpisywać adres URL, jako osobną warstwę.

Pomocnicze źródła

http://osmapa.pl/w/admin/
  • Wtyczki w edytorze JOSM:
    • Granice miejscowości z Geoportalu
wms:http://mapy.geoportal.gov.pl/wss/service/PZGIKINSP/guest/services/G2_EMUIA_WMS/MapServer/WMSServer?FORMAT=image/png&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=UliceL,UlicePow,MiejscowoscPkt,MiejscowosciPow,PunktyAdresowe&STYLES=&SRS={proj}&WIDTH={width}&HEIGHT={height}&BBOX={bbox}

Pokazuje miejsce umieszczenia węzła z nazwą miejscowości.
Niektóre węzły są umieszczone, błędnie, poza granicami danej miejscowości.

    • Granice miejscowości z EMUiA:
wms:http://emuia1.gugik.gov.pl:80/wmsproxy/emuia/wms?SERVICE=WMS&FORMAT=image/png&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=emuia:layer_miejscowosci_granica,emuia:layer_miejscowosci,emuia:layer_miejscowosci_labels&STYLES=&SRS={proj}&WIDTH={width}&HEIGHT={height}&BBOX={bbox}

Pokazuje nazwy obszarów miejscowości i podrzędne obszary osad lub mniejszych kolonii.

  • Wtyczka wikipedia - Pobieranie wartości Wikidata ID

Otrzymujemy w prawym dolnym rogu listę miejscowości które mają Wikidata ID.
Zaznaczamy węzeł miejscowości lub relację granicy miejscowości i klikamy na Wikidata ID dla tej miejscowości.

Uwaga: Niektóre miescowości nie mają jeszcze ID.
  • Filtry dla edytora JOSM
source=JerzyK | note="bing hires imagery" | boundary="national_park"
-boundary=* -tags:0 -place=* -source=emuia
landuse=* | leisure=nature_reserve | boundary=protected_area
  • Ustawienia zaawansowane w edytorze JOSM
Wartość dla simplify-way.max-error zmieniamy na 0.3.

Spowoduje to zmniejszenie liczby węzłów na liniach obrazujących granice.

Zarys granic

Przygotowanie

Po otwarciu JOSM

  • Menu => Otwórz, dodajemy plik, np gPerlejewo.osm, jako warstwę.
  • Ładujemy podkład Granice wsi z Geoportalu
  • Ładujemy zarys granic danej gminy z
    http://osmapa.pl/w/admin/
Prawy przycisk myszy wewnątrz obszary gminy i wybieramy j (edycja w JOSM) dla danej gminy.
  • Klikamy na edycję wybranej relacji dla danej gminy i następnie klikamy na Relacje podrzędne aby mieć obraz przebiegu wszystkich, wcześniej dodanych, granic w danej gminie.
  • Wybieramy, jako podkład, obszar danej gminy, stosując Plik => Pobierz w aktualnym widoku, lub Plik => Pobierz z Overpass API.
  • Zapytanie do Overpass API wybierające tylko granice (oraz wszystkie obiekty odnoszące sie do tych granic) i adresy w ramach danej gminy (w przykładzie - o kodzie terc 1804052):
[out:xml][timeout:300];
area["boundary"="administrative"]["admin_level"="7"]["teryt:terc"~"^1804052"]->.granica;
(
	relation(area.granica)["type"="boundary"];
);
out meta;
>>;
out meta;
<<;
out meta;
(
	node(area.granica)["addr:housenumber"];
	way(area.granica)["addr:housenumber"];
	node(area.granica)["place"];
    
);
out meta;
>>;
out meta;
rel(pivot.granica);
out meta;
>>;
out meta;
<<;
out meta;
>;
out meta;

Pozwala to na uniknięcie konfliktów wynikających ze sklejonych węzłów na obszarze nieaktywnym.

Pobrane istniejące granice w danej gminie

Rysowanie granic poszczególnych wsi

  • Aktywujemy plik danej gminy, np gPerlejewo.osm
  • Zaznaczamy linie granicy wybranej wsi
Zaznaczone linie obrazujące granice danej wsi
  • Kopiujemy zaznaczone linie (Ctrl+C) i usuwany (Delete) zaznaczone linie oraz linię powyższą która jest częścią danej granicy wsi.

Linie te nie będą już nam potrzebne podczas rysowania granic w tej sesji.

  • Aktywujemy <Warstwa danych 1> i de-aktywujemy oraz odznaczamy warstwę gPerlejewo.osm
  • Kopiujemy, Edycja => Wklejamy do położenia źródłowego (Ctrl+Alt+V), zaznaczone wcześniej odcinki linii.

Otrzymujemy:

Przeniesiona granica danej wsi
  • Więcej narzędzi => Uprość obraz (Ctrl+Shift+Y)

Usuwamy niepotrzebne węzły.

  • Dodajemy tagi do zaznaczonych linii:
boundary=administrative
source=EMUiA
  • Linię łamaną ciągłą, obrazującą granicę gminy Przecinamy (P) w miejscu połączenia z linią granicy wsi.
Łączenie węzłów
  • Łączmy oba węzły (M) lub przyciągając węzeł końcowy granicy wsi do węzła na granicy gminy, przytrzymując (Ctrl).
  • Szablony => Relacje => Granica

Otwieramy okno relacji dla granicy.

Nazwa: krótka nazwa wsi
Rodzaj granicy: administrative
Poziom administracyjny: 8 (dla wsi)

Klikamy na Nowa relacja

Mamy teraz otwarte nowe okno Utwórz nową relację na warstwie "Warstwa danych 1"
(Opcjonalne może dodać nazwę wsi z wikipedii, wikipedia=pl:Moczydły-Dubiny).

  • Dodajemy wszystkie odcinki linii obrazującej granicę danej wsi z:
Rola: outer.

oraz węzeł z nazwą wsi:

Rola: admin_centre

(Dla przysiołka, rolą będzie label)

Elementy granicy
  • Otwieramy edycję gminy do której należy dana wieś i dodajemy relację granicy danej wsi do listy członków jako subarea.
Łączenie węzłów
  • Plik => Wyślij dane

Konflikty

W dalszym ciągu konieczna jest edycja ręczna w przypadku gdy:

  • Linia tagowana jako granica jest również otagowana jako waterway (rzeka), lub innymi tagami obrazującymi obszary.

Można to poprawić przez utworzenie równoległej kopii linii (Shift+P) i przeniesienie na nią tagów nie związanych z granicą.

  • Sklejone węzły granicy z węzłem innych obszarów.

Rozdzielamy je i przesuwamy minimalnie (G).

Poprawa granic gmin

W podobny sposób można poprawić granice gmin na bazie:

  • PRG, mając, np, plik PRG-podkarpackie.osm.bz2
  • EMUiA, mając, np gPerlejewo.osm

Podobno granice gmin z PRG są bardziej aktualne.

Początek jest podobny do rysowania granic wsi.

  • Zaznaczamy warstwę z plikiem PRG-podkarpackie.osm.bz2 lub gPerlejewo.osm i aktywujemu ją.
  • Wybieramy odcinek granicy który chce poprawić.

Jeśli ta linia łamana przedstawia kilka odcinków granicy to ją Przecinamy (P) lub robimy to po przeniesieniu do Warstwa danych 1.

  • Kopiujemy zaznaczony odcinek (Ctrl+C) i usuwany (Delete) zaznaczony odcinek. - Linia ta nie będzie już nam potrzebna w tej sesji.
  • Aktywujemy Warstwa danych 1 i de-aktywujemy oraz odznaczamy warstwę gPerlejewo.osm
  • Kopiujemy, Edycja =>Wklejamy do położenia źródłowego (Ctrl+Alt+V), zaznaczony wcześniej odcinek linii.
  • Więcej narzędzi => Uprość obraz (Ctrl+Shift+Y) - usuwa niepotrzebne węzły.
  • Łączymy początek i koniec wybranego odcinka granicy i początkiem i końcem skopiowanego odcinka. (M) lub przyciągając węzeł końcowy granicy do węzła linii skopiowanej, przytrzymując (Ctrl).
  • Wybieramy oba odcinki przytrzymując Shift.
  • Wybieramy Więcej narzędzi => Zastąp geometrię (Ctrl+Shift+G)

Otwieram nam się okno Konflikty podczas łączenia linii

Wybieramy source=PRG
Wybieramy dla poszczególnych relacji Zachowaj, aby relacje ze starej granicy przeniosły się na nową.
Klikamy na Zastosuj

Stara granica znika i otrzymujemy nowy, zaktualizowany, odcinek granicy.


Zobacz też