Hu:JOSM/Basic editing

From OpenStreetMap Wiki
Jump to: navigation, search
Más nyelveken — JOSM/Basic editing
· Afrikaans · Alemannisch · aragonés · asturianu · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · Bân-lâm-gú · Basa Jawa · Baso Minangkabau · bosanski · brezhoneg · català · čeština · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · Kurdî · latviešu · Lëtzebuergesch · lietuvių · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk bokmål · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · português do Brasil · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tiếng Việt · Türkçe · Vahcuengh · vèneto · Wolof · Yorùbá · Zazaki · српски / srpski · беларуская · български · қазақша · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · मराठी · हिन्दी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 吴语 · 粵語 · 中文(繁體)‎ · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް
  Bevezetés   Egyszerű szerkesztések   Haladó szerkesztések   Bővítmények   Gyorsbillentyűk(en) ±

Ez az oldal bemutatja a térkép szerkesztésének egyszerűbb lépéseit.

Visszavonás / változtatások visszavonása

A JOSM általában nem tölt le vagy fel adatot az OpenStreetMap szerverre, kivéve amikor erre utasítod. Így bármikor a felötlés előtt úgy dönthetsz, hogy elveted a módosításaidat, például a JOSM bezárásával vagy az aktív adatréteg törlésével.

Egyes szerkesztési műveleteket is visszavonhatsz az eszköztáron Visszavonás (JOSM-Icon-undo.png) gombbal, vagy a Ctrl+Z megnyomásával. Szóval, nyugi! Ha valamit összekutyulsz, bármikor visszavonhatsz néhány lépést.

Kijelölés, Rajzolás, Törlés

A szerkesztésnek három alapvető művelete van:

Objekte auswaehlen.png - Kijelölés (S) - elemek kiválasztása, hogy megnézd vagy szerkeszd a tulajdonságait vagy arrébb rakd

Setze Knotenpunkt.png - Rajzolás (A) - új pontok rajzolása új vonalak létrehozásához vagy meglévők folytatásához, illetve egyedülálló pontok rajzolása

Loesche Knotenpunkt.png - Törlés (D) - elemek törlése

Mivel igen sokat fogsz majd kapcsolgatni a 3 mód között, érdemes megjegyezni a gyorsbillentyűket: 'S', 'A' 'D' (A telepített bővítményektől függően ez változhat, ezért a "Nyomd meg az 'A' gombot" jellegű szöveget inkább az adott funkció aktiválásra fordítom, mindenki eldöntheti, hogy ikont használ, menüt, vagy gyorsbillentyűt - ford..)

Vonal rajzolása

Új vonal elkezdésekor figyelni kell arra, hogy mi van kijelölve.

  • Szüntesd meg a kijelölést (Szerkesztés -> Kijelölés megszüntetése menü, vagy az Esc billentyű, vagy válts kijelölés módra és kattints egy üres területre).
  • Aktiváld a Pontok rajzolása eszközt.
  • Kattints egy üres területen, ott egy új pont fog rajzolódni.
  • Kattints máshol, oda vonal rajzolódik a pontból, majd kattintgass tovább amerre a vonalat vezetni szeretnéd.
  • A befejezéshez lépj vissza a kijelölés módba (vagy Esc).

Egyedülálló pont rajzolása

Egy pont rajzolásakor az előzőhöz hasonlóan kell eljárni:

  • Szüntesd meg a kijelölést.
  • Aktiváld a rajzolás eszközt.
  • Kattints duplán egy pont hozzáadásához .
  • Ha véletlenül egyszer kattintasz és vonal folyatódna, lépj át kijelölés módba (vagy Esc).

Panelek

A Panelek a program jobb oldalán helyezkednek el, ezeket bármikor igény szerint ki- és bekapcsolhatod, a program bal alsó részén látható ikonokkal:

layerlist.png propertiesdialog.png selectionlist.png relationlist.png commandstack.png userlist.png history.png conflict.png filter.png

Ezek kapcsolgató gombok, azaz, kattintásra az adott ablak előjön, majd újabb kattintásra eltűnik (próbáld ki). Magukon a paneleken is kikapcsolhatod, minimalizálhatod (1 soros lesz) őket vagy külön ablakká is leválaszthatod.

Némelyik panel nagyon fontos, némelyik kevésbé. Általában az aktuális tevékenységől függően kell őket kapcsolgatni. A Tulajdonságok/Tagságok címkéző panel az szinte mindig kelleni fog (egy címke az ikonja).

Címkék

A címkék a Tulajdonságok/Tagságok panelen láthatóak a jobb oldalon. Amikor kijelölsz egy elemet a térképen, a címkéi ebben az ablakban fognak megjelenni. A bal oldalon a címke kulcsa (key) jobb oldalon pedig az értéke (value). Lépj kijelölés módba és nézd meg néhány meglévő térképi elem címkéit. A területen amit letöltöttél bizonyára igen sok különböző címkét fellelhetsz. Némelyik címkének igen bonyolult a jelentése, míg mások, mint például a 'name' könnyen megtanulhatóak. A címkék listáját a hu:Map Features oldalon találhatod meg (érdemes megnézni, de ez egy nagyon hosszú lista, nem kell az egészet ismerni).

Egy új címke hozzáadásához, a kívánt pont vagy vonal kijelölése után, nyomd meg a "Hozzáadás" gombot a "Tulajdonságok/Tagságok" ablakon.

Egy meglévő címke szerkesztéséhez, duplán kattints a címke sorára, vagy jelöld ki és nyomd meg az "Szerkesztés" gombot.

Az egyes címkék beírásakor a JOSM felajánl bizonyos gyors kiegészítési lehetőségeket. Ezek a már letöltött térképen található, valamint a JOSM által ismert, gyakori címkék.

A kijelölésekről: amikor címkék szerkesztéséhez kijelölsz egy elemet, óvatosan, csak a megfelelő elemet jelöld ki. Általában egyszerre egy objektum címkéit fogod szerkeszteni, de a JOSM lehetőséget biztosít több kijelölt elem módosításra is. Több elem kijelöléséhez használhatod a Shift (csak hozzáadás) vagy a Ctrl (kapcsolgatás) gombokat miközben az elemre kattintasz vagy húzhatsz egy téglalapot.

Bizonyos pontokon vannak címkék, míg más pontok egyetlen célja, hogy egy vonal pontjaként szerepeljenek. Az egyedülálló pontok mindig rendelkeznek valamilyen címkékkel, míg a vonalakat alkotó pontok általában egyáltalán nem, de persze vannak kivételek. A címkével rendelkező pontokat a JOSM másképpen jeleníti meg mint a címke nélkülieket: A pont helyén a címkétől függően megjelenhet egy ikon (pl.: közlekedési lámpa), vagy ha a JOSM nem ismeri a címkét akkor egy világoskék kitöltött négyzetként rajzolja a pontot.

Vonal pontjainak a módosítása

A pontokat úgy lehet arrébb vinni, hogy kijelölöd majd (szintén kijelölés módban) arrébb húzod. Mivel általában egyszerre csak egy pontot fogsz mozgatni, ne felejtsd el törölni a kijelölést a mozgatás előtt. Ha esetleg egy egész vonalat arrébb raktál, nyomd meg a "Visszavonás" gombot (Ctrl-Z).

Ahhoz, hogy egy meglévő vonalra rajzolj rá egy pontot, lépj "Pontok rajzolása" módba, majd kattints a vonalon a kívánt helyre. A befejezéshez lépj vissza Kijelölés módba (vagy Esc), vagy innen kiindulva rajzolhatsz egy másik vonalat. Ha újabb pontot szeretnél hozzáadni ugyanahhoz a vonalhoz, mindenképpen szüntesd meg a kijelölést. Különösen figyelj, ha több vonal közelében rajzolsz egy új pontot (kereszteződő vagy párhuzamos vonalak), ugyanis nagyon könnyen összecsoportosíthatod a környező vonalakat az új pontodba! Ha ez történne, vond vissza a műveletet. Ennek elkerülésére érdemes átmenetileg annyira ránagyítani a kívánt részre, hogy a vonalak jól láthatóan elkülönüljenek.

Van még egy fontos módja a vonalra való pont rajzolásnak. A vonalakon kijelölés módban apró keresztek láthatóak. Kattints erre, majd húzd az egeret a kívánt helyre, így a kijelölés módban is rajzolhatsz új pontot. (Vonal alakjának a finomításához hasznos - ford.)

Egy pont törléséhez, jelöld ki a pontot, majd nyomd meg a Del gombot. Így kijelölés módban is törölhetsz tetszőleges objektumokat. Ha sok dolgot szeretnél törölni, lépj át a Törlés módba ez törli a kijelölt objektumokat és utána kattintásokkal továbbiakat is törölhetsz.

Vonalak szétvágása és egyesítése

splitway.png Egy hosszabb vonalat, szükség esetén, kisebb vonalakra vághatsz szét. Jelöld ki a pontot, ahol el szeretnéd vágni a vonalat, majd válaszd a Eszközök -> Vonal kettévágása menüpontot. A lépéseket ismételd annyiszor, ahány darabra szét szeretnéd vágni a vonalat. Az egyes szakaszokon az eredeti vonal összes címkéje szerepelni fog, de így most már az egyes részekhez egyedi tulajdonságokat is hozzáadhatsz. (A szakaszok eltérő tulajdonságai miatt, egy utca általában sok kisebb vonalra van szétvágva - ford.).

Bizonyos vágásokhoz pontosabban megadott kijelölésre van szükség. Például amikor a vágási ponton több vonal halad át, akkor a ponton kívül az elvágandó vonalat is ki kell jelölni, mielőtt a vonal kettévágását választod. A kijelöléshez a Shift vagy a Ctrl nyomva tartásával tudsz további elemeket hozzáadni (Ctrl-lal elvenni is). Ha két pontot jelölsz ki a vonalon, akkor a JOSM két helyen fogja elvágni. Ez kötelező is, amikor egy önmagába záródó vonalat vágsz ketté.

combineway.png A szétvágás ellentéte a vonalak egyesítése. Ez a művelet csak olyan vonalakra végezhető el, amelyek közös pontban találkoznak. Jelöld ki mindkét vonalat, majd válaszd ki a Eszközök -> Vonalak egyesítésemenüpontot. Ekkor a JOSM a két vonalból egy vonalat fog készíteni. Az új vonal mindkét eredeti vonal címkéit tartalmazni fogja. Ha bizonyos címkék különböző értékűek voltak, a JOSM a konfliktus feloldására fog kérni. Fontos: a címkék mindig egy vonal teljes hosszára érvényesek. Ha különböző tulajdonságokra van szükség, a külön vonalakat meg kell tartani. (Időnként nem annyira szembeötlő eltérés is lehet 2 vonalszakasz között, ezért nagyon körültekintően kell egyesíteni. Az egyik vonal lehet például egy busz útvonal darabaja, vagy lehet a kettő közötti ponton egy kanyarodási korlátozás! De persze akkor sem szabad egyesíteni, ha egy címke (pl. maxspeed=30) csak az egyik részre vonatkozik. - ford.)

wayflip.png A vonal irányának megfordítása is lehetséges, Eszközök -> Vonalak megfordítása menüpont. Minden vonalnak van iránya, amit nyilak jeleznek amikor a vonal ki van jelölve. A vonal iránya fontos lehet, ha például egyesíteni szeretnénk két vonalakat, bár szükség esetén a JOSM magától megfordítja valamelyiket, ha jóváhagyjuk. Legtöbbször a vonalak irányának nincs jelentősége, de van néhány speciális eset amikor igen:

  • Egyirányú utcák (oneway=yes)
  • Folyókat a folyásirányba kell rajzolni
  • Partvonalak esetén a szárazföldnek kell a vonal irányába nézve balra, a víznek jobbra lennie (natural=coastline)

Az egyes vonalak szerkesztése több különböző műveletsorban is elvégezhető. Ez először bonyolultnak tűnhet, de kis gyakorlással hamar megtanulható. Használd a Ctrl-Z-t a visszavonáshoz, kísérletezz!

Adatok feltöltése

Ne felejtsd el, hogy a változtatásaidat bármikor visszavonhatod (lásd fentebb). De mit tegyél ha elégedett vagy a munkáddal? Ideje felölteni az OpenStreetMap szerverre!

Egyszerűen kattints a felöltés ikonra JOSM-Icon Daten upload.jpg vagy válaszd a Fájl -> Adatok feltöltése menüpontot.

A JOSM feltöltési ablakban meg kell adnod egy rövid leírást arról, hogy mit szerkesztettél. Ez a szöveg megjelenik majd a szerkesztések listáján, illetve az átszerkesztett objektumok történetében, ha valaki valamiért kíváncsi a változtatásokra. Ne csak azt add meg, hogy mit, hanem azt is, hogy miért szerkesztetted át. De ne foglalkozz sokat a kérdéssel, egy igen tömör összefoglaló is elegendő.

Amikor először töltesz fel, a JOSM kérni fogja az OpenStreetMap.org weblapra érvényes felhasználónevedet és jelszavadat (lásd Regisztráció). A megadott adatokat el is mentheted, hogy legközelebb ne kelljen megadni.

Az OpenStreetMapre való feltöltéssel elfogadod, hogy az adataidat az OpenSteetMap Licenc alatt kezeljék. Kérjük, csak olyan adatokat küldj be, amire jogosult vagy (ne másolj máshonnan!). Innentől az beküldött adatok az OpenStreetMap szabadon elérhető és felhasználható adatbázisában vannak! Bizonyos időt vesz igénybe, amíg a szerkesztések megjelennek a weblapon látható térképen. Ez általában néhány perc, de van, hogy sokkal több (lásd Slippy map(en)). Amíg erre vársz, nyugodtan rajzolj tovább! Javasolt a szerkesztéseidet sűrűn feltölteni. (Félóránként, óránként vagy ahogy összekapcsolódó részeket befejezel - A ford.)

Amikor valaki más is ugyanazon a területen szerkeszt, megesik, hogy ütközés történik. Ha már több órája feltöltés nélkül szerkesztesz és mások is rajzolnak azon a környéken (pl. térképező parti alkalmával), akkor feltöltés előtt érdemes frissíteni a már letöltött adatokat és ellenőrizni, hogy milyen változtatások történtek. Ha valaki olyan objektumot szerkesztett, amit te is, akkor a JOSM ütközést (conflict) fog jelezni és lehetőséget ad a feloldására (lásd Hu:JOSM/Advanced editing#Resolving conflicts).



Következő >>

Most, hogy már az alapvető szerkesztési művelteket megismerted, érdekelhet néhány haladó szerkesztési fogás.