From OpenStreetMap Wiki
Jump to navigation Jump to search


Don't hesitate to tell me how to fix these if you eventually know the answer.

Nothing is displayed

I've tried on FF on linux, FF on windows, IE on windows and they all exhibit the same behavior. Same description as what a user further down the page had. I checked Firefox's error log and found these errors:

Error: OpenLayers.Layer.OSM is undefined
Source File:
Line: 309


Error: centerPx is null
Source File:
Line: 553


Error: bounds is null
Source File:
Line: 588


Error: OpenLayers.Layer.OSM is undefined
Source File:
Line: 56


Error: maxExtent is null
Source File:
Line: 577

Onlynone 21:08, 1 September 2009 (UTC)

Fixed - No routing is displayed, and 'Calculating route...' does not disappear

AppEngine only allows about max. 10 seconds CPU time per request. Thus long routing which requires a lot of downloads from tile data server will time out. I haven't find out how to catch this 'DeadlineExceededError' exception successfully, so I cannot inform the user about this. Repeat the same routing again to fill the cache, and it will show up eventually. --Indomapper 10:37, 5 August 2008 (UTC)

I figured out how to correctly catch the DeadlineExceededError. Now if the data download and route calculation takes longer than 9 seconds, it will show a straight line with error information. --Indomapper 10:46, 8 August 2008 (UTC)

Permalink does not work

at least in Firefox/Ubuntu. It always redirect to the original location and zoom. --Nosolomusic 11:27, 5 August 2008 (UTC)

Routing points are not shown on higher zooms

If you zoom in to 17 or 18 and set route points they are not shown till you zoom out. --Nosolomusic 11:27, 5 August 2008 (UTC)

Route length is overestimated

I tried this on a short straight road: the route length according to your application is 0.624km while JOSM reports it as 0.5106km. --Zorko 11:59, 5 August 2008 (UTC)

I added the beginning point and end point to the calculated route. This could be the reason for the extra length. The other reason could be that somebody modified the route since June 2008 (OJW's tile data server was last updated that month). Or that OpenLayers calculated the distance in a different way than JOSM.--Indomapper 12:33, 5 August 2008 (UTC)
That was just an example, but I tried several routes that I normally drive and distance seems to be always overestimated about 20-30%.--Zorko 16:30, 5 August 2008 (UTC)

Fixed - Can't see anything

Nothing happened when I went to the link. Just got a white screen with "OpenStreetRouting" at the top-left, a search box below, and credits links in the bottom-left. Nothing was any different after searching for a placename. Internet Explorer issue? Richard B 11:12, 6 August 2008 (UTC)

Yes it is. Thanks for reporting this. The search box should work anyway, only the map is not visible. I'm fixing this. --Indomapper 12:38, 6 August 2008 (UTC)
It's fixed now. There was one more problem with IE's xml parser. But json helped avoid it. --Indomapper 10:24, 7 August 2008 (UTC)

Fixed - Search box only accepts one word

Entering more than one word returns nothing. --Indomapper 12:43, 6 August 2008 (UTC)

It's fixed now. The query data is now urlencoded before passing to geonames. --Indomapper 09:21, 13 August 2008 (UTC)


It's possible that my mouse click wasn't exactly on target, but it was certainly within the intersection as it appeared on the map. Should find the nearest node (or nearest point on a way) to the point that was clicked and snap to it. Random832 17:08, 19 September 2008 (UTC)


Appears that Tag:highway=living street is not supported at all (well, it's not routing along them around here -- ratarsed 13:07, 24 December 2008 (UTC)

Actually, it might just be out of sync with the main database, as it does route along some, albeit on a fractionally different path. It is also ignoring the access=no for vehicle routing on Ravenswood Way in that vicinity -- also seems to go the wrong way on some oneway=yes ways, too -- ratarsed 19:22, 24 December 2008 (UTC)


Add a list of supported areas, works in UK but not in Calgary, Canada... --Mungewell 23:51, 5 August 2008 (UTC)

I thought it should work for the whole planet, at least in OJW's_tile_data_server, it mentioned planet coverage. But I tried it myself, Quebec City (Canada), Dallas (USA), New York (USA) are not covered. But Moscow (Russia), Buenos Aires (Argentina), Mumbai(India), Singapur(Singapore) work flawless. Anyone know the reason (Tiger data import?)? --Indomapper 09:35, 6 August 2008 (UTC)

It would be nice if you provide a button to clear the last route/point --Finger-digital 21:26, 23 August 2008 (UTC)


Nice app :)

--Nosolomusic 11:27, 5 August 2008 (UTC)