From OpenStreetMap Wiki
Jump to navigation Jump to search

Custom osm.xml?

Thanks for the detailed setup instructions - this finally encouraged me to set up my own rendering chain. However, I do miss the source of the osm.xml file you used to draw the lines on top of the map - is that available anywhere? Thanks a lot --Stanton 15:42, 9 January 2011 (UTC)

Hi! It's still under development and being changed every week. Please write an email to the address mentioned on (scroll down). --Marqqs 22:44, 9 January 2011 (UTC)

I'd like to offer a transport overlay for printable maps on my MapOsMatic instance, but stumbled over the missing style file, too. Is it available anywhere now, e.g. on github or elsewhere?Hholzgra (talk) 15:57, 5 November 2016 (UTC)

Hi Hholzgra, the file might not be very useful for you because it's still based on Mapnik syntax version 1. I've been planning to upgrade Mapnik for a long time but never came around for it. If you have experience in this and want to help, please let me know. :-) The old openptmap style file is no secret at all. I can send it to you via email, and you can make it public if you like. --Marqqs (talk) 15:19, 9 November 2016 (UTC)

osmfilter not working as presented

Hi, I tried to create my own renderer, and got in some problems. The osmfilter is not accepting stream from standard input so all the zcat stuff is not good.

The cli also changd the "-k" don't exist, i suppose it's --keep

Also i don't understand why you do: zcat lim.gz r.osm.gz r.osm.gz r.osm.gz a.osm.gz lim.gz a.osm.gz

In the end my tiles don't get generated so i'm still digging :)



Hi Ciprian, I'm sorry, the porgram name has changed recently. The osmfilter you're referring to is now called osmfilter version 0. Please take this version 0 if you need to read from standard input. The more advanced version osmfilter cannot read from standard input but it does not need to be fed with several copies of the input file.
presently I'm testing the new osmfilter for, the installation page will be updated soon. If you like you can take the newer program version as well, but you need to supply the input data as a file, and you must change the parameter from -k to --keep= and from -d to --drop=. I also would recommend .o5m as input format because it's much faster (see Daily update an OSM XML file). --Marqqs 15:49, 26 June 2011 (BST)
Done. --Marqqs 16:35, 28 June 2011 (BST)

Bb format without intarray

I get this error at the import to pgsql part

 The target database has the intarray contrib module loaded.
 While required for earlier versions of osm2pgsql, intarray 
 is now unnecessary and will interfere with osm2pgsql's array
 handling. Please use a database without intarray.
 Error occurred, cleaning up"

I'm on Ubuntu 11.04.

Hi! I had the same problem today. Frederik and Jon helped me fix it (thanks!). Please drop the database and create it anew without the Intarray. This patch should work for you:
sudo -u postgres -i -H
dropdb ptgis  ### here the old database is dropped
createdb -E UTF8 -O ptuser ptgis
createlang plpgsql ptgis
# for Ubuntu <=9.10:
  # psql -d ptgis -f /usr/share/postgresql/8.3/contrib/_int.sql ### (do not execute this line)
  psql -d ptgis -f /usr/share/postgresql-8.3-postgis/lwpostgis.sql
# for Ubuntu >=10.04:
  #psql -d ptgis -f /usr/share/postgresql/8.4/contrib/_int.sql ### (do not execute this line)
  psql -d ptgis -f /usr/share/postgresql/8.4/contrib/postgis.sql
psql ptgis -c "ALTER TABLE geometry_columns OWNER TO ptuser"
psql ptgis -c "ALTER TABLE spatial_ref_sys OWNER TO ptuser"

# for Ubuntu <=9.10:
  sudo /etc/init.d/postgresql-8.3 reload
# for Ubuntu >=10.04:
  sudo /etc/init.d/postgresql-8.4 reload

psql ptgis ptuser -f osm2pgsql/900913.sql

I will change the Wiki page accordingly. --Marqqs 18:58, 8 August 2011 (BST)


Do you have a reason not to use the latest version 0.7.0?

At the time I wrote this, 0.7.0 was not available. If you have tested 0.7.0, please feel free to change the Wiki page accordingly. Thanks! --Marqqs 19:56, 9 August 2011 (BST)

Overlay not transparent

The generated tiles are non-transparent, so you can't get them put over a map. I suppose a parameter to make them trasparent is needed somewhere. Do you know where?

Thanks (edit sig :)) --Ciprian 21:10, 12 August 2011 (BST)

Hi Ciprian, please sign your comments with --~~~~ (see Wikipedia:Signatures for further details), this makes Wiki discussions a bit easier. :-) Thank you very much for your recent bugfixes at the installation page! Transparent tiles can be requested via Mapnik style file osm.xml. I'm using this header:
<Map bgcolor="transparent" srs="&srs900913;" minimum_version="0.7.1">
--Marqqs 22:53, 10 August 2011 (BST)

Thanks and noted on sign --Ciprian 21:11, 12 August 2011 (BST)

Hi, something still not right, my tiles/web page still non-transparent, have a look at I regenerated the tiles (and del old ones) with the bgcolor=transparent in osm.xml. Something missing :)
Thanks for help -Ciprian 09:13, 22 August 2011 (BST)
Hi, unfortunately I have no idea why your tiles aren't transparent. I suspect that there's something wrong with the osm.xml. If you like you can send me your file (you can find my email address in's imprint – just scroll down on the map's web page). Maybe I will find the problem. If not, I will send you my osm.xml so you will be able to cross-check the issue. --Marqqs 22:21, 22 August 2011 (BST)
Just leave out the bgcolor=... and rendering of the coastline-shapefiles
<Map srs="&srs900913;" minimum_version="0.7.1" buffer_size="128">
--ajoessen 09:09, 21 October 2011 (BST)