Import/Catalogue/US/BingBuildings

From OpenStreetMap Wiki
Jump to navigation Jump to search

The caution box has been removed. This wiki page is very usable at this point. It will be improved as time goes on. You are welcome to improve upon the pages ideas. There are some sections that are still very rough.

About

Import/Catalogue/US/BingBuildings is a project of the US OSM Chapter. Bing posted building foot prints for many of the states in the US. The

  • Proposal to import the building foot prints into OSM.
  • Proposal will require dividing the data and using local communities to import and evaluate the data.

Goals


Import Data

Background

The data to be imported comes from a donation by Microsoft/Bing. The donation was a great gift by Microsoft/Bing but there will be additional work required with each of the files that are imported into the OSM database.

Data source site The source data can be found on the github page.

License

Under the terms of use and license all datasets are ODBL compliant: "This data is licensed by Microsoft under the Open Data Commons Open Database License (ODbL)".

Data license: ODbl

Link to permission: | LICENCE-DATA

ODbL Compliance verified: Yes

Data quality

The data quality is good as far as generating square building outlines and close to approximate foundation outlines. However, each file imported will require post processing during the import.

OSM Data Files

  • The ODbl licensed source geojson data files are located at github page.
  • The files need to be processed before they can be used.
  • The data will require post processing during the import process.

Import Type

This Bing building outline import is a hybrid import and not like these imports.

The three large city imports all came from curated city or county departments that kept track of lidar or CAD data files to build the outline. The Bing outlines are computer generated via big data systems. Hence, the Bing building outline import will be a hybrid import. It is a great gift that Bing has provided us access to their computer generated building outlines. The outlines will need assistance in some cases to complete the work or adjust the outlines for issues that tripped up the proper outline completion. Please don't volunteer for this project if all you want to do is shove the data into the OSM database. This is not the import for you then.

Also note, if you know of a planning and building department that has curated building outlines sourced from lidar or CAD data files, then you would be better off using that data as a source of an import. You would still need to go through the import guidelines for each data set. The Bing building outlines would be useful if you could not find a planning and building department data for your area or the department's license is not compatible with the OSM license.

At this point in time, all the US community knows from Bing/Microsoft is that the building outlines are a one time import. It is not know if there will be future outlines provided or if additional updates to the current data set will be provided when the big data system is improved or imagery is updated.

Data Preparation

The data from Bing was provided by US state boundaries in geoJSON format. The plan is to parse the data with a combination of groovy scripts and Postgresql sql scripts. A method to create smaller sections will be determined. The division of data will also assist with the import process. The data preparation will help avoid collisions with existing OSM geometries but the import process will still require careful merge steps. Zoom level 16 meta tiles may be a method to assist with the preparation.

Data Reduction & Simplification

Data preparation will not require any simplification such as remove overly noded ways. Bing has already reduced the data to just the points required for a square building. The mapper performing the import process will need to evaluate if more nodes are required to expand the outline or leave the outline as Bing created it.

Conversion and translation

Bing provides the node coordinates in EPSG:4326. EPSG:4326 is the same coordinate system that OSM uses. No additional conversion or data translations will be required.

Sample imports will be used to determine what additional steps are required of mappers during the actual import. There are two study areas that were used for this purpose. One is near the Scottsdale Arizona airport. The airport area was craft mapped by hand. There were two other mappers that contributed residential outlines west of the airport. One mapper added only rectangles. The other mapper added more precise details for each building outline. This study area between Scottsdale Road and Tatum Boulevard was used to prefect the two layer merge method, using geometry replacement function commands, and to get a general feel for the data.

The second study area is for a small town near the US Mexico border. The city is called San Luis Arizona with a postal code of 85349. Small towns in the US tend to be under represented on the map. There are many factors that may contribute to this issue such as high speed internet or general knowledge about OSM. As such there was not much in the area except major retail buildings, schools, and the Tiger imported roads. Various mappers have worked to clean up the Tiger imported roads but there was not much activity beyond the road fixup process. A listing of the 78 files for the 85349 Zipcode was developed. This list was added to a text editor to track the progress. Essentially, the list acted like a top to bottom scan of the area. A status column with three values was added at the beginning of the file. Y,Yes complete, N,No complete, and P,Processing file were used. A sample of some of the data has been provided.

  • Y bing_13_1483_3312_16_11870_26502.osm
  • Y bing_13_1483_3312_16_11871_26499.osm
  • Y bing_13_1483_3312_16_11871_26500.osm
  • Y bing_13_1483_3312_16_11871_26503.osm
  • Y bing_13_1483_3313_16_11869_26504.osm
  • Y bing_13_1483_3313_16_11869_26506.osm
  • Y bing_13_1483_3313_16_11869_26507.osm
  • Y bing_13_1483_3313_16_11870_26504.osm
  • Y bing_13_1483_3313_16_11870_26505.osm
  • Y bing_13_1483_3313_16_11870_26506.osm
  • Y bing_13_1483_3313_16_11870_26507.osm
  • Y bing_13_1483_3313_16_11870_26508.osm
  • Y bing_13_1483_3313_16_11871_26504.osm
  • Y bing_13_1483_3313_16_11871_26505.osm
  • Y bing_13_1483_3313_16_11871_26506.osm
  • Y bing_13_1483_3313_16_11871_26507.osm
  • Y bing_13_1483_3313_16_11871_26508.osm
  • P bing_13_1484_3312_16_11872_26499.osm
  • N bing_13_1484_3312_16_11872_26500.osm
  • N bing_13_1484_3312_16_11878_26501.osm
  • N bing_13_1484_3312_16_11878_26502.osm
  • N bing_13_1484_3312_16_11879_26501.osm
  • N bing_13_1484_3312_16_11879_26502.osm
  • ...
  • N bing_13_1486_3313_16_11890_26509.osm

Here are a list of the beginning and the end of the import list as of 4/30/2019.

Note that additional not import edits were performed. These changesets added landuse, performed additional Tiger fixup, and provided some OSM polish to the area.

Tagging Plans

All that Bing provides with the ODbl data outline consists of points in geoJson polygons. These files provide structure but no tagging. Here is the initial proposal of tags to be added:
building=yes
If the building type can be determined, then change the "yes" to

  • residential
  • commercial
  • retail
  • industrial
  • or one of the many other building values.

These four values will provide a good start for most of the USA. Commercial is more of an office or storage location. Retail is where you would buy an item. Industrial is more of a place that manufactures items or produces a product.

addr:postcode=XXXXX postal code for the area
addr:state=XX state code
addr:country=US

Optionally the mapper assigned to a task can add city based on the Zipcode data of each building outline. In addition, once the building in next to a street, the mapper has the option of adding the street name to the building.

addr:street=spelled out street name
addr:city=city name based on Zipcode

The Census Zipcode Tabulation areas will be good enough to add the postal Zipcode. If there is a problem with the census then it will be the mapper that will need to optionally add the city and zip at import time.

Determining the addr:city=city name based on Zipcode may be challenging for smaller jurisdictions. In large jurisdictions, one city name is associated with the Zipcode. There are instances where this is not true for political reasons. In smaller jurisdictions such as Parker Arizona, Zipcode 85344, several Arizona city names apply: Poston, Parker Strip, Parker, Bluewater, Cienega Springs, Swansea, and Planet.

Changeset Tags

There are two areas that you can communicate with other mappers. In the "Provide a brief comment for the changes you are uploading:" simply take the file name of the Bing outlines as the comment. For example, "bing_13_1483_3313_16_11871_26508.osm" would provide the comment.

The second are that you can communicate with other mappers is the "Specify the data source for the changes:" add both the imagery layer that you used such as "Bing" a semicolon, ;, and the phrase "Bing Building Outlines".

Preamble To Processing

  • The Bing Building outline process is a JOSM only operation. Other online OSM editors cannot be used.
  • You will need another OSM account apart from your regular OSM.
  • The special dedicated OSM account will have the word import in the name. Use the style that you feel comfortable with just as long as the word import is in the account name.
  • It is suggested that the new import account should reference you regular OSM account page should anyone have questions about your processing of a particular change set.
  • It is suggested that the new import account should also reference this import page so that other mappers understand what you are importing. Go to the settings page of your OSM account to add something as simple as this link.

https://wiki.openstreetmap.org/wiki/Import/Catalogue/US/BingBuildings

JOSM Features

JOSM Keyboard Shortcuts Cheat Sheet A3 300 DPI Printable version

These are the the main feature of Josm that will be used during the processing of Bing building outlines. Badita Florin's keyboard cheat sheet will help you remember some of the uses. There is also a shortcuts page on the Josm wiki that may help.

  • X key for reshaping a square building.
  • Q key for orthogonalize a shape. The Bing building outlines start out as square but reshaping the outline may cause issued that the Q key will solve.
  • ctrl+Z key sequence for undoing a change. For example you see that an outline has gone out of square. Use the undo key several times then use the Q Key to fix the problem. Now you can go back to shaping the building with the X key.
  • crtl+shift key sequence while a building is selected will allow you to rotate the shape. This is great for any skewed buildings that you may find.
  • alt+shift key sequence while a building is selected will allow you to scale the shape. This is great for any buildings that are just short of completely covering a building in the imagery.
  • B key for buildings. The B key is enabled by installing the building tools plugin. Select an existing Bing building outline then start drawing a missing outline. The angle of the existing building will help you draw the new building.
  • The utilsplugin2 will greatly assist your editing. Here are several key sequences that will assist your editing.
    • ctrl+shift+G for merging two shapes. The merge tool is provided by the utils plugin.
    • alt+X will let you split a building outline. Grab two nodes and select the alt+X sequence.
    • shift+E to select a way. Lasso nodes and ways then use the shift+E command to select the ways. This is just one way to add the street names to the new building outlines.
  • Lasso mode. Turn on the expert mode check box on the preference page to enable Lasso mode.
  • Remote control. While you are on the preference page also visit the remote control icon. This will allow you to load data from the main OSM map.
  • The continuous download plugin may be a useful way to download additional data in the OSM layer.
  • The download along a way plugin is an alternate way to download additional data in the OSM layer. This plugin requires additional effort but provides more control over the download process.

Data Merge Workflow

The approach to this assisted import is to use two layers in JOSM. One layer will be for the existing OSM data. The second, layer will be load in from the Bing file of choice. The workflow has been broken down into five phases. Most of the focus of the procedure is located in the Merge Phase.

It is also suggested that you use the Pomodora Techinque as a way to manage how much time you put into an area. A simple timer or browser plugin can be used for 25 minutes of work and a five minute break. Please see the wiki page for the full description of the Pomodora Techinque. The goal here is to keep from over working yourself.

Setup Phase

  1. This is a JOSM only import. iD, Potlatch, and other web based editors cannot be used.
  2. Checkout out a task square. You can locate a square of interest by this long/lat converter http://oms.wff.ch/calc.htm.
  3. Use the "Open Editor" button to download existing OSM data for your task square
  4. Click the "Load data for import" link which will create a new layer in JOSM for you.
  5. Use the most recent available imagery for the area the xxx todo procedure provides a method for selecting the most useful imagery layer can be found in the Look For New Look For New Building Construction Procedure.

Merge Phase

You will want to stay in this phase for as long as possible. The two layer provide you a method of working on the Bing Buildings will not touching the current OSM data. If you run out of time and cannot finalize and upload your data, then you can always perform a file save operation. That way you can come back to the area when you have more time. The important idea of this phase is to take the pressure off of you and make adjusting the Bing outlines as a pleasurable relaxing pastime.

  1. Visually compare the two layers before merging.
  2. Use the "Merge Layer" option - ctl-m - merge the data for import to the OSM Data layer
  3. Run JOSM validation on the OSM Data Layer

Finalization Phase

Any building outlines saved for replacing geometries in the Look For Which Is Better Procedure of the xx phase can now be processed in this phase. You have the old and new geometry in one layer.

  1. Fix the obvious issues - Use replace geometry command to combine duplicated features.
  2. Carefully fine tune all the new buildings and fix any errors JOSM does not catch, like building outlines that cover multiple buildings.

Upload Phase

  1. Run the JOSM validation tool one last time and look for any other issues. You may have to take some of JOSM's validations suggestions with a grain of salt. The main issue you will may have to ignore is irregular non-square building. However, you will be able to make that judgement call base on the validation section of the Merge Phase.

Data Files

State Code Data Files Location Notes
AZ Arizona Bing Outline .osm files ...
...

Procedures

The Merge Workflow provides an overview of the import/merge workflow. This Procedures section provides individual steps to think about during the merge process. There are a mixture of images and JOSM commands or steps.

Visually Compare

todo: stiking this image here for now

Draw a boundary of the area.

Here is an important suggestion for the process. After opening the file and with no imagery selected draw a boundary around the building outlines. Make sure that the boundary has no tags. The lack of tags will help you remember to delete the boundary during the last validation before upload. This boundary will help you focus on just the the geometries selected. This is especially important when you merge the two layers.

Here are some visual items to compare between layers and issues to look for in the Bing Building Footprints.


todo

Need the select a file and select an area. Need to generate the files. Need to generate the webpage for these areas. Need to generate todo need review procedures before Merge layers.

Look For New Building Construction Procedure

todo Need OSM Url

The Bing buildings may have been generated over a very active construction zone. Moreover, the imagery Bing used to generate the building outlines may not have been as up to date as a mapper would like. What you need to do in this procedure is determine if the Bing building outline is old and needs to be discarded or if the Bing outline captured an area that is stable. One of the ways to understand the imagery is by looking for construction.

August 5, 2016 front of building corner shot

July 9, 2016 back of building

July 26, 2017 elevator shafts started front of building

Ocotober 15, 2017 front of building exit hole created

Feburary 25, 2019 front of building exited hole covered

Feburary 25, 2019 front of building corner shot

Before 2017.

caption todo

Mapbox Satelite Crisper

caption todo

Esri World Imagery(Clarity) Beta

caption todo

Esri World Imagery Crisper

caption todo

DigitialGlobe Premium Imagery Crisper over zoomable

Around July 2017 foundation not poured yet The site was cleared.

caption todo

USGS Large Scale Imagery

Around July 2017

caption todo

DigitialGlobe Standard Imagery

Capture 2/1/2018 to 3/30/2018

caption todo

Bing aerial imagery

Delete the outline

The solution for this Bing outline is to delete the Bing way. The Mapillary imagery shows that the building is largely complete.

todo Need OSM Url

caption todo

Here is another example to consider. Bing outlines show four buildings and two car port roofs. The question if you don't know the area is which image and thus outlines are correct.

caption todo

In this case, Pure Midtown is a new building that replaced four discrete one level apartment buildings. The image shows how the mapper approximated the new building outline. The updated Bing imagery allows the outline to be more precisely drawn. Another way to confirm this decision is to see if there are fresh street imagery in the area.

You would think that you could just select one imagery source and be done with it. However, you need to exercise good judgement with each area.

The Bing refresh T

The screen shot of Bing is from December 25, 2018. The lighter areas have been refreshed by Bing. At this time the two buildings discussed above were not in the refresh list yet. Approximations of the building outlines had to be created. This T looking shape is slowly being removed.

bing

caption todo

Digitial standard

caption todo

OpenStreetCam, Mapillary, or GPS traces

caption todo

todo

  • setup a session file
  • Look for note
  • Look for demolision of existing buildings.
  • Look at various imagery layers.
  • Look at both old and new OpenStreetCam, Mapillary, or Bing Side Street photos.
  • Look at GPS sequences.

Look For Phantom Building Procedure

One problem to deal with is the age of the aerials and now the age of the Bing buildings. Both are still useful but here is something to look for and that is the phantom building.

A phantom building

The Phoenix metro area received an update to the Bing imagery recently. As this image shows there is a phantom building drawn where a parking lot is now. You can see that the parking lot has been nicely resurface and freshly striped.

Digital Globe shows foundations

If you look closely at the older Digital Globe image, you can make out the foundations that have been somewhat covered with asphalt. It looks like the Bing building process made an outline that would have been an over shoot where multiple building were created as one building.

You have used multiple image sources to check on this building. Hit the delete key to remove it in the Bing source OSM file.

Note if you have several imagery sources open in JOSM, then you can use the ~, tilda, key to switch between each imagery source. You must use JOSM stable version 13996 from 2018-07-01 or higher to use the Switch imagery layer feature and have two or more imagery sources open.

Improve Existing Building Geometry Procedure

caption todo

caption todo

caption todo

caption todo

caption todo


Execute the Validation Procedure

caption todo

Improve Existing Building Geometry Procedure

caption todo

caption todo

caption todo

caption todo

caption todo

caption todo

caption todo

caption todo

Look For Scale Issues Procedure

caption todo

One of the problems with the Bing building footprint process is that it appears like imagery trips up completing a footprint. It almost looks like they captured the footprint but not too scale. First use the Q key or menu>Tools>Orthogonalize Shape tool to make sure that the building is square. Now use the X key or the drafting right angle triangle icon on left side button bar. The bubble caption says "Create areas (X)". The X key will allow you to drag each segment to the proper location or to properly set the scale in this example.

Look For Over Shoot Procedure

caption todo

caption todo

caption todo

caption todo

caption todo

caption todo

caption todo

caption todo

caption todo

caption todo

caption todo

caption todo

caption todo

caption todo

Look For Missing Building Procedure

todo show the dial area.

Look For Skewed Outline Procedure

  • First there have been some reported skewing of the foot prints. In the example reported by volatile_ant it is interesting that one in three foot prints in a row shows this behavior.
  • The way to fix this issue is to
  1. Click on the building
  2. Hold shift and ctrl keys together. Shift-Ctrl enables the rotation feature of JOSM.
  3. Drag the building left or right to align the footprint with the building.

Bb skewed footprints.png

caption todo

caption todo

caption todo

caption todo

Look For Skewed Outline Procedure

caption todo

caption todo

Look For Which Is Better Procedure

caption todo

caption todo

caption todo

caption todo

caption todo

caption todo

caption todo

caption todo

caption todo

Merge Data Layers Procedure

All review of the Bing building layer should be complete before starting this procedure. The Merge Layers Procedure starts by expanding and clicking into the "Layers" dialog box.

Select two layers

Click and shift+Click the existing OSM data and the new Bing building layer that you have reviewed. Right click in the "Layers" dialog box to bring up the context sensitive menu. Slide down and click on the "Merge" menu command.

Select the existing OSM data

Select the existing OSM data layer that you downloaded. This is the target layer that you are selecting as shown in the "Select target layer" dialog box.

Prepare to merge

After the target layer has been selected you are ready to press the "Merge" button. A progress bar will be displayed as the two layers are merged.

Update data

After the merge completes use the Menu>File>Update data command. This is especially important in an actively mapped area. You will need to resolve any conflicts if the another mapper has updated an existing building while you were performing your checks.

Validation After Merge Procedure

todo Use the Menu>Windows>Validation Results command right after you merge the two layers in the Merge Layers Procedure.

caption todo


caption todo

Once the "Validation Results" dialog box displays, click on the "Validation" button. The main purpose of this step is to catch any overlapping buildings that you may have missed. Look at the "Overlapping Areas" section of the "Validation Results" dialog box. Select the new Bing building, [id:0], and delete it.

Bing Building Merge Node Procedure

The Bing Building Merge Node Procedure is started right after both the Validation After Merge Procedure. One of the problems that this assisted import seeks to avoid is overlaying or deleting existing mappers work. This assisted import desires to build on the existing work.

Two Bing buildings and two existing surveyed address nodes.

Here we see two Bing buildings and two existing surveyed address nodes.

position node

Make sure that you have squared up the building already and made any adjustments. Next position the existing address node over one of the new building nodes. Use a Menu>Edit>Tools>Join Node To Way or use the J key shortcut. Follow this operation with a Menu>Edit>Tools>Merge Nodes or use the M key shortcut. You can use use the keyboard to hit the J and the M keys in quick succession to perform the same operation. Now click on the node.

Copy all Keys and Values

Click in the "Tags and Memberships" dialog box. After your mouse cursor is in the box, then right click in any part of the tag box to bring up the context sensitive menu. Slide the mouse cursor down to the "Copy all Keys/Values" and click. This will copy all the key value pairs into the clip board feature of your operating system.

Paste Tags

Click on the new Bing building. Select Menu>Edit>Paste Tags or Ctrl+Shift+V to paste the copied key value pairs from the nodes.

Delete node tags

The tags have been copied to the new Bing building. Click back in the "Tags and Memberships" dialog box. Use the Ctrl+A key squence to select all the key value pairs. You can also click and shift+click to select the key value pairs. There are two options that can be used to delete the tags on the node now that they are selected. One, use the right click context menu and select the "Delete" menu option. Two, press the "Delete" button that is located in the "Tags and Memberships" dialog box. Three, hit the delete key on the key board. Pick the style that feels best for you.

Bing Building Merge Node With Shift+R Command Procedure

The "Copy tags from previous selection" command, Menu>More Tools>Copy tags from previous selection, can speed up the process if you are prefer the keyboard over the mouse. The description of the procedure is in the Bing Building Merge Node Procedure.

position node

Position the node over a new Bing Building node.

Use the J and M keys

Your mouse focus is still on the node. Select the target building.

Use the shift+R key to Copy the tags to the building from the node.

Click on the node again.

Delete node tags

The tags have been copied to the new Bing building. Click back in the "Tags and Memberships" dialog box. Use the Ctrl+A key squence to select all the key value pairs. Hit the delete key on the key board. Pick the style that feels best for you.

Bing Building Merge Node Via Todo Plugin Procedure

Todo Plugin Step one You may have many address nodes to merge into the new Bing building. Click on an address node. Pick a tag that all the nodes have in common. In this case the addr:city tag row has been selected. Right click in "Tags and Memberships" dialog box. Select the "Search Key/Value/Type" menu option. Todo Plugin Step two After Josm selects all the nodes matching the search criteria, select the Todo list dialog box. Click on the "Add" button to establish the todo list. After that you will have a list of address nodes with the first node row selected. Click on the "Zoom" button. This will locate the node in the map data for you. Now you can perform the existing node to new Bing Building Merge Node Procedure or the Bing Building Merge Node With Shift+R Command Procedure. After you have processed the node, click on the "Mark" button. If the search feature selected a node that does not have a new Bing building, then press either the "Pass" button or the "Mark" button. The "Pass" button allows the node row to stay in the todo list, if you want to check the node again after all other nodes have been processed. The "Mark" button removes the node row and moves to the next row in the todo list.

Improve Existing Building Geometry After Merge Procedure

There are some buildings what have been drawn in as a square or rectangle. The square captures the location but the geometry can be improved with this procedure. During your review look for these areas. You will want to decide if the Bing geometry is better than the craft mapped geometry.

  • Note that you need one geometry to have an actual existing OSM way id and the Bing outline to be a new object id for this procedure to work. You cannot use the procedure if both objects have new ids.

Replace Geometry with overlapping ways

Here is an example of a square outline and an improved Bing outline.

Select both ways

Use Menu>More Tools>Replace Geometry command. The keyboard sequece is Ctrl+shift+G.

Completed modification to existing outline

Here you see the improved outline. You may see a dialog box asking you to select one tag over another if the two buildings have different tags. Note that the history has been preserved with the process.

Caption todo

Here is another example where the existing geometry can be improved.

Caption todo

Actually this whole area was mapped by duplicating rectangles over approximate locations of the building outline. An improved procedure can be used when there are many geometries to improve.

Lasso at lease two nodes for the improving the geometry procedure.

Use the lasso tool to surround two nodes.

Two nodes selected for the improving the geometry procedure.

The two nodes have been selected.

Two ways selected via the Adjacent ways tool for the improving the geometry procedure.

Use the shift+e tool, menu>Selection>Adjacent ways, to select the existing way with an existing way id, and the new Bing geometry without an id. The id will be zero. The Adjacent ways tool will deselect the nodes in the process of selecting the desired ways.

Switch to the Replace Geometry command for the improving the geometry procedure.

Let go of the e key while still holding on to the shift key. Next add the ctrl key and the g key. The shift+ctrl+g keys activate the Replace Geometry command, menu>More Tools>Replace Geometry. The switching of keys from shift+e to shift+ctrl+g speeds up the process.

Finish the new geometry with the x key for the improving the geometry procedure.

Finally the geometry is improved by using the x key, Create Areas or button bar>triangle icon.

The new tiles are rendering after the improving the geometry procedure.

The result of the procedure is that the rectangle building outlines are replaced with improved outlines via the combination of Bing and additional shaping of the geometry. The image shows the outlines on the left and the original rectangles on the right. The tile server is in mid process of rendering the data.

Final Checks Before Upload Procedures

Validation Before Upload Procedure

What to look for during final validation.

Here are some issue that may surface during the final validation. Errors should be fixed.

  • Duplicate nodes: What happened in this case may have been the result of two things. The first is that the Bing building outlines use many digits after the decimal point. The OSM database only stores seven digits. The rounding process may create duplicate looking nodes to JOSM because the id had not been established in the changeset and the two nodes appear on each other. The second explanation is that the building was not square or using the x tool at a higher zoom level move one node over the other without combining the two nodes. This should be fixed.
  • Crossing buildings: What happened in this case was the the building was not square. This cause a section of the building to overlap the other while using the x key. You should pay attention to this warning and correct it.
  • Building with an almost square angle: In this case the other warning is just the noisy Josm validation process making a false positive. You will still want to review these kinds of warnings. The building in question had a slanted edge. There was nothing to fix.
  • Select Change set comment

Information

These are a list of items from the mailing list.

  • The we have many solar panels in Arizona because of a state mandate. Many of these are used as covered parking. The tag of yes would have to change to roof. That can happen during the import or as a second QA pass.
  • The Q in JOSM will be required for some of the black topped roofs or solar panels.
  • It is curios that some of the black roof or darker colored roofs are missed. When I craft map, sometimes I get interrupted, sometimes I get bored and I never get back to the missing buildings. Oh well! Either another mapper comes along and picks up the missing work or sits for awhile. That is what I mean by the data is no better nor no worse than a normal volunteer's work flow.
  • All the round buildings are square. That may be the result of CNTK making sure that buildings are square. The work around is to add a few more nodes and hit the O key in Josm
  • I noticed one or two buildings where they included a concrete slab as part of the building. The X tool in JOSM will be used to scale back that part of the building. Again, I've had to clean up these kinds of issues with other craft mappers including myself. Buildings that I mapped from the prior version of Bing or Yahoo, are clearer with the last Bing imagery release in my area.
  • The imagery in this area of the test.osm file is satellite based. It is not of the same high quality .5 meter and below I get to use in the metro Phoenix area. Moreover, the metro Phoenix are is flown imagery so most of it is very high nadir. MS states that they have a number of sources of imagery providers. The buildings still look respectable.
  • There was one school that I was puzzled why it came out the way it did. This is a non issue because there is an existing building. The Bing building will be deleted.

Team

  • Numerous US mappers or other mappers in the world that may be interested in contributing to this effort.