Proposal talk:Service business

From OpenStreetMap Wiki
Jump to navigation Jump to search

Discuss Proposed features/Service business here:

Shop tag

This is completely unnecessary in my point of view. A hairdresser is just as well a shop, as a food store. For mapping/routing/etc this doesn't make any sense at all. What do you have against shop=* tags? --spaetz 19:59, 23 June 2007 (BST)

I proposed this for two main reasons - first, to minimize overcrowding the shop namespace and second, so that a default icon can be used for values that don't have their own icon (would you rather mechanics show up with a shopping cart icon?). --Cohort 07:00, 27 June 2007 (BST)

Would we use the shop tag for the elevator technician? example shop=elevator. Logictheo 13:52, 9 June 2009 (UTC)

I would think this would be "shop=elevator_service". --Ceyockey 14:08, 5 June 2010 (UTC)


May I suggest that shop= is for both retail products and services and that this proposal be abandoned? It makes tagging and searching much easier to have everything in one place. MikeCollinson 21:10, 9 November 2007 (UTC)

Yes and someone's done some work on the shop=car description. That now includes additional tags for repair services. -- Harry Wood 18:26, 3 May 2009 (UTC)

Since Key:service is already in use for highway=service you should select an other name for your proposal to prevent collusion! Better names are Key:services_trade, Key:tertiary_industry, Key:service_sector and Key:service_industry! --Phobie 16:34, 6 September 2008 (UTC)

subclassed values

Shouldn't we subclass the values? I.e. service_industry=repair:vehicle, service_industry=rental:video or service_industry=care:hair User:Phobie 16:50, 6 September 2008

I agree with Phobie for subclasses. Wagner51 13:56, 11 October 2008 (UTC)
Subclasses sounds like the best way of doing this. I can think of service_industry=car_wash:automatic, service_industry=car_wash:hand, service_industry=car_wash:interior, service_industry=rental:car, service_industry=rental:bicycle, service_industry=rental:ski. One question is how to differentiate between Key:amenity and Key:service_industry. --Erik Lundin 15:52, 17 January 2009 (UTC)

Should a vote be taken?

Should a vote be taken on whether to set aside this proposal in favor of using shop=*? --Ceyockey 14:10, 5 June 2010 (UTC)