Talk:Virtual Tiles@Home - Ubuntu

From OpenStreetMap Wiki
Jump to navigation Jump to search

Discussion about vt@h

Virtual Tiles@Home Version 10.04 was published 2.5.2010.

I don't think, that I will release Version 12.04 (at the end of april 2012). I use now BOINC, but tiles@home will not support it. tah is not interested, because the @home aspect is not any more needed. It's nearly faster to calc on their server, than to make a package and offer it to download for tah. Please feel free to use the Source and do-it-your-self. --Pjw1965 17:30, 3 September 2011 (BST)

After a view on the download statistics of my homepage I decided to use the rainy weather to clean up there. I will remove the download links to my homepage since the current version is also hosted at Hetzner. If anybody really needs the old OSM64.7z just send me a message. --Leviticus 15:36, 08 October 2010 (UTC)

Source Code

list of wishes for upcoming releases

  • please install the guest additions (in the guest) to get the time sync feature of VBox. (virtual system clock is running out of sync) and is needed for shared folders too -wambacher-
    • guest additions need a graphical display like gnome or kde, this is a server-like installation, just commandline, no windows overhead. --Pjw1965 13:44, 23 June 2010 (UTC)
    • at the first runtime, ask for the keyboard (qwerty or azerty), we make mistake with the login/password. I'm confused for my poor english ...--Didier2020 02:53, 20 August 2010 (BST)

* please change the date/timestamp in tiles.log to a more "stable" format. e.g. 23:00:01 instead of 23:0:1 (allways two digits for MM,DD,HH,MM,SS) to keep the log aligned. not related to VIRTUAL T@H -wambacher-

changelog Version 10.04

  • based on Ubuntu 10.04 LTS server optimized for virtual machine
  • using now a partition whith 4 GB, no swap added
  • default swapfile 2048MB automatically createt on first boot
  • autostart using upstart
  • "sudo osm stop" waits up to 1 hour
  • "sudo osm stop-now" aborts after 10 seconds
  • MaxTilesetComplexity=5000000 removed (default is again 0)
  • directory of osm is in /home/openstreetmap/tilesAtHome
  • don't update/reinstall programs after publishing to public, security updates will still install automatically
  • http-proxy question
  • crontab not any more used
  • password entry not any more visible on typing

Bugs and Comments for Version 10.04 (2.5.2010)

  • proxy settings work only for subversion access
  • access to via proxy does not work
  • tried to set proxy in /etc/environment => no success
    • I did not get any feedback for proxy during the beta test, sorry if it's not working, any help is welcome --Pjw1965 17:34, 4 June 2010 (UTC)
  • added file to my webspace for faster downloads without ads (sha1sum checked) --Leviticus 10:43, 10 May 2010 (UTC)
  • Error @first boot: Gave up waiting for root device. --Jimmy K 12:06, 25 May 2010 (UTC)
  • Similar to Jimmy K's post, but my VM doesn't boot at all. Error: Gave up waiting for root device ... ALERT! /dev/disk/by-uuid/87b5...976b does not exist. Oracle VirtualBox V3.2.0 r61806 --Spoony 29 May 2010
    • Use SCSI-Controller for VB >3.1, but remove your openstreetmap.vdi first (unzip your download again) or you will get IO-Errors --Pjw1965 17:34, 4 June 2010 (UTC)
      • Deutsch: Massenspeicher, Rechts-Click auf SATA-Controller: Controller entfernen, Rechts-Click: SCSI-Controller hinzufügen, + klicken (=openstretmap.vdi hinzufügen)
        • Zusätzlich musste ich in den SCSI-Controller-Eigenschaften noch den Haken "Host I/O-Cache verwenden" setzen (standardmäßig nicht gesetzt). Jetzt läuft die virtuelle Maschine. --Spoony 19. Juli 2010
          • ich hatte das gleiche Problem, der Workaround hat aber geholfen. Wenn es nicht allzu zeitig im Image gefixt werden kann, sollte der Workaround in die Doku auf die Hauptseite eingebaut werden denke ich --23:53, 12 August 2010 (BST)
      • English: Storage, right-click on SATA-Controller: remove controller, right-click Add SCSI Controller, click on + (add openstreetamp.vdi)
        • In addition to that, in the properties of the SCSI controller I had to check "Use host I/O cache" which is unchecked by default. Now the virtual machine is running. --Spoony 19 July 2010
    • have 2 systems, one amd64 running fine without any changes and one Intel PIII with that problems. Changed to scsi -> running fine too :)
    • same bug here on an Apple Macbook 4,1 with Core2Duo runnig the lastest VBox in 64bit, but solving was easy with your tips, maybe the mainpage should include the hint... DooMMasteR 13:25, 14 July 2010 (UTC)
    • Switching to scsi works4me. Thanks. Klisanor 16:25, 15 November 2010 (UTC)


9.04 (29.4.2009)

Please describe what happens and what you expect and sign the message.

--Pjw1965 14:33, 29 April 2009 (UTC)

everything is running smooth, 1.2 GB RAM for the VM all other settings on default. nice job, thanks. --Leviticus 09:30, 30 April 2009 (UTC)

This version has only a 2 GB filesystem with a swapfile in. Is the inkscape with -DLARGE_CONFIG compiled? --Bibi 14:51, 5 May 2009 (UTC)

I have build a version of VT@h based on Ubuntu 9.04 Server for AMD64. This version is approximately 20 to 30 percent faster than the 32bit version, it depends on the tileset. Requirements: A 64bit-CPU that supports virtualization techniques (AMD-V or Intel VT-x), a 64bit OS like WindowsXP x64 or Vista x64 and the 64bit version of VirtualBox. Enable in VirtualBox the checkboxes PAE/NX and VT-x/AMD-V. Download the 7-zipped file at Rapidshare. --Otti38 05:57, 6 May 2009 (UTC)

  • tested this version on Windows 7 Build 7100 x64 and VirtualBox 2.2.4: runs nice and smooth. --Leviticus 16:02, 06 June 2009 (UTC)

The vT@H seems not to use Chinese and Janpanese charsets. In the tiles my client created those characters are missing. (I'm still using the last 9.04beta, but did not notice anything had changed in this aspect.)--Nhoffm 07:24, 19 May 2009 (UTC)

  • That's new for me. The Install-Guide does not really help for ubuntu. You could try aptitude install xfonts-intl-chinese xfonts-intl-japanese and write here, if it helps. --Pjw1965 16:02, 19 May 2009 (UTC)
    • Seems to make no difference.--Nhoffm 11:04, 4 June 2009 (UTC)
  • This is great! Setting up the software always scared me off, this ran in minutes! Should have known this a long time ago, always wanted to help OSM this way as well! One question: is it possible to add a command like "Finish current job(s), don't accept new ones in this session and halt after completion"? Thanks! HvW 27 May 2009
  • Modify /etc/init.d/tiles-gen-client (Exit joe with Ctrl-K,X) and then shutdown with HOST-H --Pjw1965 14:41, 28 May 2009 (UTC)
$ sudo joe /etc/init.d/tiles-gen-client
# timeout to wait for the client to finish on shutdown (20 minutes)
  • Thanks, I'll do so. HvW 29 May 2009
  • Hi, first impression so far: I converted the 64bit vdi image to a qemu image and it works fine under debian64 5.03 kernel 2.6.26-2
some initial problems were:
  • less HD space which caused the app to stop (see [1])
  • it worried me a little that the email was shown, but as I read this can be changed afterwards (todo), --Erkan Yilmaz 19:25, 13 September 2009 (UTC)

I added some diskspace for swap, so the image-file now uses 4 GiB on your harddisc. Download the new VDI at Rapidshare. --Otti38 16:58, 6 November 2009 (UTC)

How can I set a proxy for the internet connection? Might have missed this, but need it... --Quini 11:10, 14 December 2009 (UTC)

  • Wait for 10.04 or be a tester for it (see changelog on the top)

9.04 beta

works smooth, great work :-), perhaps a question during install: want to use your own login? (y/N) --Leviticus 11:55, 23 April 2009 (UTC)

very good work, but i'm missing the stop-later command? will you also publish the root password? --HMichael 15:30, 26 April 2009 (UTC)

  • Actually it's a kind of stop-later. I just added a timeout of 120 seconds (I don't like to wait for a shutdown longer and I don't think it's a proble for the server if the last upload is missing). You can higher the timeout in the file /etc/init.d/tiles-gen-client to TIMEOUT=1200 like it is in Tiles@home/Install_Guide#Init_script.
  • There is no root password (in ubuntu). However you can become root with sudo su (as user openstreetmap). And if you like you can then set a root password with passwd. --Pjw1965 17:01, 26 April 2009 (UTC)

Perhaps you could change tilesAtHome.conf to use: MaxTilesetComplexity (about 5000000 seems to be a possible start-value for assigned memory of about 512MB) and "AutoResetInkscapePrefs=1" --Nhoffm 07:32, 27 April 2009 (UTC)

  • AutoResetInkscapePrefs=1 sounds logical, I'll change this --Pjw1965 11:25, 28 April 2009 (UTC)
  • MaxTilesetComplexity is complex. I investigate this, but as everyone can change virtual memory and swap size, I don't thik it's a good idea to fix this (0 means autotuning, see --Pjw1965 11:25, 28 April 2009 (UTC)
    • Are you shure with your interpretation of MaxTilesetComplexity? Observing my clients suggest: 0 = no limit, > 1000000 = startvalue for autotuning.--Nhoffm 20:56, 28 April 2009 (UTC)
      • No, probably you're right. I'll give it a try in the release : MaxTilesetComplexity=5000000 --Pjw1965 14:36, 29 April 2009 (UTC)
  • ext4 Filesystem
    • Isn't it a bit early to change to ext4? Shouldn't have advantages to ext3 at such a small system, but stability might suffer.--Nhoffm 21:01, 28 April 2009 (UTC)
      • ext4 is the future. It's a chance to test in a virtual machine, which is not critical. If it sucks, I'll change it back. My server/desktop (ubuntu 9.04) will stay ext3 some time. --Pjw1965 09:35, 29 April 2009 (UTC)
      • as I was writing this, I used sudo osm compact. The ext4 sucks really! mpage_da_map_blocks block allocation failed for inode 57 at locical offset 363487 with max blocks 733 with error -28... This should not happen.!! Data will be lost --> I'll release it with ext3 --Pjw1965 09:40, 29 April 2009 (UTC)

Version 4 (2008-12-24)

Version 4 (2008-12-24) is ready for download via BitTorrent is based on Ubuntu/JeOS --Pjw1965 08:20, 24 December 2008 (UTC)

  • Mininova reports “The torrent you requested (id 2117143) does not exist in our database.” Ash 14:30, 24 December 2008 (UTC)
  • I'm seeding this version with 10 MBit upstream. If you tell me about new releases I'll seed those as well. I can provide http download as well if you want that --Gerryst 21:07, 27 December 2008 (UTC)
    • Thanks for fast seeding, for me it's easy to submit just a new torrent, I do not need a http download, but if someone needs one feel free to add the link in the wiki page --Pjw1965 12:49, 1 January 2009 (UTC)
  • It says "Note that current version is missing perl-module", but when I try to install it the way it says on the page, I'm told that it is already installed. Have this been fixed in the install, but not on the wiki page? --Anders Lund 13:57, 30 December 2008 (UTC)
    • liberror-perl libipc-run-perl libclass-accessor-perl libmodule-pluggable-perl are new dependencies, they are missing in the script (in V@H), but should already be installed on the V@H. The Wiki-Script install-openstreetmap is up to date. --Pjw1965 15:17, 30 December 2008 (UTC)
    • I've just now realized, what you said... I updated the wiki page (removed the message about the error). Thanks. --Pjw1965 21:26, 8 January 2009 (UTC)
  • Hi! I'm running the ubuntu vm image on a mac. At the point where i'm asked to enter my OSM username (shoud be the email address, right?) i can't enter the "@" character. I have a german keyboard, but it seems to use the US layout. So instead of pressing ALT-L I hit shift-2. But this just erases the first part of the line. Any ideas? --TheBo 08:00, 1 January 2009 (UTC)
    • Try Shift-2 for "@", or change keyboard layout: dpkg-reconfigure console-setup
  • Does anyone have any statistics as to how much upload/download bandwidth this uses per hour/day? Ash 17:47, 2 January 2009 (UTC)
    • No statistics, but a gut feeling from previous version: It does not use much bandwidth--Japa-fi 17:31, 3 January 2009 (UTC)
      • Actually looking at work from yesterday. It uses more bandwidth than I assumed. In the hour I looked at, system uploaded some 6-7 megabytes. It does depend on the complexity of the created tile and the rendering speed of your computer. Some uploaded tiles were 200kb, some were 2megabytes. --Japa-fi 07:36, 14 January 2009 (UTC)
  • Is there a reason for one to upgrade from version 3 to version 4?--Japa-fi 17:31, 3 January 2009 (UTC)
    • swap disk included, smaller (faster?) system using JeOS; optimized for virtual machines; but bigger filessize, as long as the shrink command in VB 2.1 is not working; just for fun upgrading (but remember: never change a running system ;-) ) --Pjw1965 21:22, 8 January 2009 (UTC)
      • Ok. Thanks for clarifying. I'm with limited diskspace (laptop) and can't really afford to dedicate 2.5Gb so I rather stay with the version 3. I was worried if version 3 becomes obsolete in a way that it cannot be used to contribute. Clearly that is not the case. --Japa-fi 11:31, 13 January 2009 (UTC)
  • Can't unrar the file. Ark, unrar and 7zip report errors when trying. I have downloaded the rar file twice (from EU and US), and the SHA is okay. Any suggestions why? System: Kubuntu Intrepid 64 on Intel. --Krza 17:26, 8 January 2009 (UTC)
    • rar 1:3.8b2-2 in the multiverse works (use: rar e *.rar), unrar 1:3.8.2-1 in multiverse also (use: unrar e *.rar). I got errors only if there is no space left on device. System Ubuntu/Inteprid 32 on Intel. --Pjw1965 21:08, 8 January 2009 (UTC)
      • Thanks for the tip. Iĺl look for this version at next opportunity. But actually I do not need it any longer because I succeeded to install the normal perl based environment in 3 minutes based on the instruction somewhere here in the Wiki - and it runs now and generates tiles :) --Krza 21:57, 8 January 2009 (UTC)
  • How can i clone the VirtuaBox? Answer: VBoxManage clonevdi <filename.vdi> <outputfile.vdi>

With this you can run two VirtualBoxes on one PC. --M0nty 21:09, 30 April 2009 (UTC)

Version 3 (2008-08-08)

3rd version 2008-08-08, uses Rapperswil client (use link on top) --Pjw1965 14:40, 12 August 2008 (UTC)

  • This version runs fine here at the moment. See no problems so far. I will report problems here if I find some. --ise 19:02, 15 August 2008 (UTC)
  • Works great for me also, no problems so far Cipt2001 17:42, 28 August 2008 (UTC)
  • Works for me too. One remark: I had to change the port numbers to 80 for 'GoNogoURL' and 'UploadURL' in 'general.conf' because I cannot connect to port 81 behind my firewall. Works but I'm not sure whether this should be corrected some other way --miwie 12:27, 17 September 2008 (UTC)
  • Today a new version of t@h has been released which need some more perl modules (missing You must execute apt-get install liberror-perl libipc-run-perl libclass-accessor-perl libmodule-pluggable-perl to get those modules.--Schrom 23:24, 11 October 2008 (UTC)
  • Got out of memory error while rendering with 256Mb assigned to the VM. Perhaps 256Mb is not enough... --Japa-fi 13:02, 27 October 2008 (UTC)
    • RenderStripes = 5 is the key: (cd /var/tmp/tilesAtHome/ && cp tilesAtHome.conf.linux tilesAtHome.conf && echo "RenderStripes = 5" >> tilesAtHome.conf) --Pjw1965 17:04, 27 October 2008 (UTC)
  • Getting errors with rendering.

"Could not run the following command: pngcrush -q /tmp/tile [...] please check your installation" "Could not run the following command: pngnq -e .png.cut [...] please check our installation" etc. --Japa-fi 19:34, 30 October 2008 (UTC)

Version 2 (7.7.2008)

  • new version based on ubuntu server uses less HD space and uses updated scripts (use link on top) --Pjw1965 15:46, 7 July 2008 (UTC)
    • Thanks, Pjw! Works fine for me (VirtualBox 1.6.2, host Ubuntu 8.04-desktop) --Marko2 07:12, 8 July 2008 (UTC)
    • it also works with the new TAH-server, I only had to change username & password in "/var/tmp/tilesAtHome/authentication.conf" to the OSM account
    • I changed the keyboard layout with "dpkg-reconfigure console-setup". Seams to work.
    • I have tried an "apt-get update" and saw some updates available.Is it a good idea to run an update?
      • I do it from time to time (login in Console 2 with Alt-F2 as user:root pw:root #aptitude update; aptitude dist-upgrade) --Pjw1965 18:27, 4 August 2008 (UTC)
    • By the way: Have you used the ubuntu JeOS version (shall be optimized for virtualisation) --Marko2 20:22, 15 July 2008 (UTC)
      • It's based on ubuntu server. If I have time, I'll give it a try. Or even better you could try. --Pjw1965 18:27, 4 August 2008 (UTC)
  • If I use Ctrl-H to stop, then the current rendering is not finished and uploaded to the server. Can we make use of the stopfile.txt mechanism? --Marko2 22:47, 15 July 2008 (UTC)
    • I don't like to wait up to 30 minutes after a command halt, but you just have to modify the script tiles-gen-client ( replace "stop)" by "stop-now)" and replace "stop-later)" by "stop)" )
  • Being new to Linux (well not really but back after few years of Windows), I dont remember how to stop the screensaver on bash, any idea ? Shaihulud 22:46, 19 July 2008 (UTC)
    • try "setterm -blank 0", you also could add that to the script. --Marko2 18:43, 20 July 2008 (UTC)
      • works fine thanks !
  • I have a message while rendering is running: ColorQuantizing title*.png with pngnq failed, pngnq not installed? Is this a problem, how can i fix this? --gerrit 25 July 2008
    • Same pb, even after apt-get install pngnq. According tilesathome mailing list, there's a bug with pngnq delivered with Debian (then with Ubuntu). I suppose we have to wait for an Ubuntu update. Shaihulud
    • According to this, you can install a newer version (compile) or what I did: wget; dpkg -i pngnq_0.5-3_i386.deb; --Pjw1965 15:46, 8 August 2008 (UTC)
  • The script doesnt seem to clean the job after use (got virtual disk full after around 300 runs) Shaihulud 14:11, 26 July 2008 (UTC)
    • Change DeleteZipFilesAfterUpload=1 in tilesAtHome.conf (shutdown and restart the virtual machine should also delete all the files) --Pjw1965 18:27, 4 August 2008 (UTC)

Version 1 (29.6.2008)

  • I am getting "Error reading request from Server. Idle for xx:xx". Running the script "locally" works fine at the moment, so I guess the problem is in the VDI. HannesHH 10:12, 30 June 2008 (UTC)
  • This is a network problem. I installed dhcp3-client (aptitude install dhcp3-client) and added 'dhclient' on top of the script /etc/init.d/tiles-gen-client:
 # tilesGen@home client software init script.
 # feel free to change the script.
 # (c) 2008 pjw
 # import lsb functions for init.d scripts
 . /lib/lsb/init-functions
 # Netzwerkproblem (workaround): aptitude install dhcp3-client

This should help. Could you confirm this. -- Pjw1965 05:24, 2 July 2008 (UTC)

  • confirmed, works fine now, HannesHH 10:05, 2 July 2008 (UTC)
  • it also works fine for me, how can I stop the status messages (i.e. if I want to use the terminal) --marko2 20:07, 4 July 2008 (UTC)
  • Switch to terminal 2 (Alt-F2) and log in --Pjw1965 17:13, 6 July 2008 (UTC)
  • Thanks, Pjw! The VDI works great (the original one with the dhclient patch, the ...20080702 uses HannesHH as user). I cloned it and have now 4 clients running on the same dualcore machine (most of the time 2 or 3 are waiting because of "Upload queue nearly full" --Marko2 20:36, 6 July 2008 (UTC)
    • oooops, looks like I screwed up there. I took the file down and gotta change my login. D'oh. HannesHH 06:58, 7 July 2008 (UTC)

Removed broken download link

FYI I deleted the top download link since it was a 404 - file was no longer there. Thanks - apapadop 16:55, 15 April 2011 (BST)