Fi:JOSM-opas/Peruskäyttö

From OpenStreetMap Wiki
Jump to: navigation, search
Saatavilla kielillä — JOSM/Basic editing
· Afrikaans · Alemannisch · aragonés · asturianu · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · Bân-lâm-gú · Basa Jawa · Baso Minangkabau · bosanski · brezhoneg · català · čeština · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · Kurdî · latviešu · Lëtzebuergesch · lietuvių · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk bokmål · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · português do Brasil · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tiếng Việt · Türkçe · Vahcuengh · vèneto · Wolof · Yorùbá · Zazaki · српски / srpski · беларуская · български · қазақша · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · मराठी · हिन्दी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 吴语 · 粵語 · 中文(繁體)‎ · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް
  JOSM   Alku   Peruskäyttö   Relaatioiden käsittely   Muut työkalut ±

Käyttöliittymä

Useimmille JOSMin toiminnoille on myös näppäimistökomennot, joista useimmin käytettyjä on mainittu tämän oppaan tekstin seassa. Käynnistyksen jälkeen JOSM näyttää tuoreita tietoja mm. ohjelman uusista ominaisuuksista. Käytännössä tässä tilassa ollaan vain käynnistettäessä ja ainoat käytetyt toiminnot ovat tiedoston avaaminen tai suoraan kartta-aineiston lataaminen.

Ikkunan osat

Suurimman osan JOSMin käytönaikaisesta ikkunasta vie karttanäkymä, jossa kartan kohteita muokataan. Vasemmalta löytyy työkaluvalintoja ja oikealta apupaneeleita, joissa näytetään tietoja joilla ei ole esitysmuotoa itse kartalla.

Työkalut

Vasemmassa reunassa ylimpänä ovat käytettävissä olevat työkalut. Perusasennuksen jälkeen käytettävissä on seitsemän toimintoa:

  1. Objekte auswaehlen.png Valitse, siirrä ja pyöritä (Pikanäppäin S)
  2. Setze Knotenpunkt.png Lisää pisteitä (A)
  3. Create Areas.png Luo alueita (X)
  4. Zoom.png Zoomaa ja siirrä karttaa (Z)
  5. Loesche Knotenpunkt.png Poista (D)
  6. Josm mode make parallel way.png Tee poluista rinnakkaiskopiot (Shift+P)
  7. Josm mode improve way accuracy.png Tarkenna polkua (W)

Paneelit

Työkalujen alapuolelta löytyy painikkeet oikean reunan apupaneelien näyttämiseen ja piilottamiseen. Paneeleista tärkeimmät ovat

  1. Einstellungen der Objekte.png Ominaisuudet/Jäsenyydet
  2. Liste aller Ebenen.png Tasot
  3. Fenster aktueller Objekte.png Tämänhetkinen valinta
  4. Konflikte loesen.png Yhdistämisristiriidat
  5. Liste aller Relationen.png Relaatiot

Jokaisen paneelin yläreunasta löytyy painikkeet paneelin pienentämiseksi, irroittamiseksi kelluvaksi ja piilottamiseksi.

Kartta-aineiston lataaminen

Jotta pääset muokkaamaan haluamasi alueen karttadataa, joudut lataamaan palvelimelta olemassaolevat tiedot ko. alueesta. Eri tilanteita varten tähän on kolme tapaa:

FI JOSM Avaa 2016-11-23.jpg
  1. Jos sinulla on GPX-tiedosto tai -tiedostoja alueestasi, helpointa on valita Tiedosto -> Avaa (File -> Open) tai vastaava kuvake työkalupalkista ja avata tiedostosi. Tämän jälkeen JOSM näyttää tiedostoissa olevat pisteet ikkunassaan.
    • Ennen kuin jatkat, kannattaa zoomata sille aluelle jota haluat muokata, silla JOSM lataa vain ja ainoastaan polut, jotka sijaitsevat näkymän alueella. Tämä onnistuu helpoiten hiiren rullalla.
    • Sopiva koko ladattavaksi alueeksi riippuu jonkin verran aiemmin piirretyn karttatiedon määrästä: kaupunkialueilla, joista löytyy jo talot yms. voi vasemmassa yläkulmassa olevan mittakaavajanan ilmoitettu pituus olla vain 100 metriä, kun taas vielä tiettömällä metsätaipaleella sopiva mitta voi olla seitsemän kilometriäkin.
    • FiJosmLataa.jpg
      Tämän jälkeen voit ladata alueen painamalla työkalupalkin vasemmassa reunassa olevaa Lataa-nappia (Download), tai valikosta Tiedosto -> Lataa OSM:sta. Avautuvasta ikkunasta valitse "OpenStreetMap-data" ja jos haluat ladata muiden palvelimelle lähettämät GPS-pisteet, valitse myös "Raaka GPS-data" (Raw GPS data). Tämän jälkeen paina OK ladataksesi alueen koneellesi.
  2. Jos löysit karttaa webissä selailemalla jotain korjattavaa, et tarvitse gpx-tiedostoa vaan saat löytämäsi kohdan JOSMiin seuraavasti:
    • Napsauta hiiren kakkospainikkeella selaimesi karttaikkunan alakulmassa olevaa Permalink-linkkiä ja valitse "kopioi linkin osoite" (Copy link location).
    • Käynnistä JOSM
    • FI JOSM Lataa2 2016-11-23.jpg
      Valitse taas Tiedostot -> Lataa OSM:sta (tai lataa-nappi työkaluriviltä). Valitse auenneesta ikkunasta välilehti "Rajoittava alue" ja siitä iso tekstikenttä otsikolla "URL from www.openstreetmap.org". Nyt voit liittää (ctrl+v) äsken kopioimasi osoitteen. Varmista muut asetukset (OpenStreetMap-data ja Raaka GPS-data") kuten edellisessä kohdassa ja valitse OK.
    • Kun JOSM on ladannut alueen, voi olla tarpeen zoomata muutama pykälä ulospäin hiiren rullalla ja napsauttaa uudelleen Lataa-nappia. Nyt ladattavan alueen rajat ovat päivittyneet vastaamaan näkymää ja valitsemalla OK saat editoriin hieman enemmän lähiympäristöä.
  3. FI JOSM Lataa 2016-11-23.jpg
    Uusimmissa versioissa on latausikkunassa myös välilehti Slippy Map, jolla voit selata webissä näkyvää karttaa ja etsiä ladattavan alueen tarkemmin.
    • Hiiren vasemmalla napilla raahaamalla saat siirreltyä näkyvää aluetta.
    • Hiiren rullalla tai kaksoisnapautuksella saat zoomattua karttaa lähemmäs
    • Hiiren oikealla napilla raahaamalla saat valittua näkyvältä alueelta ladattavan alueen
    • Tarkista lopuksi "OpenStreetMap-data" ja "Raaka GPS-data" valinnat ja valitse OK ladataksesi valitun alueen tiedot

Kartalla navigointi

Kartalla liikkuminen onnistuu helpoiten pitämällä hiiren oikeaa nappia pohjassa kartan päällä ja liikuttamalla hiirtä. Zoomaaminen puolestaan hoituu helpoiten hiiren rullalla. Näkymää voi liikuttaa myös näppäimistöllä: ctrl + nuolinäppäimet.

Liikuttuasi voit aina ladata näkyvällä alueelle kuuluvat tiedot painamalla Download ja OK.

Kohteiden valitseminen

Voit valita kartalta polut tai pisteen valintatyökalulla Objekte auswaehlen.png, joka on vasemman reunan paletissa toinen ylhäältä. Työkalun pikanäppäin on S. Valitessasi varo vahingossa siirtämästä valittavaa kohdetta, sillä samalla työkalulla onnistuu myös siirto. Jos teet virheen, paina Muokkaa -> Kumoa (Edit->Undo tai ctrl+z), ja JOSM pelastaa päivän. Jos haluat poistaa valinnan eli palata tyhjään valintaan, klikkaa työkalulla tyhjää kohtaa kartalla.

Jos haluat valita useampia objekteja, valitse ensin yksi ja tämän jälkeen paina shift pohjaan ja valitse muut. Voit myös painaa hiiren pohjaan tyhjällä alueella ja vetää neliön, jonka sisällä olevat objektit valitaan. Ctrl-näppäimen kanssa valintanäpäytys poistaa halutun kohteen valinnan.

Hiiren keskinapilla saa esille listan sillä kohtaa olevista päällekkäisistä poluista. Keskinapin yhä ollessa pohjaan painettuna, painamalla ja pitämällä ctrl-nappia pohjassa voit valita auenneesta listasta haluamasi polun. Muutoin halutun polun valinta päällekkäisistä poluista voi olla hankalaa tai mahdotonta.

Tagien muokkaaminen

Jos haluat muuttaa polun tai pisteen ominaisuuksia (esim. lisätä/muuttaa nimen), valitse ensin kyseinen objekti. Tämän jälkeen JOSM näyttää objektiin liittyvät tagit oikean reunan Ominaisuudet-paneelissa. Voit muokata olemassa olevaa tagia kaksoisklikkaamalla kyseistä riviä. Uuden tagin voit lisätä Lisää-nappulalla.

Katso myös Esivalinnat -valikosta jos et tiedä mitä tageja käyttäisi lisäämäsi kohteen kuvailemiseksi. Useimmat esivalinnat kysyvät muutaman lisätiedon ja lisäävät ne sopivina tageina valitulle kohteelle.

Polun lisääminen

Uuden polun voit lisätä Setze Knotenpunkt.png Piirrä pisteitä -työkalulla (vasemman reunan paletissa toinen ylhäältä).

  1. Napsauta ensin polun alkupistettä.
    • Jos jokin piste oli aiemmin valittuna, JOSM lisää polun valitusta pisteestä napauttamaasi pisteeseen. Voit estää tämän painamalla ensin Esc tai U nollataksesi valinnan, tai pitämällä vaihto-näppäintä pohjassa napsauttaessasi.
  2. Napsauttele polulle uusia pisteitä, kunnes polku on mielestäsi valmis.
    1. Jos jonkin pisteen pitäisi osua jo olemassa olevalle polulle, niin klikkaa kyseistä polkua, ja JOSM lisää pisteen kummallekin polulle.
    2. Jos et halua yhdistää uutta pistettä lähellä olemassaolevaan polkuun, pidä ctrl-näppäin pohjassa napsauttaessasi.
  3. Helpoin tapa lopettaa piirto on vaihtaa takaisin valintatyökaluun.
  4. Lisää polulle oikeat tagit Tagien muokkaaminen -kohdan ohjeiden mukaan. Sopivia tageja on esim. asuinkadun tapauksessa highway=residential ja name=*

Poistaminen

Valitse objekti, jonka haluat poistaa, ja klikkaa vasemman reunan roskiksen kuvaa Loesche Knotenpunkt.png tai paina näppäintä D. Huomaa, että JOSM jää tällöin poistotilaan ja kaikki mitä klikkaat poistetaan, ellet vaihda takaisin valintatyökaluun (tai muuhun).

Jos poistat polun, niin kaikki sen pisteet, joilla ei ole erityisiä tageja ja jotka eivät kuuluu mihinkään muuhun polkuun poistetaan oletuksena. Jos poistat polussa olevan pisteen, JOSM korjaa tien automaattisesti ohittamaan tämän kohdan, eli polku ei katkea.

Muutosten lähettäminen palvelimelle

Kun olet tehnyt muutoksia, ne eivät itsekseen päivity OSM:n palvelimille, vaan ne on erikseen lähetettävä. Tämä on yleensä kaksivaiheinen operaatio:

  1. Lataa uudestaan karttatiedot koko sille alueelle, jota olet muokannut. Jos tällä välin joku muu on muuttanut samoja teitä, JOSM kertoo mahdollisista ristiriidoista ja voit valita paremman version Ristiriita -paneelista: valitse kukin ilmoiteettu ristiriita ja avaa Selvitä -painikkeella ikkuna, jossa näet rinnakkain valitun kohteen versiot: oman muokkauksesi ja palvelimelta saadun. Nuolipainikkeilla voit yhdistellä ikkunan alaosaan halutut ominaisuudet lähetettäväksi versioksi.
  2. Paina Lähetä -nappia FiJosmUpload.jpg. JOSM näyttää listat lisättävistä, muutettavista ja poistettavista karttakohteista ja pyytää muutoskokoelmalle annettavaa kommenttia. Valitse vielä Lähetä ja JOSM lähettää muutokset palvelimelle.

Muutokset olisi hyvä lähettää aina esim. 10 minuutin välein, jolloin palvelimella on tavallaan varmuuskopio tekemistäsi muutoksista, ja jos joku muu editoi samaa aluetta, ei mahdollisia ristiriitoja tule kovin paljoa, kun tajuaa että joku muukin muokkaa samaa aluetta.

Muutoskokoelmat

Karttaan tehtävät muutokset niputetaan muutoskokoelmiin (changeset). Muutoskokoelmalle annettava kommentti on lyhyt vapaamuotoinen kuvaus tehdyistä muutoksista; toistaiseksi "hyviksi" havaittuja kommentteja olisi vaikkapa: (tai samat englanniksi)

  • lisätty katujen nimiä
  • add maxspeeds
  • X-tien ja Y-tien risteyksessä alkoi tietyöt
  • puuttuvia pyöräteitä
  • korjattu virheitä (esim. puuttuvia risteyssolmuja)
  • tarkennusta ilmakuvista (huomioithan että ilmakuva voi olla sivussa tai vääristynyt)

JOSM tarjoaa oletuksena edellisen palvelimelle lähetyksen kommenttia myös seuraavalla lähetykselle.

Muutoskokelmia voi tarkastella selaamalla uusimpia tai tarkastella alueittain (suurimmillaan n. kaupungin kokoisina alueina, esim. Tampere). Myös kunkin käyttäjän tekemistä muutoskokoelmista saa listat. Muutoskokoelman tiedot -sivulla näkyy listana muutetut karttakohteet sekä muutettujen kohteiden ympärille piirretty pienin nelikulmio - siis karkeasti alue jota muutokset koskevat - joten pelkkä alueen nimeäminen kommentissa ei tuo paljoa lisäarvoa.

Tarkastaja / Validator

JOSMin Tarkastin etsii ennen lähetystä muokatuista kohteista yleisimpiä virheitä tai mahdollisesti epäilyttäviä piirtotapoja. Huomaathan, että ilmoitukset on jaettu kolmeen luokkaan: virheet, varoitukset ja huomautukset. Erityisesti viimeisen ryhmän kohdalla joudut itse harkitsemaan, onko huomautus aiheellinen. Vertaa ilmoituksia normit ja käytännöt -sivun sisältöön.

Muita yleisiä muokkauksia

Polun katkaisu

Jakaaksesi polun kahteen osaan, valitse piste, jonka kohdalta haluat katkaista ja valitse Työkalut -> Katkaise polku (Tools->Split Way) (P). Jos saman pisteen kautta menee useampi tie, on myös kyseinen tie valittava. Voit myös valita useamman pisteen, jolloin tie katkaistaan kaikkien pisteiden kohdilta jos pisteet ovat saman polun varrella.

Ympyräpolun katkaisemiseksi joudut valitsemaan vähintään kaksi pistettä samalta polulta.

Polkujen yhdistäminen

Voit yhdistää monta polkua yhdeksi valitsemalla kaikki polut ja tämän jälkeen painamalla Työkalut -> Yhdistä polkuja (Tools->Combine Way. Yhdistettävillä poluilla täytyy olla yhteinen päätepiste jotta yhdistäminen onnistuisi. Voit käyttää myös pikanäppäintä C.

Tarkista ennen yhdistämistä että kaikkien yhdistettävien polkujen kaikki tagit sopivat yhdistettyyn polkuun. Jos jokin arvo ei sovi, et voi yhdistää kyseisiä polkuja (esimerkiksi tien numero ref=*, nopeusrajoitus tai kaistojen määrä vaihtuu). Jos jollain tagilla on eri arvoja eri poluilla yhdistettävässä joukossa, JOSM edellyttää sinun valitsevan niistä yhdistetylle polulle tulevan arvon.

Pisteiden yhdistäminen

Mikäli haluat yhdistää kaksi tai useampaa pistettä (esimerkiksi risteyksessä tiet ovat kiinni eri pisteissä vaikka todellisuudessa pitäisi olla kaikkien samassa), valitse pisteet ja tämän jälkeen Tools->Merge Nodes. Voit käyttää myös pikanäppäintä M.

Pisteen yhdistäminen toiseen polkuun

Lähellä toista polkua olevan pisteen voi lisätä lähimpiin polkuihin entisten pisteiden väliin valitsemalla pisteen ja sitten Työkalut -> Yhdistä piste polkuun. Tässä tapauksessa läheisyyden arvioinnissa huomioidaan zoomauksen mittakaava, joten voit mittakaavaa muuttamalla vaikuttaa mihin polkuihin piste yhdistetään.

Kohteiden pyörittäminen

Jos valittu kohde on kartalla vinossa, voit pyörittää sitä pitämällä ctrl + vaihto -näppäimiä pohjassa ja raahaamalla.

Linjalle pakottaminen

Suorat linjat halutaan kartalle suorina ja valitsemalla Työkalut -> kohdista pisteet samalle linjalle (pikanäppäin L) saat siirrettyä valitun polun kaikki pisteet tai kaikki valitut pisteet ääripäiden välillä kulkevalle linjalle.

Ympyräksi pakottaminen

Teitä voi olla tarpeen pakottaa ympyräksi käsivaraista piirtämistä tarkemmin, esim. kiertoliittymissä. Valitse tulevan ympyrän pisteet tai polku ja sitten Työkalut -> Siirrä pisteet ympyrän kehälle (pikanäppäin O). Toiminto siirtää pisteet tasamatkan päähän alkuperäisten pisteiden välisen keskipisteen ympärille, joten pisteet joiden olettaisit pysyvän paikallaan voivat siirtyä runsaastikin. Erityisesti kiertoliittymissä käyttö voi vaatia kiertoliittymään saapuvien teiden uudelleensäätämistä ja ympyröimisen toistamista halutun tuloksen saavuttamiseksi.

Suorakulmaiseksi pakottaminen

Esimerkiksi useat talot ovat suorakulmaisia ainakin useimmista nurkistaan, ja Työkalut - Suorakulmaista muoto -toiminnolla saat valitun polun kulmat aseteltua siten, että kulmat ovat tarkallen 90 astetta. Työkalu ei vielä osaa käsitellä muotoja joissa on yksikin piste keskellä jotain suoraa sivua.