Proposal talk:Parcel lockers and parcel postbox

From OpenStreetMap Wiki
Jump to navigation Jump to search


Don't forget this older proposal : --StephaneP (talk) 11:12, 15 November 2018 (UTC)

Thank you! I've added a link to it to this proposal. Do you know if there has been some discussion before that other proposal has been set up? Is anyone still taking care of the proposal? (The last edit of the author of the proposal is from early 2016.) Regards --SelfishSeahorse (talk) 15:56, 15 November 2018 (UTC)
PS: It would be nice if these two proposals could be merged. --SelfishSeahorse (talk) 15:57, 15 November 2018 (UTC)

Name and useful combinations

Generally, I would really like to have this approved, because it propably would allow to add dedicated icon for these objects in OSM-Carto. But I have 2 remarks:

  • As English is not mu first language I might be wrong, but shouldn't it be called "parcel_locker" (without "s" at the end) as it's just one object? Or a locker is a name for a one "pocket" in these machines?
  • Proposed scheme documentation should contain useful combinations with parcel_pickup=yes/no and parcel_mail_in=yes/no and the rest like here: Proposed features/amenity=parcel box

Tomasz W (talk) 09:11, 4 January 2019 (UTC)

Hi! Thanks for your interest in this proposal!
One locker is just one compartment, therefore the plural parcel lockers should be fine for the whole facility.
I wasn't aware of the parcel_mail_in=* key, as it isn't documented, therefore i introduced parcel:sending=*. But i were also fine with parcel_mail_in=*. As for parcel_pickup=*, i don't think that this key is necessary, or are there parcel lockers where you can't pick up parcels?
SelfishSeahorse (talk) 17:20, 4 January 2019 (UTC)
As I know there are also sending-only machines, so I would left some tag to have a possibility of proper marking them. I would go with parcel_pickup=yes/no and parcel_mail_in=yes/no scheme, because it's closer to current scheme, so it would be easier to move old objects to this new tagging scheme. Do you think documentation would be ready for voting after adding remarks mentioned above? Tomasz W (talk) 10:52, 5 January 2019 (UTC)
Do you mean parcel postboxes? I'd prefer to introduce a separate tag for them – say amenity=parcel_postbox – as they look and work quite different from parcel lockers. –SelfishSeahorse (talk) 15:15, 5 January 2019 (UTC)
PS: Prior to a vote, there needs to be a request for comment, which i haven't done yet because of limited time and other proposals currently being discussed. –SelfishSeahorse (talk) 15:21, 5 January 2019 (UTC)
OK, parcel_mail_in=yes/no for parcel lockers + separate tag for parcel postboxes is also good, but it has to be clearly described in proposed documentation.Tomasz W (talk) 09:15, 6 January 2019 (UTC)
I've now added amenity=parcel_postbox to the proposal. However i haven't replaced parcel:sending=* with parcel_mail_in=* yet, because i was wondering whether 'mail in' is correct English. I'll ask the others when sending out a RFC and, depending on their answers, change the key later. –SelfishSeahorse (talk) 17:06, 6 January 2019 (UTC)
Isn't the intent of parcel_mail_in=* to indicate that, in addition to parcels, this parcel locker also accepts regular mail? Regardless, I believe we need a way to indicate this, since in the Netherlands the parcel lockers by PostNL include a slot for regular mail (e.g. they incorporate a classical postbox for letters, replacing the standalone letter postboxes in some places). We cannot use amenity=postbox, since that does not combine with the amenity=parcel_locker from this proposal. Perhaps postbox=yes (similar to adding atm=yes to amenity=bank)?
--Matthijskooijman (talk) 21:51, 12 August 2019 (UTC)
Hi! Please excuse my late reply and thanks for your input! No, vending=parcel_mail_in means that parcels are accepted for sending. IMHO, the proposed tag parcel_sending=* is much clearer. Similary, letter_sending=* (and letter_receiving=*) could be used. --SelfishSeahorse (talk) 18:18, 18 September 2019 (UTC)
Thanks for clarifying, I agree that parcel_sending/parcel_receiving is more clear and should be preferred. As for letter_sending/letter_receiving, those do not seem to be in use yet. I have some thoughts on these, which I'll put in a separate discussion thread for clarity. --Matthijskooijman (talk) 09:01, 24 September 2019 (UTC)

Obsoleting amenity=parcel box


I just wanted to tell that I have made my proposition draft (Proposed features/amenity=parcel box) obsoleted by your scheme. The idea is the same, but I did not advance my draft enough and plural "lockers" sound closer to reality to me than single "box". I'd like to help you with this proposal, if you need some support with it. --Kocio (talk) 03:39, 30 January 2019 (UTC)

Hi, thank you! I didn't have time yet to send an RFC (i first want to make Proposed features/Tag:natural=peninsula ready for vote), but if you could support me during the discussion or if you have any other ideas for improvement, i'd really appreciate that. –SelfishSeahorse (talk) 21:09, 31 January 2019 (UTC)
PS: If by chance you come across a parcel postbox and could map it with the proposed tag amenity=parcel_postbox, this would certainly help adopting this proposal. Currently this tag hasn't been used because there aren't any parcel postboxes where i live. –SelfishSeahorse (talk) 21:27, 31 January 2019 (UTC)
OK, however I haven't seen it yet and didn't know about them until reading your draft. --Kocio (talk) 21:53, 31 January 2019 (UTC)
It was User:Tomasz W's wish to also include the sending-only parcel postboxes, which i think makes sense, so that amenity=vending_machine and vending=* isn't needed anymore for parcel sending and receiving facilities. – Looking at Overpass Turbo, most vending=parcel_mail_in are mapped in Germany. Some have also been mapped in Poland, but if i look up their name (Paczkomat) and operator (InPost) with Google, these seem to be mistagged parcel lockers (vending=parcel_pickup;parcel_mail_in), so you'll probably not find any there. –SelfishSeahorse (talk) 09:22, 1 February 2019 (UTC)

Proposed features/amenity=laundry box

I drafated also Proposed features/amenity=laundry box, but maybe it should be renamed into amenity=laundry_lockers to match your proposition? The difference is that this works both ways (sending/receiving), but still there are many lockers, not just one box. Of course there might be more similar services with automated lockers around the world. --Kocio (talk) 12:47, 30 January 2019 (UTC)

Maybe laundry lockers is more descriptive. Laundry box(es) sounds more like laundry baskets to me. –SelfishSeahorse (talk) 21:09, 31 January 2019 (UTC)
It does not look like a basket at all, it's similar to parcel lockers - see this:
--Kocio (talk) 21:23, 31 January 2019 (UTC)
Yes, i've seen the links on your proposal page. Therefore i think that amenity=laundry_lockers fits better. –SelfishSeahorse (talk) 21:32, 31 January 2019 (UTC)

Why two different tags?

You propose two different tags, amenity=parcel_lockers and amenity=parcel_postbox depending on whether receiving is possible or not. This makes it difficult to find places to send a parcel since you have to search for two very different tags. I recommend using the same top-level tag (especially because services offered may change at any time without changes to the hardware of a station) and just have two tags detailing the services offered. --Mueschel (talk) 16:30, 5 February 2019 (UTC)

Hi! Parcel postboxes and parcel lockers are two different objects: a parcel postbox is just like an ordinary postbox, but larger. On the other hand, parcel lockers are electrical devices that allow for interaction with the customers, usually by a touchscreen (for paying the postage, allocating the individual locker etc.); some of them can even be used as ordinary lockers. Parcel lockers can't be transformed into parcel postboxes and vice versa; the hardware would need to be replaced. (Instead of having just one tag for parcel postboxes and parcel lockers, i think it would make more sense to tag a parcel postbox as amenity=post_box + parcel_sending=yes and parcel lockers as amenity=post_office + self_service=yes.)
By the way, if one wants to send a letter, one already has to look for amenity=post_box and amenity=post_office, so i don't see a problem here. Or with the current scheme, if one wants to send a parcel, one has to look for amenity=post_office, vending=parcel_pickup;parcel_mail_in and vending=parcel_mail_in. –SelfishSeahorse (talk) 18:49, 5 February 2019 (UTC)
So your separating the two options by the type of device, not by the options the user has. This should be fine, but the description in the proposal should reflect this in the examples. If it looks like parcel_lockers, but somebody decided to use it for collecting parcels only, it should not be tagged as parcel_postbox.
Please don't think about tagging these machines as post offices - they don't have much in common. There is not even a consensus whether a small 'post office' corner in another shop qualifies as amenity=post_office. --Mueschel (talk) 19:09, 5 February 2019 (UTC)
I've tried to improve the definitions and introduced parcel_receiving=yes/no. – I didn't think of tagging parcel lockers as amenity=post_office, but i'm wondering why you think that this isn't okay, whereas tagging dispensers as vending machine is okay. –SelfishSeahorse (talk) 20:09, 5 February 2019 (UTC)

Regarding "currently tagged amenity=vending_machine even though they aren't vending machines."

The machines where you can hand in parcels are actually vending something - printed labels and a service. We're using the tag 'vending_machine' for various things that are not primarily vending things as such (e.g. excrement_bags). This is common practice with various other tags as well. It's a good thing to use top-level tags to describe a general notion and nothing too special. --Mueschel (talk) 16:30, 5 February 2019 (UTC)

While parcel lockers allow for paying the postage on site and thus sell a service, they don't vend anything. Paying the postage at a parcel postbox isn't even possible, like at an ordinary postbox.
And calling a dispenser, such as one where you can get excrement bags for free, a vending machine is absurd, in my opinion (see also Proposed_features/Dispenser). Regards, Markus –SelfishSeahorse (talk) 18:49, 5 February 2019 (UTC)
Using dictionary definitions of words used for tags will fail in almost every case. OSM and its tagging history is much more than blindly applying dictionaries onto real world objects. You might think it's "absurd", but it's established since many years. --Mueschel (talk) 19:06, 5 February 2019 (UTC)
If tag names differ too much from common understanding (dictionary definitions), there is a risk that tags inadvertently get misused and gradually loose its meaning (cf. landuse=forest). Regarding excrement dispensers, however, i don't see that risk, and if you think that there is little chance that this proposal gets enough support, i'm fine with abandoning it. There are too many other thinks i'm more interested in than excrement bag dispensers. :-) Cheers, –SelfishSeahorse (talk) 16:03, 6 February 2019 (UTC)

Parcel lockers with integrated postboxes

In the Netherlands, parcel lockers usually (maybe always) contain an integrated postbox: In addition to the lockers they have a slot in which you can deposit ordinary letters.

In the discusion above (under "Name and useful combinations"), it was suggested to maybe introduce letter_sending=yes and letter_receiving=yes could be used to indicate this. These tags do not seem to be in use yet, so should they be included in this proposal?

As for the tags themselves, letter_sending/letter_receiving sound like good tags for this, consistent with parcel_sending/parcel_receiving. I do wonder if letter_receiving is actually used in a locker machine in practice, but I can imagine it happens or will happen in the future.

On the other hand, there is a difference between sending a parcel using a locker in the locker machine (which requires interaction with the machine and/or preregistering a parcel from home) and sending a letter by just putting into the the integrated postbox. Should the tagging reflect that? One alternative would be to put postbox=yes on a locker node to indicate it contains a regular postbox (similar to how atm=yes and amenity=atm can both be used).

--Matthijskooijman (talk) 09:01, 24 September 2019 (UTC)

Hmm, I think the proposed letter_sending=yes would be fine for this, but so or so, programs with which you look for a postbox would have to imply a new tag next to the existing amenity=post_box, either postbox=yes or letter_sending=yes. I think the last fits much better into the proposed scheme, I can see your point but also for keeping it simple, we should not create another tag then (postbox=yes) with (nearly) the same meaning like letter_sending=yes would be, because letter_sending=yes can be used for all parcel-stations which offer this service.--Lukas458 (talk) 11:31, 4 May 2020 (UTC)

Tag for lockers' name and operator

Amazon lockers have a unique name, at least in France. For instance at St Lazare railroad station (Paris) one is called "Michelle" and the other one "Maimouna". Also, one may want to use name tag for "Amazon Locker", but it's not a name it's a type of amenity. I'm sure Amazon is not a unique case and I think it shall be clarified for all operators. I would use operator=Amazon, brand=Amazon locker + name=Michelle for instance. I would not duplicate name in ref tag. LeTopographeFou (talk) 07:51, 13 February 2020 (UTC)

Tag for the content

I think there's a need to add a tag for products inside the lockers. It can be generic content, but for example Eurospar's Mainbox is a "fridge-o-mat", since it stores shopping from their shops, mainly food. Maybe just product=*? --Kocio (talk) 07:57, 30 May 2021 (UTC)

Proposal for parcel to be a subvalue for amenity=lockers/postbox

I can see the need for precise tags about parcel lockers/postboxes and definitely encourage it. But in the mean time I propose for parcel specific elements to be a subvalue as that would allow grouping and down the line ease the maintenance of such tags. By the way the amenity=locker tag is still a draft and would benefit from sharing content with this proposal. --Lejun (talk) 14:23, 12 August 2021 (UTC)