Pt:QGIS

From OpenStreetMap Wiki
Jump to: navigation, search
Linguagens disponíveis — QGIS
· Afrikaans · Alemannisch · aragonés · asturianu · Aymar aru · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · bamanankan · Bân-lâm-gú · Basa Jawa · Basa Sunda · Baso Minangkabau · bosanski · brezhoneg · català · čeština · corsu · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · kurdî · Latina · latviešu · Lëtzebuergesch · lietuvių · Limburgs · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tagalog · Tiếng Việt · Türkçe · Türkmençe · Vahcuengh · vèneto · walon · Wolof · Yorùbá · Zazaki · isiZulu · српски / srpski · авар · Аҧсшәа · башҡортса · беларуская · български · қазақша · Кыргызча · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · भोजपुरी · मराठी · संस्कृतम् · हिन्दी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · བོད་ཡིག · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 中文(繁體)‎ · 吴语 · 粵語 · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް
QGIS
Screenshot of QGIS
Licença: GNU General Public License (grátis)
Plataformas: Windows, Linux, macOS e Android
Versão: 2.18.14 (2017-10-27)
Linguagem: inglês
Site da Internet: https://qgis.org
Instalação:
Linguagens de programação: C++ e Python

um aplicativo GIS multiplataforma livre

QGIS (anteriormente também conhecido como Quantum GIS) é uma aplicação GIS de fonte aberta (GNU GPL v2) e gratuita permitindo ao usuário visualizar, gerenciar, editar, analisar dados e compor mapas imprimíveis. Funciona em Linux, Unix, Mac OSX, Windows e Android e pode ser baixado gratuitamente a partir de qgis.org.

OpenStreetMap em QGIS

QGIS 2: Importando camadas vetoriais OSM

QGIS 2.0 integra a importação do OpenStreetMap como uma funcionalidade básica. Para obter dados OSM, use o menu "Vector → Openstreetmap":

  1. "Load data" se conectará ao servidor OSM e baixará dados. Você pode ignorar este passo se você já possui um arquivo .osm XML.
  2. "Import topology from an XML file" abaixo converterá seu arquivo .osm em um banco de dados spatialite e criará uma conexão db.
  3. "Export topology to Spatialite" em seguida, permite que você abra a conexão do banco de dados, selecione o tipo de dados que deseja (pontos, linhas e polígonos) e escolha as etiquetas para importar. Faça isso três vezes (clicando em 'Load from DB' para cada um) para criar três camadas de geometria de spatialite.
  4. Adicione esta camada ao seu projeto através do menu "add a spatialite layer".

Mais detalhes aqui. Observe que esse processo importa dados OSM GIS crus não qualquer estilo/simbologia de mapa específico.

QuickOSM

QuickOSM permite que você trabalhe rapidamente com dados OSM no QGIS, graças à API Overpass.

Plugin OpenStreetMap (obsoleto)

Para QGIS mais velho que a versão 2: O QGIS OSM Plugin permite carregar dados vetoriais de OpenStreetMap e até mesmo editar e fazer upload de suas alterações. No entanto, devido a um bug relacionado a 64-bit Identifiers, dados mais recentes não são lidos. Veja a página do QGIS OSM Plugin para obter mais informações e soluções alternativas.

Shapefiles, PostGIS e outras opções de conversão

Há vários meio de converter dados OSM para outros formatos que poderão então ser abertos no QGIS. Em particular, note as várias opções para Shapefiles e bases de dados PostGIS.

Usando mapas raster de OpenStreetMap

Há algumas abordagens diferentes para trazer tiles do OpenStreetMap (ou de outros fornecedores de tiles do OpenStreetMap) :

  • Instale o plugin QuickMapServices, encontre seu botão na barra de ferramentas e clique nele para ver uma lista de camadas, incluindo camadas OSM.
  • O Plugin QGIS OpenLayers oferece outra maneira fácil. Em QGIS2.0 vá até o menu "Plugins" -> "Manage Installed Plugins...", então procure por OpenLayers abaixo de 'Get More'. Em versões mais antigas de QGIS 1.x você precisa habilitar o "Plugin Installer" do Plugin Manager e então o "Plugins" -> "Fetch Python Plugins" e selecione o "Openlayers Plugin". A lista de camadas de tiles OSM disponíveis aparece a partir do menu "Plugins" -> "OpenLayers plugin". (Observe que este processo altera o CRS (sistema de referência de coordenadas) para o projeto QGIS e que você pode encontrar problemas com a impressão do mapa).
  • GDAL o suporte é incorporado, para que você possa GDAL XML configurar e carregar como uma camada raster.
  • O serviço Bigmap torna relativamente fácil a importação de uma imagem georreferenciada criada a partir de tiles de mapa colados (para uma área muito limitada).

Veja Pergunta: Como obter o OpenStreetMap como uma camada raster em QGIS?

Para que a camada OSM pareça lisa, certifique-se de usar projeção ESPG:3857 e definir uma escala para começar a partir de 1:2257.

Você também pode importar este arquivo para definir a pirâmide de escala para o seu projeto:

<qgsScales version="1.0">
<scale value="1:591659030"/>
<scale value="1:295829515"/>
<scale value="1:147914757"/>
<scale value="1:73957378"/>
<scale value="1:36978689"/>
<scale value="1:18489344"/>
<scale value="1:9244672"/>
<scale value="1:4622336"/>
<scale value="1:2311168"/>
<scale value="1:1155584"/>
<scale value="1:577792"/>
<scale value="1:288896"/>
<scale value="1:144448"/>
<scale value="1:72224"/>
<scale value="1:36112"/>
<scale value="1:18056"/>
<scale value="1:9028"/>
<scale value="1:4514"/>
<scale value="1:2257"/>
</qgsScales>

Estilos para dados OSM no QGIS

Há um número crescente de estilos QGIS pré-preparados e disponíveis para dados Openstreetmap - por exemplo:

Mais Plugins OpenStreetMap

  • QuickOSM, como mencionado acima, obtém dados da OSM via Overpass API.
  • OSMinfo você pode clicar para encontrar informações no OSM sobre algum objeto próximo.
  • Quantumnik foi um plugin QGIS que ajudou na criação de estilo Mapnik. Trabalhou com QGIS 1.8 ou inferior.

Informação geral QGIS

Veja também wikipedia:pt:Quantum GIS.

Características

Os principais recursos do QGIS incluem:

  • Visualização direta e exploração de dados espaciais
    • Simbologia avançada (editar estilos de renderização)
    • Navegador QGIS como um visualizador de dados simples e rápido
  • Suporte para vários formatos vetoriais, raster e banco de dados
  • Criar, editar e exportar dados espaciais
    • Trabalhar com nós, linhas e polígonos
    • Conversão entre diferentes sistemas de coordenadas (re-projeção)
    • Baixar/subir diretamente para uma unidade GPS
  • Realizar análise espacial
    • Encontrar centrídios de polígono e estatísticas básicas
    • Matriz de distância e interseções de linha
  • Publicar seu mapa na internet
  • Uma arquitetura extensível de plug-in
  • Controle remoto JOSM [1]

Documentação & Tutoriais

Renderização de Gallarate (veja o tutorial) 'Usando dados OpenStreetMap'.

A wiki QGIS fornece inúmeros guias e tutoriais em vídeo para ajudar os usuários de todas as habilidades. Para os novos usuários, um bom lugar para começar é o vídeo Introdução ao Quantun GIS. Também é importante ter uma compreensão básica sobre o #Sistema de Referência de Coordenadas.

Outras páginas úteis:

  1. O guia grátis Começando Quantum GIS armazenado no Google Docs (produzido por learnosm).
  2. Como faço isso no QGIS na wiki QGIS.
  3. Tutoriais QGIS por Ujaval Gandhi.

O QGIS permite que você crie simbologia avançada (semelhante ao Mapnik ou Osmarender) de forma poderosa, mas muito fácil (alguns cliques no rato), veja exemplos aqui e um vídeo detalhado no youtube.

Sistema de Referência de Coordenadas

A Terra é um corpo tridimensional, de forma grosseiramente esférica, mas a grande maioria dos mapas é plana (bidimensional). Um Sistema de Referência de Coordenadas (SRC) define um método para projetar toda ou parte da Terra em uma superfície 2D. O QGIS tem suporte para aproximadamente 2.700 SRC conhecidos. Alguns, como WGS-84 são projeções globais, enquanto outros representam apenas regiões específicas.

Configurando o SRC

Ao trabalhar com dados geo-espaciais é essencial que você esteja usando o SRC correto. Se você tiver sorte, a projeção será especificada como parte do arquivo vetorial (por exemplo, ESRI Shapefiles geralmente inclui dados de projeção no arquivo .prj), no entanto, muitas vezes você precisará selecionar manualmente o SRC correto.

Para especificar o SRC de uma camada vetorial, selecione a camada e escolha Layer->Set CRS of Layer(s).... Cada camada possui diferente SRC. Se for esse o caso, você precisará convertê-los para o mesmo SRC para que todos eles sejam exibidos corretamente. A maneira mais fácil de fazer isso é usar a transformação SRC "on the fly":

  1. Settings->Project Properties (ou clique no símbolo do globo no canto inferior direito).
  2. Selecione a guia Coordinate Reference System (CRS).
  3. Marque a caixa de seleção Enable 'on the fly' CRS transformation.
  4. Escolha um projeto adequado SRC para trabalhar (por exemplo, WGS-84).

Mais informação pode ser encontrada neste vídeo tutorial.

Uso do QGIS para converter um conjuno SRC

QGIS pode ser usado para converter um conjunto SRC. Abra a camada de entrada certificando-se de selecionar o SRC correto como descrito acima. Use Layer->Save As... para exportar a camada com um SRC diferente (Você pode escolher entre o "Project" SRC ou selecionar um SRC da lista extensiva do QGIS).

Ver também

Ligações externas