From OpenStreetMap Wiki
Jump to: navigation, search

Trunk ways

Are there any reasons why trunk, primary, secondary have the same weights in elemstyles.xml? Imho a faster route would go over a trunk way, instead of primary/secondary. This gives some weird routings in my areas where a new trunk road (110 kmhs straight) is constructed a few kms parallel to the old road (tagged as secondary), Because the old road goes trough villages, across roundabouts etc it is a much slower route, so definitely not the fastest route bot not the shortest. see http://tile.openstreetmap.nl/%7Elambertus/routing-world/?flat=42.697564&flon=2.860424&tlat=42.814406&tlon=2.914154&v=motorcar&fast=1 . Also does gosmore uses the maxspeed account while calculating a route? --Skywave 10:38, 21 August 2008 (UTC)

  • Primary ways should also have a higher routing value in elemstyles.xml. Now it is the same as secondary roads --Skywave 16:58, 6 September 2008 (UTC)
maxspeed still needs to be fixed -- Nic 11:53, 10 September 2008 (UTC)
Any ideas when this is fixed? It looks like using the tagged maxspeed (minus 10% (say) to get the average speed) will provide much better routing (especially within cities). --Lambertus 11:15, 16 October 2008 (UTC)

.pak file endianness

Is it the case that the format of the .pak file depends on the endianness of the processor? Someone mentioned something that seemed to imply this. Can this be fixed so that the .pak file is the same always? Rjmunro 20:12, 22 June 2007 (BST)

Yes, it needs to be fixed.

Separate the program into 3 pieces

I think that Gosmore's database system could be useful outside of Gosmore's interface. It would be great to write a mapnik backend that uses it, for example. Could gosmore be split into 3 parts - a library for accessing the database, a sample front end, and a program to make the .pak file (both of which would use the library)? Rjmunro 20:15, 22 June 2007 (BST)

Running it headless, outputting routepoints?

I wonder if it could be adjusted so it runs headlessly. I imagine a web based route planner, where the user defines a start and end point for a bicycle route. Passing both with arguments to gosmore and retrieving a list of waypoints (all direction changes or optional crossing turns only) would make it possible to display a route with waypoints which the user can still adjust. After that the user can request it as a file for his/her gps. Anyway, cool piece of software already. Playing with it is just fun :) --SlowRider 18:15, 10 July 2007 (BST)

Compile with make CFLAGS='-O2 -D HEADLESS'. It implements CGI : Run with the QUERY_STRING environment variable set to something like 'flat=-25.7786&flon=28.2906&tlat=-25.7681&tlon=28.2705&fast=1&v=motorcar' Error reporting is non existent at this stage.

Using gosmore with direct-fb (without X)

This is quite easy. Just change the line

EXTRA=`pkg-config --cflags --libs gtk+-2.0 || echo -D HEADLESS`

to lines

EXTRA=`pkg-config --cflags --libs gtk+-directfb-2.0 || echo -D HEADLESS`
EXTRA+=`pkg-config --cflags --libs gdk-directfb-2.0`

in your Makefile.

It will be very useful to adapt the window-size to your screen settings of framebuffer device.

--Art1 16:29, 21 May 2008 (UTC)

Possible Bug?

Erm, following GPSd seems to me not having any effect? Could you explain, how it works? My GPSd is w orking correctly (tested with gpsdrive). Any hints?

The program (svn-version and the versions of May 2008 sometimes crashing with double-free. I need some additional work (and time) to catch this...

I would very happy if gosmore will be reach the stable state. Because it is easy adaptable to embedd ed devices and old laptops. --Art1 16:29, 21 May 2008 (UTC)

GPSd support have been re-enabled today. I'm not sure how useful the realtime route updates / audio instructions were, so I disabled it -- Nic 21:40, 23 May 2008 (UTC)

Segmentation fault while rebuild pak file

On FreeBSD when I try to rebuild pak file for any size osm data file allways get this error:

264 for (pairs = 0; pairs < PAIRS && s2grp < S2GROUP (0) + S2GROUPS; )

Segmentation fault (core dumped)

What am I doing wrong ? Thanks for answer

--Dido 18:13, 23 May 2008 (UTC)

I noticed also a crash on Ubuntu 8.04 both with the ubuntu install as with compiling from the svn source.

This happened with rebuild upon http://download.geofabrik.de/osm/europe/netherlands.osm.bz2

But I could make it work by changing the Makefile, changing



 CFLAGS=-g -O2 

I did this to debug this problem with gdb, but "-g" also fixed the problem. If I remember correctly "-g" intializes undefined variables on 0, so it might be that gosmore uses undefined variables somewhere in its source-file.

--Stephan 13:19, 13 June 2008 (UTC)

with CFLAGS=-g -O2 I got same error

 Debug: 3724
 Debug: 372
 Debug: 3723
 Debug: 3724
 Debug: 372
 Debug: 3723
 Debug: 3724
 Debug: 372

followed by segfault --Dido 12:52, 28 July 2008 (UTC)

The program used to go into an infinite loop after creating the window when compiled with gcc-4.x -O2, but that problem has now been fixed. The program will also cause a segfault when it cannot get the memory it wants during a rebuild, so you must have a good 230 MB free. (These 'Debug:' messages does not look familiar??) -- Nic 07:13, 2 August 2008 (UTC)

BBOX rebuild problem with latest SVN version

I tried the following command as described on the main page to build a .pak file for the America's on a 32bit machine:

bzcat ../../planet-latest.osm.bz2 | nice ./gosmore rebuild -83 -30 83 179

But unfortunately Gosmore instantly fails with:

Unable to open master.pak for bbox rebuild.

Gosmore starts building the .pak file immediately when I remove the BBOX parameters though. --Lambertus 21:31, 27 June 2008 (UTC)

Did you first build the whole planet ? (3 hours) Did you then remember to mv gosmore.pak master.pak ? I would love to burn this file and the executables (1.3GB) to a directory on a DVD. I hope it runs responsively on the majority of PCs (Windows, Linux). In other words a 'live' CD that can be handed out at conferences. -- Nic 11:15, 28 June 2008 (UTC)
I have changed the way the pak file is generated: First split the planet file into two areas (Eurasia and America's) using Osmosis, then feed each area to a separate instance of Gosmore. The Eurasia area results in a pak file succesfully while the America's fails due to much data (32-bit limit). Splitting the America's into North and South won't help because the main body is the USA Tiger data which I don't like to split because that would break routing. So for 32-bit systems it seems impossible to do worldwide routing. Maybe an optional compiler switch to use a 64bit datatype at the expense of larger datafile size? --Lambertus 09:35, 7 August 2008 (UTC)

Floating point exception

I've updated the webbased routing service today with a new version of Gosmore today (svn up) and I must say that it returns many more requests succesfully then before (it used to go into a loop often). Great stuff! Unfortunately I did run into a problem with one request though where Gosmore exits with a 'floating point exception'. Can you have a look at this please? Please tell me what you want me to do to help... The commandline is: QUERY_STRING='flat=51.7967&flon=4.6715&tlat=52.37736&tlon=4.8838&fast=1&v=motorcar' nice ./gosmore using this i686 pak file. --Lambertus 15:51, 6 August 2008 (UTC)

Solved in revision 9694. -- Nic 22:13, 11 August 2008 (UTC)

Roundabout support broken

It appears that roundabout support is broken in svn version 2008-08-06. It will not route over rounabouts and makes giant detours to avoid them. --Lambertus 08:17, 7 August 2008 (UTC)

This problem was probably caused by using an old elemstyles.xml file with a new Gosmore version. Using a clean build solved it. --Lambertus 19:52, 8 August 2008 (UTC)


If you need a "Fastest Route" translation, why don't you need a "Shortest Route" and "Pedestrian Route" translation? --Lulu-Ann 16:14, 14 August 2008 (UTC)

If FastestRoute is off, the shortest route will be calculated. To get pedestrian mode, set Vehicle to 'foot'. Vehicle names are always in English. The user interface isn't very clean, but at least it works. -- Nic 20:46, 22 August 2008 (UTC)

Roads invisible

I downloaded the 2008-08-13 gosm_arm.exe. When I run it it doesn't show roads or road names but POIs appear ok. If I just replace the exe with an older version roads appear again. --Zorko 13:40, 15 August 2008 (UTC)

Executables and data files should be created / downloaded at the same time. The project is evolving rapidly a.t.m. -- Nic 20:48, 22 August 2008 (UTC)

Fatal Application Error

gosm_arm.exe crashes when using the pak faile for argentina, both from 2008-08-23, downloaded from your site --Zorko 13:56, 25 August 2008 (UTC)

Those are running fine on my GPS right now. Perhaps it will work if you delete the gosmore.opt file and try again. -- Nic 17:58, 27 August 2008 (UTC)
That did it. Thanks! --Zorko 22:10, 27 August 2008 (UTC)

mmap problem

If i start gosmore on my T-Mobile MDA/HTC Himalaya (PXA264/400Mhz 128mb ram) it says: "mmap problem. Pak file too bid ?" but the pak filled only 200k. Its a bug, a misconfiguration or is my device not supported? Thanks for help Yvesf 19:58, 8 September 2008 (UTC)

using the official germany.zip gosmore.pak file gosmore starts and then exits without anything.
same here. normal windows ce pda. and the germany pak file. i tried a smaller city pak file and i could start it. --Xsteadfastx 11:21, 10 September 2008 (UTC)

It's possible that some vendors removed support for the CreateFileMapping call and gosmore will not run on those.

After many tests I found that 400MB is the limit for most devices. So Germany is now split into 2 overlapping regions. -- Nic 11:53, 10 September 2008 (UTC)

Bicycle routing oddities

I noticed that routing for bicycle will happily route up the wrong side of a dual carriageway! I suggest that oneway should be observed for bicycles! Oneway streets that can be cycled up the other way should be tagged as such. Daveemtb 12:28, 9 September 2008 (UTC)

Which tag ? I can't find it -- Nic 11:53, 10 September 2008 (UTC)
cycleway=opposite is probably what Daveemtb means. --Lambertus 14:05, 10 September 2008 (UTC)

It seems that oneway=yes is ignored for bicycle routes. Gosmore even routes through roundabout in the wrong direction if routing for bikes! I agree that bike routing should obey oneway restriction, or at least impose a severe penalty on doing so (you must dismount and are effectively a pedestrian) FedericoCozzi 12:58, 11 January 2009 (UTC)

General comments

The functionality seems impressive, but IMHO the user interface needs a lot of improvement, it's exceedingly cumbersome at the moment on windows mobile. I would be happy to make interface suggestions if it helps. One other area that could perhaps be improved is a neater way to record road names. One other big question - what license is this software made available under? I didn't see that on the wiki page. Anyway, I'm very grateful for a WM app that can display OSM data and use the GPS on my TyTN II though! Daveemtb 13:14, 9 September 2008 (UTC)

It's PD. I'm glad you find it useful and I'm please how fast development has gone the last few months. But I'm think of taking a break until 2009. -- Nic 11:53, 10 September 2008 (UTC)

Cycling over footways allowed?

Gosmore routes over footways when a cycle route is requested. Is this wanted behavior and should bicycle=no be added to footways where cyclists are not allowed? Personally I would prefer not to route cyclists using footways unless explicitly allowed with bicycle=yes. Example using Gosmore from Sept. 3rd. --Lambertus 16:58, 11 September 2008 (UTC)

For the shortest route, which your link requests, a cyclist can dismount and walk along the footway but has to avoid any steps. If bicycle=yes is present, real cycling is possible. Alv 05:37, 12 September 2008 (UTC)
True, I hadn't thought about dismounting. --Lambertus 07:04, 12 September 2008 (UTC)
When dismounted, we are pedestrians(according to the laws). This way there is of no use a cycle route where 70% of the distance I must walk. owene 14:34, 26 September 2008 (UTC)

Routing through Parking Areas?

At present Gosmore does not calculate routes though parking areas (or other closed ways such as parks). Would it be possible to allow calculations of routes when ways are attached to the perimeter of a parking (or the like) areas? As the parking area may have an irregular shape I guess the best way to represent this on a map would be to highlight the perimeter and ignore the additional distance that this part of the route would introduce. Example of a 'faulty' route --Mungewell 18:06, 15 September 2008 (UTC)

One thought I had whilst out mapping yesterday is that an area could be marked as routeable by adding the foot=yes or bike=yes tags, Gosmore could pick up on these and route across these areas only. --Mungewell 17:44, 25 September 2008 (UTC)

Changelog, Version Number or Release Date?

I can't find information about the progress in development of Gosmore. Is there an easy to read changelog?

And where can I see what version I am using on my machine? --Stephan75 18:31, 7 October 2008 (UTC)

There is a changelog on the web at [1], but the precompiled Windows / WinCE binaries are currently a few weeks behind pending proper testing. The debian version is a lot more out dated. -- Nic 22:18, 9 October 2008 (UTC)

Gosmore gives up prematurely on long routes

Long routes often cut-off by Gosmore (JUMP) while breaking up the route in smaller portions shows that the underlying data is good enough. In effect it looks like Gosmore just gives up prematurely. Examples: 1, 2 --Lambertus 08:47, 17 October 2008 (UTC)

This patch to line 437 of libgosm.cpp should alleviate the problem. The drawback is worse performance for shorter routes.
- dhashSize = Sqr ((tlon - flon) >> 16) + Sqr ((tlat - flat) >> 16) + 20;
+ dhashSize = Sqr ((tlon - flon) >> 15) + Sqr ((tlat - flat) >> 15) + 20;
This patch causes Gosmore to find the routes okay, but at an huge cpu time impact. So much so that the server on occasion is drowned in Gosmore processes all fighting for precious I/O bandwidth (maybe caused by not able to load the entire database in memory due to lack of available RAM). I have gone back to the latest SVN version, accepting any problems with very long routes that may occur. --Lambertus 16:42, 23 November 2008 (UTC)
Doesn't work for me: gosmore result: 3, other routing engine: 4 - Same Coordinates --M0nty 00:47, 22 November 2008 (UTC)
Somehow, if you move the TO marker to another intersection on that road or reverse the route then there's no problem, so I checked the data which is OK, which points this straight at Gosmore ;-) --Lambertus 16:53, 23 November 2008 (UTC)
Other Example that don't work 5, work 6 - Same Coordinates --M0nty 14:08, 22 November 2008 (UTC)


How can i get the distance/length of a route via the QUERY_STRING variable? I get only the Route. (Linux). --M0nty 21:47, 10 November 2008 (UTC)

You will have to calculate the route length using the node coordinates yourself. --Lambertus 09:07, 11 November 2008 (UTC)
And the drive time? --M0nty 21:54, 14 November 2008 (UTC)
Is it possible to change the libgosm.cpp?, so it gives me the speedvalue back?--M0nty 20:04, 17 November 2008 (UTC)
I made a sample script in bash & python to do i
export LC_NUMERIC en_US
gosmore | awk -F  "," '{printf("%s %s\n",$1,$2)}' > tmp.dat
sed -i -e 1,2d -e "s/^M//" -e  '/^ *$/d' tmp.dat
/---------------------- measure.py --------------------------/
!/usr/bin/env python
import sys
import math
import csv
def measure(coord1, coord2):
        lat1 = float(coord1[0])
        lon1 = float(coord1[1])
        lat2 = float(coord2[0])
        lon2 = float(coord2[1])
        R = 6378.137
        dLat = (lat2 - lat1) * math.pi / 180
        dLon = (lon2 - lon1) * math.pi / 180
        a = math.sin(dLat/2) * math.sin(dLat/2) + math.cos(lat1 * math.pi / 180) * math.cos(lat2 * math.pi / 180) * math.sin(dLon/2) * math.sin(dLon/2)
        c = 2 * math.atan2(math.sqrt(a),math.sqrt(1-a))
        d = R * c
        return d * 1000
total = 0
with open("tmp.dat") as f:
        c = csv.reader(f, delimiter=' ', skipinitialspace=True)
        coord1 = c.next();
        for coord2 in c:
  total += measure(coord1, coord2)
                coord1 = coord2
print total
/---------------------- measure.py --------------------------/

Pak-File generation on Windows platform

The recommended command "gosmore -rebuild" does not work under Windows even though the program itself tells you to do so. We have checked the source code: The required function is commented out. A solution for this issue is to run it on the Linux platform just for this purpose.

  • note: if you are generating a pak file on Linux which you wish to transfer to a windows machine you will currently need to run revision 10694 in order to correctly display road names. Dmgroom 21:07, 4 January 2009 (UTC)
    • Any chance that the rebuild command will work under Windows in the near future, eg. for people without access to Linux systems (might happen :-) Drbobo 13:23, 11 February 2009 (UTC)

Layer tag

I think there is a bug in gosmore when handling "landuse" objects (and possibly other area type objects) which have a "layer" tag set. Roads and street in residential areas which are "landuse=residential" but without "layer=x" are shown fine in gosmore. Residential areas with e.g. "layer=-5" seem to be rendered on top of the streets, so that the streets cannot be seen. --R kleineisel 08:06, 20 January 2009 (UTC)


The options-file is saved at \My Documents\gosmore.opt. Also the logged GPX-Files are saved there. But, theres a big problem with this folder. It will be deletet at each restart on some navi-units. Also on my navi-unit. Is it possible to make this Ini-File in the same folder like the .exe File?

btw: great software.

Yes, just move it to the same directory as the exe, then the software will no longer use "My Documents" -- Nic 17:54, 27 January 2009 (UTC)
Thanks, it works. :-) But sometimes the Logged gpx-files are 0-byte-fils or there isnt an gpx-file.... But "GPS-Tacho" has the same problem. - Dennis
btw: Anyboy an idea what to doo against the loss of data? - Dennis

US Maps?

Has anyone prepared maps for US States? It would be great to have a link if someone has done so. --Liber 02:29, 26 January 2009 (UTC) For what purpose? Running that map on a PDA won't work as it needs a 64bit machine to handle the database size. --Lambertus 09:10, 26 January 2009 (UTC)

If you want specific US states, just ask me (nroets@gmail.com) -- Nic 17:51, 27 January 2009 (UTC)

track recording

besides navigation i use gosmore to make tracklogs mainly, as is the only soft that works great on my device, "ndrive 280" (PNA on Win CE). i would be perfect if we could change the time between points, so it works for car, bike or walk. thanks, nice work. --Sergionaranja 11:23, 1 February 2009 (UTC)

.osm file not saved if no GPS fix

The Win CE version doesn't save an .osm file if no GPS fix was found (don't know if it's a bug or a feature...). --JohannesF 08:20, 16 March 2009 (UTC)

Key bindings

Gosmore doesn't seem to have many key bindings for keyboard control, which is a pain with a track stick mouse.

I've written a quick patch to add some basic key controls. Can I send it to you guys for consideration? It may need some fixing as I'm new to GTK and no idea about the Win CE side of things.

Gosmore and gpsd

I tried Gosmore with gpsd (with an USB GPS receiver) on my eeepc running Ubunutu. Gosmore seems to work with inexact lat/lon-coords, for example: Gosmore sets the coords to: "?lat=48,20000&lon=16,31667", but gpsd send following: latitude="48.211736" longitude="16.327152". Other applications (viking, tangoGPS,...) get the right data und work with the right data. Is there a bug with a math-operation in Gosmore? I hope, there is a help, because i want to use it...

A second question i have: is it possible, to put a marker (a point, a cross, ...) at the current position on the map?

thanks! --Bananenfisch 18:49, 15 April 2009 (UTC)

In order for Gosmore not to link against libgpsd, it interprets raw NMEA data from gpsd. I tested it on a few receivers, but it's possible that your setup generates slightly different NMEA data. Please execute 'netcat localhost 2947' or 'telnet localhost 2947' and post 10 lines here. Or email it to nroets@gmail.com
Only WinCE supports placing a marker on the map. -- Nic 08:28, 24 April 2009 (UTC)
Thanks for your answer. Well, I use gpsfake for the Test, here is the Data:
gpsfake: line 1: $GPGGA,011325,4812.7042,N,01619.6291,E,1,04,5.6,1173.6,M,34.5,M,,*7C
gpsfake: line 2: $GPRMC,011325,A,4812.7042,N,01619.6291,E,74.5,188.1,010409,5,E,A*33
gpsfake: line 3: $GPGGA,011327,4812.6627,N,01619.6233,E,1,04,5.6,1104.5,M,34.5,M,,*71
gpsfake: line 4: $GPRMC,011327,A,4812.6627,N,01619.6233,E,75.0,185.4,010409,5,E,A*31
telnet to gpsd:
Connected to localhost.
Escape character is '^]'.
When I click on "Follow GPSr" at gosmore, gosmore says: "?lat=48,20000&lon=16,31667&zoom=17"
The trackfile from gosmore:
<trkpt lat="48,200000000" lon="16,316666667">
<trkpt lat="48,200000000" lon="16,316666667">
But correct Data at the trackfile from viking:
type="track" name="REALTIME"
type="trackpoint" latitude="48.211736" longitude="16.327152" altitude="1173.000000" unixtime="1238548405" extended="yes" speed="38.326000" course="188.099999" fix="3"
type="trackpoint" latitude="48.211044" longitude="16.327055" altitude="1104.000000" unixtime="1238548407" extended="yes" speed="38.582999" course="185.400000" fix="3"
This is very strange for me :-(
Thanks --Bananenfisch 00:04, 29 April 2009 (UTC)
On my computer gosmore produced the correct results (below). The one possibility that atof() is included in the math library and it was not linked in on your machine. Try adding '-lm' to the EXTRA variable in Makefile.
The other possibility is that your locale does not use '.' as the decimal sign. You should try is to run the application with 'LANG=C ./gosmore'.
<trkpt lat="48.211736667" lon="16.327151667">
<trkpt lat="48.211045000" lon="16.327055000"> -- Nic 22:41, 31 May 2009 (UTC)

where to ask this

Is there a gosmore forum, mailing-list or some other place where the development is going on? I'm constructing a web-service to collect traffic messages and would like to get input from as many other navigation -applications as possible to make the service usefull to as many of them as possible. --MarcusWolschon 08:29, 20 April 2009 (UTC)

I've been in contact with David Dean (who has done some Gosmore contributions) on the osm-dev IRC channel. Other then that all contact has been with Nic Roets through email. --Lambertus 12:00, 20 April 2009 (UTC)

WinCE Gosmore installation.

The procedure says unzip files on a SD card, insert the card then run gosm_arm.exe... But, how do I run gosm_arm.exe (or any .exe in fact) on a GPS device (a Medion or a Connex for example)? The standard interface of those devices doesn't allow me to run any software on the SD card. (With a Connex, it seems that if I put an any_prog.exe as \MobileNavigator\MobileNavigator.exe, it will run if I select 'Guide' in the main menu; I'll try 'gosmore' soon)-- Xof 17:16, 1 August 2009 (UTC)

Depends on the device. Many will run "\MobileNavigator\MobileNavigator.exe" if you tell it that your software is external. Most will allow you to change the registry if you connect it via USB to a computer with ActiveSync & CeRegEdit.exe -- Nic 17:53, 18 August 2009 (UTC)
Under WinCE there is a file explorer (german "Datei-Explorer"). Open this application, select the SD Card and the Gosmore-Exe and double click on the exe. Now the application will start. Hope this helps to solve your problem. --Wst 18:25, 21 August 2009 (UTC)
Thank you! (I can't check it now because I use Linux and don't have OpenSync (or?) installed yet) -- Xof 03:48, 22 August 2009 (UTC)
on a Medion 97430 the file explorer can be found under o of Gopal on the first screen after boot. The automagical startuo doesn't work. its said that the GPS works with compport 2, baudrate 56700 (doesn't with mine) -- Bruno 00:20, 18 July 2010 (UTC)

Adding City name behind road name in search list?

The search box allows to look for street names. If you look for a common street name which exists in several cities, the result list shows each entry, but does not specify to which city the entry belongs to. According to the program description same entries are ordered by distance from the current location, so the nearest is listed first, but that does not always help to select the right one.

I would like to suggest to add the city name in capital letters after the road name. For example: Mozartstrasse HAMBURG

On small devices there is limited space available on the screen, in this case there could be displayed just the first 3 - 5 letters of the city name (in capital letters). For example: Mozartstrasse HAM

Unfortunately I am not a programmer. Is this a lot of work to implement? Could somebody add this feature?

In SVN there is now a new version where the search results are much more verbose (although the city names are not displayed as you are requesting) as well as many improvements (Better rendering & 3D). Further improvements are being worked on and the Windows ports will only be updated at the end of the process. Please be patient. -- Nic 18:33, 1 October 2009 (UTC)

Compiler (g++) warnings

I compiled gosmore today with the -pedantic flag on my linux system (Gentoo, 64 Bit, running gcc-4.3.4) and got some errors. I will try to submit patches for those problems but it seemed best to have a list here. I consider clean compilation a really good thing since it helps you spot errors when they are introduced!

When compiling with -pedantic enabled I get the following errors/warnings:

libgosm.h:22: error: ISO C++ does not support ‘long long’

C++ does not define the long long type. A better (not totally clean) solution would be to use the int64_t type.

It's been a long time since I read the relevant docs, so it's good you tell me.


libgosm.cpp: At global scope:
libgosm.cpp:1045: warning: unused parameter ‘w’

Trivial fix ... rullzer 11:53, 24 October 2009 (CET)

Getting the compiler to shut up is easy. Writing Osm2Gosmore() so that it actually extracts the maximum information is much more difficult -- Nic 12:25, 29 October 2009 (UTC)