From OpenStreetMap Wiki
Jump to navigation Jump to search

We need feedback !

A few questions:

  • Are the PAK files too large ?
    • Because they include too many irrelevant results ?
    • Because it takes too long to download them ?
    • Because it they give mmap problems under Windows Mobile ?
      • Yes I get mmap faults often with direct reboots of the device when the file-size is above 150mb. And above 100MB the divice gets very slow by procesing the large file. So I with 100mb files my device WinCE5.0 with 64MB RAM/265MBRom. --Emil3 10:48, 19 April 2011 (BST)
  • Are the PAK files too small, preventing you from long distance routing ?
  • Is it too difficult to find the right PAK file ?
  • Is there anything that is not being rendered that you want to see ? Please specify tags.

Important outstanding issues

  • WinCE: Do not cancel routing if the user taps the screen while RoutingLoop is busy. Instead keep on calling RoutingLoop. See the bug report David filed.
  • After switching between pak files, the old pens and brushes are still used, which may be invalid.
  • Routing on ARM still uses floating point which is slow.
  • The long distance routing code is disabled. When it is enabled, some short routes are will not be calculated. I invented a way of striking a good balance, but I haven't implemented it yet.
  • Some routing issues regarding left turns and u-turns at junctions.
  • Draw thicker roads at highzoom.
  • Write an API that third party developers can use.

Should I post bugs here, or on trac ?

It's your choice. If you post it here, it is easier to manage. For example hide facts that turn out to be irrelevant, group discussion by topic etc.

So I'm touring through Germany and Austria. What should I download ?

Germany as a single file is 1.3GB. It does not fit in the Windows Mobile address space and under Linux and Windows searching may be slow and include too many irrelevant results.

Fortunately Gosmore also has a multimap map mode (default.pak + 0*.pak). (Also called auto pak file).

For multimap mode you need default.pak and a few rectangles that cover the area you are interested in. You can download them with the Windows or Linux version: Start the application and find a city that you are interested. For example search for "city:Berlin" and click the first item. (If the map blank, or nearly blank, you don't yet have a rectangle covering it and you are using default.pak) Then select O->UpdateMap. The download should start. When it's done, the file will be extracted and renamed. Restart the application and do this for the next city.

Alternatively go to this site and manually choose the rectangles : [1] Zoom in a bit and you'll see this red rectangle is the only one covering Bremmen. When you click inside it it becomes yellow so that you can see it's real size (it actually includes Brandenburg) and download it: Bremmen: [2] Koln to Leipzig: [3] East Germany & Poland: [4] East Germany North South: [5] North South (Ingolstad to Hannover): [6] Frankfurt to Stuttgart: [7] Munich: [8] Salzburg & Munich: [9] Austria & Hungary: [10] Bern & Stuttgart: [11] If you want to multimap mode, unzip gosmore.pak inside each one and rename it to NN..N.pak for example 0548034905860363.pak. Then place all these files together with default.pak in the same directory as the exe (Windows / Windows Mobile), or ~./.gosmore/ under Linux.

On Windows Mobile the bbox pak-Files mentioned above are too big... Is there any way to get smaller files (e.g. more, but smaller prebuilt-bbox files). I tried the smaller extracts, but it didn't work either --Svenglyxpilz 16:38, 14 February 2011 (UTC)

Always show current position

When I use Gosmore for mapping, there's something that bothers me: After I've added a note, I have to activate "Follow GPS" again. It would be nice, if Gosmore followed automatically after adding a node (or at least showed that green pin at the current position without moving the map). Maybe this could be done by adding a button "OK & Follow" to the add node window.

Bad U-turn

Illegal Routing

If Gosmore generates an illegal route, it is important to carefully look at the data. For example, the route in the picture includes a u-turn on a busy road. To fix the problem, the trunk way needs to be split at the 2 nodes where the u-turns occur and 2 no_u_turn restrictions needs to be added.

If you still have problems, ask here or post your question on the routing list.

  • In my opinion it does not have to be only a matter of mapping data with or without turn-restrictions, the culprit can also be the routing algorithm. I will investigate how other routing apps deal with that place. --Stephan75 15:27, 29 March 2010 (UTC)

Build / installation Isues

Map has only one parking icon

I builded map with newest svn version of gosmore. After building search list has streetnames so the data has correctly builded to pak-file. On map window there is only one parking icon (nothing more). I can zoom in and out and move the map but there isn't for example any streets or landuse areas. What's wrong? Same problem appears in linux/gtk system and wince navigator. --La4de 15:43, 6 November 2009 (UTC)

  • Xml parser uses my locales and assumes that decimal separator is comma. Osm data uses dot as decimal separator. So on my case every data went to same coordinate (decimal part of coordinates were missed). I replaced every dots to commas from osm file and after that rebuilded map. --La4de 21:45, 14 November 2009 (UTC)
Does it work if you 'unset LANG' before running gosmore, ? -- Nic 15:48, 4 February 2010 (UTC)
In a Linux Bourne syntax shell (e.g. bash) LANG="" is reported to work --Lambertus 16:28, 17 March 2010 (UTC)

PAK rebuild process seems to hang

The pak rebuild process seems to hang in step "6 while (fread (&nd, sizeof (nd), 1, groupf[i]) == 1)". The CPU is running at 100% but the tmp files haven't been touched in 18 hours and also iotop doesn't show any file I/O for Gosmore. I assume gosmore is caught in a loop somewhere? System is Centrino2 with Ubuntu 9.10 AMD64 rebuilding a pak from the 2010-03-03 planet file and Gosmore r20346. Anything I can do to determine the cause? --Lambertus 19:59, 17 March 2010 (UTC)

This particular problem is solved with the latest Gosmore versions. --Lambertus 18:54, 14 September 2010 (BST)
The problem is still present in SVN r26271, trying to rebuild the 2010-06-28 europe.osm.bz2 on a Core i7 with Debian Squeeze AMD64 system. The process hangs at step "32 while (fread (&nd, sizeof (nd), 1, groupf[i]) == 1)", 100% CPU but no file written for 10 hours --Davidl 06:50, 7 July 2011 (BST)

Custom Auto Pak ?

Is there any way to build a custom set of auto pak files? The default ones are way too big for my IPAQ. --chaosjug 08:28, 24 July 2010 (UTC)

  • I am also interested in smaller auto pak files (<100MB) for use in an WinCE device. Gosmore works fine with small files, but not with 400MB pak files. How can I create a default.pak file with my own pak-filenames? --Emil3 10:49, 19 April 2011 (BST)

build issues


Linking is now static and there is no DLLs. -- Nic 15:19, 4 February 2010 (UTC)

installation issues


I have placed a previous version map .pak file along the .exe and .dll files in the SD directory. But when i run arm-mingw32ce-gosmore.exe it gives "mmap problem. Pak file too big?". Can this be because .pak file format has changed?. And as it is not hosted, how can i build a valid .pak file in win xp? --Sergionaranja 09:41, 18 November 2009 (UTC)

  • Unfortuneately you can't build a pak file on windows based systems. Dmgroom 14:00, 20 November 2009 (UTC)
  • Same Problem here. I have successfully used the previous version on my 4.2 core device. I get the same error as Sergionaranja. I get the error with a previously working pak file (which still works with the old version which is still installed) and with a pak file I have just built. However, the new pak file will not work with the old software version. TreibAir 13:41, 18 November 2009 (UTC)
  • I get the following message when I try to run the .exe file: " "Gosmore" is not a valid Pocket PC application." How do I overcome this? (Gosmore is an excellent app! I have used the previous version a lot and it is excellent. Many thanks!)
    • I presume you did download the GosmoreWinMob.zip package and not the GosmoreWindows.zip package? Dmgroom 17:09, 21 November 2009 (UTC)
    • Yes, that's right. I have all 3 files in the folder, on the SD card (on Windows Mobile 6.1, on Mwg Zinc II (touchscreen)) ...?
      • I think that this is due to new memory management implemented in Windows Mobile 6.1, which CEGCC doesn't handle well. The workaround is to use UPX compressor on .exe (and maybe .dll) files, before running them on WM6.1 device. bartheq
        • What operation exactly should I do with UPX on the .exe ? Does that make it a .cab ? User:martinbone
          • Just download UPX from [12] and run it from command-line the with .exe file as the only parameter. Remember that it will replace this .exe file with a new one. It doesn't make .cab file, .exe file created by UPX can be run directly on your Windows Mobile device. bartheq
            • Excellent - many thanks. I've got it working using UPX on the files. Looks good. User:martinbone
  • My problem persists. In the meantime I have successfully rebuilt gosmore.pak for Germany (about 1,1 GB) and also for really small countries like Liechtenstein (less than 10 MB). In each case I get "mmap problem. Pak file too big?" and when I press ok I get something like "pak file not found". And in each case the pak files work with my linux version rather nice. I run Ubuntu 9.04 and Win CE 4.2 Core. Are there any options I don't know which I should appy during build? I've built the pak-file using "bzip2 -dc germany.osm.bz2 | gosmore rebuild" TreibAir, November 24th 2009
    • Are you using the lastest version from SVN to build the pak file, and an older version of gosmore on your mobile device? If so, then you either need to use the lastest gosmore for windows [13] or use an earlier revison of Gosmore to build the pak file, pak files built with revision 16703 work for me with an older version of gosmore for winmobile (but I cant be exactly sure which version of gosmore for win mobile I had). Dmgroom 13:55, 24 November 2009 (UTC)
      • I used the prebuilt Version which was available via apt-get. I now tried the newest svn version and the revision 16703. With revision 16703 I was able to build a pak file which could be read by the old (16.9.2008) gosm_arm.exe. However, no map was displayed. The current (3.11.2009) version did not recognize the file. The current svn did not produce any useable pak files. Both svn version also did not work properly (=no map display) on Linux. TreibAir, November 25th 2009
        • Is it possible you have the same issue as discussed under "Map has only one parking icon " above. Dmgroom 13:01, 25 November 2009 (UTC)
          • Thanks! That did it! The map for entire Germany is still not working however. I now use the map for my federal state (<100 MB) which works. TreibAir, November 26th 2009
            • Windows Mobile is limited to 400MB files. -- Nic 23:09, 20 January 2010 (UTC)
  • Hi, is it possible to use a 240x240 Windows mobile 5.0 Hardware? I tryed to take a look at gosmore on this client. It looked kind of "I yust see pices only... ". Thanks for your Help December 16th 2009

Ubuntu 9.10

On Ubuntu 9.10 you need to have gtk dev, so install it with: "sudo apt-get install libgtk2.0-dev"



Most issues have been addressed. Please try again. -- Nic 15:14, 4 February 2010 (UTC)


When into background selection if you press "+" the background colour showed is sometimes one behind the selectable.
When accessing the menu from black background map sometimes it changes to white.
When navigating sometimes black background changes to white by its own.

The bug with the lagging selection is fixed now. Black is automatic night mode and it will change to white when it calculates that it's day. -- Nic 23:09, 20 January 2010 (UTC)


It would be nice to have "iconset:0" to not show any icons at all. Sometimes in crowded areas there are too many icons to see where you are.


Most issues have been addressed. Please try again. -- Nic 15:14, 4 February 2010 (UTC)

Additional information in map view

It would be nice if there were options to display additional information while being in map view / navigation mode.

Next instruction

Gosmore seems to give an instruction only when there is no crossing way before the intersection. A simple workaround would be showing the next instruction in a corner like that.


Many navigation systems tell you when you exceed the maximum speed. Gosmore should be able to show the current speed and/or the allowed maximum speed. It would be also nice, if Gosmore also indicated if the maximum speed is exceeded. Example

Old Talk

The old discussions have been archived at Gosmore/Talk2008

Segfault while rebuilding map

Most issues have been resolved -- Nic 15:17, 4 February 2010 (UTC)

Crashes on Windows CE

  • On Win CE 4.2 if you add a node or a way and the name is longer than 44 characters it crashes Gosmore. Dmgroom 11:34, 23 June 2010 (UTC)
  • On Win CE 3.0 after I press "O" button Gosmore crashes. Unomano 17:03, 9 October 2010 (BST)

Indicate status of the O-Button

Gosmore should show what happens when the O-Button is pressed by changing it's label, e.g.:

  • O = Options
  • C = Cancel "Add way or node" [After activating "Add way or node"]
  • A = Add way or node [After activating "Add way or node" and clicking somewhere]

--gulp21 15:47, 14 July 2010 (UTC)

Only city name displayed, rest is light blue

I just compiled Gosmore from SVN. Started it, searched for "Hamburg, Germany", selected the result (the city name is displayed in the blue), pressed O and chose "Update Map". It downloaded some .pak but still did not display any map. I restarted it, no map. I manually downloaded http://dev.openstreetmap.de/gosmore/0530032905530340.zip and unzipped it to /usr/local/share/gosmore (that's what "make install" created). No luck. I had the same behaviour when I tried the Debian Armel build on another device. I am probably just missing some keypress or something like that?

Cant add POI's or trace ways

I've been using Gosmore on a Navigon Transonic 6000T for 2 years, with no problems. This week I tried it on a Navman S50 3D. Gosmore runs fine for displaying the map, and for routing, and the menu seems to work as I would expect. My problem is that it crashes when I try and add a POI or trace a way. I can click the "add way or poi" icon, I can trace a way on the screen, I can click the menu icon again, and the way and POI list comes up, but as soon as I click one of the way or POI icons I get a "Fatal Application Error. Exception 0xC0000005, Address:00000000". I have tried with both the download from sourceforge, and a most recent build I built myself, and the same issue occurs. It's frustrating as otherwise I really like the Navman. Dmgroom 12:06, 12 August 2010 (BST)

Can't I use the extracts to create AutoPak ?

I tried similar as in described above in Touring through Germany... by downloading the regional extracts for some "Bundesländer". First I used only Nordrhein-Westfalen [14], unzipped and renamed to default.pak, which worked well. Then I tried to expand my travelling area to Niedersachsen [15], unzipped and renamed to 000001.pak, which did not work. Is it necessary to have a 16 digit-filename? Do I have to use coordinates (which?) as Filename? I'm a bit confused ... can anyone help me --Svenglyxpilz 13:53, 10 February 2011 (UTC)


Where can I download beta versions of gosmore for Android Smartphones? --chris66 21:46, 11 February 2011 (UTC)