JA:JOSM/上級編

From OpenStreetMap Wiki
Jump to: navigation, search
利用できる言語 — JOSM/Advanced editing
· Afrikaans · Alemannisch · aragonés · asturianu · azərbaycanca · Bahasa Indonesia · Bahasa Melayu · Bân-lâm-gú · Basa Jawa · Basa Sunda · Baso Minangkabau · bosanski · brezhoneg · català · čeština · corsu · dansk · Deutsch · eesti · English · español · Esperanto · estremeñu · euskara · français · Frysk · Gaeilge · Gàidhlig · galego · Hausa · hrvatski · Igbo · interlingua · Interlingue · isiXhosa · isiZulu · íslenska · italiano · Kiswahili · Kreyòl ayisyen · kréyòl gwadloupéyen · Kurdî · latviešu · Lëtzebuergesch · lietuvių · magyar · Malagasy · Malti · Nederlands · Nedersaksies · norsk bokmål · norsk nynorsk · occitan · Oromoo · oʻzbekcha/ўзбекча · Plattdüütsch · polski · português · română · shqip · slovenčina · slovenščina · Soomaaliga · suomi · svenska · Tiếng Việt · Türkçe · Vahcuengh · vèneto · Wolof · Yorùbá · Zazaki · српски / srpski · беларуская · български · қазақша · македонски · монгол · русский · тоҷикӣ · українська · Ελληνικά · Հայերեն · ქართული · नेपाली · मराठी · हिन्दी · भोजपुरी · অসমীয়া · বাংলা · ਪੰਜਾਬੀ · ગુજરાતી · ଓଡ଼ିଆ · தமிழ் · తెలుగు · ಕನ್ನಡ · മലയാളം · සිංහල · བོད་ཡིག · ไทย · မြန်မာဘာသာ · ລາວ · ភាសាខ្មែរ · ⵜⴰⵎⴰⵣⵉⵖⵜ ⵜⴰⵏⴰⵡⴰⵢⵜ‎ · አማርኛ · 한국어 · 日本語 · 中文(简体)‎ · 中文(繁體)‎ · 吴语 · 粵語 · ייִדיש · עברית · اردو · العربية · پښتو · سنڌي · فارسی · ދިވެހިބަސް
その他の言語このウィキの翻訳を支援してください
  はじめに   基本編   上級編   プラグイン   FAQ(en) ±

.osmファイルのセーブとロード

多くの目的のために、データのダウンロードとユーザによるデータの変更のアップロードをしたいと思うでしょう。変更した部分をアップロードする時、変更を効果的に"保存"できます。それより良いのは、変更した部分をマップ上で見るために、他の人に渡せるようになり、また、それに対してさらに変更を行う事もできるようになります。OpenStreetMapはすべてインターネットによる共同作業です!しかし、JOSMは、ローカルディスクからファイルをセーブしたり開くことで、ローカルファイルシステム上で作業することも出来ます。この作業は他のデスクトップアプリケーションととてもよく似ています。

'ファイル' メニュー > '名前を付けて保存...'を使う事で、データ(と変更分)をファイルにセーブします。

'ファイル' メニュー > '開く...'を使う事で、以前にセーブしたファイルを編集またはアップロードのために開きます。

JOSMファイル形式は、標準.osm形式中ではOpenStreetMapのXML表現形式です。JOSMはOpenStreetMapデータに対して、変更の詳細を格納するために若干拡張しています。すなわち、ファイルをセーブする時に、その時点でアップロードされていない何らかの変更に対してです。これは、JOSMが以下のようにオフラインエディタとして使う事が出来るということを意味する、とても強力な機能です。

オフライン編集

インターネットに接続している間は...

  • 地図のある領域をダウンロードできます(1つまたはいくつかの制限された領域が指定できます)
  • ローカルディスク中に.osmファイルとしてデータをセーブできます。

インターネットに接続されていなくて、オフライン状態の時は...

  • ファイルを開きます。
  • おそらくGPSのトレースを開き、データ上にそれを上書きするでしょう(これはオフラインでもうまく動きます)。
  • 変更を行います。すなわち、調査していた間に取得したローカルな情報を追加します。
  • 変更をファイルにセーブします。ファイルはデータの移動と削除を含むすべての変更情報を含みます。

もう一度インターネットに接続した時...

  • JOSMにディスク中のファイルを開きます。
  • "ファイル"メニュー > "データの更新"を選び、作業中の領域を再度ダウンロードします。競合したら解決します(以下の節を参照)。
  • OpenStreetMapサーバに変更点をアップロードし保存します。

競合の解決

JOSMで編集している時、同じ時に同じ領域のデータを、他の人が編集できます。JOSMは問い合わせを行った時にのみ データをダウンロードします。これは、潜在的な衝突に注意することなく、とても長い編集セッションを行う事が出来るという 事を意味します。一般的に、それが行える時に、定期的にアップロードすることは良い方法で、これは、何らかの競合への 影響を減らすという可能性があります。しかし、アップロードの前にダウンロードすることも良い方法です。 ダウンロード操作はサーバからのデータによって変更した結果を上書きすることはありません。変更した結果が なくなることを心配する必要はありませんが、アップロードする前に、他の誰かが行った何らかの変更(あるいは 新たに追加したデータ)を確認する事ができる事を意味します。

明らかに、他の利用者によるこれらの変更は、アップロードの前にチェックすべきものです。もしも他の利用者が、 あなたが行ったものと、明確に同じ要素を変更した場合、JOSMは、"競合"を通知します。この段階で、あなたはまだ 行った変更をアップロードしていません。アップロードの前に競合を解決する事を強制されます。この機能は、 他の利用者にと競合した領域を見つけるために手助けになるように設計されました。これは、おのおのの場合において、 他の人の変更をあなたの変更で上書きするかをピックアップし、選択するようにします。競合を解決後、あなたの 変更点をアップロード出来ます。

右側の競合パネルの表示を、見えるようにします。そこには競合の一覧が表示されていて、おのおのを解決するためのウィンドウを 開くことが出来ます。あなた自身のものか、他の人のものか、どのバージョンを保持するかを選べる選択肢が与えられます。 数多くのタブと表示が、おのおのの場合においてのデータの表現が何なのかを理解する手助けになるよう設計されています。 これは若干複雑で明確でないように見えますが、常時単純な選択に落ち着きます:要するに、自分のものか他のものかを保持する、 ということです。"他のもの"は、最初にダウンロードした時に存在した要素の状態から変更された、サーバ上の、現在のデータの 状態を参照しています。すなわち、他の誰かがこの要素を変更したように見えると言うことです。

分離と分解

基本編において、ノードとウェイの編集方法や、ウェイの分割/併合と反転のような操作についても説明しました。データが絡み合っていたり、オーバラップしていたり、複雑な形でもつれている時、物事は若干扱いにくくなります。しかし、常時変更を行うことが出来、うまくいかない場合に少々の手間で'元に戻す'ことができる事を覚えておいてください。また、データをリストアする前に、一時的にノードを移動したり、結合の状況とオーバラップを理解するために、要素を消すことも出来ます。以下ではいくつかの補足的な編集技術を紹介します:

オーバラップしたウェイ 2つ以上のウェイが同じ2つのノードの間の、正確に最上位でお互いに描画されている場合は、何らかの事故によるものか、あるいは何らかの表現の修正かもしれません(2つのhighwayは通常このようにお互いをオーバラップすべきではないのですが、たとえば、境界にあるhighwayを共有するノードがあるlanduse領域を横切っていてるかもしれません)。この状況の場合、オーバラップしたwayの他のどれかを選択する必要があるかもしれません。これを行うためにはいくつかの方法があります:

  • マウス配下の、最上位のすべての要素の異なったタグを表示するコンテキストメニューは中ボタンクリックで現れます。
  • Ctrlキーを押しっぱなしにすると、選択を変更するためのメニューをクリックすることが出来ます。
  • その代わりに、中ボタンを繰り返しクリックすると、選択を切り替えることが出来ます。
  • もしも、中ボタンがない場合、Altキーを押して、繰り返し左クリックを行う事で、選択を切り替えることが出来ます。

ウェイの分離は'ツール'メニューのオプションです。もしも2つ(あるいはそれ以上)のウェイが1つのノードに接続されている場合、このオプションは、2番目のノードを作成し、1つのウェイから他のものを自由にします。これは通常、両方のノードが選択されたままとなっている'重複ノード'(1つのもの正確な最上位に2つの異なったノードが配置されている)が出来上がると言うことに注意してください。フォローアップとして、あるいは状況を理解するために、選択を外してもよく、その次に脇の方に、トップノードをドラッグします。データ中で重複ノードを残したままにすることを防ぐために、これを行う必要があります。通常これらは良くないことと考えられ、しばしば混乱と、ルートの接続性問題を引き起こします。データ中にそれらを置く必然性はありません。'ウェイの分離'動作はまた、ウェイの要素が選択され、その全体の長さにそって共有する任意のノードからそれを分離するために使われます。

ここで説明した機能は複雑なデータを処理する時に、部分的は便利です。ツールメニュー上では、他のいくつかの動作があり、プラグイン経由でさらにたくさんのものがインストールされます。

リレーション

リレーションは、ルートとターン規制のような、ある種のより高度な種類のマップフューチャーやgeodataを表現するために使う事が出来る、要素のタイプです。"ノード"と"ウェイ"のような要素はリレーションのメンバになれます。リレーションはリレーションのメンバにもなれます(階層的)。おのおののメンバシップのための"ロール"に名前を付けることが出来、全体のリレーションはタグを与えられます。詳細はリレーションの説明ページを参照してください。

JOSMはリレーション全体に対する生の編集能力を提供するインタフェースを用意しています。メインのリレーションダイアログにアクセスするいくつかの方法があります。

Liste aller Relationen.png
リレーションパネルは右端に表示されます。左端のボタンをクリックすることで、表示の有無を切り替えられます。パネルはダウンロード領域のすべてのリレーションを一覧表示し、作成、編集、複製、削除とリレーションの選択機能を提供します。

The "properties/membership" panel, which you normally use to view and edit tags, will also show relations, this time just those of the selected element (the element's memberships). 通常タグを表示、編集するために使う"プロパティ/メンバ"パネルは、リレーションも表示し、

For creating brand new relations you need to use the relations panel, but both the panels give access to the dialog for editing existing relations. The main relation editing dialogue is split into three areas. At the top you can edit the tags of the relation. At the bottom-left is list of elements which are members, with a column for the roles. The list is ordered (which may or may not be significant) On the bottom-right there is a pick-list of elements. This list is linked to the element selection you currently have in the background data view. Adjust your selection in the background to bring elements onto the list can then be added to the relation. まっさらの新しいリレーションの作成のためには、リレーションパネルを使う必要がありますが、両方のパネルは既存のリレーションを編集するためのダイアログにアクセス出来るようにします。メインのリレーション編集ダイアログは3つの領域に分かれます。最上位の部分では、リレーションのタグを編集できます。下の左側では、roleの欄があるメンバである要素の一覧です。一覧は(意味がある場合もあり、無い場合もある)順番になっています。下の右側は要素のパックリストがあります。この一覧はバックグラウンドのデータ表示中に現在保持している選択要素にリンクされているものです。リスト上に要素を運ぶために背景中で選択した要素を調整することは、次にリレーションに追加することになります。

これが、ごく簡単なJOSMにおけるリレーションの編集に対する説明です。これらの機能のより詳細な説明は、 'Relations' help documentationを参照してください。機能は比較的新しく、引き続き開発が行われていることに注意してください。



次 >>

これらはかなり高度な機能ですが、種々のJOSMプラグインについて学ぶためのより多くの手段があります。