El:JOSM/Advanced editing

From OpenStreetMap Wiki
Jump to: navigation, search
Ξεκινήστε και κατεβάστε δεδομένα του OSM Βασική επεξεργασία Προχωρημένη επεξεργασία Πρόσθετα FAQ (en)

Αποθηκεύοντας και φορτώνοντας αρχεία .osm

Για πολλούς λόγους ενδεχομένως θα θέλετε να κολλήσετε με τα δεδομένα που κατεβάζετε και μεταφορτώνετε και τις αλλαγές σας. Όταν μεταφρορτώνετε τις αλλαγές σας αυσιαστικά έχετε "αποθηκεύσει" (saved) τις αλλαγές σας. Καλύτερα από αυτό, έχετε κάνει τις αλλαγές σας διαθέσιμες στον υπόλοιπο κόσμο να τις δει στον χάρτη, και να να κάνει περαιτέρω αλλαγές. Το OpenStreetMap έχει να κάνει με την διαδυκτιακή συνεργασία! Ωστόσο το JOSM μπορεί επίσης να δουλέψει με αρχεία στο τοπικό σας σύστημα αρχείων, αποθηκεύοντας και ανοίγοντας αρχεία από και προς τον τοπικό σας δίσκο.

Χρησιμοποιήστε το μενού "αρχείο" (file) → "Αποθήκευση Ως..." (Save As...) για να αποθηκεύσετε τα δεδομένα (και τις αλλαγές σας) σε ένα αρχείο.

Χρησιμοποιήστε το μενού "αρχείο" (file) → "Άνοιγμα..." (Open..) για να ανοίξετε ένα αποθηκευμένο νωρίτερα αρχείο για επεξεργασία ή για μεταφόρτωση.

Το format αρχείο του JOSM είναι μία XML παρουσίαση δεδομένων του OpenStreetMap στο πρότυπο format .osm. Το JOSM το επεκτείνει αυτό λίγο για να αποθηκεύσει λεπτομένρειες των αλλαγών στα δεδομένα του OpenStreetMap, με άλλα λόγια, κάθε αλλαγή η οποία δεν μεταφορτώνετε την στιγμή που αποθηκεύτηκε το αρχείο. Αυτό είναι ένα ισχυρό χαρακτηριστικό που σημαίνει πως το JOSM μπορεί να χρησιμοποιηθεί ως επεξεργαστής εκτός σύνδεσης ως ακολούθως:

Επεξεργασία χωρίς σύνδεση

Όταν έχετε σύνδεση στο διαδίκτυο...

  • Κατεβάστε μία περιοχή του χάρτη (μπορεί να είναι ένα ή περισσότερα συνδεδεμένα κουτιά)
  • Αποθηκεύστε τα δεδομένα ως αρχεία .osm στον τοπικό σας δίσκο

Όταν βρίσκεστε σε μη σύνδεση στο διαδίκτυο...

  • Ανοίξτε το αρχείο
  • Ενδεχομένως ανοίξτε τα ίχνη GPS και επικαλύψτε τα στα δεδομένα (Αυτό μπορεί επίσης να δουλέψει εκτός σύνδεσης)
  • Κάντε αλλαγές π.χ. προσθήκη τοπικών πληροφοριών που έχετε συλλέξει κατά την αποτύπωση στο πεδίο
  • Αποθηκεύστε τις αλλαγές πίσω στο αρχείο. Το αρχείο περιλαμβάνει πληροφορίες σχετικά με όλες σας τις αλλαγές συμπεριλαμβανομένων δεδομένων κινήσεων και διαγραφών.

Όταν είστε πίσω στην σύνδεση στο διαδίκτυο...

  • Ανοίξτε το αρχείο από τον δίσκο σαςστο JOSM
  • Κάντε από το μενού "Αρχείο" (File) → "Ενημέρωση Δεδομένων" (Update Data) να ξανά κατεβάσει τις περιοχές που δουλεύατε. Επιλύστε κάθε σύγκρουση (δείτε στην ακόλουθη ενότητα)
  • Κάντε κλικ στην μεταφόρτωση για να αποθηκεύσετε τις αλλαγές στον server του OpenStreetMap.

Φιλτραρισμένα Δεδομένα

Μπορείτε να φιλτράρετε τα δεδομένα του OpenStreetMap (π.χ. βάσει ετικέτας, να δώσετε μία θεματική εξαγωγή) είτε μέσω χειρισμού αρχείων .osm στον δίσκο σας με την χρήση εργαλείων όπως το osmosis, το osmconvert ή το osmfilter, είτε μέσω αναζήτησης φιλτραρισμένων δεδομένων από μία ειδική ΑΡΙ όπως το ΧΑΡΙ ή το Overpass API. Τότε εσείς μπορείτε να φορτώσετε φιλτραρισμένα δεδομένα στο JOSM. Αυτός μπορεί να είναι ο καλύτερος τρόπος να ρίξετε μια ματιά σε αυτό, αλλά προσέξτε όταν επεξεργάζεστε. Δεν πρέπει να διαγράψετε ή να μετακινήσετε κανέναν κόμβο χωρίς να κάνετε πρώτα ένα κανονικό αφιλτράριστο κατέβασμα τριγύρω, για να έχετε όλα τα συνδεδεμένα στοιχεία.

Γεωμετρικές και τοπολογικές επεξεργασίες

Προσθέτοντας και προσαρμόζοντας κόμβους σε μία διαδρομή

Μπορείτε να μετακινήσετε κόμβους και διαδρομές επιλέγοντάς τα και, ενώ είναι ακόμα στην κατάσταση "Επιλογή" [(S)elect], να τα σύρετε.Την συντριπτική πλειοψηφία του χρόνου θα σας ενδιαφέρει να μετακινήσετε μόνο έναν κόμβο την φορά. Καθαρίστε την επιλογή σας πρις σύρετε τον κόμβο. Εάν κατά λάθος μετακινήσετε ολόκληρη την διαδρομή χρησιμοποιήστε το Ctrl-Z για να αναιρέσετε.

Μπορείτε να προσθέσετε κόμβους στην μέση μιας διαδρομής πηγαίνοντας στην κατάσταση Πρόσθεσης [(A)dd], και κάνοντας κλικ στο τμήμα της διαδρομής στο επιθυμητό σημείο. Έπειτα επιστρέψτε στην κατάσταση Επιλογής [(S)elect], εκτός και αν κατασκευάζετε μία ενωμένη διαδρομή. Για να προσθέσετε και άλλον κόμβο δίπλα από το τμήμα αυτής της διαδρομής, βεβαιωθείτε να καθαρίσετε την επιλογή σας πριν προσθέσετε ξανά. Προσέξτε όταν προσθέτετε κόμβους στο μέρος όπου πολλές διαδρομές είναι κοντά (διασταυρώνονται ή τρέχουν παράλληλα) είναι αρκετά εύκολο κατά λάθος να προστεθεί νέος κόμβος ο οποίος συσσωρεύεται μαζί με διάφορες διαδρομές.Αναιρέστε! Ο ευκολότερος τρόπος για να το αποφύγετε αυτό, είναι να κάνετε προσωρινή μεγέθυνση, ώστε τα αντικείμενα να απέχουν σωστά.

Υπάρχει και άλλο κόλπο για την προσθήκη κόμβου σε υπάρχουσα διαδρομή. Προσέξτε για τους μικρούς σταυρούς που εμφανίζονται στην μέση των τμημάτων. Μπορείτε να τους σύρετε για να προσθέσετε γρήγορα έναν κόμβο χωρίς να αφήσετε την κατάσταση επιλογής.

Διαγράψτε έναν κόμβο επιλέγοντάς τον και πατώντας το κουμπί Delete (Διαγραφή). Αυτό θα διαγράψει τα επιλεγμένα τμήματα, αλλά θα σας κρατήσει στην κατάσταση Επιλογής [(S)elect].

Χωρίζοντας και ενώνοντας διαδρομές

Splitway.png Μπορείτε να γίνει χώρισμα (split) μιας μεγάλης διαδρομής σε δύο μικρότερες διαδρομές. Επιλέξτε τον κόμβο όπου πρέπει να συμβεί το χώρισμα, και επιλέξτε από το μενού "Εργαλεία" (Tools) → "Χώρισμα Διαδρομής" (Split Way). Μπορείτε να το κάνετε αυτό αρκετές φορές και να κόψετε την διαδρομή σε αρκετά τμήματα. Οι διαδρομές που θα προκύψουν θα μοιράζονται αρχικά τις ίδιες ετικέτες, αλλά είναι ξεχωριστές διαδρομές τώρα. Γι' αυτό μπορείτε να τους δώσετε διαφορετικές ετικέτες.

Κάποιες φορές θα πρέπει να κάνετε κάποια έξυπνη επιλογή για να υποδείξετε ακριβώς ποιό χώρισμα πρέπει να εκτελέσει το JOSM. Εάν ένα κόμβος είναι συνδεδεμένος σε πολλαπλές διαδρομές, θα πρέπει να επιλέξετε τον κόμβο και την διαδρομή την οποία θέλετε να χωρίσετε. Για να το κάνετε αυτό, επιλέξτε την διαδρομή και μετά ενώ κρατάτε το shift, κάντε κλίκ στον κόμβο. Ένα άλλο κόλπο είναι να επιλέξετε δύο κόμβους πριν κάνετε κλικ στο "Χώρισμα Διαδρομής" (Split Way). Κάνοντας αυτό, μία διαδρομή μπορεί να χωριστεί σε δύο διαφορετικούς κόμβους την ίδια στιγμή. Αυτό μπορεί να κάνει εξοικονόμηση χρόνου, αλλά πραγματικά απαιτείτε να το κάνετε αυτό χωρίζετε μία διαδρομή η οποία σχηματίζει κύκλο.

Combineway.png Το αντίθετο είδος διεγασίας, είναι να γίνει ένωση (combine) δύο διαδρομών μαζί για να σχηματίσουν μία. Μπορείτε να το κάνετε αυτό μόνο με δύο τρόπους που είναι η τακτοποίηση άκρη με άκρη (είναι στην σειρά έτοιμοι να ενωθούν σε μία διαδρομή). Επιλέξτε και τους δύο από τις διαδρομές ταυτόχρονα. Πάλι αυτό μπορεί να επιτευχθεί πατώντας το shift για να προσθέσετε την επιλογή σας. Κάντε κλικ στο μενού "Εργαλεία" (Tools) → "Ένωση Διαδρομής" (Combine Way). Σε αυτό το σημείο το JOSM θα δημιουργήσει μία ενιαία διαδρομή. Εάν οι δύο διαδρομές έχουν διαφορετικές ετικέτες, τότε η ενωμένη διαδρομή θα μοιραστούν όλες τις ετικέτες και των δύο. Μπορεί να σας γίνει υπενθύμιση για "επίλυση σύγκρουση" (solve conflicts) με ετικέτες, όπου στο ίδιο κλειδί έχουν οριστεί διαφορετικές τιμές στις δύο διαφορετικές διαδρομές. Εάν χρειάζεστε διαφορετικές ετικέτες, τότε χρειάζεστε διαφορετικές διαδρομές.

Wayflip.png Η ενέργεια αντιστροφή διαδρομής θα αλλάξει την κατεύθυνση της διαδρομής. Κάθε διαδρομή έχει μία κατεύθυνση η οποία υποδεικνύεται με βέλη όταν η διαδρομή είναι επιλεγμένη. Όπως αναφέρθηκε πιο πάνω, οι διαδρομές πρέπει να τακτοποιούνται άκρη με άκρη πριν ενωθούν, και αυτό περιλαμβάνει την στόχευση προς την ίδια κατεύθυνση (αν και θα σας υποδείξει να κάνετε αυτόματα αντιστροφή εάν δεν είναι σωστά άκρη με άκρη). Συχνά η κατεύθυνση μιας διαδρομής δεν έχει σημασία, αλλά μπορεί να χρησιμοποιηθεί για να υποδείξει κατευθυντήρια χαρακτηριστικά. Μερικά σημαντικά παραδείγματα περιλαμβάνουν:

  • Περιορισμοί μονόδρομου με την ετικέτα oneway=yes.
  • Το waterway=river πρέπει να στοχεύει προς την κατεύθυνση της ροής (κατηφορικά)
  • Το natural=coastline το οποίο πρέπει να την κατεύθυνση με την γη στα αριστερά, και την θάλασσα στα δεξιά.

Μπορείτε να ρυθμίσετε την τοπολογική διάταξη των κόμβων και των διαδρομών με πολλά εναλλακτικά στη σειρά κλικ και πατήματα κουμπιών. Αυτό μπορεί να είναι περίπλοκο στην αρχή, αλλά θα γίνετε αυθεντία με λίγη πρακτική. Χρησιμοποιήστε το Ctrl-Z για να αναιρέσετε. Κάντε παιχνίδι!

Ξεκόλλημα και ξεμπλοκάρισμα

Στην ενότητα επεξεργασίας JOSM/Basic περιγράψαμε τον τρόπο επεξεργασίας κόμβων και διαδρομών, καθώς και λειτουργίες όπως χώρισμα/ένωση/αντιστροφή διαδρομών. Τα πράγματα μπορούν να γίνουν λίγο πιο πολύπλοκα όταν τα δεδομένα είναι αλληλένδετα, επικαλύπτονται ή μπερδεμένα με πολύπλοκο τρόπο, αλλά θυμηθείτε ότι μπορείτε πάντα να προσπαθήσετε να κάνετε αλλαγές και στη συνέχεια να «αναιρέσετε» μερικά βήματα αν τα πράγματα δεν λειτουργούν σωστά. Μπορείτε επίσης να μετακινήσετε προσωρινά κόμβους ή ακόμα και να διαγράψετε στοιχεία για να κατανοήσετε τις συνδέσεις και τις αλληλεπικαλύψεις, προτού αναιρέσετε την επαναφορά των δεδομένων. Ακολουθούν μερικές επιπλέον τεχνικές επεξεργασίας:

Επικαλυπτόμενες διαδρομές, όπου δύο ή περισσότερες διαδρομές είναι σχεδιασμένες ακριβώς πάνω η μία στην άλλη ανάμεσα στους ίδιους δύο κόμβους, αυτό μπορεί να γίνει από λάθος ή μπορεί να είναι η σωστή αναπαράσταση για κάτι (Δύο δρόμοι δεν πρέπει κανονικά να επικαλύπτονται μεταξύ τους έτσι, αλλά μπορεί να πλησιάζει πάνω σε περιοχές χρήσης γης (landuse) με τους κόμβους μοιρασμένους με τους γειτονικούς δρόμους για παράδειγμα). Σε αυτή την κατάσταση θα πρέπει να επιλέξετε την μία ή την άλλη επικαλυπτόμενη διαδρομή. Υπάρχουν διάφοροι τρόποι να γίνει αυτό:

  • Το μεσαίο κλικ εμφανίζει ένα πλαίσιο μενού που δείχνει τις διαφορετικές ετικέτες όλων των στοιχείων κάτω από το ποντίκι.
  • Κρατώντας κάτω το Ctrl σας επιτρέπετε να κάνετε κλικ στο μενού για να αλλάξετε την επιλογή.
  • Εναλλακτικά επαναλαμβανόμενο το μεσαίο κλικ θα γυρίσει μέσα από την επιλογή.
  • Εάν δεν έχετε ποντίκι με μεσαίο κουμπί, κρατήστε κάτω το κουμπί "Alt" στην δεξιά πλευρά του πληκτρολογίου σας και επαναλάβετε το αριστερό κλικ για να κυλίσετε μέσα από την επιλογή.

Ξεκόλλημα διαδρομών είναι μία επιλογή στο μενού "Εργαλεία" (Tools). Εάν δύο (ή περισσότερες) διαδρομές είναι συνδεδεμένες σε έναν κόμβο, αυτή η επιλογή θα δημιουργήσει έναν δεύτερο κόμβο, απελευθερώνοντας την μία διαδρομή από την άλλη. Σημειώστε πως αυτό κανονικά έχει ως αποτέλεσμα την "αντιγραφή κόμβου" (duplicate node) (δύο διαφορετικοί κόμβοι κάθονται ακριβώς ο ένας πάνω στον άλλο) και με τους δύο κόμβους να είναι επιλεγμένοι.

Ως επακόλουθο ή απλά για να κατανοήσετε την κατάσταση, μπορεί να θέλετε να καθαρίσετε την επιλογή σας και στη συνέχεια να σύρετε μόνο τον επάνω κόμβο στη μία πλευρά. Θα πρέπει να το κάνετε αυτό για να αποφύγετε να αφήσετε διπλό κόμβο μέσα στα δεδομένα. Αυτό θεωρείτε συνήθως ως κάτι κακό, με συχνό αποτέλεσμα την σύγχυση και την προβληματική συνοχή της δρομολόγησης. Δεν θα πρέπει να υπάρξει καμία ανάγκη για αυτά στα δεδομένα. Η δράση "Ξεκόλλημα διαδρομών" (unglue ways) μπορεί επίσης να χρησιμοποιηθεί με ένα επιλεγμένο στοιχείο διαδρομής, για να ξεκολλήσει από οποιοσδήποτε κόμβους μοιράζετε κατά μήκος σε ολόκληρη την έκταση. Εάν θέλετε να ενώσετε αυτούς τους κόμβους μαζί ξανά, χρησιμοποιήστε το "Εραγαλεία" (Tools) → "Ένωση Κόμβων" (Merge nodes) - αλλά σημειώστε πως αυτό ενώνει όλους τους κόμβους που βρίσκονται πολύ κοντά.

Το χαρακτηριστικό που περιγράφτηκε εδώ είναι ιδιαίτερα χρήσιμο για εργασία με πολύπλοκα δεδομένα. Υπάρχουν αρκετές άλλες ενέργειες στο μενού με τα εργαλεία (tools), και περισσότερα μπορούν να εγκατασταθούν μέσα από τα πρόσθετα.

Επιλύοντας τις συγκρούσεις

Όσο επεξεργάζεστε με το JOSM, υπάρχει μία πιθανότητα που μπορεί άλλα μέλη να επεξεργάζονται τα δεδομένα της ίδιας περιοχής την ίδια χρονική στιγμή. Το JOSM μόνο κατεβάζει δεδομένα όταν το ζητάτε, το οποίο σημαίνει ότι μπορείτε αρκετά μεγάλη περίοδο επεξεργασίας χωρίς απαραίτητα να αντιληφθείτε ενδεχόμενες συγκρούσεις με άλλους συνεισφέροντες. Γενικά είναι καλή ιδέα να μεταφορτώνετε συχνά εάν είστε σε θέση να το κάνετε αυτό, για να μειώσετε την πιθανότητα και την επίδραση οποιασδήποτε σύγκρουσης. Αλλά μπορεί να είναι επίσης καλή ιδέα να κατεβάζετε πριν μεταφορτώσετε. Η ενέργεια του κατεβάσματος δεν αντικαθιστά τις αλλαγές σας με δεδομένα από τον server. Δεν χρειάζεται να ανησυχείτε σχετικά με το να χάσετε κάποιες από τις αλλαγές σας, αλλά αυτό σημαίνει πως έχετε την δυνατότητα να δείτε οποιαδήποτε αλλαγή που άλλοι χρήστες μπορεί να έχουν κάνει (ή νέα δεδομένα έχουν προστεθεί) πριν κάνετε εσείς την μεταφόρτωση.

Προφανώς οι αλλαγές που έγιναν από άλλους χρήστες είναι κάτι που πρέπει να ελέγξετε πριν την μεταφόρτωση. Εάν άλλος χρήστης έχει αλλάξει ακριβώς το ίδιο αντικείμενο το οποίο έχετε εσείς αλλάξει, τότε το JOSM αναφέρει μία "σύγκρουση" (conflict). Σε αυτό το στάδιο δεν πρέπει ακόμα να μεταφορτώσετε τις αλλαγές σας. είστε αναγκασμένος να επιλύσετε τις συγκρούσεις πριν μεταφορτώσετε. Αυτό το χαρακτηριστικό είναι σχεδιασμένο να βρίσκετε περιοχές στις οποίες έχετε συγκρούσεις με άλλους χρήστες. Σας επιτρέπει να επιλέξετε και να αντικαταστίσετε τις αλλαγές των άλλων μελών με τις δικές σας σε κάθε περίπτωση. Αφού έχετε επιλύσει τις συγκρούσεις μπορείτε να μεταφορτώσετε τις αλλαγές σας.

Konflikte loesen.png Ενεργοποιείστε την ορατότητα του πάνελ σύγκρουσης στα δεξιά. Εδώ οι συγκρούσεις είναι σε λίστα, και μπορείτε να ανοίξετε ένα παράθυρο για να επιλύσετε το κάθε ένα. Σας δίνετε η επιλογή να επιλέξετε ποιανού η εκδοχή θα μείνει, η δική σας ή των άλλων. Διάφορες ετικέτες και παρουσιάσεις είναι σχεδιασμένα για να σας βοηθήσουν να καταλάβετε τι αντιπροσωπεύουν τα δεδομένα σε κάθε περίπτωση. Αυτό μπορεί να δείχνιε λίγο περίπλοκο και ασαφές, αλλά πάντα εμφανίζεται με την απλή επιλογή: να μείνουν τα δικά σας ή των άλλων. "Των άλλων" (Theirs) αφορά την τρέχουσα κατάσταση των δεδομένων στον server, το οποίο μπορεί να είναι αλλαγμένο από την κατάσταση των αντικειμένων όπως ήταν όταν αρχικά τα κατεβάσατε, π.χ. εμφανίζεται ότι κάποιος άλλος επεξεργάστηκε αυτό το αντικείμενο.

Σχέσεις

Οι σχέσεις είναι ένα είδος των στοιχείων ο οποίος μπορεί να χρησιμοποιηθεί για να αντιπροσωπεύσει μερικά ακόμη προχωρημένα είδη του χάρτη χαρακτηριστικά και για γεωγραφικά δεδομένα, όπως περιορισνμούς δρομολογίων και στροφών. Στοιχεία όπως "κόμβοι" (nodes) και "διαδρομές" (ways) μπορούν να είναι μέλη των σχέσεων. Σχέσεις μπορούν να είναι μέλη άλλων σχέσεων επίσης (σε ιεραρχία). Για κάθε ένα από αυτά τα μέλη ο "ρόλος" (role) μπορεί να ονοματιστεί, και η συνολική σχέση πέρνει ετικέτα. Δείτε την σελίδα των Σχέσεων (Relations) για περισσότερες λεπτομέρειες.

Το JOSM παρέχει μία διασύνδεση για να σας δώσει ωμή δύναμη επεξεργασίας πάνω στις σχέσεις. Υπάρχουν αρκετοί τρόποι για πρόσβαση στον κύριο διάλογο σχέσεων.

Liste aller Relationen.png Ο πίνακας των σχέσεων μπορεί να εμφανιστεί στην δεξιά πλευρά. Ενεργοποιήστε την ορατότητα πατώντας το κουμπί στα αριστερά. Ο πίνακας εμφανίζει σε λίστα όλες τις σχέσεις στην κατεβασμένη περιοχή, και παρέχει κουμπιά για δημιουργία, επεξεργασία, αντιγραφή και επιλογή μιας σχέσης.

Ο πίνακας "Ετικέτες/Μέλη" (Tags/Memberships), τον οποίο κανονικά χρησιμοποιείτε για να δείτε και να επεξεργαστείτε ετικέτες, δείχνει επίσης σχέσεις, αυτή την φορά μόνο αυτέςτων επιλεγμένων στοιχείων (τα στοιχεία των μελών).

Για την δημιουργία μιας ολοκαίνουργιας σχέσης χρειάζεται να χρησιμοποιήσετε τον πίνακα των σχέσεων, αλλά και οι δύο πίνακες δίνουν πρόσβαση στον διάλογο για την επεξεργασία των υπαρχόντων σχέσεων. Ο κύριος διάλογος επεξεργασίας σχέσεων είναι χωρισμένος σε τρία τμήματα. Στην κορυφή μπορείτε να επεξεργαστείτε τις ετικέτες της σχέσης. Στην βάση αριστερά είναι η λίστα με τα στοιχεία ποιανού μέλους είναι, με στήλες για τους σκοπούς. Αυτή η λίστα είναι σε σειρά (που μπορεί να είναι ή να μην είναι σημαντική). Στην βάση δεξιά υπάρχει μία λίστα στοιχείων. Αυτή η λίστα είναι συνδεδεμένη με το επιλεγμένο στοιχείο που τώρα έχετε στη θέαση δεδομένων στο φόντο. ρυθμίστε την επιλογή σας στο φόντο για να φέρετε στοιχεία μέσα στην λίστα τα οποία θα μπορούν τότε να προστεθούν στην σχέση.

Δημιουργία μιας νέας σχέσης

  • Στον πίνακα των Σχέσεων πατήστε το κουμπί "Δημιουργία μιας νέας σχέσης" (Create a new relation)
  • Στο παράθυρο "Δημιουργία νέας σχέσης" (Create new relation) προσθέστε τις κατάλληλες ετικέτες
  • Προσθέστε μέλη σχέσεων και προσθέστε ρόλους
  • Κάντε κλικ στο ΟΚ για να κλείσει το παράθυρο "Δημιουργία νέας σχέσης" (Create new relation)
  • Παράδειγμα σε Video

Προσθήκη νέων μελών σε μία σχέση

  • Στο κύριο παράθυρο επιλέξτε τις διαδρομές/κόμβους που θα προστεθούν στην σχέση
  • Επιλέξτε την απαιτούμενη σχέση από την λίστα των σχέσεων στον πίνακα των Σχέσεων
  • Κάντε κλικ στο κουμπί "Ανοίχτε τον επεξεργαστή για την επιλογή σχέσης" (Open an editor for the selected relation)
  • Στο παράθυρο "Επεξεργασία σχέσης" (Edit relation) επιλέξτε το υπάρχον μέλος (εάν παρουσιάζεται) ώστε ο νέος κόμβος/διαδρομή να είναι ο επόμενος και πατήστε κλικ στο καταλληλο κουμπί "Προσθήκη όλων των στοιχείων..." (Add all primitives...) στην περιοχή επιλογής
  • Κάντε κλικ στο ΟΚ για να κλείσετε το παράθυρο "Επεξεργασία σχέσης" (Edit relation)

Το JOSM σας επιτρέπει να ταξινομήσετε τα μέλη, και αυτό είναι το συνιστώμενο για κάποιους τύπους σχέσεων. π.χ. σχέσεις δρομολόγιου, πολυπολύγωνα, .... Η ταξινόμηση των μελών σας επιτρέπει να εξασφαλίσετε ότι τα μέλη είναι συνδεδεμένα, και να εντοπίσετε οποιαδήποτε ασύνδετη διαδρομή. Για να ταξινομήσετε τα μέλη κάντε κλικ στα κουμπιά Α-Ζ στον επεξεργαστή σχέσεων.

Περισσότερες πληροφορίες

Προκαθορισμένες Ετικέτες

Το JOSM υποστηρίζει προκαθορισμένες ετικέτες διανομής. Αυτό είναι ένα αρχείο ρύθμισης XML που περιγράφει την GUI εισαγωγή ετικετών (ή τις ιδιότητες, τους σχολιασμούς, κάποιες φορές ονομάζονται χαρακτηριστικά χάρτη) διαθέσιμη όταν χρησιμοποιείτε το μενού των Προκαθορισμένων στο JOSM. Τα XML αρχεία μπορούν να τοποθετηθούν οπουδήποτε στο διαδύκτιο ή στο τοπικό σύστημα αρχείων των χρηστών. Οι προκαθορισμένες μπορούν να προστεθούν από τους χρήστες στις Προτιμήσεις (Preferences) του JOSM μέσα στο μενού Ρυθμίσεις Χάρτη (Map Settings) στην καρτέλα Προκαθορισμένες Ετικέτες (Tagging Presets). Αφού προστεθούν, οι προκαθορισμένες (μενού ή απλά κουμπιά) μπορούν να προστεθούν στην γραμμή εργαλείων στις Προτιμήσεις του JOSM κάτω από την προσαρμογή της Γραμμής Εργαλείων (Toolbar customization).

Περισσότερες πληροφορίες στο josm.openstreetmap.de/wiki


Next >>