FR:JOSM/Plugins/OpenData

From OpenStreetMap Wiki
Jump to navigation Jump to search

Introduction

Le greffon JOSM Open Data est conçu pour faciliter l'analyse des données géographiques obtenues à partir de divers portails open data fournissant des données compatibles avec OSM. Il prend en charge une variété de formats de fichiers, permet d'appliquer des balises OSM bien connues à des données spécifiques (via des modules correspondants effectuant un mappage de champ approprié), de télécharger des données existantes dans OpenStreetMap (via Overpass API), et permettra d'effectuer une diff graphique entre elles (pas encore implémentée. Il est probable qu'il sera effectué via le greffon Conflation).

Installation

Pour obtenir la dernière version, vous devez au moins avoir installé JOSM 5132. Ouvrez JOSM et sélectionnez le menu Édition > Préférences, puis Greffon (image puzzle). Cherchez opendata dans la liste. Maintenant, redémarrez JOSM. Notez que le chargement de fichiers volumineux consomme de la mémoire et que vous pouvez souhaiter redémarrer JOSM avec plus de mémoire que vous n'en aviez précédemment. Si vous constatez que JOSM s'arrête et est lent lors de l'importation d'un fichier, cela peut être dû à un manque de mémoire plutôt qu'au greffon lui-même.

Core plugin features

Le plugin permet essentiellement de faire deux choses : importer des données, télécharger les données OSM correspondantes.

Formats de fichiers

L'installation du plugin permet à JOSM de lire ces formats de fichiers :

Format de fichiers Extension(s) Mise en œuvre Commentaires
CSV *.csv personnalisée
OpenDocument *.ods jOpenDocument Format de fichier utilisé par LibreOffice et OpenOffice
Excel *.xls Apache POI Format de fichier utilisé par Microsoft Office
KML *.kml, *.kmz personnalisée Format de fichier utilisé par Google Earth. Voir KML.
GML *.gml personnalisée Voir aussi GML
MapInfo Interchange *.mif personnalisée
MapInfo TAB *.tab personnalisée + GeoTools See also MapInfo
ESRI Shapefile *.shp GeoTools voir aussi Shapefiles.
Zip *.zip java.util
7z *.7z J7Zip
NEPTUNE *.xml personnalisée NEPTUNE est un format d'échange utilisé en France pour décrire les informations sur les transports publics.

Vous n'avez pas besoin d'installer de module pour ouvrir ces fichiers. Vous pouvez ouvrir les fichiers par simple glisser-déposer dans la fenêtre principale de JOSM, ou en utilisant Fichier->Ouvrir et en sélectionnant le filtre de fichier correspondant. Cependant, le comportement du module peut différer selon le format du fichier, voir ci-dessous. Si vous avez un fichier qui ne peut pas être ouvert avec le plugin, faites-le moi savoir sur la talk page, ou mieux, créez un nouveau ticket sur le JOSM bugtracker (component plugin opendata). N'oubliez pas de joindre ou de lier votre fichier si vous souhaitez que la fonctionnalité soit mise en œuvre.

Feuilles de calcul (CSV, XLS, ODS)

Les feuilles de calcul sont adaptées à l'échange de données de type texte mais beaucoup moins pour des données géographiques. Quand vous choisissez d'ouvrir un feulle de calcul, le greffon Open Data tentera d'identifier les deux choses suivantes, nécessaires pour récupérer les données dans OSM :

To answer these questions, the plugin applies a set a of pre-defined patterns on each column name, assuming the first non-empty line is defining the file header. These patterns are currently defined for WGS84 and several "Lambert" West-European projections. When the plugin fails to detect any coordinate, you will have the error message "No valid coordinates have been found". If your file does contain geographic coordinates, please report it on the talk page.

Sometimes, the plugin will find coordinates, but will fail to guess the projection used. In that case, you will be offered to choose a projection among those known by JOSM:

Josm opendata projection popup.png

The CSV file should enclose all fields (except for the coordinates) in quotation marks ("), and use the semicolon (;) as the field separator. Example file:

"latitude";"longitude";"name";"place"
53.5501;10.0099;"Hamburg";"city"
53.7850;10.2839;"Neritz";"village"

The columns "latitude" and "longitude" provide the position (in this case using projection WGS 84). Any additional columns will be imported as tags, with the column name as the tag key and the value for each point as the tag value. So import this example file will load two nodes, both tagged with "name" and "place".

KML/KMZ files

KML files generally express latitude/longitude in WGS84, so do not present the same problems as tabular files. However, the KML support is an extremely simple one, and may not cover all the existing files. If your file does not open, please create a new ticket on the JOSM bugtracker (component plugin opendata). Do not forget to attach or link to your file if you want the feature to be implemented.

GIS files (ESRI shapefiles, MapInfo files)

These files come from professional GIS. They usually embed the projection used in a separate text file, allowing the plugin to know it. However, some parameters known as "Bursa/Wolf parameters" are sometimes needed to convert coordinates to WGS84, and may be missing. In that case, please report it on the talk page, it should be possible to implement these parameters in the next plugin version.

The plugin allows you to bypass this limitation by using a "lenient" transformation without these parameters. A popup will allow you to choose this method or not:

Josm opendata projection error popup.png

The warning is here for a reason: this method can sometimes generate very large location errors (up to 1 km !).

Archive files

The plugin is able to search any of the other supported file formats inside Zip and 7z archives. When a single file is present, it will be opened transparently. When several files are found, you will have to choose which one to open:

Josm opendata zip.png

Download relevant OSM data

Diff

This feature is not implemented yet.

Modules

Modules are to this plugin what plugins are to JOSM: optional, independent JAR files enhancing the default behaviour, potentially written and maintained by different developers. The purpose of a module is to provide everything that is specific to a particular open data portal or geographic area. Indeed, given an open data portal, the corresponding module may, for each supported geographic data set:

  • provide an entry in "Open Data" menu allowing to download data from portal.
  • perform field mapping to convert raw data into a JOSM data layer.
  • provide an Overpass API request allowing to download relevant OSM data from OpenStreetMap database.

List of available modules

Name Country Town/Region Portal OSM wiki Supported data sets Comments Maintainer
be.bruxelles Belgium Brussels [1] 1 For test purpose
be.datagovbe Belgium Whole country [2] 1 For test purpose
fr.cg41 France Loir-et-Cher [3] 2 For test purpose
fr.datagouvfr France Whole country [4] France/data.gouv.fr 9 Don-vip
fr.paris France Paris [5] 1 For test purpose
fr.sncf France SNCF [6] 1 Don-vip
fr.toulouse France Toulouse [7] Toulouse/GrandToulouseData 36 Don-vip

Installing a module

The installation process is similar to JOSM plugins. Open JOSM and select from menu Edit > Preferences, then there Open Data > Download list. Check the module(s) in the list. Now restart JOSM.

You can also copy manually the module JAR in "%APPDATA%\JOSM\plugins\opendata\modules" (Windows) or "~/.josm/plugins/opendata/modules" (Unix).

Enabling/disabling a module

Just like JOSM plugins, check or uncheck the module in Open Data plugin preferences.

Develop a module

This section explains how to develop your own module for you favourite portal. First of all, check the license is compatible with OSM ! If not, stop right here.

Setup directory tree

Writing data sets handlers

Writing main module class

Compiling/publishing the module