From OpenStreetMap Wiki
Jump to navigation Jump to search

Discuss JOSM/Plugins/WMSPlugin here:


What is the setting "Alpha-Channel" in the WMS Layer properties good for? I don't found any documentation for this switch. --chris66 11:10, 27 November 2010 (UTC)

Setting up JOSM to use gnome-web-photo

On Ubuntu 10.04 JOSM won't let me "Select gnome-web-photo --mode=photo --format=png {0} /dev/stdout as the downloader at the bottom of the WMS preferences pane" as mentioned here. It actually won't save the setting but instead just keeps "webkit-image {0}" after closing and reopening the Preferences pane. I can't see any problems with read/write permissions of the /home/.josm folder. Also, I couldn't find any key for this setting in josm's preferences file. Any ideas? --RadHans 18:21, 24 June 2010 (UTC)

Licensing for Yahoo Satellite as opposed to Aerial Imagery

Ulf mentioned yahoo "satellite" tiles under the things which we can't use. I removed that because...

Firstly I think it's probably wrong. It seems likely to me (and yes, ideally we would ask Yahoo for clarification) that the agreement would enable us to use their satellite imagery in areas where they don't have the more detailed aerial imagery... if we really want to, although it's not really much different from landsat imagery is it? i.e. not actually detailed enough to do much with.

But secondly, because it confuses the issue. The main message, which is a very important message to get across to newbies/anyone who might be confused, is that we can trace over some things, but there are some things which we should definately not be tracing over. I dont want the same newbie/confused people to get into tiz about what is satellite and what is aerial imagery, which is something which isn't worth worrying about (as compared to the serious issue of not copying maps)

The idea of this section is not to start drawing subtle liscensing distinctions, but to inform anyone who wasn't already aware, that we don't just trace over maps.

-- Harry Wood 10:21, 21 December 2007 (UTC)

WMS server for Google Maps satellite view

I wrote a simple server to work with this plugin in Python and Twisted. Python eggs 06:26, 18 June 2008 (UTC)

Nice try, but we can't use it. See JOSM/Plugins/WMSPlugin#Licensing. Chriscf 11:26, 18 November 2008 (UTC)
So if the following code just encourages people to breach copyright, can we please change or remove it? Is there any value in this code if it is pointed it at other sources which we can use? -- Harry Wood 11:42, 18 November 2008 (UTC)

Landsat problems

Seems like Landsat doesn't work today (2008-12-08). All my tries during the night (have been working all night) have given the same result: Server returned HTTP response code: 504 for URL:,y,x,y&width=789&height=685. Is this a server problem or an application problem? Have NASA changed the API? --Skippern 10:23, 8 December 2008 (UTC)

Landsat hasn't worked for a while. My understanding is, NASA discontinued the WMS service (anyone have a link for that?) Somebody's written on the page here, landsat is... Currently broken (2008-05-26), NASA site times out. There is a version available for testing that tries to avoid this problem by using "tiled WMS" as suggested on the Landsat server. see User:Bomm#JOSM-WMS-Plugin - Tiled WMS.
But your other option is to use Yahoo. It will give you something pretty much the same as landsat provided you zoom out enough in JOSM so that it isn't trying to fetch hi-res Yahoo aerial photos (if you get the grey error message, zoom out more and try fetching again).
...or your other option is to use the OpenAerialMap WMS Server which will also give you Landsat imagery in areas where better open imagery is not available
-- Harry Wood 10:59, 8 December 2008 (UTC)
Landsat worked fine for me up until today, YWMS is out of the question when I am at work due to a combination of new firefox, runtime restrictions and firewall, and YWMS is difficult private because of (probably wrong setup in) Mac support. At home I have little or no time to trace lakes and rivers, this is mainly done when I have some spare time at work. --Skippern 11:02, 8 December 2008 (UTC)
Yeah come to think of it, I have managed to use it more recently too. Guess it's not always switched off. Seems to be at the moment though. The link I was thinking of was (same as the WMS url) Where it says "Frequent and repetitive requests for non-cached, small WMS tiles require an excessive amount of server resources and will be blocked in order to preserve server functionality". -- Harry Wood 11:22, 8 December 2008 (UTC)
I get the same error (except the code is 500) from the URL provided by OpenArealMap. I am stuck, wait a couple of days and see if landsat comes back online... --Skippern 12:15, 8 December 2008 (UTC)

Using local images (not from WMS server)?

Is there any possibility to use a local image as background for JOSM? I can probably get some pictures from the owners, but it's possible that they request me to be the only one who uses them. In other words: They don't want to have the images on a public server. Critical aspect (Map Rectifier on MetaCarta Labs): "Although you do not grant a copyright license to other users, images are currently all public, so any image you upload will be made available and usable to other users. There is no expectation of privacy or protection of data."

By the way ... is it possible to remove uploaded images from the rectifier server again? What does "private" usage (combo box in upload form) mean? Cannot find any comment on this there.

--Krza 12:47, 31 December 2008 (UTC)

This is an old question. I think there's now a "private" option on Geothings Map Warper, so that might be your best bet. I dont think anyone made a JOSM plugin for warping images locally so...
If you have your own WMS server, then it would be running at a http://localhost URL which I imagine would work. Easier might be to have your own tile set (TMS server) although may still need your own webserver. Might be a good feature request, for JOSM's imagery menu to let you load tiles from a local filesystem path. Either way you'd have to also do your own warping using GDAL tools. All highly technical to set up. Local image warping, with no servers involved, as a JOSM plugin, would be nice
-- Harry Wood 12:38, 9 January 2011 (UTC)

Proxy support in webkit-image

webkit-image checks "http_proxy" environment variable and if set - uses proxy described there. In order to use this, one should set environment variable "http_proxy" before launching JOSM. For example use such command:

http_proxy="my.proxy.server:8080" java -Xmx512M -jar josm-snapshot-1212.jar

Should work with Windows environment settings as well.

It would be nice, if sombody modify ewms plugin to set http_proxy variable from JOSM settings, in order not to duplicate proxy settings.

--Alexey 13:42, 18 January 2009 (UTC)

It seems that http_proxy doesn't work on windows. I tried it with "http://<IP>:<PORT>" and "http://<USER>:<PASSWORD>@<IP>:<PORT>" but no success. What a pitty 11:02, 23 February 2009 (UTC)
I think the problem in your (my) case is that the code does support http_proxy, but not proxy authentification. The code (look for webkit-image.cpp) uses a QTs class called QNetworkProxy which itself does support authentification, but it isn't correctly configured. So it seems that only a very little bit is missing to fix it. Something like "proxy.setUser(user); proxy.setPassword(passwd);" --DrScott 17:27, 18 June 2009 (UTC+2)

win32 proxy

I am use Windows XP and Firefox. If I configure JOSM and system for use with proxy then WMSPLUGIN not work. If I Configure JOSM and system for use without proxy then WMSPLUGIN work. I try configure IE for proxy, WMSPLUGIN not work.

How setup WMSPLUGIN for proxy?

--<<unknown poster -- please add name>>

I also observed download failures with Linux when proxies are enabled (not only on Windows as described above), and when resetting http_proxy download was successful.
Debugging the issue, in my opinion it is caused by an incorrect http_proxy implementation in webkit-image.cpp: Currently, it splits the http_proxy string on occurrence of ":" into host and port number. However, a clean http_proxy string must contain the proto scheme too (Example: "http://localhost:8118"). Current code would split this into hostname "http" and default port 8080 (because more than one ":" separator is contained). In other words, the code currently only works without scheme (Example: "localhost:8118"). However, such http_proxy format is considered illegal by nearly every other network app (google for it).
I will send two code proposals to the tool author:
  1. Use QUrl to split http_proxy string: This is easy, and will also allow easy extraction of user/password for proxy authentification (see discussion above). But this will force all users of webkit to set the correct http_proxy string including scheme. Preferred by me.
  2. Manual extraction of scheme/host/port: Unelegant solution, user/password extraction also would need to be done manually. But URLs with and w/o scheme are accepted.
--Rs 21:37, 30 December 2009 (UTC)

Yahoo! Legalities

Does this plugin conform to Yahoo's terms-of-use? Note that we are allowed to access Yahoo imagery only by way of their Javascript API! --Schuetzm 11:07, 3 November 2008 (UTC)

I believe it does - that's what gnome-web-photo is for. --Thomas Wood 19:00, 11 November 2008 (UTC)
That's right. All the "Yahoo downloader" install instructions are basically a nasty hack to have it load imagery via javascript. Bing has no such requirement, hence easier install -- Harry Wood 12:46, 9 January 2011 (UTC)

Josm on Windows shows gnome-web-photo in YAHOO (Webkit) field

my WMS-URL looks like:
yahoo://gnome-web-photo --mode=photo --format=png {0} /dev/stdout
I think this is wrong for win32/webkit? What is the correct URL? --chris66 10:56, 19 November 2008 (UTC)

Thanks I copied and pasted the
yahoo://gnome-web-photo --mode=photo --format=png {0} /dev/stdout

in my Gnu/Linux distro and renamed YAHOO webkit to simply "YAHOO". Now it works just like on Ubuntu! Logictheo 09:15, 20 January 2009 (UTC)


Does anybody have a compiled mac version of webkit-image? Or any help on how to access yahoo on a mac with ewmsplugin? --AlexPleiner 17:40, 15 December 2008 (UTC)

I wrote a native version of webkit-image that doesn't require Qt, only XCode to build. No prebuilt binaries, you can get the source from Not planning to maintain it; if it breaks, keep the pieces. --Tko 16:47, 31 July 2010 (UTC)


I use KDE (Kubuntu) and (probably) have no gnome-web-photo. Therefore I would like to use the webkit solution (as I do on Windows). The mentioned libs are already installed and the cpp is downloaded ... but how to compile this file now? I have no idea to be honest ;) And what do I need to do with the result? My Linux experience is not very deep yet ...

Oh, I see ... "by mistake" I had opened the cpp file in a text editor and found the instructions ...
/* compile with
moc webkit-image.cpp >webkit-image.h
g++ webkit-image.cpp -o webkit-image -lQtCore -lQtWebKit -lQtGui -s -O2
adding the correct directories with -L or -I:
-I C:\Progra~1\Qt\include -L C:\Progra~1\Qt\lib
... but ... the moc stuff worked (the .h file was created) but g++ was not found.
I obviously need to install that as well ... googling ... trying ... okay:
sudo apt-get install build-essential
After that I did the following as mentioned above + the mentioned additional option:
g++ webkit-image.cpp -o webkit-image -lQtCore -lQtWebKit -lQtGui -s -O2 -I /usr/include/qt4
Fine. Now I have a webkit-image. But the last question remains: What shall I do with that?
--Krza 01:12, 18 December 2008 (UTC)
Well, install it. :-)
mkdir -p /usr/local/bin
mv /your_path_to_src_dir/webkit-image /usr/local/bin/
Copying to the same directory as the JOSM executable worked for me as well on a different Debian GNU/Linux etch (4.0) system.
In fact there are two Wiki pages for the ewmsplugin, an English and a German one, but both are completely out of sync. For now, please have a look, ask, if you need. To find and merge the unique information, re-arrange and re-format the other parts, that will be a challenging task. However, as I found it, I could do that and I may try it soon.
--Hasienda 22:05, 3 January 2009 (UTC)


Anyone got success in installing webkit to Red Hat enteprise linux? or additionaly: how to use old ywms with new versions of josm?

I have the same question. I cannot load Yahoo imagery with new version of WMS plugins and YWMS does not work anymore.

Other projections

It seems that the plugin makes requests always in EPSG:4326, regardless of projection set in JSOM. It works fine if WMS server is EPSG:4326-based (like most of them are), and with certain WMS servers (e.g. MapServer-based) it probably just happens to work fine also with Mercator projection. But with other projections WMS server requires that you will make request in specific projection (coordinates are in meters etc), not in EPSG:4326 (degrees). It is especially issue with local, e.g. state-provided WMS servers, who force to use local official projections instead of Mercator or 4326. For specific Estonian system our community has made external proxies to fix the coordinates, but it would be much better to have the update in the plugin itself. --Jaakl 08:38, 18 January 2009 (UTC)

Now discovered that using proxy for projection conversion leaves uncovered areas when automatic WMS loading is used. See Media:Josm_wms_error_lest.jpg, you can see that map itself is in correct location, matches well with actual data, but requested BBOX is a bit too narrow. I guess that if wms plugin is fixed to support other projections, then this fixes also this issue --Jaakl 08:30, 19 January 2009 (UTC)

Most of the DOP Sources dosent work anymore

all have worked half a year ago. Now you get only red error messages :-( After a WMS Plugin Update, all shit.

Ubuntu Karmic

gnome-web-photo seems to work for me, it's slow, but it works.

Bad quality of Yahoo Image compared to Potlach

Apart from the white stripes (that appear sometimes) the general quality of Yahoo! is very bad compared to Potlach. Why is this the case and what can one do in that case? --westfa 18:53, 25 October 2009 (UTC)

OGC GetCapabilities

As a feature request, it would be tremendously useful for the plugin to support GetCapabilities requests, to simplify recurrent issues with URLs. A GetCapabilities request would query the target server to dynamically discover and retrieve a list of available WMS layers, which EPSG spatial reference systems are supported, WMS version, et cetera - these could then be used by the plugin to dynamically construct proper WMS GetMap requests, to eliminate manually constructing and debugging of WMS URL strings.

This would be particularly useful in the current Haiti mapping efforts, as various imagery services, scanned maps and other resources have been coming online to support the effort.

Open Geospatial Consortium &rarr WMS Implementation Specification; GetCapabilities

-DruidSmith 18:49, 21 January 2010 (UTC)

I know you started looking at doing some work on this DruidSmith. Recently Ian Dees has finally got this happening. There's a new "get layers" button which does as you describe. All available in the new built-in 'imagery' menu features -- Harry Wood 12:49, 9 January 2011 (UTC)

Imagery infinite zoom

Currently Imagery just shows the "Tiles not available" symbol when zooming in. It would be nice if the WMS Image would be displayed, even the tiles get pixelated.

Has this something to do with the Min zoom level setting in imagery (under TMS settings)? --Flow 10:18, 6 December 2010 (UTC)

Try right-click on a tile and uncheck "Auto Zoom" -> then the tiles are zoomed without new loading --Stephan75 11:52, 6 December 2010 (UTC)

Documentation update needed

Would be nice to have the menu points described when right-clicking on a WMS-layer - what is the meaning of

  • Automatic downloading
  • Alpha channel - usage?
  • Change resolution - which resolutions are available (depending on zooomlevel?)
  • Redownload erraneous tiles
  • Download visible tiles

--katpatuka 14:04, 5 November 2009 (UTC)

Agreed those things should be documented. We can add some of these details after restructuring described below -- Harry Wood 13:42, 9 January 2011 (UTC)

Restructuring docs now that it's no longer plugin

The functionality of this plugin has been rolled into JOSM core, under a new 'imagery' menu. There's some wiki documentation restructuring needed as a result. I suggest we do the following

  • Create a new page 'JOSM imagery', and move the user help information from here onto that page (also merging in user help on using tile servers from elsewhere)
  • Create a new page 'JOSM Yahoo! imagery downloader', and move the massive (rather messy) section about installing and using that from here onto that seperate page. I assume that all still works in the same way via the new 'imagery' menu, but it's all become less important with the availability of bing.
  • Leave behind only a small amount of documentation on this page. This is purely for the benefit of anyone still using an old JOSM version and this plugin. It would carry the pink label pointing out that you should just upgrade, and fat link to the 'JOSM imagery' page.
  • Fix links. They'll be many incoming links to this page, but most references will more usefully point to the 'JOSM imagery' page.

-- Harry Wood 13:42, 9 January 2011 (UTC)

"This means you should not use NPE Maps within JOSM except as a rough guideline."

Given that Potlatch gets its tile data from tms:{zoom}/{x}/{y}.png, is there any reason why I can't use this data "accurately" in JOSM? Randomgurn 15:54, 2 February 2011 (UTC)