Talk:Tiles@home/Install Guide

From OpenStreetMap Wiki
Jump to: navigation, search

Installation issues

  • I had to change xmlstarlet to xml in Otherwise it was fairly easy to get running. --JLS 19:58, 23 November 2006 (UTC)
  • I configured everything and even changed the xmlstarlet to xml as it seems more obvious but I can't generate anything. This is the output:
LimitY = 3.141587, -3.141587 (R 6.283174)
No data at this location
  • Have you put an openstreetmap username and password into it? Ojw 22:29, 23 November 2006 (UTC)
  • Yes, I did, IF my username is my e-mailaddress I used to register (or is it the wiki one). The coordinates seem strange (pi), is this because there are no decent coordinates given? Cimm 23:03, 23 November 2006 (UTC)
  • Yes, that's the correct username
The two $LimitY lines must contain exactly ±85.0511° (i.e. don't change them, they define the coordinate system)
To specify the area you want to render, change the GenerateTileset(1021, 682, 11); line. The 3 arguments are x,y,zoom
To find your local x,y,zoom, browse your local area on the slippy map, then right-click on a tile and view image. The directory name will be /zoom/x/y.png Ojw 23:23, 23 November 2006 (UTC)
  • I should define the bounding box probably but how do I have to do this?! Where can I find the Mercator coordinates for my region and which variables should I change to make this work? What is the difference between the $LimitY and $LimitY2 variables? Cimm 22:12, 23 November 2006 (UTC)
  • The final version of tiles@home will take its bounding box from a central website, so that the whole world gets rendered as efficiently as possible. Ojw 22:27, 23 November 2006 (UTC)
  • I entered my upload password and username but can't see if the generated tiles get uploaded or not. Is this logged somewhere? Cimm 11:21, 29 November 2006 (UTC)

Runtime errors

Thanks for the help Ojw, it's working better now but still not that. It downloads the data, processes some rules that look like the osmarender stuff but the last part gives some critical inkscape errors. I created a gfx/ folder which solved the first problem but now I get the following errors for every created image. I canceled the script and it produced a lot of images which are all black squares (sometimes with a green dot, sometimes a white bar at the top). When I run inkscape manually it complains that the following extensions are missing: EPSI Output, Dia Input, AI Output, Postscript Input, EPS Input, Sketch Input and Windows Metafile Input. Do I need any of these for the script? Cimm 09:36, 24 November 2006 (UTC)

gfx/16_32677_21824.png: Lat 51.399,51.396, Long -0.500,-0.494, X 274.3,329.2, Y 824.0,878.9
Rendering nice inkscape -w 256 -h 256 --export-area=274.345178:823.978125:329.214214:878.910000 --export-png=gfx/16_32677_21824.png output.svg...
** (process:15317): CRITICAL **: void gnome_canvas_bpath_def_closepath(GnomeCanvasBpathDef*): assertion `bpd->moveto_idx >= 0' failed
** (process:15317): CRITICAL **: void gnome_canvas_bpath_def_closepath(GnomeCanvasBpathDef*): assertion `bpd->moveto_idx >= 0' failed
  • Double-check your osm-map-features file is writable? Ojw 11:10, 24 November 2006 (UTC)
  • Writable, executable, all you want, still no luck. Installed most of the inkscape extensions I mentioned earlier but this doesn't help (skipped the WMF one). I'm on a Debian sarge box without any GUI so there is no GNOME either, do I need it? Seems that everything works as expected but the conversion of the output.svg to the tiles with inkscape goes wrong. The dots I mentioned earlier are not dots but the parking sign and post office symbol, they are rendered like it should, the streets and background aren't. Cimm 11:40, 24 November 2006 (UTC)
  • I get the same problem on my laptop (inkscape 0.4 on ubuntu) - when you open an osmarendered image in inkscape it appears in black/white with a black rectangle over everything. Ojw 23:58, 24 November 2006 (UTC)

Tell the world it's working now! :) Installed the latest version of inkscape (0.44, unstable Debian package), the latest version of the tiles@home script and the Almien conversion tool to make sure I'm not rendering some ocean tiles. Still get a warning when rendering the tiles but the exports seem fine. Cimm 22:08, 27 November 2006 (UTC)

I've installed Tiles@Home on Windows. But I always get the error "Can't use an undefined value as a symbol reference..." . Does a solution exist by now? --Torsten Ger 12:16, 17 October 2007 (BST)

Bug reports

  • When I enter some coordinates somewhere in Belgium in the Almien tool (lat 50.9 and long 4.7) it returns 2101,2722 at zoom level 12. When I reconvert these to degrees with the same tool it returns a different set of coordinates (Latitude: -50.902963 to -50.847504). Should be positive, shouldn't it? I got the right ones when I enter -50.9 as an initial value, think this is wrong. Cimm 15:48, 27 November 2006 (UTC)
  • Fixed now. Ojw 17:15, 27 November 2006 (UTC)
  • Inkscape 0.43 (on Ubuntu dapper) returns error due to negative width or hight on the input from the perl script or data.
/tmp//tile_12_2107_1178.png: Lat 60.500,60.457, Long 5.186,5.273, X 0.0,875.6, Y 0.0,878.9
Rendering ...GTK Accessibility Module initialized
** (inkscape:23702): WARNING **: Export area '0.000000:0.000000:875.565497:878.910000' has negative width or height. Nothing exported.
renaming /tmp//tile_12_2107_1178.png_part to /tmp//tile_12_2107_1178.png

It's also noticeable that the perl script does not catch the error, and tries to continue. --Mikemenk 15:58, 28 December 2006 (UTC)

    • That's the localisation error, where perl uses a dot for decimal separator and inkscape uses comma. See other tiles@home wiki pages for some fixes.
    • This seems to be already fixed (with i18n set to 1) in the current client - maybe we should drop this section alltogether? --Deejay1 07:33, 3 June 2008 (UTC)

I get this Warning consistantly with version 20055 (Ulm):

Warning: used uninitialized fault inkscape

This appears to come from a missing line


in the main code. (Apparently there is no real fault, but the warning is triggered by an unmatched resetFault("inkscape") )--hagman 21:05, 20 February 2010 (UTC)

Other questions

  • So, whats the typical disk usage of t@h? --Flow 11:53, 29 March 2010 (UTC)
Unless you decide to keep the generated tiles on your disk 500MB is fine and leaves enough headroom. --Stephankn 05:27, 14 April 2010 (UTC)
  • How do we know when the script gets updated? The SVN webview doesn't show a modified date and I don't feel like installing a Subversion client for this one file. Some note on the wiki page or turn on the modified date for the directory listing in the SVN web view? Cimm 11:22, 29 November 2006 (UTC)
  • It's nice to see that the script gets a random area to render now, I'll schedule my server to render some random tiles at a specific interval. Could we have something like the Render_me page as well? I would like to upload some random tiles daily and my own region weekly so it may be useful to know who renders which area at which interval rate, wouldn't it? Cimm 11:22, 29 November 2006 (UTC)
  • How does one request a username and password to upload tiles? The page says to email Ojw for a password but following the link to Ojw's page and selecting Email this user gives the error This user has not specified a valid e-mail address, or has chosen not to receive e-mail from other users.. Glen 08:04, 25 April 2007 (BST)
    • Finally found it via his talk page. [1] has details on how to email him. Glen 12:47, 3 May 2007 (BST)
  • Is it possible to run Tiles@home client behind proxy? Zdeno 12:13, 3 May 2007 (UTC)
    • Yes, as long as the proxy allows http requests outbound on port 80. Dutch 12:28, 3 May 2007 (BST)
  • I just started to be a part of t@h. And have rended a few tiles. But mostly I get "Putting job (12,3635,1587) back due to 'Download of data failed from TRAPI,ROMA,XAPI'"? Is this common or just a temporary problem? (seems like servers dont give me mapdata to render?) --Thod 10:01, 17 April 2011 (BST)

Idea: Virtual T@H-Servers to enable a one-click-setup

Setting up Tiles@home seems to be a rather complicated process if seen from the perspective of a typical (Windows) user. I know several people who would donate some sparse CPU time to render tiles, if only they had something like a one-click-setup for tiles@home. Do I have to say that they haven't yet installed any of the various things you list as prerequisites, and SVN isn't even listed there. Ok, enough complaining... Maybe I have an idea of a solution.

We could create a virtual linux machine that runs inside VMware, parallels or whatever you like, and do all the complicated stuff to setup a running Tiles@home installation. The image could be shared, as you can see at where there's a virtual Aplliance for everything you can imagine - except Tiles@home :) Given that virtual PC, every user could setup a T@H-System. I've already tried a virtual PC with an asterisk PBX on it, it was pretty easy. To get an idea how easy it could be in the ideal case, watch the video at (click on the orange "See a demo").

I would do the work by myself, but I'm in lack of time, in lack of linux experience, and with the software I have, I can only "run" virtual PCs, not "create" ones. Sorry!

mfg / wbr --Brian Schimmel 21:11, 19 December 2007 (UTC)

Update: I'm not sure if anybody reads this at all, but to prevent redundant work, I just want you to know that I found someone who will now work on this. As soon as we got a virtual renderer running, we will share it with the community. --Brian Schimmel 20:13, 1 January 2008 (UTC)
This sounds great. I tried some things out with Qemu the last days. A simple Debian-Image would be fine. Even simple Network-Configuration is done in Qemu. The only thing i ask myself is what is about the perfomance? --Xsteadfastx 12:10, 14 January 2008 (UTC)

My friend Alex tried this with VirtualBox. Sadly, we can't test it, because since two weeks, we are waiting for a passwort from Ben and Oliver, both did not answer until now. If you, or someone else has a T@H-passwortd, you can download our image from [2]. It's 278 MB compressed and 1 GB uncompressed. Thats pretty large, maybe we can reduce it to a much smaller file, but as a proof of concept it should work fine. The root password is root, and there is a user openstreetmap whose password is openstreetmap. According to Alex everything should be set up fine. --Brian Schimmel 13:43, 14 January 2008 (UTC)
There is now a wiki page at Virtual Tiles@Home, because our virtual Client is now up and running. If you have something to add to the discussion, please use the discussion page over there. --Brian Schimmel 21:12, 27 January 2008 (UTC)

Mac OS X installation instructions - Missing perl libs

I just made a *small* os x installation guide. I'm not shure if I forgot some perl libraries. I had to install almost all of them by hand and I think there are some missing in my instructions. Any ideas? --Alexander Klauke 21:31, 6 February 2008 (UTC)

I updated the os x installation guide. This guide worked twice for me (10.5.4) and appreciate any comment on that guide. I'm also looking forward that someone solves the pngnq build problem. --Gorgum 09:53, 22 August 2008 (UTC)

I don't want to edit the page, since there's too much text to change for the pngnq build workaround and i am not sure if this is the same build problem:
Undefined symbols: "_zlibVersion", referenced from: _rwpng_version_info in rwpng.o
I had no problems building it after commenting some lines in rwpng.c out (lines 47-53):
void rwpng_version_info(void)
 //  fprintf(stderr, "   Compiled with libpng %s; using libpng %s.\n",
 //    PNG_LIBPNG_VER_STRING, png_libpng_ver);
 //  fprintf(stderr, "   Compiled with zlib %s; using zlib %s.\n",
 //    ZLIB_VERSION, zlib_version);


--Egon 17:51, 15 February 2009 (UTC)

There seems to be a typo in: sudo ln -s /opt.local/lib/libpng12.0.dylib /usr/local/lib/libpng12.0.dylib This should be: sudo ln -s /opt/local/lib/libpng12.0.dylib /usr/local/lib/libpng12.0.dylib I corrected the misstyping

Structure of the page

Wouldnt it be better for the structure of this page if we split it in different articles? i think its pretty full. --Xsteadfastx 15:07, 6 August 2008 (UTC)


I'd like to propose a new section, where hints about tweaking the t@h client are gathered. Obviously most of those can be found by going through the "tilesAtHome.conf" file. However, I think it would be nice to mention some points explicitly. Like...

  • you can improve the performance on multi core systems by changing the "Fork=" value in the tilesAtHome.conf
  • you can limit the bandwith t@h may use for uploads with the command line tool "trickle" (not part of the t@h project, but a very useful Linux command line tool)

Comments on this suggestion are highly welcome!

Username login does not work

If I enter my OSM-Username in authentication.conf I cannot connect - when I use my email it works. It is a bug? I don't want to show my email-adress at the statistics-page [3].

binary for OS X ?

Hi, I wonder why no one created a binary for OS X. cu AssetBurned 22:09, 8 December 2009 (UTC)

Instruction for NetBSD ?

Hi, I successfully installed tah on NetBSD (5.0_STABLE/amd64). Should I write some installation instructions on the Wiki (it doesn't differ much from FreeBSD, though)? harenber 29 December 2009

Installation instruction paragraph

Incomplete? I don't get what is meant there, not anything on how to start a demon or what ever... Thx--Geolr 15:30, 23 January 2011 (UTC)