FR:JOSM/Guide

From OpenStreetMap Wiki
Jump to: navigation, search
Langues disponibles — JOSM/Guide
Afrikaans Alemannisch aragonés asturianu azərbaycanca Bahasa Indonesia Bahasa Melayu Bân-lâm-gú Basa Jawa Baso Minangkabau bosanski brezhoneg català čeština dansk Deutsch eesti English español Esperanto estremeñu euskara français Frysk Gaeilge Gàidhlig galego Hausa hrvatski Igbo interlingua Interlingue isiXhosa isiZulu íslenska italiano Kiswahili Kreyòl ayisyen kréyòl gwadloupéyen Kurdî latviešu Lëtzebuergesch lietuvių magyar Malagasy Malti Nederlands Nedersaksies norsk bokmål norsk nynorsk occitan Oromoo oʻzbekcha/ўзбекча Plattdüütsch polski português português do Brasil română shqip slovenčina slovenščina Soomaaliga suomi svenska Tiếng Việt Türkçe Vahcuengh vèneto Wolof Yorùbá Zazaki српски / srpski беларуская български қазақша македонски монгол русский тоҷикӣ українська Ελληνικά Հայերեն ქართული नेपाली मराठी हिन्दी অসমীয়া বাংলা ਪੰਜਾਬੀ ગુજરાતી ଓଡ଼ିଆ தமிழ் తెలుగు ಕನ್ನಡ മലയാളം සිංහල ไทย မြန်မာဘာသာ ລາວ ភាសាខ្មែរ ⵜⴰⵎⴰⵣⵉⵖⵜ አማርኛ 한국어 日本語 中文(简体)‎ 吴语 粵語 中文(繁體)‎ ייִדיש עברית اردو العربية پښتو سنڌي فارسی ދިވެހިބަސް
  Pour commencer   Édition simple   Édition avancée (optionnel)(en)   Envoi des changements à openstreetmap.org(en)   Greffons   Astuces avancées(en)   FAQ ±

Préambule

L'objectif de ce guide est de présenter OSM d'une façon simple et didactique. C'est pourquoi de nombreuses copies d'écran sont présentées et l'ensemble se trouve sur une seule page. Les changements étant très rapides, certains détails peuvent ne plus correspondre tout à fait à la version actuelle du logiciel.

Au cas où vous n'auriez pas de GPS, et donc pas de fichiers traces disponibles, vous pouvez quand même apporter vos connaissances et votre aide au projet. Si votre région, par exemple, dispose déjà de toutes les routes, mais pas votre restaurant préféré ou l'aire de jeux à coté de chez-vous, vous pourrez les ajouter en suivant ce guide. De même, vous pourrez ajouter des noms de rues manquants, corriger les erreurs comme les noms mal écrits, les sens interdits, etc.

Les copies d'écran sont en anglais. Une version française de l'éditeur est disponible mais peut ne pas être à jour. Au cas où vous seriez un développeur qui pourrait aider à la traduction, n'hésitez pas à mettre vos connaissances à disposition.

Qu'est-ce que JOSM

JOSM (Java OpenStreetMap) est un programme d'édition des données de la base OSM. Vous pouvez avec JOSM extraire une partie de la base de données, modifier ou ajouter des données hors ligne, puis transférer le résultat à nouveau dans la base.

GPX, OSM, images Landsat : les différents types de données

JOSM travaille avec quatre catégories de données, chacune utilisant ses propres types de calques :

  • Les données OSM sont des données géographiques conservées dans la base de données centrale d'OpenStreetMap. Il existe trois type d'objets : les noeuds (nodes), les chemins (ways) et les relations (voir cette page et ici). On peut attacher des attributs (tags en anglais) à ces objets, toujours sous la forme key="", value="" (voir la FAQ et la Map Features pour plus de détails). Ces données peuvent être exportées dans des fichiers textes au format XML. Lorsqu'un chemin (way) est refermé sur lui-même pour former une boucle (polygone), on parle alors de zone (ou area en anglais). Une exception: c'est le rond-point qu'on considère encore comme un chemin.
  • Les données GPX (pour GPS Exchange format) sont les tracés de récepteurs GPS sauvegardés dans un format XML particulier. JOSM n'accepte que ce format de fichier pour visualiser vos traces GPS. Certains récepteurs GPS peuvent directement exporter les tracés dans ce format. D'autres nécessitent un convertisseur du format propriétaire vers le format GPX (par exemple GPSBabel).
  • Plusieurs sources d'imagerie aériennes sont disponibles à travers le menu "Imagerie" selon votre zone d'édition. Voir la documentation pour chacune de ces sources ici pour la France.
  • Des photos prises d'un APN peuvent être importées. Il est alors possible de voir les photos prises à des endroits précis sur un tracé GPS. Certaines personnes cartographient les rues et prennent en même temps en photo les informations nécessaires comme les plaques de rues, les sens interdits, etc. à la place des notes papier.

Créer un compte utilisateur

Avant de commencer, vous aurez besoin d'un compte utilisateur que vous aurez créé au préalable sur le site d'OpenStreetMap (différent du compte wiki) et qui vous permet de modifier la base de donnée OSM. Notez bien votre nom d'utilisateur (une adresse email) et votre mot de passe.

Installation de JOSM

L'éditeur, que la plupart des membres d'OSM utilisent, est l'éditeur Java JOSM.[citation needed] Téléchargez la dernière version de JOSM. Aucune installation n'est nécessaire. Pour démarrer, il faut juste avoir un environnement Java version 1.5 ou plus ancien présent sur l'ordinateur.

  • Sur Macintosh, Java est pré-installé. Vous pouvez lancer JOSM après le téléchargement directement par un double clic.
  • Sur ubuntu, depuis la 8.04, josm est dans les dépôts officiels de la distribution. Il suffit alors de lancer synaptic et d'installer josm
  • Sur certaines distributions Linux, vous devrez installer Java vous-même. Il existe de nombreux documents qui vous aideront pour votre distribution (voir JRE 1.5). Une fois Java installé, vous pouvez cliquer, sous KDE, avec le bouton droit de la souris sur le fichier téléchargé et selectionner dans le menu contextuel l'entrée "Ouvrir avec". Ensuite, sélectionnez "Autre" et tapez "java -jar". Vérifiez que la case "Toujours pour ce type de programme" soit activée (NDT: traduction à vérifier sur KDE). Sinon, vous pouvez aussi lancer le programme à partir d'un terminal à l'aide de la commande "java -jar josm-latest.jar".
  • pour certaines versions de Windows, vous devrez installer Java vous-même. Lä encore, il existe de nombreux tutoriaux/documents sur le net qui vous guideront (cherchez "JRE 1.5"). Le cas échéant, faites-vous aider par quelqu'un de plus expérimenté. Une fois Java installé, vous pouvez démarrer JOSM en cliquant deux fois sur le fichier josm-latest.jar .

Vous trouverez d'autres informations ici (en anglais) avec, entre autres, quelques paramètres à modifier lors du lancement lorsqu'on utilise de grandes quantités de données.

Préférences

Avant de commencer, vous devez procéder à quelques réglages. Ouvrez d'abord la fenêtre des préférences, dans le menu "Edit", "Preferences":

JosmPreferences1.png

Sélectionnez les paramètres par défaut comme indiqué ici (cliquez sur l'image pour voir les détails):

JosmPreferences2.png

Sur la deuxième page, entrez l'URL de la base de données d'OpenStreetMap (http://www.openstreetmap.org/api), le nom d'utilisateur et le mot de passe du compte que vous aurez créé au préalable sur le site d'OpenStreetMap (attention: le wiki utilise un compte différent):

JosmPreferences3.png

Sur la troisième page, activez le bouton "Tagging Presets". Cela vous facilitera vos premiers pas dans l'édition.

JosmPreferences4.png

Sur la quatrième page, cliquez sur le bouton "Check for Plugins". JOSM va alors récupérer sur le réseau la liste actuelle des Plugins disponibles:

JosmPreferences5.png

Nous vous recommandons d'installer les Plugins suivants comme indiqué sur l'image:

JosmPreferences6.png

(NDT: personnellement, je n'active pas le plug-in MapPaint qui surcharge trop l'affichage. Pour désactiver un plug-in, il suffit de le désélectionner dans cette liste et de redémarrer JOSM).

Allez dans la deuxième partie de la liste en utilisant la barre de défilement vertical à droite et ajoutez encore ces Plugins:

JosmPreferences7.png

Sur la page suivante, vous pouvez adapter la barre d'outil à votre goût ou vos habitudes de travail:

JosmPreferences8.png

Cliquez sur le bouton avec les double flèches vers la droite pour vider la barre d'outils:

JosmPreferences9.png

Sélectionnez sur la partie droite l'outil que vous désirez voir dans la barre d'outils puis cliquez sur la flèche vers la gauche pour l'ajouter à votre barre d'outils. Vous pouvez changer l'ordre des boutons de la barre en utilisant les flèches haut et bas:

JosmPreferences10.png

Avec ces paramètres, vous devriez être capable de bien débuter avec JOSM. Bien sûr, vous pourrez les changer plus tard pendant vos travaux. Quittez la fenêtre des préférences. Pour pouvoir prendre en compte les nouveaux Plugins, JOSM a besoin d'être redémarré.

Démarrage

Après le redémarrage, JOSM devrait ressembler à ceci:

JosmGuide1.png

Pour commencer, chargez votre fichier trace pour activer l'écran principal. Sélectionnez le menu "File", "Open" (raccourci 'Ctrl-O'):

JosmGuide2.png

Sélectionnez le fichier trace dans le dossier approprié sur votre disque dur. Vous pouvez charger plusieurs fichiers simultanément en les sélectionnant tout en appuyant sur la touche Control:

JosmGuide3.png

Vous voyez maintenant la trace et éventuellement les points à l'écran:

JosmGuide4.png

Sur la partie gauche de l'écran se trouve, en haut, les boutons pour modifier les données et, en dessous, une série de boutons qui permettent de rendre visible ou de masquer plusieurs petites fenêtres sur la partie droite. Certaines de ces petites fenêtres étant très utiles, vous pouvez commencer par ouvrir celles correspondant aux boutons suivants:

JosmGuide5.png

Maintenant, vous devriez voir quelque chose comme ceci:

JosmGuide6.png

Le panneau "Layers" donne la liste des calques en cours d'utilisation dans JOSM. D'habitude, un calque existe pour le fichier trace GPX et un autre pour les données OSM. La première fois que vous ouvrez un tracé, il apparaît en gris. Il est quasi indispensable de choisir une couleur plus "flashi" lorsque vous superposerez ce calque avec celui des données OSM. Pour cela, cliquez avec le bouton droit de la souris sur la ligne identifiant le calque de trace GPX dans le panneau "Layers", ouvrant un menu contextuel. Sélectionnez le menu "Customize Color" et choisissez une couleur très voyante (en général vert, rouge, violet ou jaune clair par contraste avec le bleu sombre utilisé dans le calque de données OSM). Vous pouvez aussi choisir dans quel ordre les calques sont affichés ou choisir de rendre temporairement invisible un calque.

Commandes de base

Cliquez et gardez le bouton droit de la souris pour pouvoir déplacer l'espace de travail. Utilisez la molette de la souris pour zoomer en avant et en arrière. Assurez-vous que votre zone de travail ne soit pas trop grande, quelque chose comme un kilomètre carré. Si votre trace est trop grande, travaillez sur une partie restreinte pour commencer. Apprenez à utiliser les raccourcis claviers, principalement 'a','s' et 'd', malheureusement mal adaptés au clavier français. Votre plan de travail devrait ressembler à ceci maintenant:

JosmGuide7.png

Charger les données OSM

Maintenant, vous devez interroger le serveur OSM pour voir s'il contient déjà des données pour cette zone. Sélectionnez le menu "Connection", "Download from OSM" ou cliquez sur le bouton approprié de la barre d'outils:

JosmGuide8.png
Josm button download.png

JOSM calcule automatiquement la zone qu'il doit charger depuis OSM en fonction de la vue actuelle (longitude, latitude et niveau de zoom). Activez l'option "OpenStreetMap data". Cliquez ensuite sur le bouton "OK" pour lancer votre premier téléchargement du serveur OSM:

JosmGuide9.png

Pendant le traitement de la demande, vous voyez le dialogue suivant:

JosmGuide10.png

Au cas où le serveur serait en maintenance ou que la charge de travail est trop importante à ce moment là, il est possible que votre demande ne soit pas traitée. Bien que cela arrive rarement, il faudra alors attendre un peu et refaire la demande.

A la fin du chargement des données, votre écran devrait ressembler à ceci:

JosmGuide11.png

Premiers pas

Vous travaillez maintenant avec des données qui se trouvent localement sur votre ordinateur. Quand vous modifiez ces données, celles-ci ne sont pas directement sauvegardées dans la base de données du projet. Vous pouvez tirer profit de ce point pour tranquillement étudier ou modifier les données sans risque. Tant que vous ne transférez pas vos nouvelles données vers le serveur, vous pouvez utiliser l'éditeur en toute liberté. Sélectionnez maintenant le bouton pour passer en mode "déplacements" "select, move and rotate objects" symbolisé par une main (ou utilisez le raccourci clavier 's') dans la partie gauche :

JosmGuide12.png

Sélectionnez une route, ici dans notre exemple en haut à gauche. Observez la fenêtre "Properties/Memberships" sur la partie droite qui montre les attributs rattachés à cet élément. Cette route est classée comme résidentielle (attribut (tag en anglais) highway=residential), une rue donc, porte le nom "Karpfenweg" et a été créée avec JOSM (ndt: le tag "created_by" identifie en principe uniquement le logiciel d'édition, l'identifiant de la personne ayant créé un objet étant sauvegardé sous un autre format dans chaque objet de la base). Plus bas, vous voyez une liste des éléments actuellement sélectionnés.
OSM ne veut pas restreindre la liste des tags ou fixer des règles contraignantes. Même si une liste commune relativement stable existe, il y a encore de nombreux tags en discussion. De plus, chaque pays peut choisir d'utiliser ses propres attributs.

Ajouter des routes

JOSM propose une série d'outils assez simples pour ajouter de nouvelles données ou modifier des données existantes. Néanmoins, cartographier nécessite un certain apprentissage. C'est pourquoi les paragraphes suivants doivent être suivis pas à pas. Fermez l'éditeur et redémarrez-le pour être sûr de partir à zéro. Chargez un de vos fichiers traces (ou, si vous n'en disposez pas, téléchargez-en un depuis le site d'OpenStreetMap). Ne chargez pas encore de données depuis le serveur OSM, mais faites d'abord un exercise "à vide". Voici un exemple de trace :

JosmGuide20.png

Sélectionnez le bouton "Draw Nodes" (raccourci 'a') sur la partie gauche de l'éditeur pour passer dans le mode qui permet d'ajouter des nœuds :

JosmGuide21.png

Dessinez maintenant la première ligne avec deux clics de souris en ajoutant deux nœuds :

JosmGuide22.png

Observez comment l'éditeur affiche les points et les relie automatiquement. L'étape suivante est de transformer cette ligne en route. Sélectionnez la ligne droite (pas les points !) puis cliquez dans le menu "Presets", l'entrée "Road" :

JosmGuide23.png

Dans le dialogue qui apparaît, entrez le type de route (dans l'exemple ici "residential" pour une route résidentielle) et son nom :

JosmGuide24.png

Fermez le dialogue. Observez que la partie droite de l'écran affiche les différents tags rattachés à cette ligne droite tant qu'elle est sélectionnée.

JosmGuide25.png

Pour tracer maintenant une autre route qui commence à un endroit différent, il faut d'abord désélectionner la route actuelle : repassez dans le mode de sélection d'objets soit en cliquant sur le bouton "Select, move and rotate objects", soit en utilisant le raccourci clavier 's' puis cliquez dans un espace vide de l'écran. Pour démarrer une nouvelle ligne, repassez dans le mode "Draw Nodes" avec le bouton à gauche ou avec le raccourci clavier 'a' puis ajoutez de nouveaux points comme précédemment. Le passage d'un mode à l'autre est nécessaire pour interrompre le premier tracé. Avec l'expérience, vous pourrez dessiner plusieurs rues/routes adjacentes en une seule fois puis les découper en plus petites sections dans un deuxième temps. De plus, l'usage des raccourcis claviers est fortement recommandé et accélère considérablement le travail. Vos routes pourraient ressembler à ceci maintenant :

JosmGuide26.png

L'étape suivante consiste ä tracer une ligne qui va croiser les trois autres routes. Dans le mode "Draw Nodes", cliquez simplement sur un endroit de la ligne existante. Cela va ajouter automatiquement un nouveau point d'intersection et votre ligne précédente est coupée en deux segments. Procédez de la même manière pour relier les deux autres rues en cliquant sur les lignes existantes :

JosmGuide27.png

Comme vous le voyez sur l'image, la nouvelle rue n'est pas tout à fait une ligne droite. Pour pouvoir faire un alignement parfait, repassez dans le mode "select, move and rotate objects" (raccourci 's') puis cliquez n'importe où dans le vide pour ne plus avoir d'objets sélectionnés à l'écran. Puis cliquez sur les trois points que vous voulez aligner tout en maintenant la touche "Maj" appuyé. Observez le panneau "Selection" sur la partie droite de l'écran :

JosmGuide28.png

Sélectionnez maintenant dans le menu "Tools" l'entrée "Align nodes in line" (ou le raccourci clavier 'l' (petit L)). L'éditeur aligne tous les points sélectionnés :

JosmGuide29.png

La route transversale a bien meilleure allure maintenant :

JosmGuide30.png

Ajoutez maintenant le type de route et un nom comme d'habitude. Ajoutez d'autres rues, routes, passages piétons, etc. en fonction de vos besoins ou envies.

Ajouter des points d'intérêts

Une carte ne contient pas seulement des routes, mais des symboles indiquant l'emplacement de points remarquables comme des boîtes aux lettres, des supermarchés ou des églises. Ces éléments devront si possible être ajoutés dans la carte d'une manière uniforme pour être plus-tard reconnus par les logiciels de rendu de cartes.

Pour de tels éléments, passez au mode "Draw Nodes" (raccourci 'a') :

JosmGuide31.png

Ajoutez un point à l'endroit souhaité par un simple clic :

JosmGuide32.png

Sélectionnez dans le menu "Presets" l'entrée "Amenities" (qu'on peut traduire par 'équipements') :

JosmGuide33.png

Dans le dialogue qui s'ouvre, sélectionnez par exemple une cabine téléphonique :

JosmGuide34.png

Voila à quoi devrait ressembler votre espace de travail :

JosmGuide35.png

Avant de passer à un autre point d'intérêt, pensez à désélectionner le point actuel en cliquant une fois dans le vide.


En savoir plus

Transférer les données vers OSM

Vous avez pris maintenant connaissance des commandes et outils de base pour modifier et ajouter des données. Passons maintenant à la dernière étape qui est le transfert des données vers la base d'OpenStreetMap. Notez que ce transfert est définitif et aucun retour en arrière n'est possible (on peut éventuellement utiliser une des sauvegardes hebdomadaires de l'ensemble de la base de données mais c'est une opération lourde qui n'est pas à la portée de tous). Si vous êtes sûr de votre travail, sélectionnez dans le menu "Connection" l'entrée "Upload to OSM" ou cliquez sur le bouton approprié en haut de l'écran. JOSM affiche la liste de tous les éléments que vous avez modifié, ajouté ou supprimé. Si vous approuvez, les données sont ensuite transférées vers le serveur :

JosmGuide36.png

Josm button upload.png


Après votre premier exercice, il est préférable de recommencer à zéro. Soyez prudent à vos débuts en travaillant par petites touches: téléchargez, modifiez, transférez vers le serveur vos résultats. En cas d'erreur ou de doutes, recommencez avec une nouvelle feuille. Sachez aussi que quelqu'un d'autre est peut-être aussi en train de travailler dans la même zone que vous. Dans ce cas, travaillez aussi par petites sessions ou, encore mieux, contactez la personne concernée et coordonnez votre travail.

Il arrive aussi que le transfert des données vers OSM soit interrompu ou bloqué. La plupart du temps, un nouvel essai quelques minutes plus-tard devrait être couronné de succès. Mais évitez de travailler trop longtemps localement sur votre machine sans transfert. Vous risqueriez de tout perdre en cas de problème.

Annuler les dernières actions

JOSM offre une fonction de retour arrière extrêmement utile dans un éditeur de carte. Cela veut dire que toutes les actions faites durant une session de travail peuvent être annulées une par une. Un panneau de contrôle "Command Stack" affichant la file des dernières actions peut être activé sur la partie droite de l'écran (Alt-O pour l'ouvrir) :

JosmGuide50.png

Pour revenir en arrière, cliquez sur le bouton "Undo" en haut de l'écran ou utilisez le raccourci clavier 'Ctrl-Z' :

JosmGuide51.png

De la même manière, il est possible d'annuler une annulation, c'est-à-dire de refaire ce que vous venez d'annuler en cliquant sur le bouton 'Redo' ou avec le raccourci clavier 'Ctrl-Y'). Vous avez ainsi accès à des fonctions puissantes d'annulation si un résultat ne vous satisfait pas, ce que d'autres éditeurs n'offrent pas toujours.

Remarques

Nous essayons de mettre en place une documentation détaillée. Mais il faut encore attendre que le logiciel se stabilise un peu car pour l'instant, il s'améliore rapidement et fréquemment. Dans le cas où cette introduction à JOSM ou que les copies d'écran ne seraient plus actuelles, n'hésitez pas à nous contacter.

--SlowRider 22:27, 5 November 2007 (UTC) (traduction Pieren 13:46, 16 December 2007 (UTC))