FR:JOSM

From OpenStreetMap Wiki
Jump to: navigation, search
Langues disponibles — JOSM
JOSM
Screenshot of JOSM
Author: Immanuel Scholz, Dirk Stöcker and other contributors.
Website: https://josm.openstreetmap.de
Version: 8339 (2015-05-07)
License: GPL
Platform: win;linux;macosx

Offline highly expandable map editor

JOSM logo

JOSM (« éditeur Java pour OpenStreetMap ») est une application de bureau développée initialement par Immanuel Scholz et actuellement maintenue par Dirk Stöcker. Sa page d'accueil se trouve à l’adresse josm.openstreetmap.de.

Bien qu’il soit conçu pour une utilisation nécessitant une phase de prise en main, JOSM est très populaire parmi les contributeurs expérimentés du fait de ses divers greffons et de sa grande stabilité.

Installation

JOSM est écrit en langage Java et nécessite l’installation préalable d’un environnement d'exécution JRE 1.6 ou supérieur (une version récente de la JRE étant requise, voir les pré-requis systèmes pour plus de détails). JOSM fonctionne donc sur les systèmes d’exploitation où Java a été porté.

Download josm-tested button.png
josm-tested.jar : version stable de JOSM
java web-start : démarrer directement la version stable de JOSM sans l’installer (JOSM sera installé provisoirement dans le cache Internet Java).
josm-setup.exe : installation de la version stable sous Windows en tant qu’application de bureau avec une icône dans le menu Démarrer.
josm-latest.jar : dernière version de développement de JOSM (uniquement pour les utilisateurs expérimentés ou développeurs de JOSM ou d’un de ses greffons : certaines fonctionnalités supplémentaires sont expérimentales et pas encore stabilisées ; cette version autorise également les mises à jour de greffons JOSM encore en développement et non proposés dans la version stable).

Pour plus de détails, consultez JOSM/Installation.

JOSM avec affichage de photos géoréférencées.
Copie d'écran JOSM, avec le greffon WMS Yahoo!

Guide du débutant

Vous trouverez sur cette page un guide pour vous aider dans vos premiers pas avec l’éditeur.

Quel éditeur utiliser

Il existe d’autres éditeurs pour contribuer aux données OpenStreetMap, tels que les éditeurs en ligne iD ou Potlatch 2 (lequel nécessite l’installation préalable ou la prise en charge de Flash par le navigateur web), ou encore le plus ancien Merkaartor. JOSM est un éditeur riche en fonctionnalités, avec une interface utilisateur qui pourrait sembler complexe au premier abord. Consultez la page de comparaison des éditeurs si vous n’êtes pas encore sûr de quel éditeur vous conviendra le mieux.

Mais si votre intention est de devenir un grand cartographe OSM, c’est un petit investissement de temps qui en vaut la peine. Et si vous êtes déjà familier avec les ordinateurs, cela n’est pas très compliqué.

Vous préférerez JOSM si :

  • vous allez changer un large ensemble de données,
  • vous voulez changer des données sans travailler dans les données réelles (pour faire des essais),
  • vous avez pris des photos ou des sons avec un dictaphone durant vos relevés géographiques et voulez les afficher à l'endroit où vous les avez prises,
  • vous voulez utiliser un éditeur hors-ligne et éditer une zone dont vous savez que d’autres utilisateurs sont aussi en train de modifier. JOSM supporte les fusions de changements et offre une aide à la résolution de conflits sur les zones modifiées par plusieurs personnes (souvenez-vous de mettre à jour les données modifiées avant chaque transfert en retour afin de limiter l'apparition de conflits de modification en plein milieu d’un transfert incomplet).

Vous n’utiliserez probablement pas JOSM si :

  • vous voulez juste renommer une rue. Utilisez l'éditeur en ligne Potlatch,
  • vous ne voulez pas installer une application,
  • votre ordinateur se trouve derrière un pare-feu qui empêche JOSM de travailler correctement (par exemple depuis votre lieu de travail),
  • votre machine n’a pas les caractéristiques requises comme indiqué ci-dessous.

Caractéristiques requises

Pour que JOSM puisse fonctionner sur votre ordinateur, vous aurez besoin de :

  • Java 7 ou supérieur (voir les pré-requis système pour plus de détails ; il est hautement recommandé d’utiliser la dernière version du JRE prise en charge pour votre système d’exploitation, et si possible la version 64 bits si votre système le permet, afin de disposer de davantage de mémoire de travail).
  • 256 Mo de RAM ou plus (notez que la mémoire de travail de Java en version 32 bits est limitée à 256 Mo, mais en version 64 bits on peut aisément l’augmenter à 1 Go ou plus pour travailler sur des jeux de données plus importants et utiliser plus de greffons ou utiliser plusieurs fonds d’imagerie).
  • une résolution graphique de 1024×768 ou plus (800×600 n’est pas très satisfaisant) ; cependant il vous faudra davantage de mémoire de travail si vous travaillez en plein écran avec des fonds d'imagerie et souhaitez limiter les ralentissements ou pauses.
  • une carte graphique avec l’accélération 2D activée est recommandée.
Si vous avez seulement OpenGL, essayez de lancer le programme avec le paramètre -Dsun.java2d.opengl=true (cette option est surtout destinée aux systèmes Unix/Linux, elle n’est normalement pas nécessaire ni recommandée sur Windows où l’utilisation native de DirectX est prise en charge nativement par la plupart des pilotes de cartes graphiques actuelles).
Si vous avez encore des problèmes avec cette configuration OpenGL (mauvais icône et fond d’écran), utilisez : -Dsun.java2d.opengl=true -Dsun.java2d.opengl.fbobject=false tout en notant que l’option OpenGL peut causer des problèmes avec certains gestionnaires de fenêtres sur Linux.

Télécharger et installer

Vous avez besoin d’installer Java 7 ou supérieur, que vous pouvez télécharger sur le site d'Oracle la la JRE ou le JDK adapté à votre système d’exploitation (sous Windows, le JRE installé par défaut est la version 32 bits, même sur les OS 64-bits et plutôt destinée à l’utilisation comme greffon au sein des navigateurs web, puisque la plupart fonctionnent encore en version 32 bits, même sur les systèmes 64 bits ; l'installation du JRE 64 bits est séparée et recommandée pour l’utilisation dans des applications de bureau autonomes comme JOSM, qui fonctionnent hors d’un navigateur web).

Vous devez ensuite simplement télécharger le fichier jar de JOSM, que vous pouvez trouver sur le site principal.

De nombreux développeurs ont ajouté leur propre contribution à JOSM. C’est pourquoi différentes extensions (appelés greffons ou plugins) sont disponibles. Alors que la version principale de JOSM se trouve sur le site josm.openstreetmap.de, vous pouvez télécharger des versions modifiées de JOSM ou des greffons qui étendent les possibilités de JOSM (vous pouvez en obtenir une liste dans l’onglet « Greffons » du menu « Préférences », et JOSM peut également vous proposer de les mettre à jour).

Installer Java

En premier lieu, vous devez avoir Java sur votre système pour pouvoir faire fonctionner JOSM. Java 7 est nécessaire, JOSM fonctionne également avec Java 8.

L'installation de la machine virtuelle java se fait différemment suivant les plate-formes :

Linux

  • installez le JRE depuis cette page Java SE
Ubuntu
  • soit entrez :
    $ sudo apt-get install sun-java6-jre
  • ou, depuis Ubuntu 8.04 LTS, JOSM est dans le dépôt universe :
    $ sudo apt-get install josm

Note : voir, plus bas, comment utiliser la josm-latest à la place de la version de la distribution tout en gardant la même convivialité.

Debian "pure"
  • entrez (en tant que root):
    # apt-get install josm
Gentoo

Installation standard avec Portage :

emerge -av josm

Si vous êtes intéressé par les derniers développement de JOSM et des plugins supplémentaires, utilisez la couche Gentoo pour OpenStreetMap.

Il y a déjà de nombreux plugins disponibles avec ebuild. Regardez dans http://svn.openstreetmap.org/applications/utils/gentoo/ pour une liste complète.

Fedora
Entrez (en tant que root):
#yum install josm
openSUSE/Fedora/Mandriva

Les paquets de JOSM sont disponibles dans le service de compilation d'openSUSE, dans le dépôt Application:Geo.

Allez à l'adresse http://download.opensuse.org/repositories/Application:/Geo/, sélectionnez votre distribution et trouvez le RPM dans le répertoire noarch. Installez avec RPM ou votre gestionnaire de paquets favori.

Exemple avec openSUSE 10.3 utilisant zypper:

zypper ar http://download.opensuse.org/repositories/Application:/Geo/openSUSE_10.3
zypper ref
zypper in josm

Utilisez ceci pour openSUSE OneClick install :

 http://packages.opensuse-community.org/index.jsp?searchTerm=josm

Windows

  • Installez le JRE depuis cette adresse: Java SE

Mac OS X

  • Malheureusement Java 1.5 n’est pas disponible pour Mac OS X 10.3, cependant JOSM fonctionne parfaitement avec OS X 10.4.
  • Java 1.5 est déjà installé avec OS X 10.4 ou supérieur.

Java n’est plus fourni avec OS X 10.8 (Mountain Lion). Il doit être téléchargé sur le site d’Adobe.

Note sur Mac OS 10.6

10.6 utilise une version Apple de Java 6. La version 7000 de JOSM est la dernière qui tourne sous Java 6 (sur Mac et ailleurs).

Version 7000 pour Java 6 : https://josm.openstreetmap.de/download/macosx/josm-macosx-7000-java6.zip

Les greffons d’extension pour JOSM

Les greffons sont aujourd’hui facilement téléchargeables et installables à partir du menu des préférences de JOSM. Une liste des greffons se trouve sur cette page du Wiki, et aussi à l’adresse JOSM Wiki. Cependant JOSM permet aussi de télécharger cette liste depuis l’onglet « Greffons » du panneau de configuration des « préférences » et d'en sélectionner certains pour les ajouter à la configuration. Attention : l’installation de nouveaux greffons nécessite la plupart du temps un redémarrage de JOSM, ce qui peut nécessiter de sauvegarder localement un travail en cours si les données modifiées ne peuvent pas encore être transférées en l’état immédiatement vers le serveur.

Comment démarrer JOSM

Le fichier JAR doit être associé au moteur Java. Cette étape se fait différemment suivant les plateformes :

Linux

Tapez simplement java -jar josm.jar dans une fenêtre shell. Il existe aussi quelques tutoriels vidéos. L'un d'entre eux décrit les étapes pour configurer KDE de telle sorte que JOSM démarre avec un clic sur son icône. Téléchargez les tutoriels (en anglais) depuis l'un des miroirs listés à l'adresse openstreetmap.de.

Pour les utilisateurs d’Ubuntu, il y a un bon tutoriel disponible sur UbuntuForums. Si vous utilisez Ubuntu 8.04 LTS et installez JOSM via son paquet, vous pourrez simplement l'appeler avec josm.

Si vous voulez utiliser JOSM derrière un proxy, vous pouvez le signaler à l'environnement Java dans la commande de lancement de l'éditeur comme ceci: java -Dhttp.proxyHost=192.168.1.1 -Dhttp.proxyPort=3128 -jar josm.jar, avec l'adresse IP et le port de votre proxy.

Ubuntu

Si vous avez installé JOSM à partir de la logithèque Ubuntu, vous disposez des boutons/menus lanceurs bien pratiques. Mais vous aimeriez lancer la josm-latest avec ces mêmes boutons.

JOSM a été installé dans le répertoire [1]
/usr/share/josm
Le shell de lancement est à l'adresse [2]
/usr/bin/josm
Vous avez téléchargé la latest (lien ci-dessus) qui se trouve dans le répertoire [3]
~/Téléchargements
Plaçez josm-latest à côté de la version livrée par Ubuntu [4]
sudo cp ~/Téléchargements/josm-latest.jar /usr/share/josm/
Éditez le shell de lancement [5]
sudo gedit /usr/bin/josm

Entrez votre mot de passe.

Dans Gedit changez la ligne [6]
    exec $JAVACMD -Xmx512m -jar /usr/share/josm/josm-0.0.snv*.jar "$@"
pour [7]
    exec $JAVACMD -Xmx1024m -jar /usr/share/josm/josm-latest.jar "$@"

Au passage on a doublé la mémoire allouée à JOSM : 512 Mo >1024 Mo.

Sauvegardez.

Le tour est joué. Cliquez sur un lanceur (menu ou bouton), c'est la dernière version qui se lance.

note : À chaque téléchargement de mise à jour de JOSM, il faudra remplacer la version active par la commande [4] ou exécuter [8] :

sudo wget "http://josm.openstreetmap.de/josm-latest.jar" -O /usr/share/josm/josm-latest.jar

Windows

Normalement, cliquez simplement deux fois sur le fichier josm.jar pour démarrer JOSM.

Dans les rares cas où cela ne fonctionnerait pas, créez un fichier texte nommé start_JOSM.cmd par exemple avec un éditeur de texte simple comme Notepad. Puis copiez la ligne suivante dans le fichier :

java -jar josm.jar

Sauvegardez ce fichier .cmd dans le même répertoire que le fichier josm.jar. Maintenant vous pouvez lancer JOSM en double-cliquant sur le fichier .cmd.

Vous pouvez aussi créer un raccourci vers le fichier JOSM.jar, ce qui permet d'ajouter des paramètres supplémentaires. Personnellement, j'utilise le raccourci suivant qui démarre JOSM avec 512 MB de mémoire pour le processus, ce qui améliore les performances de manière significative quand on édite un nombre important de données. Bien sûr, les chemins d'accès peuvent être différents sur votre machine:

C:\WINDOWS\system32\java.exe -jar -Xmx512m "C:\path\josm-latest.jar"

Systèmes Mac OS X

Vous aurez besoin de Mac OS 10.4 ou supérieur. Mac OS 10.3 ne peut pas faire fonctionner JOSM car il n'y a pas d'environnement Java développé pour cet OS.
Mac OS 10.4.x (Tiger), ne peut pas fonctionner avec les versions de JOSM postérieures à avril 2010, car celles-ci ne fonctionnent qu'avec Java 6. Les versions ultérieures de Mac OS (10.5, 10.6 et 10.7) sont compatibles Java 6.

Options de configuration mémoire

Si vous voulez allouer d'avantage de mémoire pour JOSM (pour pouvoir éditer de larges zones), le script suivant, à exécuter dans la fenêtre du Terminal, peut vous aider :

java -jar -Xmx256m -XX:MaxPermSize=256M josm-latest.jar

Les options -Xmx... (taille mémoire maximale de la VM Java) et -Xms... (taille mémoire initiale) sont les plus utiles, la seconde permettant d’accélérer le lancement. Toutefois veuillez faire attention à ne pas allouer plus que ce dont dispose votre système d’exploitation : si votre système dispose de 4Go de RAM installée, réservez environ 1Go pour le système et son environnement de bureau, et n’allouez pas plus de la moitié de ce qui reste, ce qui donne une taille maximale de VM Java d’environ 1,5Go (option Java : -Xmx1500M). Sachez que par défaut -Xmx... est limité à 256Mo avec l’installation 32 bits de Java, afin de ne pas surcharger votre système : sur un système d’exploitation 64 bits, il est hautement recommandé alors d’installer la version 64 bits de Java afin de pouvoir aller au delà si vous travaillez sur des jeux de données un peu volumineux (les 256Mo sont facilement atteints avec plusieurs dizaines de milliers de nœuds, quelques milliers de chemins et une centaine de relations et tous leurs attributs et si vous activez 3 ou 4 fonds d’imagerie)

Si JOSM vous signale qu’il manque de mémoire, supprimez les fonds d'imagerie inutiles, sauvegardez localement votre travail. Désactivez les greffons optionnels dont vous n’avez pas besoin, et relancez JOSM pour recharger votre travail en cours et ne réactivez que les fonds d'imagerie nécessaires à votre travail.
Si cela ne résout pas le problème, augmentez la valeur donnée à l’option -Xmx.... Consultez également la console Java en appuyant sur les touches fg pour libérer de la mémoire encore allouée mais plus utilisée, et avoir un état de la mémoire disponible dans la machine virtuelle Java (JOSM commence à afficher des problèmes de mémoire pleine ou de forts ralentissements répétitifs si la machine virtuelle Java a atteint sa taille maximale et la mémoire libre tombe en dessous de 2Mo : ces ralentissements surviennent même sans aucune modification de vos données de travail, juste en déplaçant les fenêtres ou survolant des zones de la carte avec le pointeur de la souris, car JOSM peut déclencher du code contextuel selon la zone survolée ou à rafraîchir sur la carte).

L’option -XX:MaxPermSize:... est à utiliser avec prudence : elle alloue cette mémoire de façon permanente tant que l’application est utilisée et peut empêcher une autre application concurrente (par exemple une sauvegarde ou le lancement d’un navigateur web ou d’un processus de mise à jour système en arrière-plan) d’en disposer efficacement en cas de besoin. Avant de l’utiliser, consultez les statistiques de la mémoire libre sur votre système, une fois l’environnement de bureau chargé. Il peut être souhaitable que JOSM puisse décharger une partie de sa mémoire de travail la moins utilisée vers le fichier ou la partition d’échange (swap) afin de laisser de la mémoire pour les processus concurrents. JOSM fonctionnera cependant sans problème avec la valeur par défaut de -XX:MaxPermSize:... ou juste légèrement étendue à 100 Mo (si par exemple vous avez activé de nombreux greffons dans JOSM dont certains créent des processus de travail en arrière-plan).

Pour plus de détails, consultez la documentation des options de configuration de la machine virtuelle Java.

Options de configuration réseau selon votre accès Internet

Si votre connexion à Internet dispose de l’adressage et du routage natif en IPv6, vous devez en informer l’environnement Java avec l’option -Djava.net.preferIPv6Addresses=true. Toutefois de nombreuses connexions Internet fixes disposent d’une adresse et d’un routage natif uniquement en IPv4 (IPv6 n’est pris en charge que par un tunnel fourni par un tiers, lequel peut en fait ralentir les chargements de données selon la charge du serveur de tunnels IPv6-sur-IPv4).

IPv6 est en revanche recommandée sur les connexions Internet mobiles où IPv4 n’est proposé que par un tunnel dont l’adresse IPv4 de votre côté peut être très temporaire et expirer rapidement, car elle est partagée par de nombreux autres utilisateurs et le fournisseur d’accès ferme rapidement les sessions qu’il juge inactives, ce qui peut provoquer alors des problèmes de fermetures inopinées de sessions en cours de travail voire en plein milieu d’un transfert de données pour peu que le serveur OpenStreetMap mette un peu trop de temps à répondre à certaines de vos requêtes de données volumineuses, notamment lors des envois vers le serveur
Une solution pour réduire le temps maximum de réponse du serveur est aussi de limiter la taille des blocs de données envoyés afin de réduire le temps de réponse du serveur à chacun des blocs de données envoyés, en utilisant l’onglet « option avancées » du dialogue d’envoi de données, ce qui évitera une fermeture inopinée de la session d’envoi par le fournisseur d’accès avant même d’avoir reçu cette réponse du serveur. L’option IPv6 en revanche, si elle est prise en charge par votre fournisseur d’accès, lui évitera de fermer prématurément des sessions puisque vous êtes alors normalement le seul utilisateur de votre adresse IPv6, contrairement à l’adresse IPv4 fournie seulement en mode de compatibilité via un routage "NAT" où de nombreux autres abonnés peuvent être connectés en utilisant les ressources du même routeur NAT de votre fournisseur d’accès (lequel est obligé de limiter le nombre total de sessions connectés et de les répartir entre ses abonnés).
Il est donc important de vous renseigner sur le type d’accès Internet dont vous disposez pour obtenir la meilleure stabilité et les meilleures performances.

Ce qui peut donner par exemple:

java -Djava.net.preferIPv6Addresses=true -Dhttp.proxyHost=proxy.ipv6.uni-leipzig.de -Dhttp.proxyPort=3128 -jar josm/josm-snapshot-xxx.jar

Notez que le serveur OpenStreetMap ne supporte pas encore l'IPv6 pour l'instant.

Les premiers pas

(Vous pouvez aussi lire ce petit guide du débutant mieux illustré.)

  • Regardez ces vidéos instructives [1] (en anglais).
  • Si vous avez un fichier de trace au format GPX des routes que vous voulez cartographier, démarrez JOSM et choisissez File → Open (ou le raccourci clavier ctrl-O) pour sélectionner et charger votre fichier trace. JOSM va alors automatiquement se centrer sur la zone couverte par votre fichier trace.
  • Si vous ne disposez pas de fichier trace GPX, alors vous avez encore la possibilité d'utiliser ceux collectés par d'autres contributeurs (à condition qu'ils aient transféré leurs fichiers sur le serveur OSM en mode 'public'). Voyez l'exemple du Korea Mapping Guide.
  • Vous avez aussi la possibilité de manipuler les données et faire de nombreux essais pour appréhender JOSM sans altérer la base de données à condition de ne pas transférer vos modifications vers le serveur OSM (commande 'upload'). Vous pouvez à tout moment supprimer les calques et recommencer.
  • Téléchargez toujours les dernières données depuis le serveur OSM avant d'éditer une zone, même si vous conservez des données sur votre propre ordinateur.
  • Pour transférer vos modifications vers le serveur, assurez-vous d'avoir bien entré votre nom d'utilisateur ainsi que votre mot de passe dans la fenêtre des préférences de JOSM. Votre nom d'utilisateur n'est pas votre nom d'utilisateur du wiki mais bien l'adresse email que vous avez entré lors de votre enregistrement sur le site principal d'openstreetmap.org.
  • Maintenant, choisissez File → Download from OSM. Dans la fenêtre qui s'ouvre, assurez-vous que la case 'OpenStreetMap data' est bien cochée puis validez avec le bouton OK. Toujours lire des données du serveur avant d'en transférer de nouvelles.
  • Si votre trace couvre une zone trop grande, le serveur refusera de transférer les données OSM pour éviter des transactions qui monopoliseraient trop longtemps les ressources (limitées) du serveur. Vous devrez un peu zoomer pour restreindre la taille de la requête et revenir à un niveau raisonnable.
  • Attendez le temps nécessaire pour que la requête vers la base de données puis pour que le transfert des données en retour soit complet. Si la zone géographique demandée contient déjà des données OSM, vous allez maintenant les voir s'afficher sur la fenêtre principale.
  • Passez ensuite à l'édition proprement dite. Faites attention lorsque vous changez des données existantes, car il est courant que des chemins et des nœuds contiennent déjà de nombreux tags et seul l'expérience vous permettra de juger si ces tags sont correct ou non.
  • Le manuel de JOSM est disponible en ligne ici (anglais). Ce document est aussi accessible directement en pressant la touche F1 dans l'application JOSM. Si vous sentez que vos modifications sont trop incertaines, surtout à vos débuts, n'hésitez pas à supprimer les calques que vous avez modifié et recommencez (travaillez par petites sessions dans un premier temps).
  • Voyez sur cette page une liste des raccourcis clavier par défaut.

Trucs et astuces

Regardez aussi les astuces plus avancées (pour utilisateurs plus expérimentés)

  • Après l'installation d'un plugin, vous devrez jeter un coup d'œil dans la fenêtre des préférences pour activer ou désactiver chaque extension individuellement
  • Pour les nouveaux utilisateurs d'OSM, il est recommandé d'utiliser la liste des tags pré-définis disponible dans le menu (vous pouvez aussi obtenir des fichiers externes de tags prédéfinis en demandant sur la mailing list ou User:SlowRider)
  • Après avoir envoyé vos modifications vers la base de données d'OpenStreetMap.org, il faudra un certain temps (parfois une semaine) jusqu'à ce que les changements apparaissent sur la carte principale dessinée par Mapnik.
  • Si vous ne disposez pas de molette sur votre souris, vous pouvez zoomer en avant et en arrière en utilisant la combinaison de touches Ctrl-. (point) et Ctrl-, (virgule).
  • Si vous cartographiez une double voie d'autoroute, vous trouverez ici un outil qui permet de créer la voie opposée pour vous. (NDT: il est aussi possible de faire du copier-coller avec des chemins dans l'éditeur).
  • La sensibilité pour déplacer un nœud est assez basse pour éviter les fausses manœuvres. Si vous désirez augmenter cette sensibilité, allez dans la fenêtre des préférences avancées et ajoutez (ou modifiez) la clé (key) suivante "edit.initial-move-threshold" et donnez-lui une valeur de 5 par exemple.

Faire coïncider automatiquement des photos avec les traces GPS

Un des problèmes récurrents avec nos relevés avec GPS est de garder des notes précises sur les noms des rues à chaque intersection. Si vous avez un appareil photo numérique (APN), JOSM peut vous aider.

  • prenez une photo de votre écran GPS montrant l'heure où vous démarrez votre tracé.

Prenez des photos des panneaux routiers, rues, intersections pendant vos pérégrinations. Puis, de retour à la maison et en ayant chargé vos traces GPS dans JOSM :

  • dans la fenêtre "Layers", coin supérieur droit
  • cliquez avec le bouton droit sur le calque de votre trace GPS que vous venez juste de charger. Note: vous devez le faire avec vos propres fichiers de trace car il n'est pas possible de réutiliser les traces venant du serveur OSM, celui-ci ne conservant pas les données horaires des fichiers GPX.
  • sélectionnez "Import Images" (ou éventuellement "import photos" suivant la version de JOSM)
  • cliquez avec le bouton droit sur le calque des photos,
  • synchronisez les horloges en utilisant la 1ère photo que vous avez prise au début de la session (celle affichant l'heure sur l'écran du GPS).
    • Si vous ne disposez pas d'une photo de l'heure de votre GPS pour une raison ou une autre, allumez votre APN et votre GPS maintenant et observez les différences entre les deux horloges. Puis soustrayez ou ajoutez cette différence dans la fenêtre des photos, dans le champs 'sync clocks'.
  • (NDT : il y a encore la possibilité de synchroniser directement les horloges de l'APN et du GPS)

Faire coïncider automatiquement un enregistrement sonore avec les traces GPS

On dispose aujourd'hui de la même facilité de synchronisation pour les enregistrements sonores sur dictaphones ou autres MP3 ou téléphones portables.

Il y a trois méthodes décrites avec des instructions pas-à-pas dans l'aide en ligne de JOSM :

1. Bande son continue avec des marques GPS

Avec cette méthode, vous collectez des points de navigation (waypoints) le long de votre chemin en utilisant les commandes appropriées de votre GPS et vous ajoutez vos commentaires sur la signification de ces marques en parallèle dans l'enregistrement sonore continu - un nom de rue ou un point d'intérêt. Votre GPS enregistre trois informations clés pour chaque point de navigation - sa localisation, l'heure et sa référence, habituellement un numéro. La bande audio et les points de navigation sont ensuite synchronisés dans JOSM de telle manière que vous pouvez ensuite réécouter chaque descriptif en cliquant sur la marque représentant le point de navigation à l'écran.

2. Bande son continue avec points d'intérêts identifiés vocalement

Avec cette méthode, vous faites aussi un enregistrement continu du son mais à la place d'entrer des points de navigation dans votre GPS, vous dictez un son identifiant un point d'intérêt, par exemple "Marque! River Lane école primaire à gauche".

3. Clips audio avec points de navigation

Avec cette méthode, vous créez des points de navigation en identifiant des points d'intérêt. Cependant, vous enregistrez un fichier sonore séparé pour chaque point et le nom de chaque fichier est ajouté en tant qu'élément <link> dans le point de navigation correspondant dans le fichier GPX avant d'être chargé dans JOSM. Lorsque JOSM créé les marqueurs audio pour chaque point de navigation, il saura quel clip audio jouer lorsque vous cliquez sur un marqueur.

Messages d'erreurs de JOSM

Error while parsing. An error has occurred

La cause la plus probable de l'erreur ci-dessus est que le serveur est temporairement surchargé et n'a pas pu envoyé la réponse requise à JOSM dans les temps. Si cette erreur se produit, essayez juste de transférer les données une nouvelle fois, et JOSM reprendra à l'endroit oû l'erreur s'était produite.

Si vous recevez une erreur "412 precondition failed", cela veut dire que quelque chose s'est produit sur le serveur de façon inattendue. Essayez d'effacer les objets concernés.

JOSM semble bien démarrer mais l'écran est blanc

Ceci peut arriver si vous avez activé des outils graphiques du genre de compiz/beryl. La solution est simple, ajoutez la ligne suivante dans le profile utilisateur :

export AWT_TOOLKIT="MToolkit"

Notes pour les débutants

Ci-dessous se trouvent quelques notes prises par un débutant (Parsingphase) durant les premiers jours de sa prise en main avec l'éditeur JOSM (sur Mac OS X).

Les points spécifiques au Mac

  • "Installer" JOSM sur OS X est du gâteau (sic) - téléchargez et double-cliquez simplement sur le fichier .jar.
  • Utilisez une souris avec deux boutons et une molette - cela facilite considérablement les choses. Glisser avec le bouton droit de la souris enfoncé permet de déplacer la carte, la molette fait le zoom.
  • Autrement, le command-click (aussi appelé l'"Apple-click") fonctionne comme un clic droit, la combinaison ctrl et les flèches pour déplacer la carte, et ctrl- et ctrl+ pour zoomer.
  • Parce qu'il commence par un point, votre répertoire ~/.josm ne sera pas visible dans le Finder. Vous devrez soit y copier les plugins à partir d'une ligne de commande, soit ouvrir le dossier en utilisant "Aller au dossier..." dans le menu "Aller" du Finder.
  • On peut modifier l'apparence de JOSM pour être proche des conventions utilisées par Mac OS X; cela ne change rien au niveau des fonctionnalités mais ça le fait ;)

Remarques pour toutes les plateformes

  • Pour sélectionner un chemin (way) parmi d'autres qui se superposent parce qu'ils partagent les mêmes noeuds, cliquez avec le bouton du milieu puis appuyez sur la touche CTRL et sélectionnez le chemin que vous désirez sélectionner en cliquant avec le bouton gauche dans la liste qui est apparue à l'écran.
  • Installez l'extension pour le mode de rendu "mappaint". Cela rend les choses bien plus facile pour voir ce qui se passe sur vos cartes, mais au prix d'une charge supplémentaire significative pour votre processeur (mon PowerBook 12 le supportant bien). Ce plugin est maintenant intégré dans JOSM et peut être activé ou désactivé depuis le menu Affichage > Mode fil de fer.
  • Téléchargez et transférez de plus petites zone et plus fréquemment si vous travaillez à plusieurs sur un même endroit. Plus courte est la période où vous conservez des modifications localement, moindre est le risque d'avoir des conflits avec les autres contributeurs.
  • Téléchargez toujours une zone avant de travailler dessus, même si vous avez vos propres données GPX.
  • Téléchargez toujours une zone avant de transférer vos modifications, pour recevoir les modifications des autres et ainsi éviter d'écrire par-dessus leurs données.
  • Lorsque vous téléchargez une zone, vous recevez toutes les données à l'intérieur du rectangle que vous avez choisi, mais les chemins se prolongent au-delà du rectangle puisqu'ils sont chargés en entier. Il devient donc difficile de savoir avec précision quelles zones contiennent l'ensemble des données et celles qui ne sont que partiellement chargées (surtout après plusieurs téléchargements). C'est pourquoi il existe l'option "Draw boundaries of downloaded data" (dans la fenêtre "Display Preferences") qui dessine, lorsqu'elle est activée, un rectangle jaune à l'écran autour de la zone où les données sont complètes. Travailler en dehors de ce rectangle implique que des données peuvent déjà exister dans la base mais ne sont peut-être pas affichées par JOSM. Pour éviter les duplications, il vaut donc mieux procéder à un téléchargement supplémentaire de la zone non couverte par le rectangle jaune par précaution.
  • Il est souvent recommandé de faire ses premiers pas sur une "petite zone". Celle-ci peut se définir soit par un fichier trace GPX assez petit ou par un carré d'1 km² environ sur une zone connue. Cela correspond à un angle de 0.06 ° de latitude/longitude approximativement.
  • Les zones rurales contiennent en général moins de détails et cette recommandation de 1 km² concerne d'avantage des zones plus dense comme les villes et les banlieues.
  • Une fois que JOSM affiche les premières données (c.à.d. que la page d'accueil a disparu), le dialogue pour télécharger d'autres données depuis le serveur OSM (raccourci clavier CTRL-MAJ-D) prendra par défaut les limites de la zone actuellement visualisée à l'écran, quel que soit le niveau de zoom.
  • Il arrive souvent de sélectionner plus d'objet qu'il ne faudrait ce qui créer parfois des erreurs, en particulier lorsqu'on y attache des tags. C'est pourquoi il est aussi recommandé d'activer la fenêtre "Current Selection" ce qui permet de garder un oeil sur la liste de la sélection en cours.
  • Pour éviter toutes manipulations accidentelles, n'hésitez pas à revenir au mode "sélection" de votre éditeur (raccourci clavier 's') régulièrement et de cliquer dans un espace vide de la fenêtre principale pour tout dé-sélectionner. Pour les rond-points, choisissez le type de route le plus élevé si l'intersection concerne des types différents (par exemple, junction=roundabout et highway=primary si au moins une des routes est primary et les autres sont secondary).

Pourquoi mes changements n'apparaissent pas sur la carte ?

  • Étudiez la page Map Features pour voir comment taguer les routes, chemins de fer, etc. Pour les routes et chemins, il faut obligatoirement au moins un tag highway=quelque chose pour que cela apparaisse ensuite sur un des cartes tracées par Mapnik ou Osmarender. Si vous n'êtes pas sûr pour la classification d'une route (par exemple primary/secondary), choisissez dans un premier temps la version moindre (par exemple secondary).
  • Les cartes glissantes ne sont pas redessinées en permanence. Regardez sur la FAQ pour voir quelles sont les périodes de rafraîchissement pour les différentes cartes disponibles.

Voir aussi

Pages en relation

Liens externes