DE:JOSM/Guide

From OpenStreetMap Wiki
Jump to: navigation, search
Verfügbare Sprachen
  Erste Schritte   Grundlegendes Editieren   Fortgeschrittenes Editieren   Plugins   Tastenkürzel   Editor/Fenster (alt)   Werkzeuge (alt)   Praxis (alt)  

Diese Anleitung soll Ihnen den Einstieg in das Projekt so einfach wie möglich machen. Deshalb ist die Anleitung mit Registerkarten (siehe oben!) zusammengefasst und reichhaltig bebildert. Es ist das Wesen der EDV, dass sich die Dinge sehr schnell ändern. Daher bitten wir um Nachsicht, falls die Anleitung in Details von der verwendeten Software abweicht.

Falls Sie kein GPS-Gerät und somit keine GPS-Spur zur Verfügung haben, können Sie mit etwas Ortskenntnis dennoch etwas zum Projekt beitragen. Falls beispielsweise in Ihrer Umgebung schon Straßen vorhanden sind, jedoch noch Telefonzellen, Restaurants oder Spielplätze fehlen, können Sie diese anhand dieser Anleitung eintragen. Ähnliches gilt für Straßennamen: Vervollständigung und Korrekturen der Straßennamen sind möglich. Gerade die periodische Überprüfung, Aktualisierung und Korrektur der bestehenden Daten werden immer wichtiger, denn die Welt verändert sich ständig, und in OSM müssen diese Veränderungen zeitnah eingepflegt werden, damit die Karte aktuell bleibt.

Übersicht

Der Arbeitsprozess mit JOSM gestaltet sich im Großen und Ganzen folgendermaßen:

  1. Daten laden: Um mit JOSM irgendetwas machen zu können, müssen Sie erstmal Daten laden. Das können entweder OSM-Daten aus der OSM-Datenbank sein oder GPX-Spuren, die Sie auf dem PC gespeichert haben. Die Daten werden lokal im Arbeitspeicher abgelegt und können dann benutzt werden (verändert werden aber nur OSM-Daten, keine GPX-Spuren).
  2. Bearbeiten: In diesem Schritt werden die vorhandenen Daten ergänzt bzw. korrigiert oder neue Daten hinzugefügt.
  3. Änderungen hochladen: Die Bearbeitungen müssen schlussendlich wieder auf den OSM-Server hochgeladen werden.

Benutzerkonto erstellen

Bevor Sie loslegen können, benötigen Sie ein Benutzerkonto, das Sie sich über die (englischsprachige) Projektseite erstellen können. Bitte bewahren Sie die angegebene E-Mail-Adresse, das Passwort und das Pseudonym ("Display name"), das Sie für die Registrierung verwendet haben, gut auf.

Diese Zugangskennung kann neben dem Login auf der OSM-Projektseite und der Verwendung mit den Nicht-Browser-basierten Editoren wie JOSM oder Merkaartor auch für das OSM-Forum und Fehler-Meldungen zu JOSM genutzt werden.

Beim dauerhaften Ablegen des Passworts in den Programmeinstellungen der Editoren kann nicht garantiert werden, dass diese Speicherung (ausreichend) verschlüsselt erfolgt. Dies sollte bei der Wahl des Passworts bedacht werden.

JOSM installieren

Die meisten Projektmitglieder verwenden den Java-Editor JOSM. Die Installation ist ganz einfach:

Windows: automatisches Installationsprogramm
Ubuntu-Linux: automatische Installation
Debian-Linux: Debian-Pakete existieren für Squeeze und Sid in (utils), welche mit einem beliebigen Paket-Manager zu installieren sind.
Fedora-Core-Linux automatische Installation über die Textkonsole:
sudo yum install josm
es wird automatisch ein Hauptmenüeintrag unter Education bzw. Bildung angelegt.
andere Betriebssysteme:   Download

Unter Windows wird JOSM durch das Setup.exe automatisch installiert und konfiguriert. In der Schnellstartleiste wird ein Icon eingetragen, JOSM startet durch Klick.

Java installieren

Wenn JOSM über josm-setup.exe installiert wird, wird automatisch geprüft, ob die richtige Java-Version installiert ist, und wenn nicht, wird diese automatisch installiert.

Für alle anderen Installationswege gilt:

JOSM liegt in einem ausführbaren Java Archiv (JAR) vor (z.B. josm-tested.jar). Um die JAR-Datei auszuführen benötigt man eine Java Laufzeitumgebung (Java Runtime Environment, kurz JRE), im Fall von JOSM benötigt man Java ab Version 1.6.

  • Auf dem Macintosh ist Java bereits installiert. Somit können Sie JOSM nach dem Herunterladen direkt durch Doppelklick starten.
  • Auf manchen Linux-Distributionen müssen Sie Java erst nachinstallieren. An dieser Stelle kann hierzu keine Anleitung für die verschiedensten Distributionen zur Verfügung gestellt werden. Ist Java installiert, können Sie unter KDE mit der rechten Maustaste auf die heruntergeladene Datei klicken und in dem Kontextmenü auf den Eintrag "Öffnen mit" zeigen. Wählen Sie dann "Sonstige" und tragen Sie "java -jar" ein. Stellen Sie sicher, dass das Ankreuzfeld "Programm diesem Dateityp fest zuordnen" eingeschaltet ist. Alternativ starten Sie JOSM aus einem Terminal mit dem Befehl "java -jar josm-latest.jar".
  • Unter manchen Windows-Versionen müssen Sie Java ebenfalls noch nachinstallieren. Die herunterladbaren Installationsdateien und eine genaue Installationsanleitungen finden Sie auf Java.com.

JOSM aktualisieren

JOSM erkennt, ob eine neuere Version verfügbar ist und zeigt beim Programmstart einen Hinweis auf der Informationsseite:

Genutzte JOSM-Version ist 3751! Aktuell verfügbare Version ist 3751 (Entwicklung 3791).

Die Aktualisierung erfolgt am einfachsten durch einen erneuten Aufruf von josm-setup.exe, dadurch wird die neueste josm-tested.jar geladen und alle bisherigen Einstellungen bleiben erhalten.

Man kann auch von Hand die Datei "josm-tested.jar" durch die neuere Version ersetzen. Die bisherigen Voreinstellungen und installierten Plugins bleiben erhalten, troztem wird empfohlen, auch die Plugins zu aktualisieren (Menü Bearbeiten -> Einstellungen, Karteireiter Plugins (Stecker-/Steckdosensymbol), Knopf "Update").

Fortgeschrittene Nutzer können auch die neueste Enwickler-Version herunterladen. Diese ist aber nicht geprüft und kann noch fehlerhaft sein.

JOSM-Update-und-Start-Script für Linux

Es gibt ein von Cobra entwickeltes Shell-Script, das JOSM immer aktuell hält und komfortabel mit den richtigen Parametern startet. Außerdem lassen sich damit auch eine oder mehrere Dateien als Parameter übergeben, die direkt in JOSM geöffnet werden sollen. Außerdem kann auf Wunsch ein Update aus dem SVN durchgeführt sowie ältere Versionen geladen werden.

Ein alternatives, sehr einfach zu wartendes Skript ist update-josm findet

JOSM-SVN-Updater und Startscript für Linux

Wer immer die aktuellste SVN-Version benutzen will, kann das Script josm_svn.sh von Telegnom benutzen. Das Script lädt die neuste Version der JOSM-Quellen aus dem SVN und kompiliert sie. Falls es keine neuere SVN-Version gibt, wird die lokale Version gestartet.

JOSM starten

Schnellstart

Es gibt drei Arten JOSM zu starten:

  • Klick auf das JOSM-Symbol in der Schnellstartleiste
  • Doppelklick auf eine Verknüpfung auf dem Desktop (z.B. josm-latest.jar, gilt nicht, wenn JOSM über die automatische Installation installiert wurde.)
  • Windowstaste > Programme

Start über Kommandozeile

Achtung: Die Anleitung in diesem Kapitel ist gegenstandslos, wenn JOSM über die automatische Installation installiert wurde.

JOSM kann auch händisch über die Kommandozeile gestartet werden (in Windows die Eingabeaufforderung, bei Linux die Shell oder Console). Dazu ruft man den Befehl "java.exe" bzw. "java" mit dem Parameter "-jar" auf, auf den dann der Pfad zur startende Jar-Datei folgt. Auf diesen Weg bekommt man nebenbei auch etwaige Fehler angezeigt, die von Java gemeldet werden. In den Beispielen ist "<Pfad-zur-JOSM-Jar-Datei>" durch den tatsächlichen Pfad zur JAR-Datei zu ersetzen (z.B. C:\Programme\JOSM\josm-latest.jar).

Für MS Windows kann einer der folgenden Aufrufe genutzt werden

java.exe -jar <Pfad-zur-JOSM-Jar-Datei>
C:\Windows\System32\java.exe -jar <Pfad-zur-JOSM-Jar-Datei>

Und für Linux

java -jar <Pfad-zur-JOSM-Jar-Datei>
/usr/bin/java -jar <Pfad-zur-JOSM-Jar-Datei>

Auf diesem Weg ist es möglich, Java mit zusätzliche Parameter zu starten.

Zusätzliche Parameter

Achtung: Die Anleitung in diesem Kapitel ist gegenstandslos, wenn JOSM über die automatische Installation installiert wurde.

Java verfügt über weitere Parameter über die man den Aufruf an seine Begebenheiten anpassen kann. So ist es beim Verarbeiten größerer Datenmengen oftmals notwendig, die maximale Heap-Größe für Java zu erhöhen um ein ruckelfreies Arbeiten zu ermöglichen.

java -help

gibt eine Übersicht der Standardparameter aus. Weitere Parameter erhält man über den Aufruf

java -X

darunter der Parameter für die Angabe des maximalen Heap

-Xmx<size>        set maximum Java heap size

"<size>" ist mit der gewünschten Speichergröße zu ersetzen, gängige Angaben sind "512M" (512 Megabyte) oder "1G" (1 Gigabyte) für Rechner mit mehreren Gigabyte an Hauptspeicher.

Ein Beispiel

java -Xmx512M -jar <Pfad-zur-JOSM-Jar-Datei>

Weitere Informationen, u.a. wie man JOSM mit Parametern startet um ruckelfrei arbeiten zu können, sind auf der englischen JOSM-Anleitungsseite zu finden. </div>

Starten über Skriptdateien

Achtung: Die Anleitung in diesem Kapitel ist gegenstandslos, wenn JOSM über die automatische Installation installiert wurde.

Um zu vermeiden bei jedem Start von JOSM den Befehl mit sämtlichen Parametern in der Kommandozeile eingeben zu müssen, kann man sich eine ausführbare Skriptdatei anlegen über die man dann JOSM mit einen Doppelklick auf die Datei startet.

Für MS Windows legt man mit einem Texteditor wie Notepad eine Datei (Batchscript) mit der Dateiendung ".bat" an, in diese Datei schreibt man einen der oben genannten Befehle. Als Beispiel "josm.bat"

C:\Windows\System32\java.exe -Xmx512M -jar C:\Programme\JOSM\josm-latest.jar %1

Für MS Windows kann man auch eine neue Verknüpfung anlegen. Klicken Sie hierfür mit der rechten Maustaste auf eine freie Stelle des Desktops und wählen "Neu" "Verknüpfung". Als Ziel/Speicherort gegen Sie die obige Zeile ein. Die Verknüpfung kann auch in das Startmenü verschoben werden. Die Angabe von %1 am Ende des Aufrufs ist optional. Dadurch leitet das Skript Startparameter, wie zum Beispiel eine zu öffnende Datei, an JOSM weiter. Der Pfad zur Datei java.exe muss möglicherweise angepasst werden. Sollten Leerzeichen in einem Pfad vorkommen, so muss man den kompletten Pfad in "" setzen.

Für Unix-artige Betriebssystem wie Linux geht man ähnlich vor. Man legt ein Datei (Shellscript) mit der Endung ".sh" an, schreibt als erste Zeile "#!/bin/sh" und fügt als nächste Zeile einen der oben genannten Befehle ein. Als Beispiel josm.sh

#!/bin/sh

/usr/bin/java -Xmx512M -jar "/home/linuxuser/josm-latest.jar"

Bei Unix-artigen Betriebssystemen entscheidet nicht (unbedingt) die Dateiendung über den Typ der Datei (Shellscript) sondern der Inhalt, in diesen Fall die erste Zeile #!/bin/sh (die sogenannte Shebang).

Legt man die erstellte Skriptdatei in ein Verzeichnis ab, das in der PATH-Umgebungsvariable steht, kann man JOSM bequem durch einen einfachen Aufruf von "josm.bat" oder "josm.sh" von einem beliebigen Arbeitsverzeichnis aus über die Kommandozeile starten.

Voreinstellungen

Achtung: Die Anleitung in diesem Kapitel ist gegenstandslos, wenn JOSM über die automatische Installation installiert wurde.

De-JosmPreferences1.png

Bevor wir beginnen, sollten ein paar grundlegende Einstellungen vorgenommen werden, damit wir mit den selben Voraussetzungen anfangen können. Rufen Sie als erstes nach dem Start von JOSM die Voreinstellungen auf, indem sie im Bearbeiten-Menü auf den Eintrag "Einstellungen" klicken.

De-JosmPreferences6.png

Zuerst werden die Plugins installiert. Wählen Sie dazu den Plugins-Reiter auf der linken Seite und klicken dann auf die Schaltfläche "Download List" und bestätigen mit "OK". JOSM holt daraufhin eine Liste der verfügbaren Plugins ab. Schalten Sie die abgebildeten Plugins ein, indem Sie die entsprechenden Häkchen setzen.

Das im Bild angegebene deutsche Sprachpaket ist mit einer aktuellen Version nicht mehr nötig




De-JosmPreferences7.png

Betätigen Sie die Bildlaufleiste am rechten Rand, um die Plugins weiter unten in der Liste sehen zu können. Schalten Sie auch hier die abgebildeten Plugins ein. Selbstverständlich können Sie auch weitere Plugins auswählen. Verlassen Sie die Voreinstellungen, indem Sie auf "OK" klicken. Nachdem JOSM die gewünschten Plugins aus dem Netz geladen hat, starten Sie JOSM bitte neu. Das Menu sollte nach dem Neustart in Deutsch erscheinen.

De-JosmPreferences2.png

Nun werden weitere Voreinstellungen vorgenommen. Klicken Sie dazu erneut im Menu "Bearbeiten" auf den Eintrag "Einstellungen...". Wählen sie die Anzeige-Einstellungen wie abgebildet.




De-JosmPreferences3.png

Tragen Sie unter Verbindungseinstellungen die E-Mail-Adresse, die Sie zur Registrierung bei OSM verwendet haben, und Ihr Passwort ein (Passwort-Hinweis beachten):

De-JosmPreferences4.png

Schalten Sie unter Karten-Einstellungen die eingebauten "Objektvorlagen" ein. Diese werden Ihnen die ersten Editierschritte erleichtern. Wenn Sie parallel zu JOSM den Webeditor Potlatch benutzen, wählen Sie bei Karteneinstellungen unter Projektionsmethode: Mercator, dann werden beispielsweise rechteckige Bilder in beiden Editoren auch rechteckig angezeigt.




De-JosmPreferences8.png

Auf dem Reiter "Die Elemente auf der Werkzeugleiste anpassen" können Sie Ihre Werkzeugleiste an Ihre Arbeitsweise anpassen: Wählen Sie rechts in der Liste jeweils das Werkzeug aus, das Sie in Ihre Werkzeugleiste aufnehmen möchten. Klicken Sie dann auf die Schaltfläche mit dem Pfeil nach links, um das ausgewählte Werkzeug zu Ihrer Werkzeugleiste hinzuzufügen. Um ein Werkzeug aus der Toolbar zu entfernen, benutzen Sie den Pfeil nach rechts. Mit den Doppelpfeilen können Sie die Werkzeugleiste leeren bzw. alle verfügbaren Werkzeuge hinzufügen. Sie können die Anordnung der Werkzeuge in der Werkzeugleiste (linke Liste) ändern, indem Sie ein Werkzeug markieren und die Schaltflächen mit den Pfeilen auf und ab betätigen. Wählen Sie die Werkzeuge aus, die Sie voraussichtlich am häufigsten verwenden. Das variiert, je nachdem welche Art von Daten Sie einpflegen möchten. Diese Einstellungen sollten Ihnen einen guten Start ermöglichen. Während Ihrer späteren Arbeit können Sie natürlich weitere Änderungen vornehmen. Verlassen Sie die Voreinstellungen und starten Sie JOSM neu, falls Sie dazu aufgefordert werden.



Daten laden

JOSM Anfang.png

Nach dem Neustart sollte JOSM in etwa wie abgebildet aussehen:

Um mit der Arbeit von JOSM anzufangen, müssen Daten geladen werden. Grundsätzlich kann dabei unterschieden werden zwischen:

  • OSM Daten: Können entweder über eine Datei auf der Festplatte oder vom Server geladen werden, wobei vom Server wohl die gängigere Variante ist (von der Festplatte höchstens zu Testzwecken oder als Backup), auch der Aktualität wegen die vernünftigere.
  • GPS Daten
    • GPX Files (GPS-Spuren): Mit dem GPS aufgenommene Spuren, die in JOSM nachgezeichnet werden, sollen und auf der Festplatte liegen.
    • Vom Server zusammen mit den OSM-Daten heruntergeladene GPS-Punkte anderer Benutzer.

GPX-Dateien öffnen

JOSM GPS GPX Datei oeffnen.png

Meistens möchte man ja die gerade aufgezeichneten GPS-Spuren verarbeiten. Diese lassen sich per Drag and Drop einfach in das JOSM-Fenster ziehen. Alternativ geht man auf Datei — Öffnen... und öffnet mit dem Dateimanager die GPX-Datei durch Auswählen. Falls Sie Fotos mit Geotags oder eine Wegpunktedatei (NMEA-Datei) haben, können Sie auch diese in den Editor ziehen oder öffnen.

JOSM Track Fenster.png

Sie sehen jetzt die GPS-Spur und eventuell die Punkte oder Fotosymbole, sofern geladen. Diese Spur wird im Normalfall nicht direkt in eine Straße oder einen Pfad umgewandelt, das gäbe zu viele Punkte und auch fehlerhafte Ausreißer wären in der Karte. Der normale Workflow sieht so aus, dass man diese Spur nun im Editor Klick für Klick in groben Zügen nachzeichnet. Dazu mehr weiter unten im Abschnitt Straße hinzufügen.

Am linken Bildschirmrand befinden sich oben die Schaltflächen für die Datenbearbeitung und darunter eine Reihe von Schaltflächen, mit denen sich Paletten am rechten Bildschirmrand ein- und ausblenden lassen. Da einige dieser Paletten sehr nützlich sind, schalten Sie einige davon am besten dauerhaft ein.

(Hinweis: Bei den Screenshots wurde die Hintergrundfarbe auf #FFFFFF (d.h. weiß) gesetzt. Diese Einstellmöglichkeit findet sich unter Anzeigen-Einstellungen im Konfigurationsdialog.)

OSM-Daten laden

JOSM Dialg Daten herunterladen.png

OSM-Daten ebenso wie GPX-Dateien lassen sich direkt aus einer Datei laden. In der Regel wird man OSM-Daten aber vom Server beziehen. Dazu wählt man Datei — Vom OSM-Server herunterladen ... und es öffnet sich eine Dialogbox.

Dataquellen und Typen gibt an, welche Daten geladen werden sollen. Meistens will man hier sowohl OpenStreetmap Daten als auch rohe GPS-Daten von anderen Benutzern wählen. In manchen Fällen kann es aber auch sinnvoll sein, nur eines von beiden auszuwählen.

Als neue Ebene laden lädt die Daten in eine eigene Ebene (was das bedeutet später mehr).

Mit der Registerkarte (Tab) wählt man aus, wie und wo die Datei bzw. welches Gebiet heruntergeladen werden sollen.

Bei Interaktive Karte kann man komfortabel einen Bereich auswählen. Zoomen und schieben mit der Maus, mit gedrückter linker Maustaste einen kleinen rechteckigen Bereich auswählen (einen zu großer Bereich wird der Server verbieten).

Die weiteren Punkte in der Registerkarte stammen aus älteren Zeiten wo die interaktive Karte noch nicht vorhanden war. Sie können jedoch weiter verwendet werden.

Unter Lesezeichen wählt man ein Lesezeichen aus, das man aber erst erstellen muss. Lesezeichen erstellen: Ein Lesezeichen kann gespeichert werden, indem man zunächst den gewünschten Bereich unter dem Tab 'Koordinaten' eingibt (siehe nächsten Punkt) und dann unter 'Bookmarks' nach einem Klick auf 'Add' einen beliebigen Namen dafür vergibt (zum Beispiel den Namen der Stadt/Region). Will man das nächste Mal den Bookmark benutzen, wählt man ihn einfach aus der Liste aus und füllt die Felder unter 'Bounding Box' entsprechend aus.

Bei Koordinaten hat man die Wahl ob man entweder direkt die Koordinaten eingibt (wird man wohl selten auswendig wissen) oder ein Link angibt der die Koordinaten enthält. Link eintragen (URL von www.openstreetmap.org): Man geht auf eine Seite wie OpenStreetMap.org, sucht sich in der Slippy Map den gewünschten Ausschnitt, kopiert sich den 'Permanent Link' rechts unten und fügt ihn in die entsprechende Editbox per <Strg-V> ein.

Bei Bei Ladebereich um bestimmte Orte können sie die Umgebung des gewünschten Ortes herunterladen.

Bei Kachelnummern können Sie Kachelnummern eintragen. JOSM arbeitet 'Kachelbasiert', das heißt, die Welt ist in kleine Stücke geteilt.

Mit einem Klick auf 'OK' versucht JOSM nun die Daten herunterzuladen. Das kann je nach Serverauslastung und der Größe der Daten wenige Sekunden aber auch viel länger dauern.

Mehr oder schneller OSM-Daten laden

Mit der obigen Anleitung bezieht man die Daten stets vom Hauptserver, der je nach Auslastung langsam sein kann oder die Download-Größen beschneidet. Es stehen aber auch Spiegel-Server zur Verfügung, von denen sich mehr Daten und schneller herunterladen lassen. Dies geht bequem mit dem Plugin Mirrored Download.

OSM-Dateien speichern

Hat man die rohen Kartendaten vom OSM-Server heruntergeladen, speichert man sie in einer Datei ab, um sie auch im Offline-Modus verfügbar zu haben. Hierzu wählt man Datei - Speichern unter... aus. Im Feld Dateiname trägt man einen aussagekräftigen Namen für das zu bearbeitende Gebiet ein. Dann wählt man im Feld Dateityp die OSM-Server-Datei (*.osm *.xml) aus und drückt auf Speichern. (Wahlweise lassen sich auch komprimierte Dateiformate auswählen oder einzelne GPS-Spuren als GPX-Datei abspeichern). Jetzt kann man die Internet-Verbindung trennen und offline weiter arbeiten. Speichert man nach dem Editieren die Bearbeitung ab, wird sie nun in dieser Datei abgelegt und lässt sich auch ohne Internet-Verbindung wieder aufrufen. Zum erneuten Öffnen wählt man einfach Datei - Öffnen... und bekommt die abgespeicherte Datei angezeigt.

Gerade für das kartografieren in abgeschiedenen Regionen, in denen man nicht jeden Tag einen Internet-Zugang zur Verfügung hat, ist es sinnvoll, sich diese Anleitung sowie die Seite der Map-Features ebenfalls offline verfügbar zu machen.

Grundlegende Bedienung

JOSM Track Fenster verschoben.png

Karte verschieben

Bewegen Sie den Mauszeiger in das Arbeitsfenster. Danach klicken und halten Sie die rechte Maustaste, es müsste ein Fadenkreuz mit Pfeilen Pfeilkreuz.png erscheinen. Jetzt können Sie die Karte nach Belieben verschieben.

Karte vergrößern / verkleinern

Verwenden Sie das Mausrad, um den sichtbaren Ausschnitt zu vergrößern und zu verkleinern. Stellen Sie sicher, dass der sichtbare Ausschnitt maximal einem Gebiet von ca. einem Quadratkilometer entspricht. Falls Ihr Track größer ist, vergrößern Sie davon einen Abschnitt, den Sie zuerst bearbeiten möchten. Ihre Arbeitsfläche könnte jetzt so aussehen:

Daten laden / vergleichen

JOSM Track Fenster mit OSM Daten.png

Jetzt sollten Sie zuerst beim Server anfragen, ob in diesem Bereich bereits Daten vorliegen. Klicken Sie auf die Schaltfläche Kartendaten vom OSM-Server herunterladenJOSM-Icon Daten download.jpg:

JOSM ermittelt anhand ihrer GPS-Spur automatisch den Bereich, der heruntergeladen werden soll. Schalten Sie die Option "OpenStreetMap-Daten" ein. Klicken Sie anschließend auf die Schaltfläche "OK", um ihre erste Anfrage am Server zu starten:

Falls am Server gerade Wartungsarbeiten durchgeführt werden oder gerade sehr viele Kartografen Daten abrufen, kann es sein, dass Ihre Anfrage nicht bearbeitet werden kann. Dies kommt selten, aber dennoch vor. Versuchen Sie es in diesem Fall später nochmal.

Nach dem Laden der Daten sollte Ihre Arbeitsfläche etwa dem abgebildeten Beispiel ähneln:

Daten selektieren/verschieben

JOSM Palette Eigenschaften.png

Sie arbeiten jetzt mit Daten, die im Arbeitsspeicher Ihres Rechners liegen. Wenn Sie Daten ändern, werden diese noch nicht in der Projektdatenbank gespeichert. Das können Sie sich für Ihre ersten Schritte zunutze machen. Sehen Sie sich in Ruhe die vorliegenden Daten an. Solange Sie keine Änderungen hochladen, können Sie nach Lust und Laune ausprobieren, wie der Editor funktioniert und wie die Daten aussehen. Wählen Sie am besten am linken Rand das Werkzeug Objekte auswählen, bewegen, skalieren und rotieren (S) aus:Objekte auswaehlen.png

Wählen Sie eine Straße an, hier im Beispiel im linken oberen Quadranten. Beachten Sie in der Palette (rot markiert)"Eigenschaften/Mitgliedschaften" am rechten Rand die Attribute, mit denen die Straße versehen ist. Klicken Sie weitere Elemente an, eine andere Straße beispielsweise, einen einfachen Punkt oder auch einen Punkt, der als Parkplatz, Restaurant oder Spielplatz gekennzeichnet ist und achten Sie in der Palette "Eigenschaften/Mitgliedschaften" auf die zugewiesenen Attribute.

Straßen hinzufügen

Damit wir besser unsere Arbeit erkennen können, setzen wir die Hintergrundfarbe im Kartenfenster wieder auf schwarz. Klicken Sie im Menü "Bearbeiten" auf den Eintrag "Einstellungen..." Wählen Sie dazu den Erweiterte-Einstellungen-Reiter (Einstein) auf der linken Seite und klicken dann auf dem Wert-Feld neben dem Schlüssel color.background und geben Sie den Wert #000000 ein. Zum Schluss bestätigen Sie mit "ok". Damit die Einstellung wirksam wird, muss JOSM noch mal gestartet werden.

Josm weisse Linie.png

Um Daten hinzufügen oder gar existierende Daten bearbeiten zu können, stellt JOSM eine Reihe von Werkzeugen zur Verfügung. Die nachfolgenden Abschnitte sollen Sie Schritt für Schritt mit der Datenbearbeitung vertraut machen. Laden Sie Ihre Daten wie unter "Daten laden" besprochen.

Wählen Sie am linken Rand des Editors das Werkzeug Punkte setzen (A) Setze Knotenpunkt.png, zeichnen Sie jetzt mit zwei einfachen Mausklicks die erste Linie ein. Achten Sie darauf, wie der Editor zwei Punkte erzeugt und diese automatisch verbindet. So fahren Sie Stück für Stück ihre GPS-Spur nach. Wenn Sie wollen, können Sie auch im Hintergrund eine Satellitenkarte (üblicherweise von BING) laden, um Straßen, Häuser oder einzelne Punkte wie Telefonzellen danach zu positionieren. Klicken Sie dafür im Menü unter "Hintergrund" auf eine Karte. Im Ebenen-Menü rechts können Sie mit dem kleinen Augen-Symbol die BING-Karte auch jederzeit wieder ausblenden.

Werte zuweisen

JOSM Vorlagen Ortsstrasse.png

Als nächstes sollten Sie aus der Linie eine Straße machen. Da wir bei unserem Beispiel in einem Wohngebiet die Straße (Linie) gezeichnet haben, wählen wir aus dem Menü "Vorlagen" den Eintrag "Ortsstraßen".

JOSM Ortsstrasse bearbeiten.png

Im nachfolgenden Dialogfeld tragen wir - falls bekannt - den Namen der Straße ein, und bei Ebenen wählen wir den Wert 0 da es sich in unserem Beispiel nicht um einen Tunnel (-1) oder um eine Brücke (1) handelt. In dem Feld Oberfläche können wir die Beschaffenheit der Straße bestimmen, und zum Schluss kann ein Wert für die Breite der Straße angegeben werden. Nachdem wir alle Eingaben gesetzt haben schließen wir den Dialog mit OK. Nun können Sie in der Palette rechts unter Eigenschaften/Mitgliedschaften die Werte, die eingetragen wurden, betrachten.






JosmGuide26.png

Wählen Sie jetzt das Selektionswerkzeug und klicken Sie in einen freien Bereich der Arbeitsfläche, um die Straße zu deselektieren. Zeichnen Sie weitere Straßen ein. Achten Sie dabei darauf, vor dem Zeichnen der nächsten Straße mit dem Selektionswerkzeug ins Leere zu klicken. Ihre Straßen könnten jetzt so aussehen:

JosmGuide27.png

Als nächstes zeichnen Sie eine Querstraße, die mit den drei anderen Straßen verbunden ist. Klicken Sie einfach auf den gewünschten Punkt in einer existierenden Straße. Der Editor wird automatisch einen Kreuzungspunkt in die bestehende Straße einfügen. Verfahren Sie mit den beiden anderen Straßenkreuzungen genauso:

JosmGuide28.png

Wie Sie sehen, ist die Straße etwas schief geraten. Wählen Sie das Selektionswerkzeug und klicken Sie ins Leere, um die Straße zu deselektieren. Halten Sie jetzt die Umschalttaste gedrückt und klicken Sie nacheinander die drei Punkte der Querstraße an, um alle drei zu selektieren. Achten Sie auf die Selektionspalette am rechten Bildschirmrand:

JosmGuide29.png

Wählen Sie jetzt aus dem Menü "Werkzeuge" den Eintrag "Punkte in einer Gerade anordnen". Der Editor versucht jetzt, alle selektierten Punkte auf einer Linie auszurichten:

JosmGuide30.png

Anschließend sieht die Straße viel besser aus als vorher:

Vergeben Sie jetzt wie gewohnt den Straßentyp und den Namen. Erstellen Sie weitere Straßen, Fußwege usw., je nachdem was Sie vor Ort vorgefunden haben.

Sonderpunkte hinzufügen

Eine Karte besteht nicht nur aus Straßen, sondern auch aus Symbolen für Gegebenheiten vor Ort wie Briefkästen, Supermärkten oder Kirchen. Auch solche Elemente sollten wenn möglich eingetragen werden, um eine möglichst vollständige Karte zu erhalten.

JosmGuide31.png

Verwenden Sie auch für solche Elemente das Werkzeug "Punkte setzen (A)":

Siehe Elemente für Sonderpunkte

JosmGuide32.png

Setzen Sie mit einem einfachen Klick den Punkt an die gewünschte Stelle:

JosmGuide33.png

Wählen Sie aus dem Menü "Vorlagen" den Eintrag "Einrichtungen":

JosmGuide34.png

Im nachfolgenden Dialog wählen Sie beispielsweise das Symbol Telefonhörer für eine Telephonzelle:

JosmGuide35.png

Nachfolgend könnte Ihr Arbeitsbereich in etwa so aussehen:

Vor dem Setzen des nächsten Punktes klicken Sie mit dem Selektionswerkzeug einmal ins Leere, um den momentan selektierten Punkt zu deselektieren.

Änderungen rückgängig machen

JosmGuide50.png

JOSM bietet als leistungsstarker Editor eine unbegrenzte Rückgängig-Funktion. Das bedeutet, dass alle Ihre Aktivitäten während einer Sitzung in einer Liste vorgehalten werden und somit Schritt für Schritt rückgängig gemacht werden können. Als Kontrollmöglichkeit steht Ihnen rechts die Palette "Befehlsliste" zur Verfügung, in der Sie alle Aktivitäten zurückverfolgen können:

JosmGuide51.png

Um ein paar Schritte zurückzugehen, klicken Sie mehrmals auf die Schaltfläche Letzte Aktion zurücknehmen JOSM-Icon-undo.png:

Ebenfalls existiert eine Schaltfläche Letzte Änderung wiederherstellen JOSM-Icon-redo.png, die zurückgenommene Befehle wiederherstellt. Diese Funktionen laden Sie dazu ein, mutig zu sein und einfach auszuprobieren. Sofern dabei ein nicht erwünschtes Resultat entsteht, haben Sie jederzeit Zugriff auf die Rückgängigfunktionen.

Daten hochladen

JosmGuide36.png

Sie haben jetzt die wichtigsten Grundwerkzeuge zur Datenerstellung kennengelernt. Falls Sie in einem Gebiet kartografieren, in dem noch keine Daten vorhanden sind, könnten Sie Ihre Daten bereits hochladen. Sind jedoch schon Kartendaten anderer Kartografen vorhanden, sollten Sie vor dem Hochladen noch einmal den von Ihnen bearbeiteten Kartenausschnitt aktualisieren, indem Sie auf den grünen Download-Pfeil drücken. JOSM baut nun eine Internetverbindung auf und lädt die derzeit aktuellen Daten des Kartenausschnitts herunter. Die eigene Bearbeitung wird hierdurch nicht beeinflusst oder gar überschrieben sondern bleibt erhalten. Man stellt jedoch auf diese Weise sicher, dass man nicht die Bearbeitung eines anderen Kartografen zerstört, der möglicherweise gleichzeitig dasselbe Gebiet bearbeitet. Diesen aktualisierten Kartenausschnitt kann man nun guten Gewissens hochladen.

Das Hochladen: Wählen Sie dazu die Schaltfläche Alle Änderungen in der aktuellen Datenebene zum OSM-Server hochladen JOSM-Icon Daten upload.jpg. JOSM listet Ihnen zur Kontrolle die neuen (oder auch die geänderten) Elemente auf. Weiter kann es vorkommen, dass JOSM an dieser Stelle eine Fehlerwarnung ausgibt. Dies geschieht z.B. wenn sich zwei Linien überlappen, oder wenn ein neuer Weg nicht benannt wurde. JOSM gibt einem hierduch die Möglichkeit, potenzielle Fehler vor dem Hochladen zu korrigieren.

Vor dem letztendlichen Hochladen werden Sie gebeten, eine kurze Beschreibung dessen was Sie geändert oder neu angelegt haben hinzuzufügen. Diese Beschreibung wird mit den Daten auf dem Server gespeichert und dient reinen Informationszwecken beispielsweise für die Recent-Changes-Liste oder wenn sich jemand per RSS-Feed über Änderungen in einer Gegend auf dem laufenden halten möchte.

Mit Klick auf OK können die Daten nun an den Server übermittelt werden. Sie sollten Ihre ersten Trockenübungen jedoch besser verwerfen und auf Abbrechen klicken. Bitte seien Sie umsichtig beim Herunterladen, Bearbeiten und Hochladen von Daten. Sehen Sie im Zweifelsfall lieber vom Hochladen ab, wenn Sie sich nicht sicher sind, ob alles korrekt ist. Während einer Sitzung sollten Sie außerdem regelmäßig kleine Häppchen hochladen und nicht erst am Schluss alles auf einmal.

Weiterführende Links

Erstellen von Relationen
Anpassen der Vorlagen

Weitere Anmerkungen

Wir sind bestrebt, eine detaillierte Dokumentation des Editiervorganges zu erstellen. Derzeit wird das System jedoch so schnell und häufig verbessert, dass man mit der Dokumentation kaum hinterherkommt. Falls diese Anleitung oder die Bildschirmabbildungen nicht mehr dem aktuellsten Stand entsprechen, sehen Sie uns dies bitte nach.