DE:JOSM/Werkzeuge

From OpenStreetMap Wiki
Jump to: navigation, search
  Erste Schritte   Grundlegendes Editieren   Fortgeschrittenes Editieren   Plugins   Tastenkürzel   Editor/Fenster (alt)   Werkzeuge (alt)   Praxis (alt)  

Diese Seite erklärt die Lösung der wichtigsten Aufgaben beim Zeichnen einer Karte mit JOSM.

Voraussetzungen

Vorausgesetzt wird, dass du folgende Dinge erledigt hast:

  1. JOSM installiert, konfiguriert und geöffnet
  2. Benutzerkonto angelegt, eingeloggt
  3. das Zeichenfenster ist entsprechend vorbereitet
    1. zum Abzeichnen ist Yahoo-Map geladen
    2. zum Bearbeiten sind GPS-Daten geladen
    3. zum Bearbeiten ist ein Ausschnitt aus der Datenbank geladen
    4. oder du willst nur ein bisschen spielen oder üben, dann drück die Taste <Strg-n>.

Symbole

Werkzeuge

Zoom.png Objekte auswaehlen.png Setze Knotenpunkt.png Loesche Knotenpunkt.png Create Areas.png

Übersicht

Liste aller Ebenen.png Einstellungen der Objekte.png Versionen Objekte.png Fenster aktueller Objekte.png Autorenliste.png Konflikte loesen.png Undo Befehle.png Liste aller Relationen.png Validation.png

Add-In

Merge Notes.png Knodes einfuegen.png Ueberfluessige Nodes loeschen.png

Karte zentrieren

Adjust WMS-Layer.png

Die Grundelemente

In der JOSM-Befehlsübersicht findest du alle Tastatur- und Maus-Befehle.

Die Werkzeugleiste befindet sich am linken Rand des JOSM-Fensters:

Werkzeug Icon Taste Tastaturbefehl Maus Funktion
Lupe Zoom.png <z> <z> + ↑ ↓ Mausrad Zoomen, Anzeige vergrößern, verkleinern
Auswahl Objekte auswaehlen.png <s> Objekte auswählen, verschieben, drehen
Zeichnen Setze Knotenpunkt.png <a> Punkt, Linie, Fläche zeichnen
Löschen Loesche Knotenpunkt.png <Strg> + <Entf> einzelnen Punkt oder ganzes Objekt löschen

Punkt

Wähle das "Zeichnen-Werkzeug" Setze Knotenpunkt.png der Mauszeiger wandelt sich in ein Fadenkreuz JOSM-Icon-Cursor-crosshair 20.jpg. Klick mit der Maus da, wo du einen Punkt setzen willst.

Linie

Wähle das "Zeichnen-Werkzeug" Setze Knotenpunkt.png, der Mauszeiger verwandelt sich in ein Fadenkreuz JOSM-Icon-Cursor-crosshair 20.jpg. Klick mit der Maus da, wo du eine Linie beginnen willst. Mit jedem weiteren Klick wird die Linie automatisch verlängert. Wenn das Zeichnen einer Linie beendet werden soll, einfach den Bearbeitungsmodus wechseln, z.B. nach Objekte auswaehlen.png "Auswahl-Werkzeug".

Fläche

Nimm das "Zeichnen-Werkzeug" Setze Knotenpunkt.png, der Mauszeiger verwandelt sich in ein Fadenkreuz JOSM-Icon-Cursor-crosshair 20.jpg. Klick mit der Maus da, wo du den Umriss der Fläche beginnen willst. Mit jedem weiteren Klick wird der Umriss automatisch verlängert. Klick zum Schluss auf den Anfangspunkt, um das Polygon zu schließen.

Allgemeine Aufgaben

Auswählen

Objekte auswaehlen.png   <S>   JOSM-Icon-Cursor-Select 20.jpg

Nimm das "Auswahlwerkzeug" Objekte auswaehlen.png, der Mauszeiger verwandelt sich in einen "Pfeil mit Rechteck" JOSM-Icon-Cursor-Select 20.jpg. Klick auf einen Einzelpunkt. Dessen Farbe ändert sich von rot auf weiß. Oder klick auf eine Gerade zwischen zwei Punkten, dann wird das ganze Element markiert. Dessen Farbe ändert sich auf weiß und an den Enden der Segmente werden Pfeile angezeigt. Bei Flächen wird die Fläche weiß angezeigt, und es erscheinen ebenso die Pfeile der Segmente der Umrisslinie.

Absicht Mausaktion Tastaturbefehl
alleinstehenden Punkt auswählen klick auf einen alleinstehenden Punkt
oder: zieh ein kleines Rechteck um den Punkt
S
Punkt in einer Linie auswählen klick auf einen Punkt
oder: zieh ein kleines Rechteck um den Punkt oder um mehrere Punkte
S
ein ganzes Element auswählen klick auf eine Verbindungslinie zwischen zwei Punkten
oder: zieh ein Rechteck um das Element
S
Achtung 
Die Elemente bleiben so lange ausgewählt, bis du ein anderes Werkzeug nimmst oder bis du mit dem Auswahlwerkzeug Objekte auswaehlen.png in einen leeren Bereich klickst!
Wenn du das vergisst, wirkt sich jede Aktion auf alle ausgewählten Punkte aus. Wenn du den Fehler rechtzeitig bemerkst, kannst du ihn mit <Strg.Z> rückgängig machen.

Mehrfachauswahl

Objekte auswaehlen.png   <S>   JOSM-Icon-Cursor-Select 20.jpg

Wenn du viele Punkte auswählen willst, beispielsweise um in einer GPS-Spur überflüssige Punkte auf einer geraden Strecke zu löschen, oder überflüssige Punkte aus einem "Knäuel", nimm das "Auswahl-Werkzeug" Objekte auswaehlen.png, der Cursor verwandelt sich in einen "Pfeil mit Rechteck" JOSM-Icon-Cursor-Select 20.jpg. Zieh mit gedrückter Maustaste ein Rechteck um die zu löschenden Punkte, die Farbe der ausgewählten Punkte wechselt von rot auf weiss. Achtung: Achte darauf, dass du nicht versehentlich auch Punkte eines anderen Elementes wählst, die du NICHT bearbeiten willst. Mit <shift>+Klick kannst du zusätzlich zu den bisher ausgewählten Punkten weitere Punkte einzeln auswählen. Oder mit <shift>+Ziehen kannst du mehrere zusätzliche Punkte in einem weiteren Rechteck auswählen. Mit <ctrl>+Klick, <shift>+Ziehen oder einfachen Linksklick auf der freien Fläche kannst du ausgewählte Punkte wieder abwählen.

Aus übereinander liegenden Elementen wählen

Objekte auswaehlen.png   <S>   JOSM-Icon-Cursor-Select 20.jpg

Mehrere Wege können übereinander liegen (Beispiel: Waldrand und Straße, zwei Hausmauern, Waldrand und Seeufer). Um gezielt das eine oder andere auszuwählen: Mit mittlere_Maustaste auf den Weg klicken, dann wird eine Liste aller Elemente angezeigt. Aus der Liste das gewünschte Element auswählen.

Alternativ kannst du mit <ALT>+linke Maustaste zwischen den verschiedenen Wegen und Flächen durchschalten.

Löschen

Loesche Knotenpunkt.png   <D>   JOSM-Icon-Cursor-delete 20.jpg

Nimm das "Lösch-Werkzeug" Loesche Knotenpunkt.png, der Mauszeiger wandelt sich in einen "Pfeil mit X" JOSM-Icon-Cursor-delete 20.jpg. Klicke mit der Maus da, wo du etwas löschen willst.

Absicht Mausaktion Tastaturbefehl
alleinstehenden Punkt löschen klick auf einen alleinstehenden Punkt D
Punkt am Ende einer Linie löschen klick auf einen Endpunkt D
Punkte innerhalb einer Linie löschen klick auf einen Punkt D
ein ganzes Element löschen klick auf eine Verbindungslinie zwischen zwei Punkten
oder: klick auf ein markiertes Element
D

Mit jedem weiteren Klick wird ein weiteres Element gelöscht.

Wenn du nicht weiter löschen willst, klick auf ein anderes Werkzeug.
Achtung: Erst wenn der Mauszeiger KEIN "X" JOSM-Icon-Cursor-delete 20.jpg mehr zeigt, ist der Löschmodus ausgeschaltet.

Viele Punkte gleichzeitig löschen
Wenn du viele Punkte löschen willst, beispielsweise aus einer GPS-Spur auf einer geraden Strecke oder aus einem "Knäuel", nimm das "Auswahl-Werkzeug" Objekte auswaehlen.png. Der Cursor verwandelt sich in einen "Pfeil mit Rechteck" JOSM-Icon-Cursor-Select 20.jpg, und wähl mehrere Punkte gleichzeitig wie unter "Mehrfachauswahl" beschrieben.
Klick auf das "Lösch-Werkzeug" Loesche Knotenpunkt.png und alle ausgewählten Punkte sind gelöscht. Achtung: Das "Lösch-Werkzeug" bleibt solange eingeschaltet - der Mauszeiger ist ein "Pfeil mit X" JOSM-Icon-Cursor-delete 20.jpg - bis wieder ein anderes Werkzeug gewählt wird.

Rückgängig machen

JOSM-Icon-undo.png   <ctrl-z>

Jede Aktion kann wieder rückgängig gemacht werden. Jeder Klick auf das Symbol, oder jedes <ctrl-z> macht eine weitere Aktion rückgängig.

Wiederholen

JOSM-Icon-redo.png   <ctrl-y>

Rückgängig gemachte Aktionen können mit <ctrl-y> in umgekehrter Reihenfolge wiederhergestellt werden.

Verschieben

Objekte auswaehlen.png   <S>   JOSM-Icon-Cursor-Select 20.jpg

Nimm das Auswahlwerkzeug Objekte auswaehlen.png. Der Cursor verwandelt sich in einen "Pfeil mit Rechteck" JOSM-Icon-Cursor-Select 20.jpg.

Hinweis: Klicken auf eine leere Stelle hebt eine Auswahl wieder auf.

Einzelpunkt oder Punkt einer Linie verschieben
Klicke auf den Punkt, er wird rot, verschiebe ihn mit gedrückter Maustaste.
Linie verschieben
Klicke auf die Linie, jedoch nicht auf das Kreuz in der Mitte, die Linie wird rot, verschiebe sie mit gedrückter Maustaste.
Fläche verschieben
Klick auf eine Randlinie der Fläche, jedoch nicht auf das Kreuz in der Mitte. Die Randlinien und die Fläche werden rot. Verschieb sie mit gedrückter Maustaste.

Drehen (rotieren)

Klick mit dem Auswahlwerkzeug Objekte auswaehlen.png auf das Objekt, um es auszuwählen (so wie oben bei "Verschieben" beschrieben). Halte dann die Strg- und die Umschalttaste gedrückt. Wenn du dann die Maus mit gedrückter Maustaste (am besten etwas entfernt vom ausgewählten Objekt) bewegst, dreht sich das Objekt. Achtung: Die Fläche bleibt danach ausgewählt. Klick also in einen leeren Bereich, dann wird das Objekt verlassen, und es ändert sich in eine blassweisse Umrisslinie mit roten Punkten.

Kopieren

Achte darauf, dass beim Markieren einer Linie oder Fläche nur die Linie, nicht aber die Punkte der Linie markiert sind.

Element und Eigenschaften
Markiere das Element mit der Maus, kopiere es mit <Strg-c>, klick da, wo du das Element einfügen willst mit der Maus in die Zeichenebene und füge es mit <Strg-v> wieder ein.
Alternativ: Markiere das Element mit der Maus, dupliziere es mit <Strg-d> und verschiebe es dorthin, wo du es brauchst
nur Eigenschaften
Markiere das Element mit der Maus, kopiere es mit <Strg-c> und füge es mit <Strg-Shift-v> wieder ein. Dabei werden die eingefügten Eigenschaften zu den bereits vorhandenen hinzugefügt, bzw., falls doppelt vorhanden, werden die alten durch die eingefügten ersetzt.
nur einzelne Eigenschaften
Wenn du nur einzelne Eigenschaften kopieren willst, diese aber für viele Objekte brauchst:
- kopiere ein passendes Objekt mit <Strg-d>
- lösche in der Kopie alle Eigenschaften die Du nicht kopieren willst
- kopiere das bereinigte Objekt mit <Strg-c>
- lösche das bereinigte Objekt mit <Entf>
- füge die so kopierten Eigenschaften mit <Strg-Shift-v> in jedes Objekt ein wo du es brauchst

Zeichnen

Punkt zeichnen

Achte darauf, dass kein Element angewählt ist. Zur Sicherheit kannst du mit dem Auswahlwerkzeug Objekte auswaehlen.png, der Cursor ändert sich in einen "Pfeil mit Rechteck" JOSM-Icon-Cursor-Select 20.jpg. In einen leeren Bereich klicken (oder die Taste U drücken).

Nimm das Zeichnenwerkzeug Setze Knotenpunkt.png. Der Cursor ändert sich in ein Fadenkreuz JOSM-Icon-Cursor-crosshair 20.jpg. Klick da, wo der Punkt sein soll. Wenn keine Linie gezeichnet werden soll, klick den Punkt nocheinmal an (bzw. mach einen Doppelklick).

Linie zeichnen

Nimm das Zeichnenwerkzeug Setze Knotenpunkt.png. Der Cursor ändert sich in ein Fadenkreuz JOSM-Icon-Cursor-crosshair 20.jpg. Klick da, wo die Linie beginnen soll. Am Cursor hängt automatisch eine Linie zu diesem Anfangspunkt. Der zweite Klick erzeugt eine definierte Linie. Jeder weitere Klick setzt einen neuen Punkt und verlängert die Linie. Klick erneut auf den letzten Punkt (bzw. mache einen Doppelklick), um die Linie fertigzustellen.

Fläche zeichnen

Nimm das Zeichnenwerkzeug Setze Knotenpunkt.png. Der Cursor ändert sich in ein Fadenkreuz JOSM-Icon-Cursor-crosshair 20.jpg. Klick irgendwo auf dem Umriss der gewünschten Fläche. Am Cursor hängt automatisch eine Linie zu diesem Anfangspunkt. Der zweite Klick erzeugt eine definierte Linie. Jeder weitere Klick setzt einen neuen Punkt und verlängert die Umrisslinie. Den letzten Punkt setzt du genau auf den Anfangspunkt. Dadurch entsteht eine geschlossene Umrisslinie, die die Fläche enthält.

Kreis zeichnen

Regelmäßiger Kreis

Nimm das Zeichnenwerkzeug Setze Knotenpunkt.png. Der Cursor ändert sich in ein Fadenkreuz JOSM-Icon-Cursor-crosshair 20.jpg. Zeichne da wo du den Kreis haben willst eine Linie in der Länge des Durchmessers durch den gewünschten Mittelpunkt des Kreises. Oder zeichne ein Dreieck, dessen Eckpunkte auf dem gewünschten Umkreis liegen. Wähle im Menü "Werkzeuge" den Punkt "Kreis erstellen", oder benutze die Tastenkombination <Shift-O>.

Einstellungen

Die Anzahl der durch "Kreis erstellen" erzeugten Punkte kann man einstellen. Dazu muss man erst einen Kreis erstellen (den man anschliessend wieder löschen kann - denn nur so kommt man an die Einstellungen dran). Jetzt im Menü "Bearbeiten", Punkt "Einstellungen", unter "Einstellungseinträge direkt setzen" (letztes Icon, "Schraubenschlüssel"), in der Zeile "createcircle.nodecount" die gewünschte Punktezahl eintragen (bitte vorsichtig sein). Standard sind 8 Punkte, sinnvoll sind 12 oder 16 Punkte, beispielsweise für einen Kreisverkehr, für ein Silo, einen Gastank oder Öltank, oder für eine runde Kuppel. Für sehr große Kreise (100 m) sind 24 Punkte sinnvoll, dann sind die Winkeländerungen der Segmente 15°.

Kreisverkehr

Bei einem Kreisverkehr sind die einmündenden Straßen meist unregelmäßig angeordnet, liegen aber dennoch auf einem Kreis. Zeichne den Kreisverkehr zuerst nur durch die verbundenen Einmündungspunkte. Ergänze Zwischenpunkte abhängig von der Entfernung der einzelnen Einmündungen so, dass 8/12/16 Punkte auf einem Kreisbogen zusammen kommen. Markiere den Kreisverkehr und wähle im Menü "Werkzeuge" den Punkt "Im Kreis anordnen" oder benutze die Tastenkombination <O>. Die Punkte liegen danach alle auf einer Kreislinie, sind aber unregelmässig verteilt, so wie in der Realität auch. Gegebenenfalls ist die Größe und Lage des so erstellten Kreisverkehrs noch leicht anzupassen.

Alternativ kann man auch den Kreisverkehr als unabhängigen Kreis erstellen (wie bei "Regelmässiger Kreis" erläutert) und die Einmündungen mit "Merge" (Tastenkombination <M>) oder "Punkt in Weg einfügen" (Tastenkombination <J>) in diesen einbinden. Eventuell ist noch einmal "Im Kreis anordnen" (Tastenkombination <O>) auszuführen, um den Kreis wieder abzurunden.

Anmerkung: Versucht man ausschließlich mit den Punkten der Einmündungen mithilfe von "Im Kreis anordnen" einen Kreis zu erstellen, wird man schmerzhaft erkennen, dass es in JOSM/OSM nur Vielecke gibt. Bei vier Punkten ergibt sich ein ziemlich verzogenes Viereck und kein angenäherter Kreis.

Punkte einfügen

Nimm das Zeichnenwerkzeug Setze Knotenpunkt.png. Der Cursor ändert sich in ein Fadenkreuz JOSM-Icon-Cursor-crosshair 20.jpg. Klicke auf eine Linie. Wenn du mehrere Punkte einfügen willst, drück die <shift>-Taste und klicke an den gewünschten Stellen auf eine Linie.

JOSM hat eine "Einfang-Funktion": wenn man einen Punkt in der Nähe einer Linie setzt, dann kommt dieser automatisch auf der Linie zu liegen. Das hilft beim Einfügen eines Punktes auf einer Linie. Wenn man das nicht will, beispielsweise wenn Punkte einer Strasse am Waldrand entlang führen, soll der Straßenpunkt ja nicht Bestandteil des Waldrandes werden, dann drück die <Strg>-Taste beim Klicken.

Linie verlängern

Nimm das Auswahlwerkzeug Objekte auswaehlen.png. Der Cursor ändert sich in einen "Pfeil mit Rechteck" JOSM-Icon-Cursor-Select 20.jpg. Klicke auf den äußersten Punkt einer Linie. Dessen Farbe ändert sich von rot auf weiß. Nimm jetzt das Zeichnenwerkzeug Setze Knotenpunkt.png. Der Cursor ändert sich zu einem Fadenkreuz JOSM-Icon-Cursor-crosshair 20.jpg. Jeder Klick setzt nun einen neuen Punkt, der die bestehende Linie verlängert.

Ursprüngliche Linie und Verlängerung sind eine Einheit. Die Verlängerung erhält also automatisch die Eigenschaften, die der bestehenden Linie zugeordnet waren. Soll die Verlängerung ein eigenständiger Weg werden, so muss beim Setzen der neuen Knotenpunkte die ALT-Taste gehalten werden.

Linie verkürzen

Nimm das "Lösch-Werkzeug" Loesche Knotenpunkt.png, der Mauszeiger verwandelt sich in einen "Pfeil mit X" JOSM-Icon-Cursor-delete 20.jpg. Klicke auf den überflüssigen Punkt. (oder: markiere den überflüssigen Punkt und drücke die <Entf> Taste.

Abzweigung einfügen/löschen

Nimm das Zeichnenwerkzeug Setze Knotenpunkt.png. Der Cursor ändert sich in ein Fadenkreuz JOSM-Icon-Cursor-crosshair 20.jpg. Klicke auf einer Linie, da wo du die Abzweigung einfügen willst, auf die grade Verbindung zweier Punkte. Dadurch entsteht dort ein zusätzlicher Punkt in weißer Farbe, und am Fadenkreuz hängt von diesem Punkt ausgehend eine weiße Linie als Abzweigung. Jeder weitere Klick setzt einen weiteren Punkt und verlängert die Linie der Abzweigung.

Wenn das Cursorkreuz auf eine weitere Linie stößt, leuchten die Punkte dieser Linie auf, als Zeichen dafür, dass bei einem Klick die Abzweigung mit jener Linie verbunden wird.

Es gibt keinen Befehl für "jetzt ist die Linie zuende". Jeder weitere Klick verlängert die Linie, bis das Werkzeug gewechselt wird.

Die Abzweigung ist zwar mit der ersten (und ggf. auch mit der zweiten) Linie verbunden, enthält aber noch keine Eigenschaften. Diese müssen der Abzweigung gesondert zugewiesen werden.

Kreuzung von zwei Linien

Wenn sich zwei Linien kreuzen, haben sie keine Beziehung zueinander. Das ist beispielsweise sinnvoll, wenn sich eine Straße und ein Bach oder eine Hochspannungsleitung kreuzen. Bei der grafischen Darstellung geht der Renderer nach Regeln vor. Beispielsweise nimmt er an, dass der Bach unter der Straße durchführt. Falls es in Wirklichkeit anders ist, muss dies den Objekten durch Eigenschaften mitgeteilt werden, beispielsweise durch verschiedene Ebenen (Key:layer). Das gilt auch für Straßen, die über eine Brücke oder durch eine Unterführung führen.

Unklar ist aber, welcher Renderer nach welchen Regeln vorgeht, und in welchem Fall die Anwendung von Ebenen notwendig ist, und in welchem nicht.

Kreuzung

Wenn an der Kreuzung eine Verbindung zwischen den Elementen sein soll, beispielsweise wenn sich zwei Straßen kreuzen, dann muss die Verbindung gezielt erstellt werden:

Nimm nun das Zeichnenwerkzeug Setze Knotenpunkt.png. Der Cursor ändert sich in ein Fadenkreuz JOSM-Icon-Cursor-crosshair 20.jpg. Klicke damit nahe an der Kreuzung erst auf eine Linie, dann mit <Shift-Klick> auf die zweite Linie. Nimm nun das Auswahlwerkzeug Objekte auswaehlen.png. Der Cursor ändert sich in einen "Pfeil mit Rechteck" JOSM-Icon-Cursor-Select 20.jpg. Markiere damit die beiden Punkte. Jetzt sind beide Punkte weiß. Drück die Taste <m>. Jetzt sind die beiden Punkte verschmolzen. Die beiden Linien bilden eine Kreuzung. Wahrscheinlich hat sich dabei der Kreuzungspunkt etwas verschoben. Zieh ihn mit der Maus wieder an die richtige Stelle.

Wenn in einer Stadt die Straßen wie auf einem Schachbrett verlaufen, dann muss an jeder Kreuzung eine solche Verbindung erstellt werden.

Knotenpunkt

Wenn mehrere Fahrradwege an einem Knotenpunkt zusammenkommen, dann muss am Knotenpunkt gezielt eine Verbindung hergestellt werden. Der kreuzende Weg erhält dazu einen Punkt an diesem Knotenpunkt, genau über dem gekreuzten Weg. Dadurch werden die zwei Wege miteinander verbunden. Auch ein abzweigender Weg beginnt oder endet mit einem eigenen Punkt an diesem Knotenpunkt. Dadurch wird der Knotenpunkt sozusagen mehrfach genutzt.


Kreuzung auftrennen

Linie in Teilstücke auftrennen

Objekte auswaehlen.png   Linie, <shift> Punkt,   <p>

Beispielsweise um den beiden Teilstücken unterschiedliche Eigenschaften zuzuweisen.

Nimm das Auswahlwerkzeug Objekte auswaehlen.png. Der Cursor ändert sich in einen "Pfeil mit Rechteck" JOSM-Icon-Cursor-Select 20.jpg. Klicke auf die Linie, die getrennt werden soll. Drück die <shift>-Taste und klicke zusätzlich auf den Punkt, an dem die Linie aufgetrennt werden soll (Mehrfachauswahl mit shift) oder markiere den Punkt, indem du die <shift>-Taste drückst und mit gedrückter Maustaste ein kleines Rechteck und den Punkte ziehst. Drück jetzt die Taste <p> (P für sPlit). Dann kannst du jeden Abschnitt einzeln auswählen und ihm die gewünschten Eigenschaften zuordnen.

Die zwei Teilstücke bleiben im Trennpunkt verbunden, d. h. der Punkt ist Bestandteil von beiden Teilstücken.

Geschlossene Linienzüge (Polygone): Wähle mit gedrückter <shift>-Taste nicht einen, sondern zwei Trennpunkte, bevor du auf P drückst.

Zwei Teilstücke einer Linie zu einem zusammenführen

Objekte auswaehlen.png   Linie, <shift> Linie,   <c>

Beispielsweise wenn zwei Teilstücken dieselben Eigenschaften haben und nicht getrennt sein sollen.

Nimm das Auswahlwerkzeug Objekte auswaehlen.png. Der Cursor ändert sich in einen "Pfeil mit Rechteck" JOSM-Icon-Cursor-Select 20.jpg. Klicke auf die Linie des einen Teilstückes. Drück die <shift>-Taste und klicke zusätzlich auf die Linie des zweiten Teilstückes (Mehrfachauswahl mit shift). Drück jetzt die Taste <c> (C für Combine).

Nun sind die beiden Teilstücke zu einem Teilstück geworden, das die Summe der Eigenschaften der ursprünglichen Teilstücke in sich vereint. Wenn einzelne Eigenschaften überflüssig geworden sind, können diese gelöscht werden, oder zusätzliche können ergänzt werden.

Linie ganz auftrennen

Objekte auswaehlen.png   Punkt,   <p>
Objekte auswaehlen.png   Punkt,   <g>

Aus einer Linie zwei machen, die ganz unabhängig voneinander sind.

Nimm das Auswahlwerkzeug Objekte auswaehlen.png. Der Cursor ändert sich in einen "Pfeil mit Rechteck" JOSM-Icon-Cursor-Select 20.jpg. Markiere den Punkt, an dem du die Linie trennen willst.

Oder nimm das Zeichnenwerkzeug Setze Knotenpunkt.png. Der Cursor ändert sich in ein Fadenkreuz JOSM-Icon-Cursor-crosshair 20.jpg. Klicke auf die Linie, da wo du sie trennen willst. Dadurch hast du einen Punkt eingefügt, der jetzt weiß markiert ist. Wechsle anschließend zum Auswahlwerkzeug Objekte auswaehlen.png. Der Cursor ändert sich in einen "Pfeil mit Rechteck" JOSM-Icon-Cursor-Select 20.jpg.

Drück die Taste-<p> (für sPlit). Nun sind die Linien links und rechts vom Punkt markiert. Klicke (immer noch mit dem Auswahl-Werkzeug) ins Leere, damit nichts mehr markiert ist, und markiere wieder den Punkt. Drück nun die Taste-<g> (für unGlue). Klick anschließend wieder mit dem Auswahlwerkzeug Objekte auswaehlen.png ins Leere, damit nichts mehr markiert ist.

Mit dem Auswahlwerkzeug Objekte auswaehlen.png kannst du jetzt jeden Endpunkt einzeln oder jede Linie als Ganze anfassen und verschieben.

Zwei Linien zu einer zusammenfügen

Objekte auswaehlen.png   Punkt, Punkt,   <m>

Bring die Endpunkte beider Linien ganz nah zusammen. Markiere beide Endpunkte. Drück die Taste-<m> (für Merge) und aus den beiden Linien ist eine geworden.

Wenn die Enden nicht nahe beieinander liegen, bilden sie einen gemeinsamen Punkt in der Mitte.

Wenn mehrere Punkte markiert werden, verbinden sich alle markierten Punkte.

Die verbundenen Linien bleiben als einzelne Abschnitte getrennt. Sie behalten also die ursprünglichen Eigenschaften.

Spezielle Aufgaben

Bestehende Linie als Abzweigung einfügen

Nimm das Auswahlwerkzeug Objekte auswaehlen.png. Der Cursor ändert sich in einen "Pfeil mit Rechteck" JOSM-Icon-Cursor-Select 20.jpg. Klicke auf den Endpunkt der einzufügenden Linie. Dadurch wird der Punkt weiß. Nimm nun das Zeichnenwerkzeug Setze Knotenpunkt.png. Der Cursor ändert sich in ein Fadenkreuz JOSM-Icon-Cursor-crosshair 20.jpg und hat eine Verbindung zum Endpunkt der Linie. Klicke nun auf der Linie, auf der die Abzweigung erstellt werden soll, auf den zukünftigen Abzweigungspunkt.

Alternative: Nimm das Auswahlwerkzeug Objekte auswaehlen.png. Der Cursor ändert sich in einen "Pfeil mit Rechteck" JOSM-Icon-Cursor-Select 20.jpg. Klicke auf den Endpunkt der einzufügenden Linie. Dadurch wird der Punkt weiß. Ziehe den Endpunkt in die Nähe der Linie, auf der die Abzweigung erstellt werden soll. Drücke die   Taste <j>   (Join).

Linie aus Abzweigung lösen

Objekte auswaehlen.png   gemeinsamer Punkt   <g>

Markiere den gemeinsamen Punkt, trenne ihn mit der Taste <g> (für "unGlue").

Mittig zusammengebunden Linien lösen

Objekte auswaehlen.png   gemeinsamer Punkt   <g>

Beispielsweise wenn der Waldrand irrtümlich mit der Straße "verschmolzen" wurde.

Markier den gemeinsamen Punkt, trenn ihn mit der   Taste <g>   (für "unGlue").

Achtung: Wird der gemeinsame Punkt auch noch von einer weiteren (einmündenden) Linie verwendet, ist diese nachher nicht mehr mit der Hauptlinie verbunden. Hier noch einmal den Punkt der Hauptlinie und den Endpunkt der einmündenden Linie markieren und mit   Taste <m>   (Merge) wieder vereinen.

Route über mehrere Linienstücke

Siehe Hauptartikel Relationen

Tunnel, Brücken und Ebenen

Objekte auswaehlen.png   Punkt,   <p>

Bei einem Tunnel wird auf der durch diesen führenden Straße davor und danach ein zusätzlicher Punkt gezeichnet. An diesen beiden Punkten wird die Linie in drei Teilstücke aufgetrennt . Der Tunnel wird dann als tunnel=yes gekennzeichnet. Ein normaler Tunnel bekommt dann noch die Kennzeichnung layer=-1. Gegebenenfalls kann die maximale Durchfahrtshöhe mit maxheight=# ergänzt werden.

Bei einer Brücke wird auf der über diese führenden Straße davor und danach ein zusätzlicher Punkt gezeichnet. An diesen beiden Punkten wird die Linie in drei Teilstücke aufgetrennt. Die Brücke wird dann als bridge=yes gekennzeichnet. Eine normale Brücke bekommt dann noch die Kennzeichnung layer=1. Gegebenenfalls kann die maximal zulässige Achslast mit maxweight=# ergänzt werden. Die unten durchführende Straße wird mit maxheight=# für die max. Durchfahrtshöhe gekennzeichnet.

Bei komplizierteren mehrstöckigen Über- und Unterführungen werden die verschiedenen Ebenen mit layer=# gekennzeichnet, wobei die zulässigen Werte von -5 bis +5 reichen.

Haus mit Erker zeichnen

<a> <x>

Zeichne eine Seite als Linie. Drücke die Taste-<x>, dadurch schaltest du in den Geometrie-Modus und, der Cursor ändert sich in einen Pfeil mit einem kleinen rechtwinkligen Dreieck. Ziehe damit mit gedrückter linker Maustaste an der Linie. Dadurch entsteht ein Rechteck.

Wechsle zum Zeichenwerkzeug. Der Cursor ändert sich zu einem Fadenkreuz. Markiere mit der Maus bei gedrückter <Esc>-Taste zwei Punkte auf einer Hausseite, wo der Erker entstehen soll. Wechsle mit Taste-<x> wieder in den Geometrie-Modus, und ziehe an der Linie zwischen den zwei neuen Punkten den Erker heraus.

Im Geometrie-Modus lassen sich auch komplexe Gebäude schnell und rechtwinklig zeichnen. Bei schrägen Linien entstehen entsprechend schräge, aber dennoch rechtwinklige Ein- und Ausbuchtungen-

Flächen ineinander

Siehe Hauptartikel Relation:Multipolygon

Beispielsweise eine Waldlichtung im Wald, eine Insel im See oder Fluss, oder ein Innenhof im Gebäude.

.o0(Wie ist das mit Haus, Kirche, öffentlichem Gebäude in einer Siedlung? Oder mit einer Fabrik im Industriegelände?
Wäre es nicht einfacher, einen Schlüssel "Waldlichtung" oder "Insel" oder "Innenhof" zu machen?
)

Solche Flächen innerhalb einer anderen Fläche werden mit einer Relation:Multipolygon gekennzeichnet, also mit zwei Flächen und einer Relation:

  • Bei einfachen Multipolygonen hat nur die äußere Umrisslinie einen Schlüssel, beispielsweise landuse=forest. Die innere Umrisslinie hat KEINE Schlüssel (also nicht, wie manchmal empfohlen wird, ebenfalls landuse=forest).
  • Die beiden Flächen sind in einer Multipolygon-Relation mit role=outer bzw. role=inner verbunden. Die Richtung der Linien (Uhrzeigersinn/Gegenuhrzeigersinn) spielt KEINE Rolle.
Mapnik rendert anscheinend Multipolygone nur richtig, wenn die äußere Linie im Uhrzeigersinn und die innere gegen den Uhrzeigersinn gezeichnet sind. Es sei denn, die innere Linie ist als etwas anderes attributiert als die äußere, dann geht es auch mit gleichen Richtungen. --Crissiloop 18:42, 14 August 2008 (UTC)
  • Wenn die innere Fläche zugleich etwas anderes ist (z.B. See im Wald), dann wird wie oben vorgegangen (KEINE zusätzliche Line auf den Punkten der inneren Fläche). Lediglich bekommt die innere Linie dann zusätzlich einen Schlüssel für das, was innen drin ist, beispielsweise wen das Innere ein See ist natural=water.
  • Falls im Loch wiederum ein Loch ist, beispielsweise: im Wald liegt ein See und im See ist eine Insel, so wird im See noch eine Insel gezeichnet natural=land und zusätzlich eine zweite Multipolygon-Relation angelegt, im Beispiel also zwischen See und Insel.

Auf keinen Fall darf in dieser Situation mit dem Attribut layer gearbeitet werden (See über Wald zeichnen und Wald mit layer=1 setzen).


Eigenschaften festlegen

Grundlagen

Die geometrischen Grundelemente Punkt, Linie und Fläche werden erst dann zu einem darstellbaren Objekt, wenn sie mit Eigenschaften verknüpft'/code>.

Einstellungen

Die Anzahl der durch "Kreis erstellen" erzeugten Punkte kann man einstellen. Dazu muss man erst einen Kreis erstellen (den man anschliessend wieder löschen kann - denn nur so kommt man an die Einstellungen dran). Jetzt im Menü "Bearbeiten", Punkt "Einstellungen", unter "Einstellungseinträge direkt setzen" (letztes Icon, "Schraubenschlüssel"), in der Zeile "createcircle.nodecount" die gewünschte Punktezahl eintragen (bitte vorsichtig sein). Standard sind 8 Punkte, sinnvoll sind 12 oder 16 Punkte, beispielsweise für einen Kreisverkehr, für ein Silo, einen Gastank oder Öltank, oder für eine runde Kuppel. Für sehr große Kreise (100 m) sind 24 Punkte sinnvoll, dann sind die Winkeländerungen der Segmente 15°.

Kreisverkehr

Bei einem Kreisverkehr sind die einmündenden Straßen meist unregelmäßig angeordnet, liegen aber dennoch auf einem Kreis. Zeichne den Kreisverkehr zuerst nur durch die verbundenen Einmündungspunkte. Ergänze Zwischenpunkte abhängig von der Entfernung der einzelnen Einmündungen so, dass 8/12/16 Punkte auf einem Kreisbogen zusammen kommen. Markiere den Kreisverkehr und wähle im Menü "Werkzeuge" den Punkt "Im Kreis anordnen" oder benutze die Tastenkombination ' werden. Daraus macht dann die Software beispielsweise aus einem Punkt ein Denkmal oder eine Grillstelle, oder aus einer Linie eine Autobahn oder einen Fluss, oder aus einer Fläche einen See oder ein Industriegebiet.

Die Eigenschaften eines Objektes sind immer in einem oder mehreren Eigenschaften-Paaren gespeichert:

Schlüssel - Wert (key - value)

Diese Eigenschaftspaare müssen sorgfältig ausgewählt und korrekt gefüllt werden. Sie erzeugen - zusammen mit den genauen Wegpunkten - die eigentliche Qualität der OSM-Karte.

Es gibt verschiedene Gruppen solcher Objektarten (Straße, Gewässer, Bahnlinie, etc). In jeder Gruppe gibt es unterschiedliche Objektarten (Autobahn, Land- oder Staatsstraße, Kreisstraße, Gemeindestraße). Jede Art hat bestimmte mögliche Schlüssel-Eigenschaften (Straßennummer, Straßenname, erlaubte Höchstgeschwindigkeit, usw.). Und jeder Schlüssel hat einen eindeutigen Wert (Mühlenweg, 30 km/h). Welche Eigenschaften ein Objekt haben darf und welche Werte dabei erlaubt sind, das wird durch Regeln festgelegt. Bitte darauf achten, bei Straßen zwischen die Objektart (z.B. B, L, K) und die Straßennummer ein Leerzeichen einzufügen. Also B  4711 und nicht B4711 schreiben. -Straßen- werden in Deutschland mit ß geschrieben, in der Schweiz mit ss.

Gruppen von Objektarten Straßen, Gewässer, Bahnlinien, etc.
Objektarten Autobahnen, Land- oder Staatsstraßen, Kreisstraßen, Gemeindestraßen, etc.
Objekt Gemeindestraße
Eigenschaften Schlüssel: Straßennummer, Straßenname, erlaubte Höchstgeschwindigkeit, etc.
Wert: A 3, Mühlenweg, 30 km/h, etc.


Beispiel für "Wohnstraße"
Schlüssel Wert
highway residential
name Kindergartenweg
maxspeed 30
Beispiel für "See"
Schlüssel Wert
natural water
name Fischweiher
Beispiel für "Bank"
Schlüssel Wert
amenity bank
name Sparkasse
atm yes (Geldautomat)

Achtung! maxspeed beinhaltet schon die Angabe "km/h". Sie wird also nicht an den Wert angefügt!

was wann wie wo wofür und warum nicht...

Siehe

Teilstücke mit unterschiedlichen Eigenschaften

Eine Straße kann in verschiedenen Teilstücken unterschiedliche Eigenschaften haben. Die "B 27" heißt in Stuttgart beispielsweise erst Heilbronner-, dann Friedrichstraße. Und mal ist die Höchstgeschwindigkeit 50, mal 80 km/h. Damit die wechselnden Eigenschaften unterschieden und die Straße dennoch als eine einzige erkannt wird, sind folgende Schritte erforderlich:

  1. Linie in Teilstücke auftrennen und diesen die unterschiedlichen Eigenschaften zuwiesen
  2. Teilstücke in einer Relation zusammenfassen

Eigenschaften kopieren

Mehrere Objekte mit gleichen Eigenschaften können mit <strg-d> aus dem ersten Objekt dupliziert werden.

Man kann auch die Eigenschaften eines vorhandenen Objektes mit <strg-c> übernehmen und einem anderen Objekt mit <Umschalt-strg-v> zuordnen. Die Eigenschaften des Quell-Objektes werden dann zu denen des Ziel-Objektes hinzugefügt.

unterbrochene zusammengehörende Linien

Eine Straße kann unterbrochen sein. Beispielsweise eine Autobahn bei der das Geld für die Brücke fehlt (oder umgekehrt), ein Bach der versickert, aber woanders wieder hervorquillt; ein Fernwanderweg der ein Stück über eine Bundesstraße führt; eine Bahnstrecke die beim Umstieg 10 Minuten Fussweg erfordert oder mittels Fähre über einen Fluss führt. Hier werden die Teilstücke in einer Relation zusammengefasst.

Relationen

Allgemeine Beschreibung: Relationen
  1. Auf der linken Symbolleiste den Schalter Öffne eine Liste aller Relationen anklicken oder die Tastenkombination <Alt+Umschalt+R> benutzen.
  2. Auf der rechten Seite erscheint ein neues Fenster, in dem die geladenen Relationen mit einem Zahnradsymbol angezeigt wird.
  3. Um eine neue Relation anzulegen, den Schalter Add/Neu bzw. den Schalter mit dem Zahnrad und dem + anklicken.
  4. Jetzt öffnet sich der Relation-Editor.
  5. Im oberen Bereich Tags (Attribute) wird der Typ der Relation festgelegt z.B. Schlüssel: type und Wert: multipolygon.
  6. Im unteren Bereich Members werden nun die zur Relation gehörenden Mitglieder hinzugefügt. Die Angabe der Rolle ist vom Relationstyp abhängig. Sie kann zwingend sein, aber auch optional.
  7. Es können Punkte, Linien und Relationen als Mitglieder zu einer Relation hinzugefügt werden. Diese werden markiert (einer oder mehrere) und durch Anklicken von Add/Hinzufügen in die Liste der Mitglieder aufgenommen. Relationen, die eingefügt werden sollen, markiert man durch Drücken auf das kleine Feld rechts neben dem Papierkorb. Danach kann man sie wie normale Objekte zu der gewünschten Relation hinzufügen.
  8. Für jedes Mitglied muss dann die Rolle (sofern erforderlich) eingegeben werden. Im Beispiel multipolygon würden die Rollen outer und inner gesetzt werden.
  9. Mitgliederlinien werden dann farblich unterlegt im Editorfenster dargestellt, um die Zugehörigkeit zu einer Relation anzuzeigen.
  10. Falls ein Objekt einer Relation zugeordnet werden soll, die sich noch nicht in der Liste der Relationen befindet, kann diese wie folgt in die Liste übernommen werden:
    1. Voraussetzung: Relation-ID (4-7 stellige Relationsnummer) ist bekannt.
    2. In der JOSM Menu - Datei / Adresse öffnen... wählen
    3. Als URL http://api.openstreetmap.org/api/0.6/relation/<Relation ID> eingeben, den Marker Separate Ebene deselektieren und die Schaltfläche URL herunterladen drücken. Die URL ist identisch mit der Adresse der XML-Beschreibung einer Relation, die überlicherweise in den einschlägigen Übersichtslisten als Hyperlink gelistet ist (z. B. WikiProject_Germany/Wanderwege-Netz). Diese kann dann einfach per Rechtsklick über XML / Link Adress kopieren in den Cut & Paste Puffer übertragen werden.
Ein Film zum Thema Multipolygon in JOSM findet sich unter [1] - dort wird allerdings eine veraltete Version des Relationen-Editors verwendet.

Multipolygon

  1. Alt+Umschalten+R drücken damit rechts der "Relationen"-Bereich aufgeht (falls noch nicht offen).
  2. Äußere Fläche markieren.
  3. Im Relationenbereich rechts dann auf "+" für neue Relation klicken.
  4. Das weiße Feld unter "schlüssel" anklicken und dort "type" eingeben (ohne ""). Als Wert "multipolygon".
  5. Das immer noch ausgewählte Element sollte auch im Relationen-Editor zu sehen sein und dort dann mit dem Button die Relation hinzufügen (zur Info: alle Buttons haben tooltips).
  6. Das Element sollte, wenn erfolgreich hinzugefügt, in dem linken Bereich des Relationen-Editors erscheinen. Links neben dem Element in dem linken Bereich ist eine Spalte "rolle". Dort hineinklicken und "outer" eingeben.
  7. Nun in die Karte oder die oberste Leiste vom JOSM-Editor klicken und der Relationen-Editor bleibt offen aber inaktiv (graue Leiste oben).
  8. Nun die innere Fläche suchen und markieren.
  9. Im immer noch offenen Relationen-Editor wieder durch Betätigen des "Hinzufügen"-Buttons inneres Element hinzufügen und als "rolle" diesmal "inner" vorgeben.

Relationen-Editor mit "ok" schließen. Zur Info: Wenn man Abbruch anklickt, werden alle Änderungen an der Relation verworfen.

Wenn man im Relationsbereich die neue Relation anklickt, dann kann man anschließend dem Multipolygon Attribute zuweisen. Dies ist wichtig, wenn der äußere Teil aus einzelnen Linien besteht.

  • Hier ist ein Video über die grundlegende Benutzung von JOSM zu sehen. (Achtung: Zu klären ist, ob das Video alte Verfahren enthält. Weder spielt die Richtung der Polygone eine Rolle, noch muss das innere Polygon mit Attributen versehen werden. Falls das innere Polygon attributiert wird, dann beschreiben die Attribute natürlich die Eigenschaften des inneren Polygons.)

Konflikte beheben

Wenn zwischen Herunterladen und Hochladen jemand anderes irgendwoanders etwas an den Wegstücken der Relation gemacht hat, gibt es einen Konflikt. Das passiert z. B. auch, wenn jemand Busrouten oder Wanderwege anlegt und einen Weg dafür aufspalten muss.

In JOSM bekommt man bei der Konfliktlösung (das Symbol mit den aufeinander gerichteten Dreiecken) drei Spalten von Wegelementen vorgesetzt: Die eigenen, die endgültigen und die auf dem Server. Linienelemente, die im eigenen Datenbestand und auf dem Server identisch sind, sind dabei grün unterlegt. Diese kann man bedenkenlos in die mittlere Spalte verschieben. Rot unterlegte Linienelemente stimmen nicht überein. Hier muss man nach eigenem Gewissen entscheiden, ob man die eigenen oder die vom Server aus der jeweiligen Spalte in die leere, mittlere Spalte verschiebt. Anschließend wählt man fixieren. Lässt man die mittlere Spalte leer, ist dann anschließend die ganze Relation leer. Leider wird das von JOSM und dem OSM-Server so ohne Murren akzepiert.

Gelöschte Relationen wieder herstellen

Das Wiederherstellen gelöschter Relationen ist wie folgt möglich:

  1. Zunächst muss die ID der gelöschten Relation bekannt sein.
  2. Aktuelle Version der Relation aus der Ansichtsseite auslesen. Man findet diese unter http://www.openstreetmap.org/browse/relation/<Relations-ID>. Auf dieser Seite kann man sich auch die Chronik (history) der Relation anzeigen lassen. Wenn die aktuelle Versionsnummer über hundert liegt, kann die Anzeige der history sehr lange dauern. Dann ist es sinnvoller, gleich mit dem 4. Schritt und der Versionsnummer 1 weiterzumachen.
  3. Als nächstes gilt es, die letzte brauchbare Version der Relation zu finden. Diese wird in den nächsten Schritten wieder hergestellt. Die Versionen lassen sich auf der unter dem 2. Schritt genannten Seite anzeigen. In der angezeigten History-Liste solange zurück gehen, bis man eine Version findet, die den gewünschten ursprünglichen Zustand wiedergibt (Versionsnummer merken).
  4. Die in Schritt 3 gefundene Versionsnummer ruft man nun in einem beliebigen Browser über http://api.openstreetmap.org/api/0.6/relation<Relations-ID>/<Versionsnummer> auf und speichert die Seite als OSM- oder xml-Datei ab.
  5. Mit dem Texteditor die im 4. Schritt gespeicherte Datei öffnen. In das Element <relation> ein action="modify" hinzufügen und die Versionsnummer auf die der letzten auf dem Server befindlichen anpassen. (Das sollte dann die Versionsnummer des Löschvorgangs sein.)
  6. Die im 5. Schritt erzeugte Datei in JOSM laden und hochladen - fertig
  7. Wenn Konflikte auftretet, dann in JOSM die Relation aktualisieren lassen (File -> Update Data bzw. Datei -> Daten aktualisieren). Danach sollten Konflikte auftreten. Die Konflikte lösen, bis keine mehr gemeldet werden. Das heißt, fehlende Mitglieder hinzufügen und gelöschte Ways aus der Relation entfernen.
  8. Die Änderungen wie gewohnt zum Server hochladen.

Daten herunterladen

Nicht-rechtwinklige Region

JOSM kann Lesezeichen nur für eine rechteckige "bounding-Box" erstellen.

Wenn man von immer derselben Gegend Daten bearbeiten will, beispielsweise ein gekrümmter Flussverlauf mit Uferbereichen oder ein Straßendorf, und wenn bei einer rechteckigen "bounding-Box" viel zu viele unnötige Daten geladen werden müssten, dann hilft folgendes Vorgehen:

  1. lade den dich interessierenden Bereich einmalig herunter, mühsam Stück für Stück.
  2. speichere den Bereich als OSM-Datei
  3. öffne die OSM-Datei mit einem Editor (EditPad).
    am Anfang der Datei stehen lauter Einträge der Art
    <bounds .... />
    und danach erst kommen <node>, <way>, <relation>.
  4. suche den ersten <node>...
    drücke <Strg-Shift-Ende> und markiere so alle folgenden Einträge bis zum Dateiende
    lösche die markierten Einträge. und füge am Ende als letzte Zeile "</osm>" ein:
<osm>
<bounds .... />
<bounds .... />
<bounds .... />
<bounds .... />
</osm>

Diese Datei kannst du nun in JOSM öffnen und mittels "Aktualisieren" im Datei-Menue stets exakt den gewünschten Inhalt vom Server holen.

Thematische Daten

Manche Benutzer kümmern sich hauptsächlich um bestimmte Datenarten, um das Erstellen thematischer Karten zu ermöglichen. In solchen Fällen ist es besser, nur die Daten zu laden, die man auch wirklich braucht. Das bremst JOSM weniger aus, und die Übersicht ist besser, weil man nur die Daten angezeigt bekommt, die man sehen will. Um das zu erreichen, muss die heruntergeladene Datei gefiltert werden, bevor man sie mit JOSM lädt. Hier ist einer der Wege dies zu tun:

Zuerst müssen die Programme osmconvert und osmfilter heruntergeladen werden. Anschließend können die folgenden Kommandos ausgeführt werden, um zum Beispiel alle Bahnlinien der Schweiz zu erhalten.

osmconvert switzerland.osm.pbf --out-o5m >switzerland.o5m
osmfilter switzerland.o5m --keep="railway= route=train =rail" >swiss_railways.osm

Vorsicht beim Editieren! Keine Punkte löschen oder verschieben. Man kann nicht sicher sein, ob sie von anderen Linien genutzt werden, weil man die Daten nicht vollständig in den Editor geladen hat. Gefilterte Daten zu editieren, ist eine geschickte Möglichkeit, sich um bestimmte Attribute oder Relationen zu kümmern, aber nicht ratsam, wenn man Form oder Positionen von Objekten ändern will.

Daten exportieren

Mit JOSM können Daten (Punkte, Linien, Flächen, Attribute) aus der OSM-Datenbank ausgewählt und direkt als GPX-Datei exportiert werden:

  1. Lade den gewünschten Bereich aus der Datenbank in JOSM.
  2. Markiere die gewünschten Elemente (mehrere Elemente mit <Shift>-Klick).
    Funktioniert nur mit Linien...
  3. Kopiere die Auswahl mit <Strg-C>.
  4. Öffne eine neue Karte mit <Strg-N>.
  5. Füge in der neuen Karte die ausgewählten Elemente mit <Strg-V> ein.
    Achtung: Dabei werden die Elemente mit einem Versatz eingefügt
    (Die Kopie ist dadurch bei Kopiervorgängen innerhalb einer Karte einfacher zu finden - hier aber ist das störend!)
  6. Verschiebe die ausgewählten Elemente deckungsgleich (Zoom!) an die richtige Stelle.
  7. Exportiere die Elemente nun mit <Strg-E>, oder Rechtsklick auf Datenebene,
    und speichere sie als GPX-Datei.

Fehler in JOSM melden

Fehler und Verbesserungsideen und -wünsche zu JOSM werden vom JOSM-Entwicklerteam entgegengenommen.